所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

S1720, S2700, S5700, S6720 V200R011C10 配置指南-QoS

本文档介绍了如何配置QoS功能,主要包括MQC配置、优先级映射配置、流量监管配置、流量整形配置、接口限速配置、拥塞避免配置、拥塞管理配置、报文过滤配置、重定向配置、流量统计配置、基于ACL的简化流策略配置和HQoS配置。
评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
配置优先级映射示例

配置优先级映射示例

通过配置优先级映射,设备将来自不同用户的报文中的DSCP优先级映射成新的DSCP优先级,从而提供差异化的服务。

组网需求

图6-4所示,SwitchA和SwitchB都与路由器互连,企业分支机构1和企业分支结构2可经由LSW1和LSW2访问网络。

由于企业分支机构1需要得到更好的QoS保证,因此将来自企业分支机构1的数据报文DSCP优先级映射为45,将来自企业分支机构2的数据报文DSCP优先级映射为30。Switch信任报文的DSCP优先级。当拥塞发生时,Switch优先处理DSCP优先级高的报文。

图6-4  优先级映射配置组网图

配置思路

采用如下的思路配置优先级映射:
  1. 创建VLAN,并配置各接口,使企业都能够访问网络。
  2. 配置优先级映射,将来自企业分支机构1的数据报文优先级映射为45,将来自企业分支结构2的数据报文优先级映射为30。

操作步骤

  1. 配置SwitchA

    # 创建VLAN100。

    <HUAWEI> system-view
    [HUAWEI] sysname SwitchA
    [SwitchA] vlan batch 100
    

    # 将接口GE0/0/1、GE0/0/2的接入类型分别配置为trunk,并加入VLAN100。

    [SwitchA] interface gigabitethernet 0/0/1
    [SwitchA-GigabitEthernet0/0/1] port link-type trunk
    [SwitchA-GigabitEthernet0/0/1] port trunk allow-pass vlan 100
    [SwitchA-GigabitEthernet0/0/1] quit
    [SwitchA] interface gigabitethernet 0/0/2
    [SwitchA-GigabitEthernet0/0/2] port link-type trunk
    [SwitchA-GigabitEthernet0/0/2] port trunk allow-pass vlan 100
    [SwitchA-GigabitEthernet0/0/2] quit

    # 配置接口信任报文的DSCP优先级。

    [SwitchA] interface gigabitethernet 0/0/1
    [SwitchA-GigabitEthernet0/0/1] trust dscp
    [SwitchA-GigabitEthernet0/0/1] quit
    [SwitchA] interface gigabitethernet 0/0/2
    [SwitchA-GigabitEthernet0/0/2] trust dscp
    [SwitchA-GigabitEthernet0/0/2] quit
    

    # 配置优先级映射。

    [SwitchA] qos map-table dscp-dscp
    [SwitchA-dscp-dscp] input 0 to 63 output 45 
    [SwitchA-dscp-dscp] quit
    

  2. 配置SwitchB

    # 创建VLAN200。

    <HUAWEI> system-view
    [HUAWEI] sysname SwitchB
    [SwitchB] vlan batch 200
    

    # 将接口GE0/0/1、GE0/0/2的接入类型分别配置为trunk,并加入VLAN200。

    [SwitchB] interface gigabitethernet 0/0/1
    [SwitchB-GigabitEthernet0/0/1] port link-type trunk
    [SwitchB-GigabitEthernet0/0/1] port trunk allow-pass vlan 200
    [SwitchB-GigabitEthernet0/0/1] quit
    [SwitchB] interface gigabitethernet 0/0/2
    [SwitchB-GigabitEthernet0/0/2] port link-type trunk
    [SwitchB-GigabitEthernet0/0/2] port trunk allow-pass vlan 200
    [SwitchB-GigabitEthernet0/0/2] quit

    # 配置接口信任报文的DSCP优先级。

    [SwitchB] interface gigabitethernet 0/0/1
    [SwitchB-GigabitEthernet0/0/1] trust dscp
    [SwitchB-GigabitEthernet0/0/1] quit
    [SwitchB] interface gigabitethernet 0/0/2
    [SwitchB-GigabitEthernet0/0/2] trust dscp
    [SwitchB-GigabitEthernet0/0/2] quit
    

    # 配置优先级映射。

    [SwitchB] qos map-table dscp-dscp
    [SwitchB-dscp-dscp] input 0 to 63 output 30 
    [SwitchB-dscp-dscp] quit
    

  3. 验证配置结果

    # 查看SwitchA上的优先级映射信息。

    [SwitchA] display qos map-table dscp-dscp
    Input DSCP       DSCP
    ------------------------
    0                45
    1                45
    2                45
    3                45
    4                45
    ......
    63               45 
    

    # 查看SwitchA上接口的配置信息。

    [SwitchA] interface gigabitethernet 0/0/1
    [SwitchA-GigabitEthernet0/0/1] display this
    #
    interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk allow-pass vlan 100
     trust dscp
    #                                                                               
    return   
    [SwitchA-GigabitEthernet0/0/1] quit
    [SwitchA] interface gigabitethernet 0/0/2
    [SwitchA-GigabitEthernet0/0/2] display this
    #
    interface GigabitEthernet0/0/2
     port link-type trunk
     port trunk allow-pass vlan 100
     trust dscp
    #                                                                               
    return   

    # 查看SwitchB上的优先级映射信息。

    [SwitchB] display qos map-table dscp-dscp
    Input DSCP       DSCP
    ------------------------
    0                30
    1                30
    2                30
    3                30
    4                30
    ......
    63               30 
    

    # 查看SwitchB上接口的配置信息。

    [SwitchB] interface gigabitethernet 0/0/1
    [SwitchB-GigabitEthernet0/0/1] display this
    #
    interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk allow-pass vlan 200
     trust dscp
    #                                                                               
    return   
    [SwitchB-GigabitEthernet0/0/1] quit
    [SwitchB] interface gigabitethernet 0/0/2
    [SwitchB-GigabitEthernet0/0/2] display this
    #
    interface GigabitEthernet0/0/2
     port link-type trunk
     port trunk allow-pass vlan 200
     trust dscp
    #                                                                               
    return   
    

配置文件

  • SwitchA的配置文件
    #
    sysname SwitchA
    #
    vlan batch 100
    # 
    interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk allow-pass vlan 100
     trust dscp
    # 
    interface GigabitEthernet0/0/2
     port link-type trunk
     port trunk allow-pass vlan 100
     trust dscp
    #
    qos map-table dscp-dscp
      input 0 to 44 output 45
      input 46 to 63 output 45
    #                                                                               
    return   
    
  • SwitchB的配置文件
    #
    sysname SwitchB
    #
    vlan batch 200
    # 
    interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk allow-pass vlan 200
     trust dscp
    # 
    interface GigabitEthernet0/0/2
     port link-type trunk
     port trunk allow-pass vlan 200
     trust dscp
    #
    qos map-table dscp-dscp
      input 0 to 29 output 30
      input 31 to 63 output 30
    #                                                                               
    return   
    
翻译
下载文档
更新时间:2019-03-28

文档编号:EDOC1000178152

浏览量:14607

下载量:883

平均得分:
本文档适用于这些产品
相关文档
相关版本
分享
上一页 下一页