所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

S7700, S7900, S9700 V200R011C10 配置指南-可靠性

本文档针对设备可靠性业务,主要包括BFD配置、DLDP配置、VRRP配置、Smart Link和Monitor Link配置、EFM配置、CFM配置、Y.1731配置和MAC Swap配置。
评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
配置Smart Link主备备份示例

配置Smart Link主备备份示例

组网需求

图6-17所示,为了保证网络的可靠性,用户侧网络采用双上行方式组网。用户希望能够破除网络环路,实现主备链路冗余备份和快速收敛。

图6-17  配置Smart Link主备备份示例

配置思路

采用如下的思路配置Smart Link功能:

  1. 创建VLAN,并配置接口允许相应VLAN通过。

  2. 在SwitchA上创建Smart Link备份组,并指定端口角色。

  3. 在SwitchA上使能回切功能,使得故障恢复后,流量切换到相对稳定的原主链路上。

  4. 在SwitchA上使能发送Flush报文功能。

  5. 在SwitchB、SwitchC和SwitchD三台设备对应端口上使能Flush报文接收功能。

  6. 在SwitchA上使能Smart Link组功能。

操作步骤

  1. 配置VLAN信息

    # 在SwitchA上创建VLAN,并配置接口允许相应VLAN通过。SwitchB、SwitchC和SwitchD的配置与SwitchA类似,详见配置文件。

    <HUAWEI> system-view
    [HUAWEI] sysname SwitchA
    [SwitchA] vlan batch 10 to 30 
    [SwitchA] interface gigabitethernet 1/0/1
    [SwitchA-GigabitEthernet1/0/1] port link-type trunk
    [SwitchA-GigabitEthernet1/0/1] port trunk allow-pass vlan 10 to 30
    [SwitchA-GigabitEthernet1/0/1] quit
    [SwitchA] interface gigabitethernet 1/0/2
    [SwitchA-GigabitEthernet1/0/2] port link-type trunk
    [SwitchA-GigabitEthernet1/0/2] port trunk allow-pass vlan 10 to 30
    [SwitchA-GigabitEthernet1/0/2] quit
    

  2. SwitchA上创建Smart Link备份组,并指定端口角色

    # 配置SwitchA

    [SwitchA] interface gigabitethernet 1/0/1
    [SwitchA-GigabitEthernet1/0/1] stp disable
    [SwitchA-GigabitEthernet1/0/1] quit
    [SwitchA] interface gigabitethernet 1/0/2
    [SwitchA-GigabitEthernet1/0/2] stp disable
    [SwitchA-GigabitEthernet1/0/2] quit
    [SwitchA] smart-link group 1
    [SwitchA-smlk-group1] port gigabitethernet 1/0/1 master
    [SwitchA-smlk-group1] port gigabitethernet 1/0/2 slave
    

  3. 使能回切功能并设置回切时间

    # 配置SwitchA。

    [SwitchA-smlk-group1] restore enable
    [SwitchA-smlk-group1] timer wtr 30
    

  4. 使能发送Flush报文功能

    # 配置SwitchA,并指定发送Flush报文的密码为SHA加密方式。

    [SwitchA-smlk-group1] flush send control-vlan 10 password sha 123
    

  5. 使能接收Flush报文功能

    # 配置SwitchB,并指定接收Flush报文的密码为SHA加密方式。

    [SwitchB] interface gigabitethernet 1/0/1
    [SwitchB-GigabitEthernet1/0/1] smart-link flush receive control-vlan 10 password sha 123
    [SwitchB-GigabitEthernet1/0/1] stp disable
    [SwitchB-GigabitEthernet1/0/1] quit
    [SwitchB] interface gigabitethernet 1/0/2
    [SwitchB-GigabitEthernet1/0/2] smart-link flush receive control-vlan 10 password sha 123
    [SwitchB-GigabitEthernet1/0/2] stp disable
    [SwitchB-GigabitEthernet1/0/2] quit
    

    # 配置SwitchC,并指定接收Flush报文的密码为SHA加密方式。

    [SwitchC] interface gigabitethernet 1/0/1
    [SwitchC-GigabitEthernet1/0/1] smart-link flush receive control-vlan 10 password sha 123
    [SwitchC-GigabitEthernet1/0/1] stp disable
    [SwitchC-GigabitEthernet1/0/1] quit
    [SwitchC] interface gigabitethernet 1/0/2
    [SwitchC-GigabitEthernet1/0/2] smart-link flush receive control-vlan 10 password sha 123
    [SwitchC-GigabitEthernet1/0/2] stp disable
    [SwitchC-GigabitEthernet1/0/2] quit
    

    # 配置SwitchD,并指定接收Flush报文的密码为SHA加密方式。

    [SwitchD] interface gigabitethernet 1/0/1
    [SwitchD-GigabitEthernet1/0/1] smart-link flush receive control-vlan 10 password sha 123
    [SwitchD-GigabitEthernet1/0/1] stp disable
    [SwitchD-GigabitEthernet1/0/1] quit
    [SwitchD] interface gigabitethernet 1/0/2
    [SwitchD-GigabitEthernet1/0/2] smart-link flush receive control-vlan 10 password sha 123
    [SwitchD-GigabitEthernet1/0/2] stp disable
    [SwitchD-GigabitEthernet1/0/2] quit
    

  6. SwitchA使能Smart Link组功能

    [SwitchA-smlk-group1] smart-link enable
    [SwitchA-smlk-group1] quit

  7. 验证配置结果

    # 使用display smart-link group命令查看SwitchA上的Smart Link组信息。如果显示如下信息,则表示配置成功。

    • Smart Link组功能已经使能
    • 回切时间为30秒
    • 控制VLAN编号为10
    • 接口GE1/0/1为主接口且处于Active状态,接口GE1/0/2为从接口且处于Inactive。
    [SwitchA] display smart-link group 1
    Smart Link group 1 information :
      Smart Link group was enabled
      Wtr-time is: 30 sec.
      There is no Load-Balance
      There is no protected-vlan reference-instance
      DeviceID: 0018-2000-0083  Control-vlan ID: 10
      Member                  Role   InstanceID State    Flush Count Last-Flush-Time
      ---------------------------------------------------------------------------------
    
      GigabitEthernet1/0/1    Master 0          Active   1           2009/01/05 10:33:46 UTC+05:00
      GigabitEthernet1/0/2    Slave  0          Inactive 0           0000/00/00 00:00:00 UTC+05:00
    

    # 使用shutdown命令关闭接口GE1/0/1,可以看到接口GE1/0/1已经处于Inactive状态,接口GE1/0/2为Active状态。

    [SwitchA] interface gigabitethernet 1/0/1
    [SwitchA-GigabitEthernet1/0/1] shutdown
    [SwitchA-GigabitEthernet1/0/1] display smart-link group 1
    Smart Link group 1 information :
      Smart Link group was enabled
      Wtr-time is: 30 sec.
      There is no Load-Balance
      There is no protected-vlan reference-instance 
      DeviceID: 0018-2000-0083  Control-vlan ID: 10
      Member                  Role   InstanceID State    Flush Count Last-Flush-Time
      ---------------------------------------------------------------------------------
    
      GigabitEthernet1/0/1    Master 0          Inactive 1           2009/01/05 10:33:46 UTC+05:00
      GigabitEthernet1/0/2    Slave  0          Active   1           2009/01/05 10:34:46 UTC+05:00
    

    # 使用undo shutdown命令开启接口GE1/0/1

    [SwitchA-GigabitEthernet1/0/1] undo shutdown

    # 等待30秒后,可以看到接口GE1/0/1处于Active状态,接口GE1/0/2为Inactive状态。

    [SwitchA-GigabitEthernet1/0/1] display smart-link group 1
    Smart Link group 1 information :
      Smart Link group was enabled
      Wtr-time is: 30 sec.
      There is no Load-Balance
      There is no protected-vlan reference-instance 
      DeviceID: 0018-2000-0083  Control-vlan ID: 10
      Member                  Role   InstanceID State    Flush Count Last-Flush-Time
      ---------------------------------------------------------------------------------
    
      GigabitEthernet1/0/1    Master 0          Active   2           2009/01/05 10:35:46 UTC+05:00
      GigabitEthernet1/0/2    Slave  0          Inactive 1           2009/01/05 10:34:46 UTC+05:00
    

配置文件

  • SwitchA的配置文件

    #
    sysname SwitchA
    #
    vlan batch 10 to 30
    #
    interface GigabitEthernet1/0/1
     port link-type trunk
     port trunk allow-pass vlan 10 to 30
     stp disable
    #
    interface GigabitEthernet1/0/2
     port link-type trunk
     port trunk allow-pass vlan 10 to 30
     stp disable
    #
    smart-link group 1
     restore enable
     smart-link enable
     port GigabitEthernet1/0/1 master
     port GigabitEthernet1/0/2 slave
     timer wtr 30
     flush send control-vlan 10 password sha %^%#rwIhOw`~g7,xyl>~|:v9Cyw2CH,7l2\dbzA[cH3YA9BdA;1qqSs%WJHM3|hO%^%#
    #
    return
  • SwitchB的配置文件

    #
    sysname SwitchB
    #
    vlan batch 10 to 30
    #
    interface GigabitEthernet1/0/1
     port link-type trunk
     port trunk allow-pass vlan 10 to 30
     stp disable
     smart-link flush receive control-vlan 10 password sha %^%#fR)IGHHT:>]iNbG:Nq#)<^1p#`np!T#/\V&%)iHB_ibX!99]e#E{/L2Sxw!I%^%#
    #
    interface GigabitEthernet1/0/2
     port link-type trunk
     port trunk allow-pass vlan 10 to 30
     stp disable
     smart-link flush receive control-vlan 10 password sha %^%#XbPxG#g5C6$/*d2^GRU>3ODTJF_C(Bht`^*}tT05u]7SIZ5y%9bQ!x~3:v;O%^%#
    #
    return
  • SwitchC的配置文件

    #
    sysname SwitchC
    #
    vlan batch 10 to 30
    #
    interface GigabitEthernet1/0/1
     port link-type trunk
     port trunk allow-pass vlan 10 to 30
     stp disable
     smart-link flush receive control-vlan 10 password sha %^%#IOf[Q`=F=QK"O4-j9A}Y-N7<,F~cn%/NR:G-,L5*[SMN,FlIYAZd88*ObE;T%^%#
    #
    interface GigabitEthernet1/0/2
     port link-type trunk
     port trunk allow-pass vlan 10 to 30
     stp disable
     smart-link flush receive control-vlan 10 password sha %^%#vMK'GvJozEo1Fi:%~jkO<ge&0HgYZVh@ch709e49'r8&M{k6X.NzX)<K_R<P%^%#
    #
    return
  • SwitchD的配置文件

    #
    sysname SwitchD
    #
    vlan batch 10 to 30
    #
    interface GigabitEthernet1/0/1
     port link-type trunk
     port trunk allow-pass vlan 10 to 30
     stp disable
     smart-link flush receive control-vlan 10 password sha %^%#:ssvXl%=T&UGOl$eoPWJaQ'>)@+TbEELAQM=7sh~J1>;>,H<HIEjK$@kW1B1%^%#
    #
    interface GigabitEthernet1/0/2
     port link-type trunk
     port trunk allow-pass vlan 10 to 30
     stp disable
     smart-link flush receive control-vlan 10 password sha %^%#i~K431w:TERjN]OK0kS+Y*VB=*-BP2+X33UoHVG#{<qPBD:s1.~,2h/s($\&%^%#
    #
    return
翻译
下载文档
更新时间:2019-04-17

文档编号:EDOC1000178275

浏览量:34214

下载量:333

平均得分:
本文档适用于这些产品
相关文档
相关版本
分享
上一页 下一页