所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

S7700, S7900, S9700 V200R011C10 配置指南-可靠性

本文档针对设备可靠性业务,主要包括BFD配置、DLDP配置、VRRP配置、Smart Link和Monitor Link配置、EFM配置、CFM配置、Y.1731配置和MAC Swap配置。
评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
配置Smart Link和Monitor Link综合应用示例

配置Smart Link和Monitor Link综合应用示例

组网需求

图6-19所示,设备SwitchC向下连接用户网络,通过双归属上行连接到SwitchA和SwitchB两台设备上,最后向上连接到骨干网。

为了防止上行链路出现故障导致下游业务中断,需要引入一种监控机制。即在上行链路出现故障时,能够使下行链路迅速感知,从而及时进行链路切换,缩短业务中断时间。

图6-19  配置Smart Link和Monitor Link综合应用示例

配置思路

采用如下的思路配置组网:

  1. SwitchA和SwitchC两台设备上配置Smart Link组,并将相应接口加入Smart Link组中。
  2. SwitchA和SwitchC两台设备上使能发送Flush报文功能。
  3. SwitchA和SwitchB两台设备上使能接收Flush报文功能。
  4. SwitchA上配置Monitor Link组,其上行链路为Smart Link组。此处Smart Link和Monitor Link配合使用,Smart Link组提高了Monitor Link组上行链路的可靠性。
  5. SwitchB上配置Monitor Link组,使得SwitchC上的Smart Link可以迅速感知上行链路上的故障,扩大了Smart Link的应用范围。

操作步骤

  1. SwitchA、SwitchB和SwitchC三台设备上配置控制VLAN,并将加入Smart Link组或Monitor Link组的接口加入该VLAN中

    # 配置SwitchA。SwitchB和SwitchC的配置与SwitchA类似,详见配置文件。

    <HUAWEI> system-view
    [HUAWEI] sysname SwitchA
    [SwitchA] vlan batch 10
    [SwitchA] interface gigabitethernet 1/0/1
    [SwitchA-GigabitEthernet1/0/1] port link-type trunk
    [SwitchA-GigabitEthernet1/0/1] port trunk allow-pass vlan 10
    [SwitchA-GigabitEthernet1/0/1] quit
    [SwitchA] interface gigabitethernet 1/0/2
    [SwitchA-GigabitEthernet1/0/2] port link-type trunk
    [SwitchA-GigabitEthernet1/0/2] port trunk allow-pass vlan 10
    [SwitchA-GigabitEthernet1/0/2] quit
    [SwitchA] interface gigabitethernet 2/0/1
    [SwitchA-GigabitEthernet2/0/1] port link-type trunk
    [SwitchA-GigabitEthernet2/0/1] port trunk allow-pass vlan 10
    [SwitchA-GigabitEthernet2/0/1] quit
    [SwitchA] interface gigabitethernet 2/0/2
    [SwitchA-GigabitEthernet2/0/2] port link-type trunk
    [SwitchA-GigabitEthernet2/0/2] port trunk allow-pass vlan 10
    [SwitchA-GigabitEthernet2/0/2] quit
    

  2. 创建Smart Link组功能

    # 配置SwitchA。

    [SwitchA] smart-link group 1
    [SwitchA-smlk-group1] quit

    # 配置SwitchC。

    [SwitchC] smart-link group 2
    [SwitchC-smlk-group2] quit

  3. 将接口加入Smart Link组并指定主接口、从接口

    # 配置SwitchA。

    [SwitchA] interface gigabitethernet 1/0/1
    [SwitchA-GigabitEthernet1/0/1] stp disable
    [SwitchA-GigabitEthernet1/0/1] quit
    [SwitchA] interface gigabitethernet 1/0/2
    [SwitchA-GigabitEthernet1/0/2] stp disable
    [SwitchA-GigabitEthernet1/0/2] quit
    [SwitchA] smart-link group 1
    [SwitchA-smlk-group1] port gigabitethernet 1/0/1 master
    [SwitchA-smlk-group1] port gigabitethernet 1/0/2 slave
    

    # 配置SwitchC。

    [SwitchC] interface gigabitethernet 1/0/1
    [SwitchC-GigabitEthernet1/0/1] stp disable
    [SwitchC-GigabitEthernet1/0/1] quit
    [SwitchC] interface gigabitethernet 1/0/2
    [SwitchC-GigabitEthernet1/0/2] stp disable
    [SwitchC-GigabitEthernet1/0/2] quit
    [SwitchC] smart-link group 2
    [SwitchC-smlk-group2] port gigabitethernet 1/0/1 master
    [SwitchC-smlk-group2] port gigabitethernet 1/0/2 slave
    

  4. 使能回切功能并设置回切时间

    # 配置SwitchA。

    [SwitchA-smlk-group1] restore enable
    [SwitchA-smlk-group1] timer wtr 30
    

    # 配置SwitchC。

    [SwitchC-smlk-group2] restore enable
    [SwitchC-smlk-group2] timer wtr 30
    

  5. 使能发送/接收Flush报文功能

    # 配置SwitchA,并指定发送、接收Flush报文的密码为SHA加密方式。

    [SwitchA-smlk-group1] flush send control-vlan 10 password sha 123
    [SwitchA-smlk-group1] quit
    [SwitchA] interface gigabitethernet 2/0/1
    [SwitchA-GigabitEthernet2/0/1] smart-link flush receive control-vlan 10 password sha 123
    [SwitchA-GigabitEthernet2/0/1] stp disable
    [SwitchA-GigabitEthernet2/0/1] quit
    [SwitchA] interface gigabitethernet 2/0/2
    [SwitchA-GigabitEthernet2/0/2] smart-link flush receive control-vlan 10 password sha 123
    [SwitchA-GigabitEthernet2/0/2] stp disable
    [SwitchA-GigabitEthernet2/0/2] quit
    

    # 配置SwitchB,并指定接收Flush报文的密码为SHA加密方式。

    [SwitchB] interface gigabitethernet 2/0/1
    [SwitchB-GigabitEthernet2/0/1] smart-link flush receive control-vlan 10 password sha 123
    [SwitchB-GigabitEthernet2/0/1] stp disable
    [SwitchB-GigabitEthernet2/0/1] quit
    [SwitchB] interface gigabitethernet 2/0/2
    [SwitchB-GigabitEthernet2/0/2] smart-link flush receive control-vlan 10 password sha 123
    [SwitchB-GigabitEthernet2/0/2] stp disable
    [SwitchB-GigabitEthernet2/0/2] quit
    

    # 配置SwitchC,并指定发送Flush报文的密码为SHA加密方式。

    [SwitchC-smlk-group2] flush send control-vlan 10 password sha 123
    [SwitchC-smlk-group2] quit

  6. 使能Smart Link组

    # 配置SwitchA。

    [SwitchA] smart-link group 1
    [SwitchA-smlk-group1] smart-link enable
    [SwitchA-smlk-group1] quit

    # 配置SwitchC。

    [SwitchC] smart-link group 2
    [SwitchC-smlk-group2] smart-link enable
    [SwitchC-smlk-group2] quit

  7. 创建Monitor Link组,并添加上行/下行链路接口

    # 配置SwitchA。

    [SwitchA] monitor-link group 1
    [SwitchA-mtlk-group1] smart-link group 1 uplink
    [SwitchA-mtlk-group1] port gigabitethernet 2/0/1 downlink 1
    

    # 配置SwitchB。

    [SwitchB] monitor-link group 2
    [SwitchB-mtlk-group2] port gigabitethernet 1/0/1 uplink
    [SwitchB-mtlk-group2] port gigabitethernet 2/0/1 downlink 1
    

  8. 配置Monitor Link组的回切时间

    # 配置SwitchA。

    [SwitchA-mtlk-group1] timer recover-time 10
    [SwitchA-mtlk-group1] quit

    # 配置SwitchB。

    [SwitchB-mtlk-group2] timer recover-time 10
    [SwitchB-mtlk-group2] quit

  9. 验证配置结果

    [SwitchA] display smart-link group 1
    Smart Link group 1 information :
      Smart Link group was enabled
      Wtr-time is: 30 sec.
      There is no Load-Balance
      There is no protected-vlan reference-instance 
      DeviceID: 0018-2000-0083  Control-vlan ID: 10
      Member                  Role   InstanceID State    Flush Count Last-Flush-Time
      ---------------------------------------------------------------------------------
    
      GigabitEthernet1/0/1    Master 0          Active   1           0000/00/00 00:00:00 UTC+05:00
      GigabitEthernet1/0/2    Slave  0          Inactive 0           0000/00/00 00:00:00 UTC+05:00
    
    [SwitchA] display monitor-link group 1
    Monitor Link group 1 information : 
      Recover-timer is 10 sec.                                                       
        Member              Role     State Last-up-time                       Last-down-time 
     Smart-link1            UpLk     UP    0000/00/00 00:00:00 UTC+05:00      0000/00/00 00:00:00 UTC+05:00
     GigabitEthernet2/0/1   DwLk[1]  UP    0000/00/00 00:00:00 UTC+05:00      0000/00/00 00:00:00 UTC+05:00
    

配置文件

  • SwitchA的配置文件

    #
    sysname SwitchA
    #
    vlan batch 10
    #
    interface GigabitEthernet1/0/1
     port link-type trunk
     port trunk allow-pass vlan 10
     stp disable
    #
    interface GigabitEthernet1/0/2
     port link-type trunk
     port trunk allow-pass vlan 10
     stp disable
    #
    interface GigabitEthernet2/0/1
     port link-type trunk
     port trunk allow-pass vlan 10
     stp disable
     smart-link flush receive control-vlan 10 password sha %^%#rwIhOw`~g7,xyl>~|:v9Cyw2CH,7l2\dbzA[cH3YA9BdA;1qqSs%WJHM3|hO%^%#
    #
    interface GigabitEthernet2/0/2
     port link-type trunk
     port trunk allow-pass vlan 10
     stp disable
     smart-link flush receive control-vlan 10 password sha %^%#fR)IGHHT:>]iNbG:Nq#)<^1p#`np!T#/\V&%)iHB_ibX!99]e#E{/L2Sxw!I%^%#
    #
    smart-link group 1
     restore enable
     smart-link enable 
     port GigabitEthernet1/0/1 master
     port GigabitEthernet1/0/2 slave 
     timer wtr 30
     flush send control-vlan 10 password sha %^%#XbPxG#g5C6$/*d2^GRU>3ODTJF_C(Bht`^*}tT05u]7SIZ5y%9bQ!x~3:v;O%^%#
    #
    monitor-link group 1
     smart-link group 1 uplink
     port GigabitEthernet2/0/1 downlink 1
     timer recover-time 10
    #
    return
  • SwitchB的配置文件

    #
    sysname SwitchB
    #
    vlan batch 10
    #
    interface GigabitEthernet1/0/1
     port link-type trunk
     port trunk allow-pass vlan 10
    #
    interface GigabitEthernet2/0/1
     port link-type trunk
     port trunk allow-pass vlan 10
     stp disable
     smart-link flush receive control-vlan 10 password sha %^%#IOf[Q`=F=QK"O4-j9A}Y-N7<,F~cn%/NR:G-,L5*[SMN,FlIYAZd88*ObE;T%^%#
    #
    interface GigabitEthernet2/0/2
     port link-type trunk
     port trunk allow-pass vlan 10
     stp disable
     smart-link flush receive control-vlan 10 password sha %^%#vMK'GvJozEo1Fi:%~jkO<ge&0HgYZVh@ch709e49'r8&M{k6X.NzX)<K_R<P%^%#
    #
    monitor-link group 2
     port GigabitEthernet1/0/1 uplink
     port GigabitEthernet2/0/1 downlink 1
     timer recover-time 10
    #
    return
  • SwitchC的配置文件

    #
    sysname SwitchC
    #
    vlan batch 10
    #
    interface GigabitEthernet1/0/1
     port link-type trunk
     port trunk allow-pass vlan 10
     stp disable
    #
    interface GigabitEthernet1/0/2
     port link-type trunk
     port trunk allow-pass vlan 10
     stp disable
    #
    smart-link group 2
     restore enable
     smart-link enable 
     port GigabitEthernet1/0/1 master
     port GigabitEthernet1/0/2 slave 
     timer wtr 30
     flush send control-vlan 10 password sha %^%#:ssvXl%=T&UGOl$eoPWJaQ'>)@+TbEELAQM=7sh~J1>;>,H<HIEjK$@kW1B1%^%#
    #
    return
翻译
下载文档
更新时间:2019-04-17

文档编号:EDOC1000178275

浏览量:30586

下载量:318

平均得分:
本文档适用于这些产品
相关文档
相关版本
分享
上一页 下一页