所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

S7700, S7900, S9700 V200R011C10 配置指南-可靠性

本文档针对设备可靠性业务,主要包括BFD配置、DLDP配置、VRRP配置、Smart Link和Monitor Link配置、EFM配置、CFM配置、Y.1731配置和MAC Swap配置。
评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
配置双向时延统计功能示例(VLAN)

配置双向时延统计功能示例(VLAN)

组网需求

随着网络的快速普及和应用的日益深入,各种增值业务(如IPTV,视频会议、VOIP等)得到了广泛部署,链路的连通性和网络性能的好坏直接影响着承载网络上的各种业务。因此,作为业务承载管道的性能检测显得尤为重要。

图10-12所示,CE之间部署CFM检测链路的连通性。为了满足用户对视频业务质量的更高要求,用户希望在链路连通性检测的同时能够实时监控移动承载链路的双向时延性能,以便在视频业务质量下降时及时做出调整。

图10-12  VLAN的Y.1731组网图

配置思路

采用如下的思路配置双向时延统计功能:
  1. 配置CE之间链路的按需双向时延检测,实现端到端设备CE之间链路时延的周期性检测和统计。

操作步骤

  1. 配置VLAN信息。

    # 配置CE1设备

    <HUAWEI> system-view
    [HUAWEI] sysname CE1
    [CE1] vlan 2
    [CE1-vlan2] quit
    [CE1] interface gigabitethernet 1/0/1
    [CE1-GigabitEthernet1/0/1] port link-type trunk
    [CE1-GigabitEthernet1/0/1] port trunk allow-pass vlan 2
    [CE1-GigabitEthernet1/0/1] quit
    

    # 配置CE2设备

    <HUAWEI> system-view
    [HUAWEI] sysname CE2
    [CE2] vlan 2
    [CE2-vlan2] quit
    [CE2] interface gigabitethernet 1/0/1
    [CE2-GigabitEthernet1/0/1] port link-type trunk
    [CE2-GigabitEthernet1/0/1] port trunk allow-pass vlan 2
    [CE2-GigabitEthernet1/0/1] quit

    # 配置PE1设备

    <HUAWEI> system-view
    [HUAWEI] sysname PE1
    [PE1] vlan 2
    [PE1-vlan2] quit
    [PE1] interface gigabitethernet 1/0/1
    [PE1-GigabitEthernet1/0/1] port link-type trunk
    [PE1-GigabitEthernet1/0/1] port trunk allow-pass vlan 2
    [PE1-GigabitEthernet1/0/1] quit
    [PE1] interface gigabitethernet 1/0/2
    [PE1-GigabitEthernet1/0/2] port link-type trunk
    [PE1-GigabitEthernet1/0/2] port trunk allow-pass vlan 2
    [PE1-GigabitEthernet1/0/2] quit

    # 配置PE2设备

    <HUAWEI> system-view
    [HUAWEI] sysname PE2
    [PE2] vlan 2
    [PE2-vlan2] quit
    [PE2] interface gigabitethernet 1/0/1
    [PE2-GigabitEthernet1/0/1] port link-type trunk
    [PE2-GigabitEthernet1/0/1] port trunk allow-pass vlan 2
    [PE2-GigabitEthernet1/0/1] quit
    [PE2] interface gigabitethernet 1/0/2
    [PE2-GigabitEthernet1/0/2] port link-type trunk
    [PE2-GigabitEthernet1/0/2] port trunk allow-pass vlan 2
    [PE2-GigabitEthernet1/0/2] quit

  2. 配置以太网CFM的基本功能,指定MEP类型为Outward型。

    在CE1和CE2上配置以太网CFM的基本功能。MD的名称是md3,MA的名称是ma3,并且配置MA与VLAN绑定。

    # 配置CE1

    [CE1] cfm enable
    [CE1] cfm md md3
    [CE1-md-md3] ma ma3
    [CE1-md-md3-ma-ma3] map vlan 2
    [CE1-md-md3-ma-ma3] mep mep-id 3 interface gigabitethernet 1/0/1 outward
    [CE1-md-md3-ma-ma3] mep ccm-send mep-id 3 enable
    [CE1-md-md3-ma-ma3] remote-mep mep-id 4
    [CE1-md-md3-ma-ma3] remote-mep ccm-receive mep-id 4 enable
    [CE1-md-md3-ma-ma3] quit
    [CE1-md-md3] quit

    # 配置CE2

    [CE2] cfm enable
    [CE2] cfm md md3
    [CE2-md-md3] ma ma3
    [CE2-md-md3-ma-ma3] map vlan 2
    [CE2-md-md3-ma-ma3] mep mep-id 4 interface gigabitethernet 1/0/1 outward
    [CE2-md-md3-ma-ma3] mep ccm-send mep-id 4 enable
    [CE2-md-md3-ma-ma3] remote-mep mep-id 3
    [CE2-md-md3-ma-ma3] remote-mep ccm-receive mep-id 3 enable
    [CE2-md-md3-ma-ma3] quit
    [CE2-md-md3] quit

  3. 验证CFM配置结果。

    # 在CE1和CE2上执行命令display cfm remote-mep,可以查看到MEP信息。

    [CE1] display cfm remote-mep
    The total number of RMEPs is : 1
    The status of RMEPs : 1 up, 0 down, 0 disable        
    --------------------------------------------------
     MD Name            : md3
     Level              : 0
     MA Name            : ma3
     RMEP ID            : 4
     VLAN ID            : 2
     VSI Name           : --
     L2VC ID            : --
     MAC                : 4c1f-cc6b-c208
     CCM Receive        : enabled
     Trigger-If-Down    : disabled
     CFM Status         : up
     Alarm Status       : none
     Interface TLV      : --
     Connect Status     : up
    [CE2] display cfm remote-mep
    The total number of RMEPs is : 1
    The status of RMEPs : 1 up, 0 down, 0 disable
    --------------------------------------------------
     MD Name            : md3
     Level              : 0
     MA Name            : ma3
     RMEP ID            : 3
     VLAN ID            : 2
     VSI Name           : --
     L2VC ID            : --
     MAC                : 0044-0141-5410
     CCM Receive        : enabled
     Trigger-If-Down    : disabled
     CFM Status         : up
     Alarm Status       : none
     Interface TLV      : --
     Connect Status     : up 

  4. 在CE2设备上配置接收DMM报文功能。

    # 配置CE2。

    [CE2] cfm md md3
    [CE2-md-md3] ma ma3
    [CE2-md-md3-ma-ma3] delay-measure two-way receive mep 4
    [CE2-md-md3-ma-ma3] quit
    [CE2-md-md3] quit

  5. 使能按需双向时延统计功能。

    # 配置CE1。

    [CE1] cfm md md3
    [CE1-md-md3] ma ma3
    [CE1-md-md3-ma-ma3] delay-measure two-way send mep 3 remote-mep 4 interval 1000 count 20
    [CE1-md-md3-ma-ma3] quit
    [CE1-md-md3] quit

  6. 验证配置结果。

    # 配置完成后,在CE1上执行display y1731 statistic-type twoway-delay md md3 ma ma3,可以看到双向时延的性能统计信息。

    [CE1] display y1731 statistic-type twoway-delay md md3 ma ma3
    Measurement Start Time : 2014-11-01 15:41:27
    Latest two-way delay statistics:                                                
    --------------------------------------------------------------------------------
    Index    Delay(usec)    Delay variation(usec)                                   
    --------------------------------------------------------------------------------
        1            442                        -                                   
        2            417                       25                                   
        3            435                       18                                   
        4            579                      144                                   
        5            429                      150                                   
        6            428                        1                                   
        7            432                        4                                   
        8            437                        5                                   
        9            439                        2                                   
       10            435                        4                                   
       11            585                      150                                   
       12            443                      142                                   
       13            441                        2                                   
       14            510                       69                                   
       15            456                       54                                   
       16            445                       11                                   
       17            435                       10                                   
       18            435                        0                                   
       19            451                       16                                   
       20            601                      150                                   
    --------------------------------------------------------------------------------
    Average delay(usec) :        463    Average delay variation(usec) :         50
    Maximum delay(usec) :        601    Maximum delay variation(usec) :        150
    Minimum delay(usec) :        417    Minimum delay variation(usec) :          0

配置文件

  • CE1的配置文件

    #
    sysname CE1
    #
    vlan batch 2
    #
    cfm enable
    #
    interface GigabitEthernet1/0/1
     port link-type trunk
     port trunk allow-pass vlan 2
    #
    cfm md md3
     ma ma3
      map vlan 2
      mep mep-id 3 interface GigabitEthernet1/0/1 outward
      mep ccm-send mep-id 3 enable
      remote-mep mep-id 4
      remote-mep ccm-receive mep-id 4 enable
    #
    return
  • CE2的配置文件

    #
    sysname CE2
    #
    vlan batch 2
    #
    cfm enable
    #
    interface GigabitEthernet1/0/1
     port link-type trunk
     port trunk allow-pass vlan 2
    #
    cfm md md3
     ma ma3
      map vlan 2
      mep mep-id 4 interface GigabitEthernet1/0/1 outward
      mep ccm-send mep-id 4 enable
      remote-mep mep-id 3
      remote-mep ccm-receive mep-id 3 enable
      delay-measure two-way receive mep 4
    #
    return
  • PE1的配置文件

    #                                                                               
    sysname PE1                                                                    
    #                                                                               
    vlan batch 2                                                                    
    #                                                                               
    interface GigabitEthernet1/0/1                                                  
     port link-type trunk                                                           
     port trunk allow-pass vlan 2                                                   
    #                                                                               
    interface GigabitEthernet1/0/2                                                  
     port link-type trunk                                                           
     port trunk allow-pass vlan 2                                                   
    #                                                                               
    return   
  • PE2的配置文件

    #                                                                               
    sysname PE2                                                                    
    #                                                                               
    vlan batch 2                                                                    
    #                                                                               
    interface GigabitEthernet1/0/1                                                  
     port link-type trunk                                                           
     port trunk allow-pass vlan 2                                                   
    #                                                                               
    interface GigabitEthernet1/0/2                                                  
     port link-type trunk                                                           
     port trunk allow-pass vlan 2                                                   
    #                                                                               
    return   
翻译
下载文档
更新时间:2019-04-17

文档编号:EDOC1000178275

浏览量:30117

下载量:315

平均得分:
本文档适用于这些产品
相关文档
相关版本
分享
上一页 下一页