所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

S7700, S7900, S9700 V200R011C10 配置指南-可靠性

本文档针对设备可靠性业务,主要包括BFD配置、DLDP配置、VRRP配置、Smart Link和Monitor Link配置、EFM配置、CFM配置、Y.1731配置和MAC Swap配置。
评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
配置BFD for IPv6单跳检测示例

配置BFD for IPv6单跳检测示例

组网需求

图2-27所示,SwitchA和SwitchB通过VLANIF接口实现三层互通。用户希望可以实现设备间链路故障的快速检测。

图2-27  配置BFD for IPv6单跳检测组网图

配置思路

配置BFD for IPv6单跳检测:

  1. 在SwitchA上配置BFD6会话,检测SwitchA到SwitchB的直连链路。

  2. 在SwitchB上配置BFD6会话,检测SwitchB到SwitchA的直连链路。

说明:

BFD控制报文的发送间隔、接收间隔、本地检测倍数等都使用缺省值。

操作步骤

  1. 配置设备间网络互连

    # 配置设备各接口的IPv6地址,以SwitchA为例。SwitchB的配置与SwitchA类似,详见配置文件。

    <HUAWEI> system-view
    [HUAWEI] sysname SwitchA
    [SwitchA] vlan batch 100
    [SwitchA] interface gigabitethernet 1/0/1
    [SwitchA-GigabitEthernet1/0/1] port link-type trunk
    [SwitchA-GigabitEthernet1/0/1] port trunk allow-pass vlan 100
    [SwitchA-GigabitEthernet1/0/1] quit
    [SwitchA] ipv6
    [SwitchA] interface vlanif 100
    [SwitchA-Vlanif100] ipv6 enable
    [SwitchA-Vlanif100] ipv6 address fc00:0:0:2001::1 64
    [SwitchA-Vlanif100] quit

  2. 配置BFD6单跳检测

    # 在SwitchA上使能BFD功能,并配置与SwitchB之间的BFD6会话。配置单跳检测需要在BFD6会话中绑定出接口。

    [SwitchA] bfd
    [SwitchA-bfd] quit
    [SwitchA] bfd atob bind peer-ipv6 fc00:0:0:2001::2 interface vlanif 100
    [SwitchA-bfd-session-atob] discriminator local 1
    [SwitchA-bfd-session-atob] discriminator remote 2
    [SwitchA-bfd-session-atob] commit
    [SwitchA-bfd-session-atob] quit

    # 在SwitchB上使能BFD功能,并配置与SwitchA之间的BFD6会话。配置单跳检测需要在BFD6会话中绑定出接口。

    [SwitchB] bfd
    [SwitchB-bfd] quit
    [SwitchB] bfd btoa bind peer-ipv6 fc00:0:0:2001::1 interface vlanif 100
    [SwitchB-bfd-session-btoa] discriminator local 2
    [SwitchB-bfd-session-btoa] discriminator remote 1
    [SwitchB-bfd-session-btoa] commit
    [SwitchB-bfd-session-btoa] quit

  3. 验证配置结果

    # 在网络稳定后,在SwitchA和SwitchB上执行display bfd session all verbose命令,可以看到建立了一个单跳(one hop)的BFD6会话,且状态为Up。

    以SwitchA上的显示结果为例。

    [SwitchA] display bfd session all verbose
    --------------------------------------------------------------------------------
    Session MIndex : 4096      (One Hop) State : Up        Name : atob
    --------------------------------------------------------------------------------
    Local Discriminator    : 1                Remote Discriminator   : 2
    Session Detect Mode    : Asynchronous Mode Without Echo Function
    BFD Bind Type          : Interface(Vlanif100)
    Bind Session Type      : Static
    Bind Peer IP Address   : FC00:0:0:2001::2
    NextHop Ip Address     : FC00:0:0:2001::2
    Bind Interface         : Vlanif100
    FSM Board Id           : 0                TOS-EXP                : 7
    Min Tx Interval (ms)   : 1000             Min Rx Interval (ms)   : 1000
    Actual Tx Interval (ms): 1000             Actual Rx Interval (ms): 1000
    Local Detect Multi     : 3                Detect Interval (ms)   : 3000
    Echo Passive           : Disable          Acl Number             : -
    Destination Port       : 3784             TTL                    : 255
    Proc Interface Status  : Disable          Process PST            : Disable
    WTR Interval (ms)      : -
    Active Multi           : 3                DSCP                   : -
    Last Local Diagnostic  : No Diagnostic
    Bind Application       : No Application Bind
    Session TX TmrID       : -                Session Detect TmrID   : -
    Session Init TmrID     : -                Session WTR TmrID      : -
    Session Echo Tx TmrID  : -
    PDT Index              : FSM-0 | RCV-0 | IF-0 | TOKEN-0
    Session Description    : -
    --------------------------------------------------------------------------------
    
    Total UP/DOWN Session Number : 1/0

配置文件

  • SwitchA的配置文件

    #
    sysname SwitchA
    #
    ipv6
    #
    vlan batch 100 
    #
    bfd
    #
    interface Vlanif100
     ipv6 enable
     ipv6 address FC00:0:0:2001::1/64
    #
    interface GigabitEthernet1/0/1
     port link-type trunk 
     port trunk allow-pass vlan 100 
    # 
    bfd atob bind peer-ipv6 FC00:0:0:2001::2 interface Vlanif100
     discriminator local 1
     discriminator remote 2
     commit
    #
    return
    
  • SwitchB的配置文件

    #
    sysname SwitchB
    #
    ipv6
    #
    vlan batch 100 
    #
    bfd
    #
    interface Vlanif100
     ipv6 enable
     ipv6 address FC00:0:0:2001::2/64
    #
    interface GigabitEthernet1/0/1
     port link-type trunk 
     port trunk allow-pass vlan 100 
    #
    bfd btoa bind peer-ipv6 FC00:0:0:2001::1 interface Vlanif100
     discriminator local 2
     discriminator remote 1
     commit
    #
    return
    
翻译
下载文档
更新时间:2019-04-17

文档编号:EDOC1000178275

浏览量:30149

下载量:315

平均得分:
本文档适用于这些产品
相关文档
相关版本
分享
上一页 下一页