所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

S7700, S7900, S9700 V200R011C10 配置指南-可靠性

本文档针对设备可靠性业务,主要包括BFD配置、DLDP配置、VRRP配置、Smart Link和Monitor Link配置、EFM配置、CFM配置、Y.1731配置和MAC Swap配置。
评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
配置单臂回声功能示例

配置单臂回声功能示例

组网需求

图2-26所示,SwitchA和SwitchB通过直连链路连通,SwitchA支持BFD功能,SwitchB不支持BFD功能。用户希望实现对链路故障的快速检测。

图2-26  配置单臂回声功能组网图

配置思路

采用如下思路配置链路单跳检测:

  • 在SwitchA上配置单臂回声功能BFD会话,检测SwitchA到SwitchB的直连链路。

操作步骤

  1. SwitchA和SwitchB上创建VLAN,将GE1/0/1接口配置为hybrid接口并加入VLAN

    # 配置SwitchA。

    <HUAWEI> system-view
    [HUAWEI] sysname SwitchA
    [SwitchA] vlan 13
    [SwitchA-vlan13] quit
    [SwitchA] interface gigabitethernet 1/0/1
    [SwitchA-GigabitEthernet1/0/1] port link-type hybrid
    [SwitchA-GigabitEthernet1/0/1] port hybrid pvid vlan 13
    [SwitchA-GigabitEthernet1/0/1] port hybrid untagged vlan 13 
    [SwitchA-GigabitEthernet1/0/1] quit

    # 配置SwitchB。

    <HUAWEI> system-view
    [HUAWEI] sysname SwitchB
    [SwitchB] vlan 13
    [SwitchB-vlan13] quit
    [SwitchB] interface gigabitethernet 1/0/1
    [SwitchB-GigabitEthernet1/0/1] port link-type hybrid
    [SwitchB-GigabitEthernet1/0/1] port hybrid pvid vlan 13
    [SwitchB-GigabitEthernet1/0/1] port hybrid untagged vlan 13 
    [SwitchB-GigabitEthernet1/0/1] quit

  2. 为VLANIF接口配置IP地址,使SwitchA和SwitchB之间实现三层互通

    # 配置SwitchA

    [SwitchA] interface vlanif13
    [SwitchA-Vlanif13] ip address 10.1.1.5 24
    [SwitchA-Vlanif13] quit

    # 配置SwitchB

    [SwitchB] interface vlanif13
    [SwitchB-Vlanif13] ip address 10.1.1.6 24
    [SwitchB-Vlanif13] quit

  3. 配置单臂ECHO功能的BFD会话

    # 配置SwitchA。

    [SwitchA] bfd
    [SwitchA-bfd] quit
    [SwitchA] bfd atob bind peer-ip 10.1.1.6 interface vlanif13 source-ip 10.1.1.5 one-arm-echo
    [SwitchA-bfd-session-atob] discriminator local 1
    [SwitchA-bfd-session-atob] min-echo-rx-interval 100
    [SwitchA-bfd-session-atob] commit
    [SwitchA-bfd-session-atob] quit

  4. 验证配置结果

    # 在网络稳定后,在SwitchA上执行display bfd session all verbose命令,可以看到建立了一个单跳(one hop)的BFD会话,且状态为Up。

    [SwitchA] display bfd session all verbose
    --------------------------------------------------------------------------------
    Session MIndex : 256       (One Hop) State : Up        Name : atob
    --------------------------------------------------------------------------------
      Local Discriminator    : 1                Remote Discriminator   : -
      Session Detect Mode    : Asynchronous One-arm-echo Mode
      BFD Bind Type          : Interface(Vlanif13)
      Bind Session Type      : Static
      Bind Peer IP Address   : 10.1.1.6
      NextHop Ip Address     : 10.1.1.6
      Bind Interface         : Vlanif13
      Bind Source IP Address : 10.1.1.5
      FSM Board Id           : 0                TOS-EXP                : 7
      Echo Rx Interval (ms)  : 100
      Actual Tx Interval (ms): 100              Actual Rx Interval (ms): 100
      Local Detect Multi     : 3                Detect Interval (ms)   : 300
      Echo Passive           : Disable          Acl Number             : -
      Destination Port       : 3784             TTL                    : 255
      Proc Interface Status  : Disable          Process PST            : Disable
      WTR Interval (ms)      : -                
      Active Multi           : 3                DSCP                   : - 
      Last Local Diagnostic  : No Diagnostic
      Bind Application       : No Application Bind
      Session TX TmrID       : -                Session Detect TmrID   : -
      Session Init TmrID     : -                Session WTR TmrID      : -
      Session Echo Tx TmrID  : -
      PDT Index              : FSM-0 | RCV-0 | IF-0 | TOKEN-0
      Session Description    : -
    --------------------------------------------------------------------------------
    
         Total UP/DOWN Session Number : 1/0   

配置文件

  • SwitchA的配置文件

    #
    sysname SwitchA
    #
    vlan batch 13
    #
    bfd
    #
    interface Vlanif13
     ip address 10.1.1.5 255.255.255.0
    #
    interface GigabitEthernet1/0/1
     port link-type hybrid
     port hybrid pvid vlan 13 
     port hybrid untagged vlan 13
    #
    bfd atob bind peer-ip 10.1.1.6 interface Vlanif13 source-ip 10.1.1.5 one-arm-echo
     discriminator local 1
     min-echo-rx-interval 100
     commit
    #
    return
  • SwitchB的配置文件

    #
    sysname SwitchB
    #
    vlan batch 13
    #
    interface Vlanif13
     ip address 10.1.1.6 255.255.255.0
    #
    interface GigabitEthernet1/0/1
     port link-type hybrid
     port hybrid pvid vlan 13 
     port hybrid untagged vlan 13
    #
    return
翻译
下载文档
更新时间:2019-04-17

文档编号:EDOC1000178275

浏览量:33518

下载量:331

平均得分:
本文档适用于这些产品
相关文档
相关版本
分享
上一页 下一页