所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

S7700, S7900, S9700 V200R011C10 配置指南-可靠性

本文档针对设备可靠性业务,主要包括BFD配置、DLDP配置、VRRP配置、Smart Link和Monitor Link配置、EFM配置、CFM配置、Y.1731配置和MAC Swap配置。
评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
配置Dot1q终结子接口支持VRRP示例

配置Dot1q终结子接口支持VRRP示例

组网需求

图3-22所示,局域网内的主机通过Switch双归属到SwitchA和SwitchB,Switch上送的用户报文中带有一层Tag。用户希望实现:
  • 正常情况下,主机以SwitchA为默认网关接入Internet,当SwitchA故障时,SwitchB接替作为网关继续进行工作,实现网关的冗余备份。

  • SwitchA故障恢复后,可以在20秒内重新成为网关。

说明:

请确保该场景下互联接口的STP处于未使能状态。同时将互连接口退出VLAN1,避免形成环路。因为在使能STP的环形网络中,如果用交换机的VLANIF接口构建三层网络,会导致某个端口被阻塞,从而导致三层业务不能正常运行。

图3-22  配置Dot1q终结子接口支持VRRP组网图

配置思路

采用Dot1q终结子接口支持VRRP实现网关的冗余备份,配置思路如下:

  1. 配置各设备接口IP地址及路由协议,使网络层路由可达。
  2. SwitchA和SwitchB的子接口上配置VRRP备份组,其中,SwitchA上配置较高优先级和20秒抢占延时,作为Master设备承担流量转发;SwitchB上配置较低优先级,作为备用交换机,实现冗余备份。

操作步骤

  1. 配置设备间的网络互连

    # 配置设备各接口的IP地址,以SwitchA为例。SwitchB和SwitchC的配置与SwitchA类似,详见配置文件。

    <HUAWEI> system-view
    [HUAWEI] sysname SwitchA
    [SwitchA] interface gigabitethernet 2/0/0.1
    [SwitchA-GigabitEthernet2/0/0.1] ip address 10.1.1.1 24
    [SwitchA-GigabitEthernet2/0/0.1] quit
    [SwitchA] interface gigabitethernet 1/0/0
    [SwitchA-GigabitEthernet1/0/0] undo portswitch
    [SwitchA-GigabitEthernet1/0/0] ip address 192.168.2.1 24
    [SwitchA-GigabitEthernet1/0/0] quit

    # 配置Switch的二层转发功能。

    <HUAWEI> system-view
    [HUAWEI] sysname Switch
    [Switch] vlan 10
    [Switch-vlan10] quit
    [Switch] interface gigabitethernet 1/0/0
    [Switch-GigabitEthernet1/0/0] port link-type access
    [Switch-GigabitEthernet1/0/0] port default vlan 10
    [Switch-GigabitEthernet1/0/0] quit
    [Switch] interface gigabitethernet 1/0/1
    [Switch-GigabitEthernet1/0/1] port link-type trunk
    [Switch-GigabitEthernet1/0/1] port trunk allow-pass vlan 10
    [Switch-GigabitEthernet1/0/1] quit
    [Switch] interface gigabitethernet 1/0/2
    [Switch-GigabitEthernet1/0/2] port link-type trunk
    [Switch-GigabitEthernet1/0/2] port trunk allow-pass vlan 10
    [Switch-GigabitEthernet1/0/2] quit
    

    # 配置SwitchA、SwitchB和SwitchC间采用OSPF协议进行互连。以SwitchA为例,SwitchB和SwitchC的配置与SwitchA类似,详见配置文件。

    [SwitchA] ospf 1
    [SwitchA-ospf-1] area 0
    [SwitchA-ospf-1-area-0.0.0.0] network 10.1.1.0 0.0.0.255
    [SwitchA-ospf-1-area-0.0.0.0] network 192.168.2.0 0.0.0.255
    [SwitchA-ospf-1-area-0.0.0.0] quit
    [SwitchA-ospf-1] quit

  2. 配置Dot1q终结子接口支持VRRP

    # 在SwitchA的接口GE2/0/0.1上创建VRRP备份组1,配置SwitchA在该备份组中的优先级为120,并配置抢占时间为20秒。

    [SwitchA] interface gigabitethernet 2/0/0.1
    [SwitchA-GigabitEthernet2/0/0.1] dot1q termination vid 10
    [SwitchA-GigabitEthernet2/0/0.1] arp broadcast enable
    [SwitchA-GigabitEthernet2/0/0.1] dot1q vrrp vid 10
    [SwitchA-GigabitEthernet2/0/0.1] vrrp vrid 1 virtual-ip 10.1.1.111
    [SwitchA-GigabitEthernet2/0/0.1] vrrp vrid 1 priority 120
    [SwitchA-GigabitEthernet2/0/0.1] vrrp vrid 1 preempt-mode timer delay 20
    [SwitchA-GigabitEthernet2/0/0.1] quit

    # 在SwitchB的接口GE2/0/0.1上创建VRRP备份组1,其在该备份组中的优先级为缺省值100。

    [SwitchB] interface gigabitethernet 2/0/0.1
    [SwitchB-GigabitEthernet2/0/0.1] dot1q termination vid 10
    [SwitchB-GigabitEthernet2/0/0.1] arp broadcast enable
    [SwitchB-GigabitEthernet2/0/0.1] dot1q vrrp vid 10
    [SwitchB-GigabitEthernet2/0/0.1] vrrp vrid 1 virtual-ip 10.1.1.111
    [SwitchB-GigabitEthernet2/0/0.1] quit

  3. 验证配置结果

    # 完成上述配置后,分别在SwitchA和SwitchB上执行display vrrp命令,可以看到SwitchA在备份组中的状态是Master,SwitchB在备份组中的状态为Backup。

    [SwitchA] display vrrp
      GigabitEthernet2/0/0.1 | Virtual Router 1
        State          : Master
        Virtual IP       : 10.1.1.111
        Master IP        : 10.1.1.1
        PriorityRun      : 120
        PriorityConfig   : 120
        MasterPriority   : 120
        Preempt          : YES   Delay Time : 20 s 
        TimerRun         : 1 s 
        TimerConfig      : 1 s
        Auth type        : NONE
        Virtual MAC      : 0000-5e00-0101
        Check TTL        : YES
        Config type      : normal-vrrp
        Backup-forward   : disabled
        Create time : 2012-05-30 21:25:47                                           
        Last change time : 2012-05-30 21:25:51      
    [SwitchB] display vrrp
      GigabitEthernet2/0/0.1 | Virtual Router 1
        State          : Backup
        Virtual IP       : 10.1.1.111
        Master IP        : 10.1.1.1
        PriorityRun      : 100
        PriorityConfig   : 100
        MasterPriority   : 120
        Preempt          : YES   Delay Time : 0 s 
        TimerRun         : 1 s 
        TimerConfig      : 1 s
        Auth type        : NONE
        Virtual MAC      : 0000-5e00-0101
        Check TTL        : YES
        Config type      : normal-vrrp
        Backup-forward   : disabled
        Create time : 2012-05-30 21:25:47                                           
        Last change time : 2012-05-30 21:25:51      

    # 分别在SwitchA和SwitchB上执行display ip routing-table命令,SwitchA上可以看到路由表中有一条目的地址为虚拟IP地址的直连路由,而SwitchB上该路由为OSPF路由。

    [SwitchA] display ip routing-table
    Route Flags: R - relay, D - download to fib
    ------------------------------------------------------------------------------
    Routing Tables: Public
             Destinations : 8       Routes : 9
    
    Destination/Mask    Proto  Pre  Cost     Flags NextHop         Interface
    
           10.1.1.0/24  Direct 0    0          D   10.1.1.1        GigabitEthernet2/0/0.1
           10.1.1.1/32  Direct 0    0          D   127.0.0.1       GigabitEthernet2/0/0.1
         10.1.1.111/32  Direct 0    0          D   127.0.0.1       GigabitEthernet2/0/0.1
          127.0.0.0/8   Direct 0    0          D   127.0.0.1       InLoopBack0
          127.0.0.1/32  Direct 0    0          D   127.0.0.1       InLoopBack0
        192.168.1.0/24  OSPF   10   2          D   192.168.2.2     GigabitEthernet1/0/0
                        OSPF   10   2          D   10.1.1.2        GigabitEthernet2/0/0.1
        192.168.2.0/24  Direct 0    0          D   192.168.2.1     GigabitEthernet1/0/0
        192.168.2.1/32  Direct 0    0          D   127.0.0.1       GigabitEthernet1/0/0
    
    [SwitchB] display ip routing-table
    Route Flags: R - relay, D - download to fib
    ------------------------------------------------------------------------------
    Routing Tables: Public
             Destinations : 8       Routes : 9
    
    Destination/Mask    Proto  Pre  Cost     Flags NextHop         Interface
    
           10.1.1.0/24  Direct 0    0          D  10.1.1.2         GigabitEthernet2/0/0.1
           10.1.1.2/32  Direct 0    0          D  127.0.0.1        GigabitEthernet2/0/0.1
         10.1.1.111/32  OSPF   10   2          D  10.1.1.1         GigabitEthernet2/0/0.1
          127.0.0.0/8   Direct 0    0          D  127.0.0.1        InLoopBack0
          127.0.0.1/32  Direct 0    0          D  127.0.0.1        InLoopBack0
        192.168.1.0/24  Direct 0    0          D  192.168.1.1      GigabitEthernet1/0/0
        192.168.1.1/32  Direct 0    0          D  127.0.0.1        GigabitEthernet1/0/0
        192.168.2.0/24  OSPF   10   2          D  192.168.1.2      GigabitEthernet1/0/0
                        OSPF   10   2          D  10.1.1.1         GigabitEthernet2/0/0.1

    # 在SwitchA的接口GE2/0/0.1上执行shutdown命令,模拟链路故障。

    [SwitchA] interface gigabitethernet 2/0/0.1
    [SwitchA-GigabitEthernet2/0/0.1] shutdown
    [SwitchA-GigabitEthernet2/0/0.1] quit

    # 分别在SwitchA和SwitchB上执行display vrrp命令,可以看到SwitchA在备份组中的状态切换为Initialize,SwitchB在备份组中的状态切换为Master。

    [SwitchA] display vrrp
      GigabitEthernet2/0/0.1 | Virtual Router 1
        State          : Initialize
        Virtual IP       : 10.1.1.111
        Master IP        : 0.0.0.0
        PriorityRun      : 120
        PriorityConfig   : 120
        MasterPriority   : 0
        Preempt          : YES   Delay Time : 20 s 
        TimerRun         : 1 s 
        TimerConfig      : 1 s
        Auth type        : NONE
        Virtual MAC      : 0000-5e00-0101
        Check TTL        : YES
        Config type      : normal-vrrp
        Backup-forward   : disabled
        Create time : 2012-05-30 21:27:47                                           
        Last change time : 2012-05-30 21:27:51      
    [SwitchB] display vrrp
      GigabitEthernet2/0/0.1 | Virtual Router 1
        State          : Master
        Virtual IP       : 10.1.1.111
        Master IP        : 10.1.1.2
        PriorityRun      : 100
        PriorityConfig   : 100
        MasterPriority   : 100
        Preempt          : YES   Delay Time : 0 s 
        TimerRun         : 1 s 
        TimerConfig      : 1 s
        Auth type        : NONE
        Virtual MAC      : 0000-5e00-0101
        Check TTL        : YES
        Config type      : normal-vrrp
        Backup-forward   : disabled
        Create time : 2012-05-30 21:27:47                                           
        Last change time : 2012-05-30 21:27:51      

    # 在SwitchA的接口GE2/0/0.1上执行undo shutdown命令,恢复链路故障。

    [SwitchA] interface gigabitethernet 2/0/0.1
    [SwitchA-GigabitEthernet2/0/0.1] undo shutdown
    [SwitchA-GigabitEthernet2/0/0.1] quit

    # 等待20秒后,分别在SwitchA和SwitchB上执行display vrrp命令,可以看到SwitchA在备份组中的状态恢复为Master,SwitchB在备份组中的状态恢复为Backup。

    [SwitchA] display vrrp
      GigabitEthernet2/0/0.1 | Virtual Router 1
        State          : Master
        Virtual IP       : 10.1.1.111
        Master IP        : 10.1.1.1
        PriorityRun      : 120
        PriorityConfig   : 120
        MasterPriority   : 120
        Preempt          : YES   Delay Time : 20 s 
        TimerRun         : 1 s 
        TimerConfig      : 1 s
        Auth type        : NONE
        Virtual MAC      : 0000-5e00-0101
        Check TTL        : YES
        Config type      : normal-vrrp
        Backup-forward   : disabled
        Create time : 2012-05-30 21:28:47                                           
        Last change time : 2012-05-30 21:28:51      
    [SwitchB] display vrrp
      GigabitEthernet2/0/0.1 | Virtual Router 1
        State          : Backup
        Virtual IP       : 10.1.1.111
        Master IP        : 10.1.1.1
        PriorityRun      : 100
        PriorityConfig   : 100
        MasterPriority   : 120
        Preempt          : YES   Delay Time : 0 s 
        TimerRun         : 1 s 
        TimerConfig      : 1 s
        Auth type        : NONE
        Virtual MAC      : 0000-5e00-0101
        Check TTL        : YES
        Config type      : normal-vrrp
        Backup-forward   : disabled
        Create time : 2012-05-30 21:28:47                                           
        Last change time : 2012-05-30 21:28:51      

配置文件

  • SwitchA的配置文件

    #
    sysname SwitchA
    #
    interface GigabitEthernet1/0/0
     undo portswitch
     ip address 192.168.2.1 255.255.255.0
    #
    interface GigabitEthernet2/0/0.1
     dot1q termination vid 10
     dot1q vrrp vid 10
     ip address 10.1.1.1 255.255.255.0
     vrrp vrid 1 virtual-ip 10.1.1.111
     vrrp vrid 1 priority 120
     vrrp vrid 1 preempt-mode timer delay 20
     arp broadcast enable
    #
    ospf 1
     area 0.0.0.0
      network 10.1.1.0 0.0.0.255
      network 192.168.2.0 0.0.0.255
    #
    return
  • SwitchB的配置文件

    #
    sysname SwitchB
    #
    interface GigabitEthernet1/0/0
     undo portswitch
     ip address 192.168.1.1 255.255.255.0
    #
    interface GigabitEthernet2/0/0.1
     dot1q termination vid 10
     dot1q vrrp vid 10
     ip address 10.1.1.2 255.255.255.0
     vrrp vrid 1 virtual-ip 10.1.1.111
     arp broadcast enable
    #
    ospf 1
     area 0.0.0.0
      network 10.1.1.0 0.0.0.255
      network 192.168.1.0 0.0.0.255
    #
    return
  • SwitchC的配置文件

    #
    sysname SwitchC
    #
    interface GigabitEthernet1/0/0
     undo portswitch
     ip address 192.168.2.2 255.255.255.0
    #
    interface GigabitEthernet2/0/0
     undo portswitch
     ip address 192.168.1.2 255.255.255.0
    #
    ospf 1
     area 0.0.0.0
      network 192.168.1.0 0.0.0.255
      network 192.168.2.0 0.0.0.255
    #
    return
  • Switch的配置文件

    #
    sysname Switch
    #
    vlan batch 10
    #
    interface GigabitEthernet1/0/0
     port link-type access
     port default vlan 10
    #
    interface GigabitEthernet1/0/1
     port link-type trunk
     port trunk allow-pass vlan 10
    #
    interface GigabitEthernet1/0/2
     port link-type trunk
     port trunk allow-pass vlan 10
    #
    return
翻译
下载文档
更新时间:2019-04-17

文档编号:EDOC1000178275

浏览量:33627

下载量:333

平均得分:
本文档适用于这些产品
相关文档
相关版本
分享
上一页 下一页