所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

CloudEngine 12800 V200R003C00 配置指南-MPLS

本文档介绍了MPLS的配置,具体包括MPLS基础、MPLS LDP配置、MPLS QoS配置、MPLS TE配置和SR-TE配置。
评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
配置动态BFD检测SR-TE LSP示例

配置动态BFD检测SR-TE LSP示例

组网需求

图5-13所示,PE1要建立一条到PE2的隧道,同时建立主备两条LSP,路径的生成和数据的转发采用SR(Segment Routing)协议。PE1为隧道的入节点,P1为中间节点,PE2为出节点。PE2负责收集网络拓扑信息并通过BGP-LS发布路由信息的方式上报给控制器,控制器通过收集的拓扑信息计算标签路径,并将路径信息下发给入节点PE1。

该隧道采用热备份保护方式,通过配置动态BFD检测SR-TE LSP,可以快速检测SR-TE LSP的故障,为SR-TE LSP中的流量提供保护。当主LSP故障时,流量切换到备份LSP;当主LSP故障恢复,则进行流量回切。

说明:

与第三方对接时,如果对端不支持BFD功能,可通过配置BFD单臂检测,对链路进行检测。

图5-13 配置动态BFD for SR-TE LSP组网图

配置思路

采用如下的思路配置动态BFD检测SR-TE LSP:

  1. 配置接口IP地址和IS-IS协议,实现各节点路由可达。

  2. 在各节点使能全局的MPLS、MPLS TE和SR能力,使能各接口的MPLS和MPLS TE,以便建立SR-TE隧道。

  3. 在各节点配置IS-IS的SR-TE能力,使得TE信息可以发布到其他节点。

  4. 在PE2和控制器之间建立BGP-LS邻居,通过BGP-LS发布路由信息的方式将拓扑信息上报控制器。

  5. 在PE1创建隧道接口,指定隧道的IP地址、隧道协议、目的地址以及隧道带宽。

  6. 在PE1配置隧道的CR-LSP热备份。

  7. 在PE1使能BFD,配置动态BFD for TE LSP能力;在PE2使能被动创建BFD会话。

数据准备

为完成此配置例,需准备如下数据:

  • 网络中设备互连的接口IP地址,如图5-13所示。

  • IS-IS协议的进程号为1,各节点的IS-IS System ID由各节点Loopback0的IP地址转换得到,IS-IS级别为Level-2。

  • BGP协议的进程号为100,在控制器和P1之间建立BGP-LS邻居,如图5-13所示。

  • BFD会话的名称,本地和远端标识符。

操作步骤

  1. 配置各接口的IP地址

    配置各接口的IP地址和掩码。具体配置请参考配置文件

  2. 配置IS-IS协议发布各节点接口所连网段和LSR-ID的主机路由

    在PE1、P1和PE2上配置IS-IS,使设备间路由互通。具体配置请参考配置文件

  3. 配置MPLS基本能力,使能MPLS TE

    # 配置PE1。P1、PE2的配置与PE1类似,这里不再赘述。具体配置请参考配置文件

    [~PE1] mpls lsr-id 1.1.1.1
    [*PE1] mpls
    [*PE1-mpls] mpls te
    [*PE1-mpls] quit
    [*PE1] interface 10ge 1/0/1
    [*PE1-10GE1/0/1] mpls
    [*PE1-10GE1/0/1] mpls te
    [*PE1-10GE1/0/1] quit
    [*PE1] commit

  4. 在各节点全局使能SR能力

    # 配置PE1。P1、PE2的配置与PE1类似,这里不再赘述。具体配置请参考配置文件

    [~PE1] segment-routing
    [*PE1-segment-routing] quit
    [*PE1] commit

  5. 在各节点配置IS-IS的SR-TE能力

    # 配置PE1。P1、PE2的配置与PE1类似,这里不再赘述。具体配置请参考配置文件

    [~PE1] isis 1
    [~PE1-isis-1] cost-style wide
    [*PE1-isis-1] traffic-eng level-2
    [*PE1-isis-1] segment-routing mpls
    [*PE1-isis-1] quit
    [*PE1] commit

  6. 配置控制器和转发器之间的BGP-LS邻居

    在控制器和PE2之间配置BGP-LS邻居,使控制器和PE2能够互通,以便PE2通过BGP-LS发布路由信息的方式将拓扑信息上报控制器。

    # 在PE2上配置IS-IS协议向BGP发布网络拓扑的能力。
    [~PE2] isis 1
    [~PE2-isis-1] bgp-ls enable level-2
    [*PE2-isis-1] bgp-ls identifier 20
    [*PE2-isis-1] quit
    [*PE2] commit
    # 在PE2上配置BGP-LS路由发布能力。
    [~PE2] bgp 100
    [*PE2-bgp] peer 10.2.1.2 as-number 100
    [*PE2-bgp] link-state-family unicast
    [*PE2-bgp-af-ls] peer 10.2.1.2 enable
    [*PE2-bgp-af-ls] quit
    [*PE2-bgp] quit
    [*PE2] commit

  7. 在入节点配置隧道接口

    # 配置PE1。

    [~PE1] interface tunnel1
    [*PE1-Tunnel1] ip address unnumbered interface loopback 0
    [*PE1-Tunnel1] tunnel-protocol mpls te
    [*PE1-Tunnel1] destination 3.3.3.3
    [*PE1-Tunnel1] mpls te tunnel-id 1
    [*PE1-Tunnel1] mpls te signal-protocol segment-routing
    [*PE1-Tunnel1] mpls te pce delegate
    [*PE1-Tunnel1] mpls te backup hot-standby
    [*PE1-Tunnel1] quit
    [*PE1] commit
    

  8. 检查配置结果

    # 上述配置成功后,在PE1上执行display mpls te tunnel-interface命令,可以看到SR-TE隧道的接口信息。

    [~PE1] display mpls te tunnel-interface tunnel 1
        Tunnel Name       : Tunnel1
        Signalled Tunnel Name: -
        Tunnel State Desc : Primary CR-LSP Up and HotBackup CR-LSP Up
        Tunnel Attributes   :     
        Active LSP          : Primary LSP
        Traffic Switch      : - 
        Session ID          : 1
        Ingress LSR ID      : 1.1.1.1               Egress LSR ID: 3.3.3.3
        Admin State         : UP                    Oper State   : UP
        Signaling Protocol  : Segment-Routing
        FTid                : 32769
        Tie-Breaking Policy : None                  Metric Type  : None
        Bfd Cap             : None                  
        Reopt               : Disabled              Reopt Freq   : -              
        Auto BW             : Disabled              Threshold    : - 
        Current Collected BW: -                     Auto BW Freq : -
        Min BW              : -                     Max BW       : -
        Offload             : Disabled              Offload Freq : - 
        Low Value           : -                     High Value   : - 
        Readjust Value      : - 
        Offload Explicit Path Name: -
        Tunnel Group        : Primary
        Interfaces Protected: -
        Excluded IP Address : -
        Referred LSP Count  : 0
        Primary Tunnel      : -                     Pri Tunn Sum : -
        Backup Tunnel       : -
        Group Status        : Up                    Oam Status   : None
        IPTN InLabel        : -                     Tunnel BFD Status : -
        BackUp LSP Type     : Hot-Standby           BestEffort   : Disabled
        Secondary HopLimit  : -
        BestEffort HopLimit  : -
        Secondary Explicit Path Name: -
        Secondary Affinity Prop/Mask: 0x0/0x0
        BestEffort Affinity Prop/Mask: 0x0/0x0  
        IsConfigLspConstraint: -
        Hot-Standby Revertive Mode:  Revertive
        Hot-Standby Overlap-path:  Disabled
        Hot-Standby Switch State:  CLEAR
        Bit Error Detection:  Disabled
        Bit Error Detection Switch Threshold:  -
        Bit Error Detection Resume Threshold:  -
        Ip-Prefix Name    : -
        P2p-Template Name : -
        PCE Delegate      : Active                 LSP Control Status : PCE control
        Auto BW Remain Time   : -                     Reopt Remain Time     : -
                    
                    
        Primary LSP ID      : 1.1.1.1:21
        LSP State           : UP                    LSP Type     : Primary
        Setup Priority      : 7                     Hold Priority: 7
        IncludeAll          : 0x0
        IncludeAny          : 0x0
        ExcludeAny          : 0x0
        Affinity Prop/Mask  : 0x0/0x0               Resv Style   :  SE
        Configured Bandwidth Information:
        CT0 Bandwidth(Kbit/sec): 0               CT1 Bandwidth(Kbit/sec): 0
        CT2 Bandwidth(Kbit/sec): 0               CT3 Bandwidth(Kbit/sec): 0
        CT4 Bandwidth(Kbit/sec): 0               CT5 Bandwidth(Kbit/sec): 0
        CT6 Bandwidth(Kbit/sec): 0               CT7 Bandwidth(Kbit/sec): 0
        Actual Bandwidth Information:
        CT0 Bandwidth(Kbit/sec): 0               CT1 Bandwidth(Kbit/sec): 0
        CT2 Bandwidth(Kbit/sec): 0               CT3 Bandwidth(Kbit/sec): 0
        CT4 Bandwidth(Kbit/sec): 0               CT5 Bandwidth(Kbit/sec): 0
        CT6 Bandwidth(Kbit/sec): 0               CT7 Bandwidth(Kbit/sec): 0
        Explicit Path Name  : -                                Hop Limit: -
        Record Route        : Disabled              Record Label : Disabled
        Route Pinning       : Disabled
        FRR Flag            : Disabled
        IdleTime Remain     : -
        BFD Status          : -
        Soft Preemption     : Disabled
        Reroute Flag        : Enabled
        Pce Flag            : Normal
                    
        Backup LSP ID       : 1.1.1.1:26
        IsBestEffortPath    : No
        LSP State           : UP                    LSP Type     : Hot-Standby
        Setup Priority      : 7                     Hold Priority: 7
        IncludeAll          : 0x0
        IncludeAny          : 0x0
        ExcludeAny          : 0x0
        Affinity Prop/Mask  : 0x0/0x0               Resv Style   :  SE
        Configured Bandwidth Information:
        CT0 Bandwidth(Kbit/sec): 0               CT1 Bandwidth(Kbit/sec): 0
        CT2 Bandwidth(Kbit/sec): 0               CT3 Bandwidth(Kbit/sec): 0
        CT4 Bandwidth(Kbit/sec): 0               CT5 Bandwidth(Kbit/sec): 0
        CT6 Bandwidth(Kbit/sec): 0               CT7 Bandwidth(Kbit/sec): 0
        Actual Bandwidth Information:
        CT0 Bandwidth(Kbit/sec): 0               CT1 Bandwidth(Kbit/sec): 0
        CT2 Bandwidth(Kbit/sec): 0               CT3 Bandwidth(Kbit/sec): 0
        CT4 Bandwidth(Kbit/sec): 0               CT5 Bandwidth(Kbit/sec): 0
        CT6 Bandwidth(Kbit/sec): 0               CT7 Bandwidth(Kbit/sec): 0
        Explicit Path Name  : -                                Hop Limit: -
        Record Route        : Disabled              Record Label : Disabled
        Route Pinning       : Disabled
        FRR Flag            : Disabled
        IdleTime Remain     : -
        BFD Status          : -
        Soft Preemption     : Disabled
        Reroute Flag        : Enabled
        Pce Flag            : Normal

    # 在PE1上执行display mpls te tunnel命令,可以看到SR-TE隧道的建立情况。

    [~PE1] display mpls te tunnel
    -------------------------------------------------------------------------------
    Ingress LsrId   Destination     LSPID In/OutLabel     R Tunnel-name
    -------------------------------------------------------------------------------
    1.1.1.1         3.3.3.3         21    -/33200         I Tunnel1
    1.1.1.1         3.3.3.3         26    -/33153         I Tunnel1
    -------------------------------------------------------------------------------
    R: Role, I: Ingress, T: Transit, E: Egress
    # 在PE1上执行display mpls te tunnel path命令,可以看到SR-TE隧道的路径信息。
    [~PE1] display mpls te tunnel path
     Tunnel Interface Name : Tunnel1
     Lsp ID : 1.1.1.1 :1 :21
     Hop Information
      Hop 0    Link label 33200    NAI 10.1.1.2
    
     Tunnel Interface Name : Tunnel1
     Lsp ID : 1.1.1.1 :1 :26
     Hop Information
      Hop 0    Link label 33153    NAI 10.1.2.2
      Hop 1    Link label 40001    NAI 10.1.3.1

  9. 在入节点PE1上使能BFD,并配置BFD for SR-TE LSP能力

    # 在PE1上的Tunnel接口下使能BFD for SR-TE LSP能力,并指定本地发送BFD报文的最小时间间隔和允许接收的最小时间间隔都为100毫秒,BFD本地检测倍数为3。

    [~PE1] bfd
    [*PE1-bfd] quit
    [*PE1] interface tunnel 1
    [*PE1-Tunnel1] mpls te bfd enable
    [*PE1-Tunenl1] quit
    [*PE1] commit

  10. 在出节点PE2使能被动创建BFD会话

    [~PE2] bfd
    [*PE2-bfd] mpls-passive
    [*PE2-bfd] quit
    [*PE2] commit

    # 完成此步骤后,在PE1上执行display bfd session mpls-te interface tunnel,在PE2上执行display bfd session all,可发现BFD会话状态为Up。

    [~PE1] display bfd session mpls-te interface tunnel 1 te-lsp
    S: Static session
    D: Dynamic session
    IP: IP session
    IF: Single-hop session
    PEER: Multi-hop session
    LDP: LDP session
    LSP: Label switched path
    TE: Traffic Engineering
    AUTO: Automatically negotiated session
    VXLAN: VXLAN session
    (w): State in WTR
    (*): State is invalid
    Total UP/DOWN Session Number : 2/0
    --------------------------------------------------------------------------------
    Local      Remote     PeerIpAddr      State     Type        InterfaceName 
    --------------------------------------------------------------------------------
    16385      16386      3.3.3.3         Up        D/TE-LSP     Tunnel1
    16386      16387      3.3.3.3         Up        D/TE-LSP     Tunnel1
    --------------------------------------------------------------------------------
    [~PE2] display bfd session all
    S: Static session
    D: Dynamic session
    IP: IP session
    IF: Single-hop session
    PEER: Multi-hop session
    LDP: LDP session
    LSP: Label switched path
    TE: Traffic Engineering
    AUTO: Automatically negotiated session
    VXLAN: VXLAN session
    (w): State in WTR
    (*): State is invalid
    Total UP/DOWN Session Number : 2/0
    --------------------------------------------------------------------------------
    Local      Remote     PeerIpAddr      State     Type        InterfaceName 
    --------------------------------------------------------------------------------
    16386      16385      1.1.1.1         Up        E_Dynamic          -
    16387      16386      1.1.1.1         Up        E_Dynamic          -
    --------------------------------------------------------------------------------

配置文件

  • PE1的配置文件

    #
    sysname PE1
    #
    bfd
    #
    mpls lsr-id 1.1.1.1
    #
    mpls
     mpls te
    #
    segment-routing
    #
    isis 1
     is-level level-2
     cost-style wide
     network-entity 11.2222.2222.2222.00
     traffic-eng level-2
     segment-routing mpls
    #
    interface 10GE1/0/1
     undo portswitch
     ip address 10.1.1.1 255.255.255.0
     isis enable 1
     mpls
     mpls te
    #
    interface 10GE1/0/2
     undo portswitch
     ip address 10.1.2.1 255.255.255.0
     isis enable 1
     mpls
     mpls te
    #
    interface LoopBack0
     ip address 1.1.1.1 255.255.255.255
     isis enable 1
    #
     interface Tunnel1
     ip address unnumbered interface LoopBack0
     tunnel-protocol mpls te
     destination 3.3.3.3
     mpls te signal-protocol segment-routing
     mpls te backup hot-standby
     mpls te tunnel-id 1
     mpls te pce delegate
     mpls te bfd enable
    #
    return
  • P1的配置文件

    #
    sysname P1
    #
    mpls lsr-id 2.2.2.2
    #
    mpls
     mpls te
    #
    segment-routing
    #
    isis 1
     is-level level-2
     cost-style wide
     network-entity 11.1111.1111.1111.00
     traffic-eng level-2
     segment-routing mpls
    #
    interface 10GE1/0/2
     undo portswitch
     ip address 10.1.2.2 255.255.255.0
     isis enable 1
     mpls
     mpls te
    #
    interface 10GE1/0/3
     undo portswitch
     ip address 10.1.3.2 255.255.255.0
     isis enable 1
     mpls
     mpls te
    #
    interface LoopBack0
     ip address 2.2.2.2 255.255.255.255
     isis enable 1
    #
    return
  • PE2的配置文件

    #
    sysname PE2
    #
    bfd
     mpls-passive
    #
    mpls lsr-id 3.3.3.3
    #
    mpls
     mpls te
    #
    segment-routing
    #
    isis 1
     is-level level-2
     cost-style wide
     network-entity 11.3333.3333.3333.00
     traffic-eng level-2
     segment-routing mpls
     bgp-ls enable level-2
     bgp-ls identifier 20
    #
    interface 10GE1/0/1
     undo portswitch
     ip address 10.1.1.2 255.255.255.0
     isis enable 1
     mpls
     mpls te
    #
    interface 10GE1/0/2
     undo portswitch
     ip address 10.2.1.1 255.255.255.0
     isis enable 1
     mpls
     mpls te
    #
    interface 10GE1/0/3
     undo portswitch
     ip address 10.1.3.1 255.255.255.0
     isis enable 1
     mpls
     mpls te
    #
    interface LoopBack0 
     ip address 3.3.3.3 255.255.255.255
     isis enable 1
    #
    bgp 100
     peer 10.2.1.2 as-number 100
     #
     ipv4-family unicast
      peer 10.2.1.2 enable
     #
     link-state-family unicast
      peer 10.2.1.2 enable
    #
    return
翻译
下载文档
更新时间:2019-05-05

文档编号:EDOC1100004215

浏览量:29223

下载量:483

平均得分:
本文档适用于这些产品
相关文档
相关版本
Share
上一页 下一页