所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

CloudEngine 12800 V200R003C00 配置指南-MPLS

本文档介绍了MPLS的配置,具体包括MPLS基础、MPLS LDP配置、MPLS QoS配置、MPLS TE配置和SR-TE配置。
评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
配置SR-TE隧道示例

配置SR-TE隧道示例

组网需求

图5-11所示,PE1要建立一条到PE2的隧道,同时建立一条PE1到PE2的LSP,路径的生成和数据的转发采用SR(Segment Routing)协议。PE1为隧道的入节点,P1为中间节点,PE2为出节点。P1负责收集网络拓扑信息并通过BGP-LS发布路由信息的方式上报给控制器,控制器通过收集的拓扑信息计算标签路径,并将路径信息下发给入节点PE1。

图5-11 配置SR-TE隧道组网图

配置思路

采用如下的思路配置SR-TE隧道:

  1. 配置接口IP地址和IS-IS协议,实现各节点路由可达。

  2. 在各节点使能全局的MPLS、MPLS TE和SR能力,使能各接口的MPLS和MPLS TE,以便建立SR-TE隧道。

  3. 在各节点配置IS-IS的SR-TE能力,使得TE信息可以发布到其他节点。

  4. 在P1和控制器之间建立BGP-LS邻居,通过BGP-LS发布路由信息的方式将拓扑信息上报控制器。

  5. 在PE1创建隧道接口,指定隧道的IP地址、隧道协议、目的地址以及隧道带宽。

数据准备

为完成此配置例,需准备如下数据:

  • 网络中设备互连的接口IP地址,如图5-11所示。

  • IS-IS协议的进程号为1,各节点的IS-IS System ID由各节点Loopback0的IP地址转换得到,IS-IS级别为Level-2。

  • BGP协议的进程号为100,在控制器和P1之间建立BGP-LS邻居,如图5-11所示。

操作步骤

  1. 配置各接口的IP地址

    配置各接口的IP地址和掩码。具体配置请参考配置文件

  2. 配置IS-IS协议发布各节点接口所连网段和LSR-ID的主机路由

    在PE1、P1和PE2上配置IS-IS,使设备间路由互通。具体配置请参考配置文件

  3. 配置MPLS基本能力,使能MPLS TE

    # 配置PE1。P1、PE2的配置与PE1类似,这里不再赘述。具体配置请参考配置文件

    [~PE1] mpls lsr-id 2.1.2.9
    [*PE1] mpls
    [*PE1-mpls] mpls te
    [*PE1-mpls] quit
    [*PE1] interface 10ge 1/0/1
    [*PE1-10GE1/0/1] mpls
    [*PE1-10GE1/0/1] mpls te
    [*PE1-10GE1/0/1] quit
    [*PE1] commit

  4. 在各节点全局使能SR能力

    # 配置PE1。P1、PE2的配置与PE1类似,这里不再赘述。具体配置请参考配置文件

    [~PE1] segment-routing
    [*PE1-segment-routing] quit
    [*PE1] commit

  5. 在各节点配置IS-IS的SR-TE能力

    # 配置PE1。P1、PE2的配置与PE1类似,这里不再赘述。具体配置请参考配置文件

    [~PE1] isis 1
    [~PE1-isis-1] cost-style wide
    [*PE1-isis-1] traffic-eng level-2
    [*PE1-isis-1] segment-routing mpls
    [*PE1-isis-1] quit
    [*PE1] commit

  6. 配置控制器和转发器之间的BGP-LS邻居

    在控制器和P1之间配置BGP-LS邻居,使控制器和P1能够互通,以便P1通过BGP-LS发布路由信息的方式将拓扑信息上报控制器。

    # 在P1上配置IS-IS协议向BGP发布网络拓扑的能力。
    [~P1] isis 1
    [~P1-isis-1] bgp-ls enable level-2
    [*P1-isis-1] bgp-ls identifier 20
    [*P1-isis-1] quit
    [*P1] commit
    # 在P1上配置BGP-LS路由发布能力。
    [~P1] bgp 100
    [*P1-bgp] peer 7.1.2.9 as-number 100
    [*P1-bgp] link-state-family unicast
    [*P1-bgp-af-ls] peer 7.1.2.9 enable
    [*P1-bgp-af-ls] quit
    [*P1-bgp] quit
    [*P1] commit

  7. 在入节点配置隧道接口

    # 配置PE1。

    [~PE1] interface tunnel1
    [*PE1-Tunnel1] ip address unnumbered interface loopback 0
    [*PE1-Tunnel1] tunnel-protocol mpls te
    [*PE1-Tunnel1] destination 4.1.2.9
    [*PE1-Tunnel1] mpls te tunnel-id 1
    [*PE1-Tunnel1] mpls te signal-protocol segment-routing
    [*PE1-Tunnel1] mpls te pce delegate
    [*PE1-Tunnel1] quit
    [*PE1] commit
    

  8. 检查配置结果

    # 上述配置成功后,在P1上执行display bgp link-state unicast peer命令,可以查看到BGP-LS对等体及其状态信息。
    [~P1] display bgp link-state unicast peer
     BGP local router ID        : 11.1.1.2
     Local AS number            : 100
     Total number of peers      : 1
     Peers in established state : 1
    
      Peer            V          AS  MsgRcvd  MsgSent  OutQ  Up/Down       State  PrefRcv
      7.1.2.9         4         100       27       48     0 00:29:11 Established       17
    
    # 在PE1上执行display interface tunnel命令,可以看到Tunnel接口的状态为Up。
    [~PE1] display interface tunnel
    Tunnel1 current state : UP (ifindex: 1554)
    Line protocol current state : UP 
    Last line protocol up time : 2017-04-06 14:20:51
    Description: 
    Route Port,The Maximum Transmit Unit is 1500
    Internet Address is unnumbered, using address of LoopBack0(2.1.2.9/32)
    Encapsulation is TUNNEL, loopback not set
    Tunnel destination 4.1.2.9
    Tunnel up/down statistics 1
    Tunnel ct0 bandwidth is 0 Kbit/sec
    Tunnel protocol/transport MPLS/MPLS, ILM is available
    primary tunnel id is 0x6001, secondary tunnel id is 0x0
    Current system time: 2017-04-06 15:41:50
        0 seconds output rate 0 bits/sec, 0 packets/sec
        0 seconds output rate 0 bits/sec, 0 packets/sec
        0 packets output,  0 bytes
        0 output error
        0 output drop
        Last 300 seconds input utility rate:  --
        Last 300 seconds output utility rate: --
    
    # 在PE1上执行display mpls te tunnel命令,可以看到SR-TE隧道的建立情况。
    [~PE1] display mpls te tunnel
    -------------------------------------------------------------------------------
    Ingress LsrId   Destination     LSPID In/OutLabel     R Tunnel-name
    -------------------------------------------------------------------------------
    2.1.2.9         4.1.2.9         7     -/33153         I Tunnel1
    -------------------------------------------------------------------------------
    R: Role, I: Ingress, T: Transit, E: Egress
    # 在PE1上执行display mpls te tunnel path命令,可以看到SR-TE隧道的路径信息。
    [~PE1] display mpls te tunnel path
     Tunnel Interface Name : Tunnel1
     Lsp ID : 2.1.2.9 :1 :7
     Hop Information
      Hop 0    Link label 33153    NAI 10.1.23.3
      Hop 1    Link label 40001    NAI 20.1.34.4
    
    

配置文件

  • PE1的配置文件

    #
    sysname PE1
    #
    mpls lsr-id 2.1.2.9
    #
    mpls
     mpls te
    #
    segment-routing
    #
    isis 1
     is-level level-2
     cost-style wide
     network-entity 11.2222.2222.2222.00
     traffic-eng level-2
     segment-routing mpls
    #
    interface 10GE1/0/1
     undo portswitch
     ip address 10.1.23.2 255.255.255.0
     isis enable 1
     mpls
     mpls te
    #
    interface LoopBack0
     ip address 2.1.2.9 255.255.255.255
     isis enable 1
    #
    interface Tunnel1
     ip address unnumbered interface LoopBack0
     tunnel-protocol mpls te
     destination 4.1.2.9
     mpls te signal-protocol segment-routing
     mpls te tunnel-id 1
     mpls te pce delegate
    #
    return
  • P1的配置文件

    #
    sysname P1
    #
    mpls lsr-id 3.1.2.9
    #
    mpls
     mpls te
    #
    segment-routing
    #
    isis 1
     is-level level-2
     cost-style wide
     network-entity 11.1111.1111.1111.00
     traffic-eng level-2
     segment-routing mpls
     bgp-ls enable level-2
     bgp-ls identifier 20
    #
    interface 10GE1/0/1
     undo portswitch
     ip address 10.1.23.3 255.255.255.0
     isis enable 1
     mpls
     mpls te
    #
    interface 10GE1/0/2
     undo portswitch
     ip address 20.1.34.3 255.255.255.0
     isis enable 1
     mpls
     mpls te
    #
    interface 10GE1/0/3
     undo portswitch
     ip address 7.1.2.10 255.255.255.0
     isis enable 1
    #
    interface LoopBack0
     ip address 3.1.2.9 255.255.255.255
     isis enable 1
    #
    bgp 100
     peer 7.1.2.9 as-number 100
     #
     ipv4-family unicast
      peer 7.1.2.9 enable
     #
     link-state-family unicast
      peer 7.1.2.9 enable
    #
    return
  • PE2的配置文件

    #
    sysname PE2
    #
    mpls lsr-id 4.1.2.9
    #
    mpls
     mpls te
    #
    segment-routing
    #
    isis 1
     is-level level-2
     cost-style wide
     network-entity 11.3333.3333.3333.00
     traffic-eng level-2
     segment-routing mpls
    #
    interface 10GE1/0/2
     undo portswitch
     ip address 20.1.34.4 255.255.255.0
     isis enable 1
     mpls
     mpls te
    #
    interface LoopBack0 
     ip address 4.1.2.9 255.255.255.255
     isis enable 1
    #
    return
翻译
下载文档
更新时间:2019-05-05

文档编号:EDOC1100004215

浏览量:27864

下载量:477

平均得分:
本文档适用于这些产品
相关文档
相关版本
Share
上一页 下一页