所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

CloudEngine 12800 V200R003C00 配置指南-MPLS

本文档介绍了MPLS的配置,具体包括MPLS基础、MPLS LDP配置、MPLS QoS配置、MPLS TE配置和SR-TE配置。
评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
配置LDP GR示例

配置LDP GR示例

组网需求

图2-25所示,LSRA、LSRB、LSRC为MPLS骨干网设备,LSR上部署了MPLS LDP业务。设备主备倒换或系统升级过程中,邻居会因为会话进入Down状态而删除LSP,造成流量短时间中断。要求在主备倒换或系统升级过程中,邻居不会因为会话进入Down状态而删除LSP,实现流量短时间不中断。

图2-25 配置LDP GR组网

配置思路

配置LDP GR,可以实现此需求。采用如下配置思路:

  1. 在LSR上配置OSPF,实现骨干网的IP连通性。
  2. 在LSR配置本地LDP会话,实现创建LDP LSP来承载业务。
  3. 在LSR上配置LDP GR,实现流量短时间不中断。

操作步骤

  1. 交换机上创建VLAN、VLANIF接口,配置VLANIF接口的IP地址,并将相应的物理接口加入到VLAN

    # 配置LSRA。LSRB和LSRC的配置与LSRA类似,不再赘述。

    <HUAWEI> system-view
    [~HUAWEI] sysname LSRA
    [*HUAWEI] commit
    [~LSRA] interface loopback 0
    [*LSRA-LoopBack0] ip address 1.1.1.1 32
    [*LSRA-LoopBack0] quit
    [*LSRA] vlan batch 10
    [*LSRA] interface vlanif 10
    [*LSRA-Vlanif10] ip address 10.1.1.1 24
    [*LSRA-Vlanif10] quit
    [*LSRA] interface 10ge 1/0/1
    [*LSRA-10GE1/0/1] port link-type trunk
    [*LSRA-10GE1/0/1] port trunk allow-pass vlan 10
    [*LSRA-10GE1/0/1] quit
    [*LSRA] commit

  2. 配置OSPF协议发布各节点接口所连网段和LSR ID的主机路由

    # 配置LSRA。

    [~LSRA] ospf 1
    [*LSRA-ospf-1] area 0
    [*LSRA-ospf-1-area-0.0.0.0] network 1.1.1.1 0.0.0.0
    [*LSRA-ospf-1-area-0.0.0.0] network 10.1.1.0 0.0.0.255
    [*LSRA-ospf-1-area-0.0.0.0] commit
    [~LSRA-ospf-1-area-0.0.0.0] quit
    [~LSRA-ospf-1] quit

    # 配置LSRB。

    [~LSRB] ospf 1
    [*LSRB-ospf-1] area 0
    [*LSRB-ospf-1-area-0.0.0.0] network 2.2.2.2 0.0.0.0
    [*LSRB-ospf-1-area-0.0.0.0] network 10.1.1.0 0.0.0.255
    [*LSRB-ospf-1-area-0.0.0.0] network 10.2.1.0 0.0.0.255
    [*LSRB-ospf-1-area-0.0.0.0] commit
    [~LSRB-ospf-1-area-0.0.0.0] quit
    [~LSRB-ospf-1] quit

    # 配置LSRC。

    [~LSRC] ospf 1
    [*LSRC-ospf-1] area 0
    [*LSRC-ospf-1-area-0.0.0.0] network 3.3.3.3 0.0.0.0
    [*LSRC-ospf-1-area-0.0.0.0] network 10.2.1.0 0.0.0.255
    [*LSRC-ospf-1-area-0.0.0.0] commit
    [~LSRC-ospf-1-area-0.0.0.0] quit
    [~LSRC-ospf-1] quit

    # 配置完成后,在各节点上执行display ip routing-table命令,可以看到相互之间都学到了彼此的路由。

  3. 配置本地LDP会话

    # 配置LSRA。LSRB和LSRC的配置与LSRA类似,不再赘述。

    [~LSRA] mpls lsr-id 1.1.1.1
    [*LSRA] mpls
    [*LSRA-mpls] quit
    [*LSRA] mpls ldp
    [*LSRA-mpls-ldp] quit
    [*LSRA] interface vlanif 10
    [*LSRA-Vlanif10] mpls
    [*LSRA-Vlanif10] mpls ldp
    [*LSRA-Vlanif10] commit
    [~LSRA-Vlanif10] quit

    完成上述配置后,LSRA和LSRB、LSRB和LSRC之间的本地LDP会话建立成功。

    在各节点上执行display mpls ldp session命令,可以看到LDP会话的建立情况。以LSRA的显示为例:

    [~LSRA] display mpls ldp session
     LDP Session(s) in Public Network
     LAM: Label Advertisement Mode,  KA: KeepAlive
     SsnAge: Session Age, Unit(DDDD:HH:MM)
     An asterisk (*) before a session means the session is being deleted.
    ------------------------------------------------------------------------------
     PeerID             Status      LAM  SsnRole  SsnAge      KASent/Rcv
    ------------------------------------------------------------------------------
     2.2.2.2:0          Operational DU   Passive  0000:00:02   9/9
    ------------------------------------------------------------------------------
    TOTAL: 1 Session(s) Found.
    

  4. 配置LDP GR功能

    # 配置LSRA。

    [~LSRA] mpls ldp
    [~LSRA-mpls-ldp] graceful-restart
    [*LSRA-mpls-ldp] commit
    [~LSRA-mpls-ldp] quit

    # 配置LSRB。

    [~LSRB] mpls ldp
    [~LSRB-mpls-ldp] graceful-restart
    [*LSRB-mpls-ldp] commit
    [~LSRB-mpls-ldp] quit

    # 配置LSRC。

    [~LSRC] mpls ldp
    [~LSRC-mpls-ldp] graceful-restart
    [*LSRC-mpls-ldp] commit
    [~LSRC-mpls-ldp] quit

  5. 检查配置结果

    # 完成上述配置后,在LSR上执行display mpls ldp session verbose命令,可以看到“Session FT Flag”字段的值为“On”。以LSRA的显示为例。

    [~LSRA] display mpls ldp session verbose
     LDP Session(s) in Public Network
     ------------------------------------------------------------------------
     Peer LDP ID     : 2.2.2.2:0            Local LDP ID   : 1.1.1.1:0
     TCP Connection  : 1.1.1.1 <- 2.2.2.2
     Session State   : Operational          Session Role   : Passive
     Session FT Flag : On                   MD5 Flag       : Off
     Reconnect Timer : 300 Sec              Recovery Timer : 300 Sec
     Keychain Name   : --
     P2MP Capability      : Off
     MP2MP Capability     : Off
     Negotiated Keepalive Hold Timer   : 45 Sec
     Configured Keepalive Send Timer   : --
     Keepalive Message Sent/Rcvd       : 1/1 (Message Count)
     Label Advertisement Mode          : Downstream Unsolicited
     Label Resource Status(Peer/Local) : Available/Available
     Session Age                       : 0000:00:00  (DDDD:HH:MM)
    
     Outbound&Inbound Policies applied:
     outbound peer all split-horizon
    
     Addresses received from peer: ( Count: 3 )
     2.2.2.2             10.1.1.2            10.2.1.1
     ------------------------------------------------------------------------
    

    # 或者在LSR上执行display mpls ldp peer verbose命令,可以看到“Peer FT Flag”字段的值为“On”。以LSRA的显示为例。

    [~LSRA] display mpls ldp peer verbose
     LDP Peer Information in Public network
     -------------------------------------------------------------------------------
     Peer LDP ID            : 2.2.2.2:0
     Peer Max PDU Length    : 4096         Peer Transport Address : 2.2.2.2
     Peer Loop Detection    : Off          Peer Path Vector Limit : --
     Peer FT Flag           : On           Peer Keepalive Timer   : 45 Sec
     Recovery Timer         : 300 Sec      Reconnect Timer        : 300 Sec
     Peer Type              : Local
     Peer Label Advertisement Mode : Downstream Unsolicited
     Distributed ID         : 0
     Peer Discovery Source  : Vlanif10
     Capability-Announcement       : Off
     Peer mLDP P2MP Capability     : Off
     Peer mLDP MP2MP Capability    : Off
     Peer mLDP MBB Capability      : Off
     -------------------------------------------------------------------------------

配置文件

  • LSRA的配置文件

    #
    sysname LSRA
    #
    vlan batch 10
    #
    mpls lsr-id 1.1.1.1
    #
    mpls
    #
    mpls ldp
     graceful-restart
     #
     ipv4-family
    #
    interface Vlanif10
     ip address 10.1.1.1 255.255.255.0
     mpls
     mpls ldp
    #
    interface 10GE1/0/1
     port link-type trunk 
     port trunk allow-pass vlan 10 
    #
    interface LoopBack0
     ip address 1.1.1.1 255.255.255.255
    #
    ospf 1  
     area 0.0.0.0
      network 1.1.1.1 0.0.0.0
      network 10.1.1.0 0.0.0.255
    #
    return
  • LSRB的配置文件

    #
    sysname LSRB
    #
    vlan batch 10 20
    #
    mpls lsr-id 2.2.2.2
    #
    mpls
    #
    mpls ldp
     graceful-restart
     #
     ipv4-family
    #
    interface Vlanif10
     ip address 10.1.1.2 255.255.255.0
     mpls
     mpls ldp
    #
    interface Vlanif20
     ip address 10.2.1.1 255.255.255.0
     mpls
     mpls ldp
    #
    interface 10GE1/0/1
     port link-type trunk 
     port trunk allow-pass vlan 10 
    #
    interface 10GE2/0/2
     port link-type trunk 
     port trunk allow-pass vlan 20 
    #
    interface LoopBack0
     ip address 2.2.2.2 255.255.255.255
    #
    ospf 1 
     area 0.0.0.0
      network 2.2.2.2 0.0.0.0
      network 10.1.1.0 0.0.0.255
      network 10.2.1.0 0.0.0.255
    #
    return
  • LSRC的配置文件

    #
    sysname LSRC
    #
    vlan batch 20
    #
    mpls lsr-id 3.3.3.3
    #
    mpls
    #
    mpls ldp
     graceful-restart
     #
     ipv4-family
    #
    interface Vlanif20
     ip address 10.2.1.2 255.255.255.0
     mpls
     mpls ldp
    #
    interface 10GE1/0/1
     port link-type trunk 
     port trunk allow-pass vlan 20 
    #
    interface LoopBack0
     ip address 3.3.3.3 255.255.255.255
    #
    ospf 1  
     area 0.0.0.0
      network 3.3.3.3 0.0.0.0
      network 10.2.1.0 0.0.0.255
    #
    return
翻译
下载文档
更新时间:2019-05-05

文档编号:EDOC1100004215

浏览量:29286

下载量:486

平均得分:
本文档适用于这些产品
相关文档
相关版本
Share
上一页 下一页