所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

CloudEngine 12800 V200R003C00 配置指南-MPLS

本文档介绍了MPLS的配置,具体包括MPLS基础、MPLS LDP配置、MPLS QoS配置、MPLS TE配置和SR-TE配置。
评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
配置LDP Outbound策略示例

配置LDP Outbound策略示例

组网需求

图2-27所示网络中,部署了MPLS LDP业务。LSRD是接入设备,性能较低。如果不对LSRD收到的标签进行控制,则会建立大量的LSP,消耗大量内存,LSRD无法承受,所以LSRD只与LSRC建立LDP LSP。要求有效地减少LSP的数量,从而节约LSRD内存,减少资源的浪费。

图2-27 配置LDP Outbound策略组网

配置思路

配置LDP Outbound策略,可以实现此需求。采用如下配置思路:

  1. 在LSR上配置OSPF,实现骨干网的IP连通性。
  2. 在LSR上配置本地LDP会话,实现建立LDP LSP。
  3. 在LSRB上配置LDP Outbound策略,只给LSRD发送到LSRC的标签映射消息,实现节约LSRD内存,减少资源的浪费。

操作步骤

  1. 交换机上创建VLAN、VLANIF接口,配置VLANIF接口的IP地址

    # 配置LSRA。

    <HUAWEI> system-view
    [~HUAWEI] sysname LSRA
    [*HUAWEI] commit
    [~LSRA] interface loopback 1
    [*LSRA-LoopBack1] ip address 1.1.1.9 32
    [*LSRA-LoopBack1] quit
    [*LSRA] interface 10ge 1/0/1
    [*LSRA-10GE1/0/1] port link-type trunk
    [*LSRA-10GE1/0/1] port trunk allow-pass vlan 10
    [*LSRA-10GE1/0/1] quit
    [*LSRA] vlan 10
    [*LSRA-vlan10] quit
    [*LSRA] interface vlanif 10
    [*LSRA-Vlanif10] ip address 10.1.1.1 24
    [*LSRA-Vlanif10] quit
    [*LSRA] commit

    LSRB、LSRC、LSRD的配置与LSRA类似,不再赘述。

  2. 配置OSPF协议发布各节点接口所连网段和LSR ID的主机路由

    # 配置LSRA。

    [~LSRA] ospf 1
    [*LSRA-ospf-1] area 0
    [*LSRA-ospf-1-area-0.0.0.0] network 1.1.1.9 0.0.0.0
    [*LSRA-ospf-1-area-0.0.0.0] network 10.1.1.0 0.0.0.255
    [*LSRA-ospf-1-area-0.0.0.0] commit
    [~LSRA-ospf-1-area-0.0.0.0] quit
    [~LSRA-ospf-1] quit

    LSRB、LSRC、LSRD的配置与LSRA类似,不再赘述。

  3. 配置本地LDP会话

    # 配置LSRA。

    [~LSRA] mpls lsr-id 1.1.1.9
    [*LSRA] mpls
    [*LSRA-mpls] quit
    [*LSRA] mpls ldp
    [*LSRA-mpls-ldp] quit
    [*LSRA] interface vlanif 10
    [*LSRA-Vlanif10] mpls
    [*LSRA-Vlanif10] mpls ldp
    [*LSRA-Vlanif10] quit
    [*LSRA] commit

    # 配置LSRB。

    [~LSRB] mpls lsr-id 2.2.2.9
    [*LSRB] mpls
    [*LSRB-mpls] quit
    [*LSRB] mpls ldp
    [*LSRB-mpls-ldp] quit
    [*LSRB] interface vlanif 10
    [*LSRB-Vlanif10] mpls
    [*LSRB-Vlanif10] mpls ldp
    [*LSRB-Vlanif10] quit
    [*LSRB] interface vlanif 20
    [*LSRB-Vlanif20] mpls
    [*LSRB-Vlanif20] mpls ldp
    [*LSRB-Vlanif20] quit
    [*LSRB] interface vlanif 30
    [*LSRB-Vlanif30] mpls
    [*LSRB-Vlanif30] mpls ldp
    [*LSRB-Vlanif30] quit
    [*LSRB] commit

    # 配置LSRC。

    [~LSRC] mpls lsr-id 3.3.3.9
    [*LSRC] mpls
    [*LSRC-mpls] quit
    [*LSRC] mpls ldp
    [*LSRC-mpls-ldp] quit
    [*LSRC] interface vlanif 20
    [*LSRC-Vlanif20] mpls
    [*LSRC-Vlanif20] mpls ldp
    [*LSRC-Vlanif20] quit
    [*LSRC] commit

    # 配置LSRD。

    [~LSRD] mpls lsr-id 4.4.4.9
    [*LSRD] mpls
    [*LSRD-mpls] quit
    [*LSRD] mpls ldp
    [*LSRD-mpls-ldp] quit
    [*LSRD] interface vlanif 30
    [*LSRD-Vlanif30] mpls
    [*LSRD-Vlanif30] mpls ldp
    [*LSRD-Vlanif30] quit
    [*LSRD] commit

    # 配置完成后,在LSRD上执行display mpls lsp命令,查看已经建立的LSP。

    [~LSRD] display mpls lsp
    -------------------------------------------------------------------------------
    LSP Information: LDP LSP
    -------------------------------------------------------------------------------
                  FEC  In/Out Label    In/Out IF                      Vrf Name
            1.1.1.9/32 NULL/1024       -/Vlanif30                     
            2.2.2.9/32 NULL/3          -/Vlanif30                     
            3.3.3.9/32 NULL/1025       -/Vlanif30                     
            4.4.4.9/32 3/NULL          -/-                            
    

    从显示信息可以看到,LSRD上建立了到LSRA、LSRB、LSRC的LSP。

  4. 配置LDP Outbound策略

    # 在LSRB上配置IP地址前缀列表,只允许到LSRC的路由通过。

    [~LSRB] ip ip-prefix prefix1 permit 3.3.3.9 32
    [*LSRB] commit

    # 在LSRB上配置Outbound策略,只给LSRD发送到LSRC的标签映射消息。

    [~LSRB] mpls ldp
    [*LSRB-mpls-ldp] ipv4-family
    [*LSRB-mpls-ldp-ipv4] outbound peer 4.4.4.9 fec ip-prefix prefix1
    [*LSRB-mpls-ldp-ipv4] commit
    [~LSRB-mpls-ldp-ipv4] quit
    [~LSRB-mpls-ldp] quit

  5. 检查配置结果

    配置完成后,在LSRD上执行display mpls lsp命令,可以看到只建立了到LSRC的LSP。

    [~LSRD] display mpls lsp
    -------------------------------------------------------------------------------
    LSP Information: LDP LSP
    -------------------------------------------------------------------------------
                  FEC  In/Out Label    In/Out IF                      Vrf Name
            3.3.3.9/32 NULL/1025       -/Vlanif30                     
            4.4.4.9/32 3/NULL          -/-                            
    

配置文件

  • LSRA的配置文件

    #
    sysname LSRA
    #
    vlan batch 10
    #
    mpls lsr-id 1.1.1.9
    #
    mpls
    #
    mpls ldp
     #
     ipv4-family
    #
    interface Vlanif10
     ip address 10.1.1.1 255.255.255.0
     mpls
     mpls ldp
    #
    interface 10GE1/0/1
     port link-type trunk 
     port trunk allow-pass vlan 10 
    #
    interface LoopBack1
     ip address 1.1.1.9 255.255.255.255
    #
    ospf 1
     area 0.0.0.0
      network 1.1.1.9 0.0.0.0
      network 10.1.1.0 0.0.0.255
    #
    return
  • LSRB的配置文件

    #
    sysname LSRB
    #
    vlan batch 10 20 30
    #
    mpls lsr-id 2.2.2.9
    #
    mpls
    #
    mpls ldp
     #
     ipv4-family
      outbound peer 4.4.4.9 fec ip-prefix prefix1
    #
    interface Vlanif10
     ip address 10.1.1.2 255.255.255.0
     mpls
     mpls ldp
    #
    interface Vlanif20
     ip address 10.1.2.1 255.255.255.0
     mpls
     mpls ldp
    #
    interface Vlanif30
     ip address 10.1.3.2 255.255.255.0
     mpls
     mpls ldp
    #
    interface 10GE1/0/1
     port link-type trunk 
     port trunk allow-pass vlan 10 
    #
    interface 10GE2/0/3
     port link-type trunk 
     port trunk allow-pass vlan 20 
    #
    interface 10GE1/0/2
     port link-type trunk 
     port trunk allow-pass vlan 30 
    #
    interface LoopBack1
     ip address 2.2.2.9 255.255.255.255
    #
    ospf 1
     area 0.0.0.0
      network 2.2.2.9 0.0.0.0
      network 10.1.1.0 0.0.0.255
      network 10.1.2.0 0.0.0.255
      network 10.1.3.0 0.0.0.255
    #
     ip ip-prefix prefix1 index 10 permit 3.3.3.9 32
    #
    return
  • LSRC的配置文件

    #
    sysname LSRC
    #
    vlan batch 20 
    #
    mpls lsr-id 3.3.3.9
    #
    mpls
    #
    mpls ldp
     #
     ipv4-family
    #
    interface Vlanif20
     ip address 10.1.2.2 255.255.255.0
     mpls
     mpls ldp
    #
    interface 10GE1/0/1
     port link-type trunk 
     port trunk allow-pass vlan 20 
    #
    interface LoopBack1
     ip address 3.3.3.9 255.255.255.255
    #
    ospf 1
     area 0.0.0.0
      network 3.3.3.9 0.0.0.0
      network 10.1.2.0 0.0.0.255
    #
    return
  • LSRD的配置文件

    #
    sysname LSRD
    #
    vlan batch 30 
    #
    mpls lsr-id 4.4.4.9
    #
    mpls
    #
    mpls ldp
     #
     ipv4-family
    #
    interface Vlanif30
     ip address 10.1.3.1 255.255.255.0
     mpls
     mpls ldp
    #
    interface 10GE1/0/1
     port link-type trunk 
     port trunk allow-pass vlan 30 
    #
    interface LoopBack1
     ip address 4.4.4.9 255.255.255.255
    #
    ospf 1
     area 0.0.0.0
      network 4.4.4.9 0.0.0.0
      network 10.1.3.0 0.0.0.255
    #
    return
翻译
下载文档
更新时间:2019-05-05

文档编号:EDOC1100004215

浏览量:27551

下载量:477

平均得分:
本文档适用于这些产品
相关文档
相关版本
Share
上一页 下一页