所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

CloudEngine 12800 V200R003C00 配置指南-MPLS

本文档介绍了MPLS的配置,具体包括MPLS基础、MPLS LDP配置、MPLS QoS配置、MPLS TE配置和SR-TE配置。
评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
配置LDP over SR-TE示例

配置LDP over SR-TE示例

组网需求

图2-22所示,P1、P3为IP骨干网的边缘设备。PE1和PE2上需要部署MPLS L2VPN或L3VPN业务来实现VPN站点的互联。为了防止VPN流量在某些节点发生拥堵,需要使用SR-TE对流量进行调整,但是整个网络SR-TE的部署、维护比较复杂,而且PE设备不一定都支持SR-TE。因此用户可以规划一个核心的SR-TE区域,在此区域中部署SR-TE,此区域外运行LDP,从而保证VPN业务的正常运行。

图2-22 配置LDP over SR-TE组网

配置思路

采用如下思路配置LDP over SR-TE:

  1. 配置各个节点的接口IP地址及作为LSR ID的Loopback地址,并配置IGP协议发布路由。
  2. 在IP骨干网区域建立SR-TE隧道。
  3. 在非IP骨干网区域使能MPLS LDP,并在P1和P3设备上配置LDP远端会话。
  4. 在P1和P3设备上配置转发捷径功能。

操作步骤

  1. 配置个各节点的接口IP地址及作为LSR ID的Loopback地址,并配置IGP协议发布路由
    1. 交换机上创建Loopback接口、VLAN、VLANIF接口,配置Loopback接口和VLANIF接口的IP地址,并将相应的物理接口加入到VLAN

      # 配置PE1。P1、P2、P3和PE2的配置与PE1类似,不再赘述。

      <HUAWEI> system-view
      [~HUAWEI] sysname PE1
      [*HUAWEI] commit
      [~PE1] interface loopback 0
      [*PE1-LoopBack0] ip address 1.1.1.1 32
      [*PE1-LoopBack0] quit
      [*PE1] vlan batch 10
      [*PE1] interface vlanif 10
      [*PE1-Vlanif10] ip address 10.1.1.1 24
      [*PE1-Vlanif10] quit
      [*PE1] interface 10ge 1/0/1
      [*PE1-10GE1/0/1] port link-type trunk
      [*PE1-10GE1/0/1] port trunk allow-pass vlan 10
      [*PE1-10GE1/0/1] quit
      [*PE1] commit

    2. 配置IS-IS协议发布各节点接口所连网段和LSR ID的主机路由

      # 配置PE1。P1、P2、P3和PE2的配置与PE1类似,不再赘述。

      [~PE1] isis 1
      [*PE1-isis-1] network-entity 11.1111.1111.1111.00
      [*PE1-isis-1] cost-style wide
      [*PE1-isis-1] quit
      [*PE1] interface vlanif 10
      [*PE1-Vlanif10] isis enable 1
      [*PE1-Vlanif10] quit
      [*PE1] interface loopback 0
      [*PE1-LoopBack0] isis enable 1
      [*PE1-LoopBack0] quit
      [*PE1] commit

      # 配置完成后,在各节点上执行display ip routing-table命令,可以看到相互之间都学到了彼此的路由。

      以PE1的显示为例。

      [~PE1] display ip routing-table
      Proto: Protocol        Pre: Preference
      Route Flags: R - relay, D - download to fib, T - to vpn-instance, B - black hole route
      ------------------------------------------------------------------------------
      Routing Table : _public_
               Destinations : 15       Routes : 15
      
      Destination/Mask    Proto   Pre  Cost        Flags NextHop         Interface
      
              1.1.1.1/32  Direct  0    0             D   127.0.0.1       LoopBack0
              2.2.2.2/32  ISIS    15   1             D   10.1.1.2        Vlanif10
              3.3.3.3/32  ISIS    15   2             D   10.1.1.2        Vlanif10
              4.4.4.4/32  ISIS    15   3             D   10.1.1.2        Vlanif10
              5.5.5.5/32  ISIS    15   4             D   10.1.1.2        Vlanif10
             10.1.1.0/24  Direct  0    0             D   10.1.1.1        Vlanif10
             10.1.1.1/32  Direct  0    0             D   127.0.0.1       Vlanif10
           10.1.1.255/32  Direct  0    0             D   127.0.0.1       Vlanif10
             10.2.1.0/24  ISIS    15   2             D   10.1.1.2        Vlanif10
             10.3.1.0/24  ISIS    15   3             D   10.1.1.2        Vlanif10
             10.4.1.0/24  ISIS    15   4             D   10.1.1.2        Vlanif10
            127.0.0.0/8   Direct  0    0             D   127.0.0.1       InLoopBack0
            127.0.0.1/32  Direct  0    0             D   127.0.0.1       InLoopBack0
      127.255.255.255/32  Direct  0    0             D   127.0.0.1       InLoopBack0
      255.255.255.255/32  Direct  0    0             D   127.0.0.1       InLoopBack0

  2. 在IP骨干网区域创建SR-TE隧道
    1. 在节点P1、P2和P3上全局使能MPLS、MPLS TE和SR,配置IS-IS的SR-TE能力;在隧道沿途的接口上使能MPLS和MPLS TE。

      # 配置P1。P2和P3的配置与P1类似,不再赘述。

      [~P1] mpls lsr-id 2.2.2.2
      [*P1] mpls
      [*P1-mpls] mpls te
      [*P1-mpls] quit
      [*P1] segment-routing
      [*P1-segment-routing] quit
      [*P1] isis 1
      [*P1-isis-1] traffic-eng
      [*P1-isis-1] segment-routing mpls
      [*P1-isis-1] quit
      [*P1] interface vlanif 20
      [*P1-Vlanif20] mpls
      [*P1-Vlanif20] mpls te
      [*P1-Vlanif20] quit
      [*P1] commit
      

    2. 配置控制器和转发器之间的BGP-LS邻居。

      在控制器和P3之间配置BGP-LS邻居,使控制器和P3能够互通,以便P3通过BGP-LS发布路由信息的方式将拓扑信息上报控制器。

      # 在P3上配置IS-IS协议向BGP发布网络拓扑的能力。
      [~P3] isis 1
      [~P3-isis-1] bgp-ls enable
      [*P3-isis-1] bgp-ls identifier 20
      [*P3-isis-1] quit
      [*P3] commit
      # 在P3上配置BGP-LS路由发布能力。
      [~P3] bgp 100
      [*P3-bgp] peer 7.1.2.9 as-number 100
      [*P3-bgp] link-state-family unicast
      [*P3-bgp-af-ls] peer 7.1.2.9 enable
      [*P3-bgp-af-ls] quit
      [*P3-bgp] quit
      [*P3] commit

    3. 在隧道入节点上创建Tunnel接口,并配置Tunnel接口的IP地址、隧道协议、目的地址、Tunnel ID、动态信令协议。

      # 配置P1。

      [~P1] interface tunnel 1
      [*P1-Tunnel1] ip address unnumbered interface loopback 0
      [*P1-Tunnel1] tunnel-protocol mpls te
      [*P1-Tunnel1] destination 4.4.4.4
      [*P1-Tunnel1] mpls te tunnel-id 100
      [*P1-Tunnel1] mpls te signal-protocol segment-routing
      [*P1-Tunnel1] mpls te pce delegate
      [*P1-Tunnel1] commit
      [~P1-Tunnel1] quit

      # 配置P3。

      [~P3] interface tunnel 1
      [*P3-Tunnel1] ip address unnumbered interface loopback 0
      [*P3-Tunnel1] tunnel-protocol mpls te
      [*P3-Tunnel1] destination 2.2.2.2
      [*P3-Tunnel1] mpls te tunnel-id 101
      [*P3-Tunnel1] mpls te signal-protocol segment-routing
      [*P3-Tunnel1] mpls te pce delegate
      [*P3-Tunnel1] commit
      [~P3-Tunnel1] quit

    # 上述配置完成后,在节点P1、P3上执行display interface tunnel命令可以看到隧道接口状态为UP。

    以P1的显示为例。

    [~P1] display interface tunnel 1
    Tunnel1 current state : UP (ifindex: 3147)
    Line protocol current state : UP
    Last line protocol up time : 2017-03-25 14:20:51
    Description:
    Route Port,The Maximum Transmit Unit is 1500
    Internet Address is unnumbered, using address of LoopBack0(2.2.2.2/32)
    Encapsulation is TUNNEL, loopback not set
    Tunnel destination 4.4.4.4
    Tunnel up/down statistics 1
    Tunnel ct0 bandwidth is 10000 Kbit/sec
    Tunnel protocol/transport MPLS/MPLS, ILM is available
    primary tunnel id is 0x41, secondary tunnel id is 0x0
    Current system time: 2017-03-25 14:30:58
        0 seconds output rate 0 bits/sec, 0 packets/sec
        0 seconds output rate 0 bits/sec, 0 packets/sec
        0 packets output,  0 bytes
        0 output error
        0 output drop
        Last 300 seconds input utility rate:  --
        Last 300 seconds output utility rate: --
    

    # 在节点P1、P3上执行display mpls te tunnel-interface命令可以看到隧道接口信息。

    以P1的显示为例。

    [~P1] display mpls te tunnel-interface
        Tunnel Name       : Tunnel1
        Signalled Tunnel Name: -
        Tunnel State Desc : CR-LSP is Up
        Tunnel Attributes   :
        Active LSP          : Primary LSP
        Traffic Switch      : -
        Session ID          : 100
        Ingress LSR ID      : 2.2.2.2               Egress LSR ID: 4.4.4.4
        Admin State         : UP                    Oper State   : UP
        Signaling Protocol  : Segment-Routing
        FTid                : 1
        Tie-Breaking Policy : None                  Metric Type  : None
        Bfd Cap             : None
        Reopt               : Disabled              Reopt Freq   : -
        Auto BW             : Disabled              Threshold    : -
        Current Collected BW: -                     Auto BW Freq : -
        Min BW              : -                     Max BW       : -
        Offload             : Disabled              Offload Freq : -
        Low Value           : -                     High Value   : -
        Readjust Value      : -
        Offload Explicit Path Name: -
        Tunnel Group        : Primary
        Interfaces Protected: -
        Excluded IP Address : -
        Referred LSP Count  : 0
        Primary Tunnel      : -                     Pri Tunn Sum : -
        Backup Tunnel       : -
        Group Status        : Up                    Oam Status   : None
        IPTN InLabel        : -                     Tunnel BFD Status : -
        BackUp LSP Type     : None                  BestEffort   : Disabled
        Secondary HopLimit  : -
        BestEffort HopLimit  : -
        Secondary Explicit Path Name: -
        Secondary Affinity Prop/Mask: 0x0/0x0
        BestEffort Affinity Prop/Mask: 0x0/0x0
        IsConfigLspConstraint: -
        Hot-Standby Revertive Mode:  Revertive
        Hot-Standby Overlap-path:  Disabled
        Hot-Standby Switch State:  CLEAR
        Bit Error Detection:  Disabled
        Bit Error Detection Switch Threshold:  -
        Bit Error Detection Resume Threshold:  -
        Ip-Prefix Name    : -
        P2p-Template Name : -
        PCE Delegate      : Active                 LSP Control Status : PCE control
        Auto BW Remain Time   : -                     Reopt Remain Time     : -
    
    
        Primary LSP ID      : 1.1.1.1:21
        LSP State           : UP                    LSP Type     : Primary
        Setup Priority      : 7                     Hold Priority: 7
        IncludeAll          : 0x0
        IncludeAny          : 0x0
        ExcludeAny          : 0x0
        Affinity Prop/Mask  : 0x0/0x0               Resv Style   :  SE
        Configured Bandwidth Information:
        CT0 Bandwidth(Kbit/sec): 0               CT1 Bandwidth(Kbit/sec): 0
        CT2 Bandwidth(Kbit/sec): 0               CT3 Bandwidth(Kbit/sec): 0
        CT4 Bandwidth(Kbit/sec): 0               CT5 Bandwidth(Kbit/sec): 0
        CT6 Bandwidth(Kbit/sec): 0               CT7 Bandwidth(Kbit/sec): 0
        Actual Bandwidth Information:
        CT0 Bandwidth(Kbit/sec): 0               CT1 Bandwidth(Kbit/sec): 0
        CT2 Bandwidth(Kbit/sec): 0               CT3 Bandwidth(Kbit/sec): 0
        CT4 Bandwidth(Kbit/sec): 0               CT5 Bandwidth(Kbit/sec): 0
        CT6 Bandwidth(Kbit/sec): 0               CT7 Bandwidth(Kbit/sec): 0
        Explicit Path Name  : -                                Hop Limit: -
        Record Route        : Disabled              Record Label : Disabled
        Route Pinning       : Disabled
        FRR Flag            : Disabled
        IdleTime Remain     : -
        BFD Status          : -
        Soft Preemption     : Disabled
        Reroute Flag        : Enabled
        Pce Flag            : Normal
    

  3. 在非IP骨干网区域使能MPLS LDP,并在P1和P3设备上配置LDP远端会话
    1. 配置PE1与P1、P3与PE2之间的LDP本地会话。

      # 配置PE1。PE2的配置与PE1类似,不再赘述。

      [~PE1] mpls lsr-id 1.1.1.1
      [*PE1] mpls
      [*PE1-mpls] quit
      [*PE1] mpls ldp
      [*PE1-mpls-ldp] quit
      [*PE1] interface vlanif 10
      [*PE1-Vlanif10] mpls
      [*PE1-Vlanif10] mpls ldp
      [*PE1-Vlanif10] commit
      [~PE1-Vlanif10] quit

      # 配置P1。P3的配置与P1类似,不再赘述。

      [~P1] mpls ldp
      [*P1-mpls-ldp] quit
      [*P1] interface vlanif 10
      [*P1-Vlanif10] mpls
      [*P1-Vlanif10] mpls ldp
      [*P1-Vlanif10] commit
      [~P1-Vlanif10] quit

      完成上述配置后,PE1与P1之间,P3与PE2之间的本地LDP会话已经建立成功。

      # 在节点PE1、P1、P3和PE2上执行命令display mpls ldp session,可以看到PE1与P1、P3与PE2之间的本地LDP会话状态为“Operational”。

      以PE1的显示为例:

      [~PE1] display mpls ldp session
       LDP Session(s) in Public Network
       LAM: Label Advertisement Mode,  KA: KeepAlive
       SsnAge: Session Age, Unit(DDDD:HH:MM)
       An asterisk (*) before a session means the session is being deleted.
      --------------------------------------------------------------------------
       PeerID             Status      LAM  SsnRole  SsnAge       KASent/Rcv
      --------------------------------------------------------------------------
       2.2.2.2:0          Operational DU   Active   0000:15:56   3826/3826
      --------------------------------------------------------------------------
      TOTAL: 1 Session(s) Found.

      # 在节点PE1、P1、P3和PE2上执行命令display mpls ldp peer,可以看到LDP对等体情况。

      以PE1的显示为例:

      [~PE1] display mpls ldp peer
       LDP Peer Information in Public network
       An asterisk (*) before a peer means the peer is being deleted.
       -------------------------------------------------------------------------------
       PeerID                 TransportAddress               DiscoverySource
       -------------------------------------------------------------------------------
       2.2.2.2:0              2.2.2.2                        Vlanif10
       -------------------------------------------------------------------------------
       TOTAL: 1 Peer(s) Found.

      # 在节点P1和P3上执行命令display mpls lsp查看LSP信息,发现新增了LDP LSP信息。

      以P1的显示为例:

      [~P1] display mpls lsp
      -------------------------------------------------------------------------------
      LSP Information: LDP LSP
      -------------------------------------------------------------------------------
                    FEC  In/Out Label    In/Out IF                      Vrf Name
              1.1.1.1/32 NULL/3          -/Vlanif10                     
              2.2.2.2/32 3/NULL          -/-                            
      

    2. 配置P1与P3上之间的LDP远端会话。

      # 配置P1。

      [~P1] mpls ldp remote-peer P3
      [*P1-mpls-ldp-remote-P3] remote-ip 4.4.4.4
      [*P1-mpls-ldp-remote-P3] commit
      [~P1-mpls-ldp-remote-P3] quit

      # 配置P3。

      [~P3] mpls ldp remote-peer P1 
      [*P3-mpls-ldp-remote-P1] remote-ip 2.2.2.2
      [*P3-mpls-ldp-remote-P1] commit
      [~P3-mpls-ldp-remote-P1] quit

      # 完成上述配置后,在P1与P3之间已建立LDP远端会话,在P1或P3上执行命令display mpls ldp remote-peer可以看到LDP远端对等体信息。

      以P1的显示为例。

      [~P1] display mpls ldp remote-peer P3
       LDP Remote Entity Information
       ------------------------------------------------------------------------------
       Remote Peer Name  : P3
       Remote Peer IP    : 4.4.4.4            LDP ID        : 2.2.2.2:0
       Transport Address : 2.2.2.2            Entity Status : Active
      
       Configured Keepalive Hold Timer : 45 Sec
       Configured Keepalive Send Timer : ----
       Configured Hello Hold Timer     : 45 Sec
       Negotiated Hello Hold Timer     : 45 Sec
       Configured Hello Send Timer     : ----
       Configured Delay Timer          : ----
       Hello Packet sent/received      : 61/59
       Label Advertisement Mode        : Downstream Unsolicited
       Auto-config                     : ----
       Session-Protect effect          : NO
       Session-Protect Duration        : ----
       Session-Protect Remain          : ----
       ------------------------------------------------------------------------------
       TOTAL: 1 Remote-Peer(s) Found.
      

  4. 在Tunnel接口上使能转发捷径功能,并调整转发捷径的metric值,使到PE1或PE2的流量经过该SR-TE隧道

    # 配置P1。

    [~P1] interface tunnel 1
    [~P1-Tunnel1] mpls te igp shortcut isis
    [*P1-Tunnel1] mpls te igp metric absolute 1
    [*P1-Tunnel1] isis enable 1
    [*P1-Tunnel1] quit
    [*P1] commit
    

    # 配置P3。

    [~P3] interface tunnel 1
    [~P3-Tunnel1] mpls te igp shortcut isis
    [*P3-Tunnel1] mpls te igp metric absolute 1
    [*P3-Tunnel1] isis enable 1
    [*P3-Tunnel1] quit
    [*P3] commit
    

  5. 检查配置结果

    # 完成上述配置后,在节点P1、P3上执行命令display ip routing-table显示路由信息。

    以P1的显示信息为例,发现到P3和PE2的出接口为Tunnel1。

    [~P1] display ip routing-table
    Proto: Protocol        Pre: Preference
    Route Flags: R - relay, D - download to fib, T - to vpn-instance, B - black hole route
    ------------------------------------------------------------------------------
    Routing Table : _public_
             Destinations : 17       Routes : 18
    
    Destination/Mask    Proto   Pre  Cost        Flags NextHop         Interface
    
            1.1.1.1/32  ISIS    15   1             D   10.1.1.1        Vlanif10
            2.2.2.2/32  Direct  0    0             D   127.0.0.1       LoopBack0
            3.3.3.3/32  ISIS    15   1             D   10.2.1.2        Vlanif20
            4.4.4.4/32  ISIS    15   1             D   2.2.2.2         Tunnel1
            5.5.5.5/32  ISIS    15   2             D   2.2.2.2         Tunnel1
           10.1.1.0/24  Direct  0    0             D   10.1.1.2        Vlanif10
           10.1.1.2/32  Direct  0    0             D   127.0.0.1       Vlanif10
         10.1.1.255/32  Direct  0    0             D   127.0.0.1       Vlanif10
           10.2.1.0/24  Direct  0    0             D   10.2.1.1        Vlanif20
           10.2.1.1/32  Direct  0    0             D   127.0.0.1       Vlanif20
         10.2.1.255/32  Direct  0    0             D   127.0.0.1       Vlanif20
           10.3.1.0/24  ISIS    15   2             D   2.2.2.2         Tunnel1
                        ISIS    15   2             D   10.2.1.2        Vlanif20
           10.4.1.0/24  ISIS    15   2             D   2.2.2.2         Tunnel1
          127.0.0.0/8   Direct  0    0             D   127.0.0.1       InLoopBack0
          127.0.0.1/32  Direct  0    0             D   127.0.0.1       InLoopBack0
    127.255.255.255/32  Direct  0    0             D   127.0.0.1       InLoopBack0
    255.255.255.255/32  Direct  0    0             D   127.0.0.1       InLoopBack0

    # 在节点P1、P2和P3上执行命令display mpls lsp查看LSP信息,发现新增了几条的LDP LSP。

    以P1的显示为例:

    [~P1] display mpls lsp
    -------------------------------------------------------------------------------
    LSP Information: LDP LSP
    -------------------------------------------------------------------------------
                  FEC  In/Out Label    In/Out IF                      Vrf Name
            1.1.1.1/32 NULL/3          -/Vlanif10                     
            1.1.1.1/32 17/3            -/Vlanif10                     
            2.2.2.2/32 3/NULL          -/-                            
            4.4.4.4/32 NULL/3          -/Tun1                         
            4.4.4.4/32 18/3            -/Tun1                         
            5.5.5.5/32 NULL/22         -/Tun1                         
            5.5.5.5/32 19/22           -/Tun1                         
    

配置文件

  • PE1的配置文件

    #
    sysname PE1
    #
    vlan batch 10
    #
    mpls lsr-id 1.1.1.1
    #
    mpls
    #
    mpls ldp
     #
     ipv4-family
    #
    isis 1
     cost-style wide
     network-entity 11.1111.1111.1111.00
    #
    interface Vlanif10
     ip address 10.1.1.1 255.255.255.0
     isis enable 1
     mpls
     mpls ldp
    #
    interface 10GE1/0/1
     port link-type trunk 
     port trunk allow-pass vlan 10 
    #
    interface LoopBack0
     ip address 1.1.1.1 255.255.255.255
     isis enable 1
    #
    return
  • P1的配置文件

    #
    sysname P1
    #
    vlan batch 10 20
    #
    mpls lsr-id 2.2.2.2
    #
    mpls
     mpls te
    #
    mpls ldp
     #
     ipv4-family
    #
    mpls ldp remote-peer P3
     remote-ip 4.4.4.4
    #
    segment-routing
    #
    isis 1
     cost-style wide
     network-entity 11.2222.2222.2222.00
     traffic-eng level-1-2
     segment-routing mpls
    #
    interface Vlanif10
     ip address 10.1.1.2 255.255.255.0
     isis enable 1
     mpls
     mpls ldp
    #
    interface Vlanif20
     ip address 10.2.1.1 255.255.255.0
     isis enable 1
     mpls
     mpls te
    #
    interface 10GE1/0/1
     port link-type trunk 
     port trunk allow-pass vlan 10
    #
    interface 10GE1/0/2
     port link-type trunk 
     port trunk allow-pass vlan 20
    #
    interface LoopBack0
     ip address 2.2.2.2 255.255.255.255
     isis enable 1
    #
    interface Tunnel1
     ip address unnumbered interface LoopBack0
     tunnel-protocol mpls te
     mpls te igp shortcut isis
     mpls te igp metric absolute 1
     isis enable 1
     destination 4.4.4.4
     mpls te signal-protocol segment-routing
     mpls te tunnel-id 100
     mpls te pce delegate
    #
    return
  • P2的配置文件

    #
    sysname P2
    #
    vlan batch 20 30
    #
    mpls lsr-id 3.3.3.3
    #
    mpls
     mpls te
    #
    segment-routing
    #
    isis 1
     cost-style wide
     network-entity 11.3333.3333.3333.00
     traffic-eng level-1-2
     segment-routing mpls
    #
    interface Vlanif20
     ip address 10.2.1.2 255.255.255.0
     isis enable 1
     mpls
     mpls te
    #
    interface Vlanif30
     ip address 10.3.1.1 255.255.255.0
     isis enable 1
     mpls
     mpls te
    #
    interface 10GE1/0/1
     port link-type trunk 
     port trunk allow-pass vlan 20
    #
    interface 10GE1/0/2
     port link-type trunk 
     port trunk allow-pass vlan 30
    #
    interface LoopBack0
     ip address 3.3.3.3 255.255.255.255
     isis enable 1
    #
    return
  • P3的配置文件

    #
    sysname P3
    #
    vlan batch 30 40
    #
    mpls lsr-id 4.4.4.4
    #
    mpls
     mpls te
    #
    mpls ldp
     #
     ipv4-family
    #
    mpls ldp remote-peer P1
     remote-ip 2.2.2.2
    #
    segment-routing
    #
    isis 1
     cost-style wide
     network-entity 11.4444.4444.4444.00
     traffic-eng level-1-2
     segment-routing mpls
     bgp-ls enable level-1-2
     bgp-ls identifier 20
    #
    interface Vlanif30
     ip address 10.3.1.2 255.255.255.0
     isis enable 1
     mpls
     mpls te
    #
    interface Vlanif40
     ip address 10.4.1.1 255.255.255.0
     isis enable 1
     mpls
     mpls ldp
    #
    interface 10GE1/0/1
     port link-type trunk 
     port trunk allow-pass vlan 30
    #
    interface 10GE1/0/2
     port link-type trunk 
     port trunk allow-pass vlan 40
    #
    interface 10GE/0/3
     undo portswitch
     ip address 7.1.2.10 255.255.255.0
     isis enable 1
    #
    interface LoopBack0
     ip address 4.4.4.4 255.255.255.255
     isis enable 1
    #
    interface Tunnel1
     ip address unnumbered interface LoopBack0
     tunnel-protocol mpls te
     mpls te igp shortcut isis
     mpls te igp metric absolute 1
     isis enable 1
     destination 2.2.2.2
     mpls te signal-protocol segment-routing
     mpls te tunnel-id 101
     mpls te pce delegate
    #
    bgp 100
     peer 7.1.2.9 as-number 100
     #
     ipv4-family unicast
      peer 7.1.2.9 enable
     #
     link-state-family unicast
      peer 7.1.2.9 enable
    #
    return
  • PE2的配置文件

    #
    sysname PE2
    #
    vlan batch 40
    #
    mpls lsr-id 5.5.5.5
    #
    mpls
    #
    mpls ldp
     #
     ipv4-family
    #
    isis 1
     cost-style wide
     network-entity 11.5555.5555.5555.00
    #
    interface Vlanif40
     ip address 10.4.1.2 255.255.255.0
     isis enable 1
     mpls
     mpls ldp
    #
    interface 10GE1/0/1
     port link-type trunk 
     port trunk allow-pass vlan 40 
    #
    interface LoopBack0
     ip address 5.5.5.5 255.255.255.255
     isis enable 1
    #
    return
翻译
下载文档
更新时间:2019-05-05

文档编号:EDOC1100004215

浏览量:27355

下载量:474

平均得分:
本文档适用于这些产品
相关文档
相关版本
Share
上一页 下一页