所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

CloudEngine 12800 V200R003C00 配置指南-MPLS

本文档介绍了MPLS的配置,具体包括MPLS基础、MPLS LDP配置、MPLS QoS配置、MPLS TE配置和SR-TE配置。
评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
配置MPLS TE隧道亲和属性示例

配置MPLS TE隧道亲和属性示例

组网需求

图4-34所示,LSRA上存在两条到达LSRD的动态MPLS TE隧道Tunnel1和Tunnel2。要求根据各链路上的管理组属性,使用隧道的亲和属性及掩码,使LSRA上的Tunnel1使用LSRA→LSRB→LSRC→LSRD的物理链路,Tunnel2使用LSRA→LSRB→LSRE→LSRC→LSRD的物理链路。

图4-34 配置MPLS TE隧道亲和属性组网图

配置思路

采用如下的思路配置隧道亲和属性:

  1. 配置各接口的IP地址,并使用OSPF协议实现各节点之间公网路由可达。

  2. 配置LSR ID并全局使能各节点以及接口的MPLS TE、RSVP-TE、CSPF功能,使能OSPF TE。

  3. 在各节点的隧道出接口上配置链路的管理组属性。

  4. 在主隧道入节点创建隧道接口,配置隧道的IP地址、隧道协议、目的地址、隧道ID、动态信令协议RSVP-TE。

  5. 通过查看链路的管理组属性及组网需求,确定并配置各隧道的亲和属性及掩码。

操作步骤

  1. 配置各接口的IP地址,并配置OSPF

    # 配置LSRA。按图4-34配置各设备的接口IP地址,其中LSRB、LSRC、LSRD和LSRE的配置与LSRA类似,不再赘述。

    <HUAWEI> system-view
    [~HUAWEI] sysname LSRA
    [*HUAWEI] commit
    [~LSRA] vlan batch 100
    [*LSRA] interface vlanif 100
    [*LSRA-Vlanif100] ip address 172.1.1.1 255.255.255.0
    [*LSRA-Vlanif100] quit
    [*LSRA] interface 10ge 1/0/1
    [*LSRA-10GE1/0/1] port link-type trunk
    [*LSRA-10GE1/0/1] port trunk allow-pass vlan 100
    [*LSRA-10GE1/0/1] quit
    [*LSRA] interface loopback 1
    [*LSRA-LoopBack1] ip address 1.1.1.9 255.255.255.255
    [*LSRA-LoopBack1] quit
    [*LSRA] ospf 1
    [*LSRA-ospf-1] area 0
    [*LSRA-ospf-1-area-0.0.0.0] network 1.1.1.9 0.0.0.0
    [*LSRA-ospf-1-area-0.0.0.0] network 172.1.1.0 0.0.0.255
    [*LSRA-ospf-1-area-0.0.0.0] quit
    [*LSRA-ospf-1] quit
    [*LSRA] commit
    

    # 配置完成后,在各节点上执行display ip routing-table命令,应可以看到相互之间都学到了到对方Loopback1的路由。以LSRA的显示为例:

    [~LSRA] display ip routing-table
    Proto: Protocol        Pre: Preference
    Route Flags: R - relay, D - download to fib, T - to vpn-instance, B - black hole route
    ------------------------------------------------------------------------------
    Routing Table : _public_
             Destinations : 13       Routes : 13        
    
    Destination/Mask    Proto   Pre  Cost          Flags NextHop         Interface
    
            1.1.1.9/32  Direct  0    0             D   127.0.0.1       LoopBack1      
            2.2.2.9/32  OSPF    10   1             D   172.1.1.2       Vlanif100
            3.3.3.9/32  OSPF    10   2             D   172.1.1.2       Vlanif100
            4.4.4.9/32  OSPF    10   3             D   172.1.1.2       Vlanif100
            5.5.5.9/32  OSPF    10   2             D   172.1.1.2       Vlanif100
          127.0.0.0/8   Direct  0    0             D   127.0.0.1       InLoopBack0    
          127.0.0.1/32  Direct  0    0             D   127.0.0.1       InLoopBack0    
          172.1.1.0/24  Direct  0    0             D   172.1.1.1       Vlanif100
          172.1.1.1/32  Direct  0    0             D   127.0.0.1       Vlanif100
          172.2.1.0/24  OSPF    10   2             D   172.1.1.2       Vlanif100
          172.3.1.0/24  OSPF    10   3             D   172.1.1.2       Vlanif100
          172.4.1.0/24  OSPF    10   2             D   172.1.1.2       Vlanif100
          172.5.1.0/24  OSPF    10   3             D   172.1.1.2       Vlanif100
    

  2. 配置MPLS基本能力,使能MPLS TE、RSVP-TE和CSPF

    # 配置LSRA。LSRB、LSRC、LSRD和LSRE的配置与LSRA类似,不再赘述。其中,只需在主隧道的入节点上使能CSPF。

    [~LSRA] mpls lsr-id 1.1.1.9
    [*LSRA] mpls
    [*LSRA-mpls] mpls te
    [*LSRA-mpls] mpls rsvp-te
    [*LSRA-mpls] mpls te cspf
    [*LSRA-mpls] quit
    [*LSRA] interface vlanif 100
    [*LSRA-Vlanif100] mpls
    [*LSRA-Vlanif100] mpls te
    [*LSRA-Vlanif100] mpls rsvp-te
    [*LSRA-Vlanif100] quit
    [*LSRA] commit
    

  3. 配置OSPF TE

    # 配置LSRA。LSRB、LSRC、LSRD和LSRE的配置与LSRA类似,不再赘述。

    [~LSRA] ospf 1
    [~LSRA-ospf-1] opaque-capability enable
    [*LSRA-ospf-1] area 0
    [*LSRA-ospf-1-area-0.0.0.0] mpls-te enable
    [*LSRA-ospf-1-area-0.0.0.0] quit
    [*LSRA-ospf-1] quit
    [*LSRA] commit
    

  4. 配置各节点出接口的MPLS TE属性

    # 在LSRA上配置链路的管理组属性。

    [~LSRA] interface vlanif 100
    [~LSRA-Vlanif100] mpls te link administrative group 10001
    [*LSRA-Vlanif100] quit
    [*LSRA] commit
    

    # 在LSRB上配置链路的管理组属性。

    [~LSRB] interface vlanif 200
    [~LSRB-Vlanif200] mpls te link administrative group 10101
    [*LSRB-Vlanif200] quit
    [*LSRB] interface vlanif 400
    [*LSRB-Vlanif400] mpls te link administrative group 10011
    [*LSRB-Vlanif400] quit
    [*LSRB] commit
    

    # 在LSRC上配置链路的管理组属性。

    [~LSRC] interface vlanif 300
    [~LSRC-Vlanif300] mpls te link administrative group 10001
    [*LSRC-Vlanif300] quit
    [*LSRC] commit
    

    # 在LSRE上配置链路的管理组属性。

    [~LSRE] interface vlanif 500
    [~LSRE-Vlanif500] mpls te link administrative group 10011
    [*LSRE-Vlanif500] quit
    [*LSRE] commit
    

    # 配置完成后,可在设备上查看TEDB,其中包括各链路的Color字段,此即为各链路的管理组属性。以LSRA为例:

    [~LSRA] display mpls te cspf tedb node
     Router ID: 1.1.1.9
     IGP Type: OSPF      Process ID: 1      IGP Area: 0
      MPLS-TE Link Count: 1
      Link[1]:
        OSPF Router ID: 1.1.1.9       Opaque LSA ID: 1.0.0.1
        Interface IP Address: 172.1.1.1
        DR Address: 172.1.1.1
        IGP Area: 0
        Link  Type: Multi-access  Link Status: Active
        IGP Metric: 1               TE Metric: 1           Color: 0x10001
    ...

  5. 在入节点创建MPLS TE Tunnel

    # 在LSRA上创建Tunnel1

    [~LSRA] interface tunnel 1
    [*LSRA-Tunnel1] ip address unnumbered interface loopback 1
    [*LSRA-Tunnel1] tunnel-protocol mpls te
    [*LSRA-Tunnel1] destination 4.4.4.9
    [*LSRA-Tunnel1] mpls te tunnel-id 100
    [*LSRA-Tunnel1] mpls te record-route label
    [*LSRA-Tunnel1] mpls te affinity property 10101 mask 11011
    [*LSRA-Tunnel1] quit
    [*LSRA] commit
    

    # 在LSRA上创建Tunnel2

    [~LSRA] interface tunnel 2
    [*LSRA-Tunnel2] ip address unnumbered interface loopback 1
    [*LSRA-Tunnel2] tunnel-protocol mpls te
    [*LSRA-Tunnel2] destination 4.4.4.9
    [*LSRA-Tunnel2] mpls te tunnel-id 101
    [*LSRA-Tunnel2] mpls te record-route label
    [*LSRA-Tunnel2] mpls te affinity property 10011 mask 11101
    [*LSRA-Tunnel2] quit
    [*LSRA] commit

  6. 检查配置结果

    # 配置完成后,执行display mpls te tunnel-interface命令在LSRA上查看Tunnel的状态,可以看到Tunnel1和Tunnel2状态为Up。

    [~LSRA] display mpls te tunnel-interface
        Tunnel Name       : Tunnel1
        Signalled Tunnel Name: -
        Tunnel State Desc : CR-LSP is Up
        Tunnel Attributes   :     
        Active LSP          : Primary LSP
        Traffic Switch      : - 
        Session ID          : 100
        Ingress LSR ID      : 1.1.1.9               Egress LSR ID: 4.4.4.9
        Admin State         : UP                    Oper State   : UP
        Signaling Protocol  : RSVP
        FTid                : 1
        Tie-Breaking Policy : None                  Metric Type  : None
        Bfd Cap             : None                  
        Reopt               : Disabled              Reopt Freq   : -              
        Auto BW             : Disabled              Threshold    : - 
        Current Collected BW: -                     Auto BW Freq : -
        Min BW              : -                     Max BW       : -
        Offload             : Disabled              Offload Freq : - 
        Low Value           : -                     High Value   : - 
        Readjust Value      : - 
        Offload Explicit Path Name: -
        Tunnel Group        : Primary
        Interfaces Protected: -
        Excluded IP Address : -
        Referred LSP Count  : 0
        Primary Tunnel      : -                     Pri Tunn Sum : -
        Backup Tunnel       : -
        Group Status        : Up                    Oam Status   : None
        IPTN InLabel        : -                     Tunnel BFD Status : -
        BackUp LSP Type     : None                  BestEffort   : Disabled
        Secondary HopLimit  : -
        BestEffort HopLimit  : -
        Secondary Explicit Path Name: -
        Secondary Affinity Prop/Mask: 0x0/0x0
        BestEffort Affinity Prop/Mask: 0x0/0x0  
        IsConfigLspConstraint: -
        Hot-Standby Revertive Mode:  Revertive
        Hot-Standby Overlap-path:  Disabled
        Hot-Standby Switch State:  CLEAR
        Bit Error Detection:  Disabled
        Bit Error Detection Switch Threshold:  -
        Bit Error Detection Resume Threshold:  -
        Ip-Prefix Name    : -
        P2p-Template Name : -
        PCE Delegate      : No                     LSP Control Status : Local control
        Auto BW Remain Time   : -                     Reopt Remain Time     : -
        
                    
        Primary LSP ID      : 1.1.1.9:28
        LSP State           : UP                    LSP Type     : Primary
        Setup Priority      : 7                     Hold Priority: 7
        IncludeAll          : 0x0
        IncludeAny          : 0x10001
        ExcludeAny          : 0x1010
        Affinity Prop/Mask  : 0x10001/0x11011       Resv Style   :  SE
        Configured Bandwidth Information:
        CT0 Bandwidth(Kbit/sec): 0               CT1 Bandwidth(Kbit/sec): 0
        CT2 Bandwidth(Kbit/sec): 0               CT3 Bandwidth(Kbit/sec): 0
        CT4 Bandwidth(Kbit/sec): 0               CT5 Bandwidth(Kbit/sec): 0
        CT6 Bandwidth(Kbit/sec): 0               CT7 Bandwidth(Kbit/sec): 0
        Actual Bandwidth Information:
        CT0 Bandwidth(Kbit/sec): 0               CT1 Bandwidth(Kbit/sec): 0
        CT2 Bandwidth(Kbit/sec): 0               CT3 Bandwidth(Kbit/sec): 0
        CT4 Bandwidth(Kbit/sec): 0               CT5 Bandwidth(Kbit/sec): 0
        CT6 Bandwidth(Kbit/sec): 0               CT7 Bandwidth(Kbit/sec): 0
        Explicit Path Name  : -                                Hop Limit: -
        Record Route        : Enabled               Record Label : Enabled
        Route Pinning       : Disabled
        FRR Flag            : Disabled
        IdleTime Remain     : -
        BFD Status          : -
        Soft Preemption     : Disabled
        Reroute Flag        : Enabled
        Pce Flag            : Normal
        
        Tunnel Name       : Tunnel2
        Signalled Tunnel Name: -
        Tunnel State Desc : CR-LSP is Up
        Tunnel Attributes   :     
        Active LSP          : Primary LSP
        Traffic Switch      : - 
        Session ID          : 101
        Ingress LSR ID      : 1.1.1.9               Egress LSR ID: 4.4.4.9
        Admin State         : UP                    Oper State   : UP
        Signaling Protocol  : RSVP
        FTid                : 2
        Tie-Breaking Policy : None                  Metric Type  : None
        Bfd Cap             : None                  
        Reopt               : Disabled              Reopt Freq   : -              
        Auto BW             : Disabled              Threshold    : - 
        Current Collected BW: -                     Auto BW Freq : -
        Min BW              : -                     Max BW       : -
        Offload             : Disabled              Offload Freq : - 
        Low Value           : -                     High Value   : - 
        Readjust Value      : - 
        Offload Explicit Path Name: -
        Tunnel Group        : Primary
        Interfaces Protected: -
        Excluded IP Address : -
        Referred LSP Count  : 0
        Primary Tunnel      : -                     Pri Tunn Sum : -
        Backup Tunnel       : -
        Group Status        : Up                    Oam Status   : None
        IPTN InLabel        : -                     Tunnel BFD Status : -
        BackUp LSP Type     : None                  BestEffort   : Disabled
        Secondary HopLimit  : -
        BestEffort HopLimit  : -
        Secondary Explicit Path Name: -
        Secondary Affinity Prop/Mask: 0x0/0x0
        BestEffort Affinity Prop/Mask: 0x0/0x0  
        IsConfigLspConstraint: -
        Hot-Standby Revertive Mode:  Revertive
        Hot-Standby Overlap-path:  Disabled
        Hot-Standby Switch State:  CLEAR
        Bit Error Detection:  Disabled
        Bit Error Detection Switch Threshold:  -
        Bit Error Detection Resume Threshold:  -
        Ip-Prefix Name    : -
        P2p-Template Name : -
        PCE Delegate      : No                     LSP Control Status : Local control
    
    
        Primary LSP ID      : 1.1.1.9:29
        LSP State           : UP                    LSP Type     : Primary
        Setup Priority      : 7                     Hold Priority: 7
        IncludeAll          : 0x0
        IncludeAny          : 0x10001
        ExcludeAny          : 0x1100
        Affinity Prop/Mask  : 0x10001/0x11101       Resv Style   :  SE
        Configured Bandwidth Information:
        CT0 Bandwidth(Kbit/sec): 0               CT1 Bandwidth(Kbit/sec): 0
        CT2 Bandwidth(Kbit/sec): 0               CT3 Bandwidth(Kbit/sec): 0
        CT4 Bandwidth(Kbit/sec): 0               CT5 Bandwidth(Kbit/sec): 0
        CT6 Bandwidth(Kbit/sec): 0               CT7 Bandwidth(Kbit/sec): 0
        Actual Bandwidth Information:
        CT0 Bandwidth(Kbit/sec): 0               CT1 Bandwidth(Kbit/sec): 0
        CT2 Bandwidth(Kbit/sec): 0               CT3 Bandwidth(Kbit/sec): 0
        CT4 Bandwidth(Kbit/sec): 0               CT5 Bandwidth(Kbit/sec): 0
        CT6 Bandwidth(Kbit/sec): 0               CT7 Bandwidth(Kbit/sec): 0
        Explicit Path Name  : -                                Hop Limit: -
        Record Route        : Enabled               Record Label : Enabled
        Route Pinning       : Disabled
        FRR Flag            : Disabled
        IdleTime Remain     : -
        BFD Status          : -
        Soft Preemption     : Disabled
        Reroute Flag        : Enabled
        Pce Flag            : Normal
        

    # 执行display mpls te tunnel path命令查看隧道经过的路径,证实隧道的亲和属性及掩码必须与各链路的管理组属性相匹配。

    [~LSRA] display mpls te tunnel path
     Tunnel Interface Name : Tunnel1
     Lsp ID : 1.1.1.9 :100 :28
     Hop Information
      Hop 0   172.1.1.1
      Hop 1   172.1.1.2 Label 1065
      Hop 2   2.2.2.9 Label 1065
      Hop 3   172.2.1.1
      Hop 4   172.2.1.2 Label 1075
      Hop 5   3.3.3.9 Label 1075
      Hop 6   172.3.1.1 
      Hop 7   172.3.1.2 Label 3
      Hop 8   4.4.4.9 Label 3
    
     Tunnel Interface Name : Tunnel2
     Lsp ID : 1.1.1.9 :101 :29
     Hop Information
      Hop 0   172.1.1.1
      Hop 1   172.1.1.2 Label 1067
      Hop 2   2.2.2.9 Label 1067
      Hop 3   172.4.1.1
      Hop 4   172.4.1.2 Label 1040
      Hop 5   5.5.5.9 Label 1040
      Hop 6   172.5.1.1 
      Hop 7   172.5.1.2 Label 1077
      Hop 8   3.3.3.9 Label 1077
      Hop 9   172.3.1.1
      Hop 10  172.3.1.2 Label 3
      Hop 11  4.4.4.9 Label 3

配置文件

  • LSRA的配置文件

    #
    sysname LSRA
    #
    vlan batch 100
    #
    mpls lsr-id 1.1.1.9
    #
    mpls
     mpls te
     mpls rsvp-te
     mpls te cspf
    #
    interface Vlanif100
     ip address 172.1.1.1 255.255.255.0
     mpls
     mpls te
     mpls te link administrative group 10001
     mpls rsvp-te
    #
    interface 10GE1/0/1
     port link-type trunk
     port trunk allow-pass vlan 100
    #
    interface LoopBack1
     ip address 1.1.1.9 255.255.255.255
    #
    interface Tunnel1
     ip address unnumbered interface LoopBack1
     tunnel-protocol mpls te
     destination 4.4.4.9
     mpls te record-route label
     mpls te affinity property 10101 mask 11011
     mpls te tunnel-id 100
    #
    interface Tunnel2
     ip address unnumbered interface LoopBack1
     tunnel-protocol mpls te
     destination 4.4.4.9
     mpls te record-route label
     mpls te affinity property 10011 mask 11101
     mpls te tunnel-id 101
    #
    ospf 1
     opaque-capability enable
     area 0.0.0.0
      network 1.1.1.9 0.0.0.0
      network 172.1.1.0 0.0.0.255
      mpls-te enable
    #
    return
  • LSRB的配置文件

    #
    sysname LSRB
    #
    vlan batch 100 200 400
    # 
    mpls lsr-id 2.2.2.9
    #
    mpls
     mpls te
     mpls rsvp-te
    #
    interface Vlanif100
     ip address 172.1.1.2 255.255.255.0
     mpls
     mpls te
     mpls rsvp-te
    # 
    interface Vlanif200
     ip address 172.2.1.1 255.255.255.0
     mpls
     mpls te
     mpls te link administrative group 10101
     mpls rsvp-te
    #
    interface Vlanif400
     ip address 172.4.1.1 255.255.255.0
     mpls
     mpls te
     mpls te link administrative group 10011
     mpls rsvp-te
    #
    interface 10GE1/0/1
     port link-type trunk
     port trunk allow-pass vlan 100
    # 
    interface 10GE1/0/2
     port link-type trunk
     port trunk allow-pass vlan 200
    #
    interface 10GE1/0/3
     port link-type trunk
     port trunk allow-pass vlan 400
    #
    interface LoopBack1
     ip address 2.2.2.9 255.255.255.255
    # 
    ospf 1
     opaque-capability enable
     area 0.0.0.0
      network 2.2.2.9 0.0.0.0
      network 172.1.1.0 0.0.0.255
      network 172.2.1.0 0.0.0.255
      network 172.4.1.0 0.0.0.255
      mpls-te enable
    #
    return
  • LSRC的配置文件

    #
    sysname LSRC
    #
    vlan batch 200 300 500
    #
    mpls lsr-id 3.3.3.9
    #
    mpls
     mpls te
     mpls rsvp-te
    #
    interface Vlanif200
     ip address 172.2.1.2 255.255.255.0
     mpls
     mpls te 
     mpls rsvp-te
    #
    interface Vlanif300
     ip address 172.3.1.1 255.255.255.0
     mpls
     mpls te
     mpls te link administrative group 10001
     mpls rsvp-te
    #
    interface Vlanif500
     ip address 172.5.1.2 255.255.255.0
     mpls
     mpls te
     mpls rsvp-te
    #
    interface 10GE1/0/1
     port link-type trunk
     port trunk allow-pass vlan 200
    #
    interface 10GE1/0/2
     port link-type trunk
     port trunk allow-pass vlan 300
    #
    interface 10GE1/0/3
     port link-type trunk
     port trunk allow-pass vlan 500
    #
    interface LoopBack1
     ip address 3.3.3.9 255.255.255.255
    #
    ospf 1
     opaque-capability enable
     area 0.0.0.0
      network 3.3.3.9 0.0.0.0
      network 172.2.1.0 0.0.0.255
      network 172.3.1.0 0.0.0.255
      network 172.5.1.0 0.0.0.255
      mpls-te enable
    #
    return
  • LSRD的配置文件

    #
    sysname LSRD
    #
    vlan batch 300
    #
    mpls lsr-id 4.4.4.9
    #
    mpls
     mpls te
     mpls rsvp-te
    #
    interface Vlanif300
     ip address 172.3.1.2 255.255.255.0
     mpls
     mpls te
     mpls rsvp-te
    #
    interface 10GE1/0/1
     port link-type trunk
     port trunk allow-pass vlan 300
    #
    interface LoopBack1
     ip address 4.4.4.9 255.255.255.255
    #
    ospf 1
     opaque-capability enable
     area 0.0.0.0
      network 4.4.4.9 0.0.0.0
      network 172.3.1.0 0.0.0.255
      mpls-te enable
    #
    return
  • LSRE的配置文件

    #
    sysname LSRE
    #
    vlan batch 400 500
    #
    mpls lsr-id 5.5.5.9
    #
    mpls
     mpls te
     mpls rsvp-te
    #
    interface Vlanif400
     ip address 172.4.1.2 255.255.255.0
     mpls
     mpls te
     mpls rsvp-te
    #
    interface Vlanif500
     ip address 172.5.1.1 255.255.255.0
     mpls
     mpls te
     mpls te link administrative group 10011
     mpls rsvp-te
    #
    interface 10GE1/0/1
     port link-type trunk
     port trunk allow-pass vlan 400
    #
    interface 10GE1/0/2
     port link-type trunk
     port trunk allow-pass vlan 500
    #
    interface LoopBack1
     ip address 5.5.5.9 255.255.255.255
    #
    ospf 1
     opaque-capability enable
     area 0.0.0.0
      network 5.5.5.9 0.0.0.0
      network 172.4.1.0 0.0.0.255
      network 172.5.1.0 0.0.0.255
      mpls-te enable
    #
    return
翻译
下载文档
更新时间:2019-05-05

文档编号:EDOC1100004215

浏览量:29686

下载量:487

平均得分:
本文档适用于这些产品
相关文档
相关版本
Share
上一页 下一页