所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

CloudEngine 12800 V200R003C00 配置指南-MPLS

本文档介绍了MPLS的配置,具体包括MPLS基础、MPLS LDP配置、MPLS QoS配置、MPLS TE配置和SR-TE配置。
评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
配置静态BFD检测LDP LSP示例

配置静态BFD检测LDP LSP示例

组网需求

图2-23所示,网络拓扑结构简单并且稳定,PE、P为MPLS骨干网设备,骨干网上已建立LDP LSP来承载网络业务。

目前网络业务对实时性的要求越来越高,例如VoIP,在线游戏,在线视频业务等,链路发生故障导致的数据丢失会对这些业务造成比较严重的影响。现要求当主用LSP故障时,流量能够快速切换到备份LSP,尽可能地避免流量的丢失。因此需要配置静态BFD检测LDP LSP来实现快速检测LDP LSP。

请确保该场景下STP处于未使能状态,否则可能会导致主用链路不可用。

图2-23 配置静态BFD检测LDP LSP组网

配置思路

采用如下思路配置静态BFD检测LDP LSP:

  1. 在PE、P上配置OSPF,实现骨干网的IP连通性。
  2. 在PE、P上配置本地LDP会话,实现创建LDP LSP承载网络业务。
  3. 在PE上配置静态BFD,实现快速检测LDP LSP。

操作步骤

  1. 交换机上创建VLAN、VLANIF接口,配置VLANIF接口的IP地址,并将相应的物理接口加入到VLAN

    # 配置PE1。P1、P2和PE2的配置与PE1类似,不再赘述。

    <HUAWEI> system-view
    [~HUAWEI] sysname PE1
    [*HUAWEI] commit
    [~PE1] interface loopback 1
    [*PE1-LoopBack1] ip address 1.1.1.1 32
    [*PE1-LoopBack1] quit
    [*PE1] vlan batch 10 30
    [*PE1] interface vlanif 10
    [*PE1-Vlanif10] ip address 10.1.1.1 24
    [*PE1-Vlanif10] quit
    [*PE1] interface vlanif 30
    [*PE1-Vlanif30] ip address 10.3.1.1 24
    [*PE1-Vlanif30] quit
    [*PE1] interface 10ge 1/0/1
    [*PE1-10GE1/0/1] port link-type trunk
    [*PE1-10GE1/0/1] port trunk allow-pass vlan 10
    [*PE1-10GE1/0/1] quit
    [*PE1] interface 10ge 2/0/2
    [*PE1-10GE2/0/2] port link-type trunk
    [*PE1-10GE2/0/2] port trunk allow-pass vlan 30
    [*PE1-10GE2/0/2] quit
    

  2. 配置OSPF协议发布各节点接口所连网段和LSR ID的主机路由

    # 配置PE1。P1、P2和PE2的配置与PE1类似,不再赘述。

    [*PE1] ospf 1
    [*PE1-ospf-1] area 0
    [*PE1-ospf-1-area-0.0.0.0] network 1.1.1.1 0.0.0.0
    [*PE1-ospf-1-area-0.0.0.0] network 10.1.1.0 0.0.0.255
    [*PE1-ospf-1-area-0.0.0.0] network 10.3.1.0 0.0.0.255
    [*PE1-ospf-1-area-0.0.0.0] quit
    [*PE1-ospf-1] quit

  3. 配置PE1的接口VLANIF30的cost值为1000

    [*PE1] interface vlanif 30 
    [*PE1-Vlanif30] ospf cost 1000 
    [*PE1-Vlanif30] quit
    [*PE1] commit

    上述配置完成后,在各节点上执行display ip routing-table命令,可以看到相互之间都学到了到达彼此的路由,且PE1到PE2路由的出接口为Vlanif10。

  4. 配置本地LDP会话

    # 配置PE1。P1、P2和PE2的配置与PE1类似,不再赘述。

    [~PE1] mpls lsr-id 1.1.1.1 
    [*PE1] mpls 
    [*PE1-mpls] quit
    [*PE1] mpls ldp
    [*PE1-mpls-ldp] quit
    [*PE1] interface vlanif 10
    [*PE1-Vlanif10] mpls
    [*PE1-Vlanif10] mpls ldp
    [*PE1-Vlanif10] quit
    [*PE1] interface vlanif 30
    [*PE1-Vlanif30] mpls
    [*PE1-Vlanif30] mpls ldp
    [*PE1-Vlanif30] quit
    [*PE1] commit

    # 执行命令display mpls ldp lsp,可以看到在PE1上建立了到目的地址为4.4.4.4/32的LDP LSP。

    [~PE1] display mpls ldp lsp
     LDP LSP Information
     An asterisk (*) before an LSP means the LSP is not established
     An asterisk (*) before a Label means the USCB or DSCB is stale
     An asterisk (*) before a UpstreamPeer means the session is in GR state
     An asterisk (*) before a DS means the session is in GR state
     An asterisk (*) before a NextHop means the LSP is FRR LSP
     -------------------------------------------------------------------------------
     DestAddress/Mask   In/OutLabel    UpstreamPeer    NextHop          OutInterface
     -------------------------------------------------------------------------------
            1.1.1.1/32   3/NULL         2.2.2.2         127.0.0.1        InLoop0
            1.1.1.1/32   3/NULL         3.3.3.3         127.0.0.1        InLoop0
           *1.1.1.1/32   Liberal/1024                   DS/2.2.2.2
           *1.1.1.1/32   Liberal/1024                   DS/3.3.3.3
            2.2.2.2/32   NULL/3         -               10.1.1.2         Vlanif10
            2.2.2.2/32   1024/3         2.2.2.2         10.1.1.2         Vlanif10
            2.2.2.2/32   1024/3         3.3.3.3         10.1.1.2         Vlanif10
           *2.2.2.2/32   Liberal/1025                   DS/3.3.3.3
            3.3.3.3/32   NULL/1026      -               10.1.1.2         Vlanif10
            3.3.3.3/32   1026/1026      2.2.2.2         10.1.1.2         Vlanif10
            3.3.3.3/32   1026/1026      3.3.3.3         10.1.1.2         Vlanif10
           *3.3.3.3/32   Liberal/3                      DS/3.3.3.3
            4.4.4.4/32   NULL/1025      -               10.1.1.2         Vlanif10
            4.4.4.4/32   1025/1025      2.2.2.2         10.1.1.2         Vlanif10
            4.4.4.4/32   1025/1025      3.3.3.3         10.1.1.2         Vlanif10
           *4.4.4.4/32   Liberal/1026                   DS/3.3.3.3
     -------------------------------------------------------------------------------
     TOTAL: 11 Normal LSP(s) Found, 5 Liberal LSP(s) Found
            0 FRR LSP(s) Found.

  5. 在被检测链路两端节点上使能全局BFD能力

    # 配置PE1。

    [~PE1] bfd
    [*PE1-bfd] quit

    # 配置PE2。

    [~PE2] bfd
    [*PE2-bfd] quit

  6. 在PE1上配置绑定到LDP LSP的BFD会话,发送报文的时间间隔是100毫秒,接收报文的时间间隔是100毫秒,并且能够修改端口状态表

    # 配置PE1。

    [*PE1] bfd pe1tope2 bind ldp-lsp peer-ip 4.4.4.4 nexthop 10.1.1.2 interface vlanif 10
    [*PE1-bfd-lsp-session-pe1tope2] discriminator local 1
    [*PE1-bfd-lsp-session-pe1tope2] discriminator remote 2
    [*PE1-bfd-lsp-session-pe1tope2] min-tx-interval 100
    [*PE1-bfd-lsp-session-pe1tope2] min-rx-interval 100
    [*PE1-bfd-lsp-session-pe1tope2] commit
    [~PE1-bfd-lsp-session-pe1tope2] quit

  7. 在PE2上配置绑定到IP链路的BFD会话,用来将LDP LSP的故障通告给PE1

    # 配置PE2。

    [*PE2] bfd pe2tope1 bind peer-ip 1.1.1.1
    [*PE2-bfd-session-pe2tope1] discriminator local 2
    [*PE2-bfd-session-pe2tope1] discriminator remote 1
    [*PE2-bfd-session-pe2tope1] min-tx-interval 100
    [*PE2-bfd-session-pe2tope1] min-rx-interval 100
    [*PE2-bfd-session-pe2tope1] commit
    [~PE2-bfd-session-pe2tope1] quit

  8. 检测配置结果

    # 配置完成后,在PE1上执行命令display bfd session all,可以看到“State”字段的值为“Up”。

    [~PE1] display bfd session all
    S: Static session
    D: Dynamic session
    IP: IP session
    IF: Single-hop session
    PEER: Multi-hop session
    LDP: LDP session
    LSP: Label switched path
    TE: Traffic Engineering
    AUTO: Automatically negotiated session
    VXLAN: VXLAN session
    (w): State in WTR
    (*): State is invalid
    Total UP/DOWN Session Number : 1/0
    --------------------------------------------------------------------------------
    Local      Remote     PeerIpAddr      State     Type        InterfaceName
    --------------------------------------------------------------------------------
    1          2          4.4.4.4         Up        S/LDP-LSP   Vlanif10
    --------------------------------------------------------------------------------

    # 在PE2上执行命令display bfd session all,可以看到“State”字段的值为“Up”。

    [~PE2] display bfd session all
    S: Static session
    D: Dynamic session
    IP: IP session
    IF: Single-hop session
    PEER: Multi-hop session
    LDP: LDP session
    LSP: Label switched path
    TE: Traffic Engineering
    AUTO: Automatically negotiated session
    VXLAN: VXLAN session
    (w): State in WTR
    (*): State is invalid
    Total UP/DOWN Session Number : 1/0
    --------------------------------------------------------------------------------
    Local      Remote     PeerIpAddr      State     Type        InterfaceName
    --------------------------------------------------------------------------------
    2          1          1.1.1.1         Up        S/IP-PEER   -
    --------------------------------------------------------------------------------
    

配置文件

  • PE1的配置文件

    #
    sysname PE1
    #
    vlan batch 10 30
    #
    bfd
    #
    mpls lsr-id 1.1.1.1
    # 
    mpls
    #
    mpls ldp
     #
     ipv4-family
    #
    interface Vlanif10
     ip address 10.1.1.1 255.255.255.0
     mpls
     mpls ldp
    #
    interface Vlanif30
     ip address 10.3.1.1 255.255.255.0
     ospf cost 1000
     mpls
     mpls ldp
    #
    interface 10GE1/0/1
     port link-type trunk 
     port trunk allow-pass vlan 10 
    #
    interface 10GE2/0/2
     port link-type trunk 
     port trunk allow-pass vlan 30 
    #
    interface LoopBack1
     ip address 1.1.1.1 255.255.255.255
    #
    ospf 1
     area 0.0.0.0
      network 1.1.1.1 0.0.0.0
      network 10.1.1.0 0.0.0.255
      network 10.3.1.0 0.0.0.255
    #
    bfd pe1tope2 bind ldp-lsp peer-ip 4.4.4.4 nexthop 10.1.1.2 interface Vlanif10
     discriminator local 1 
     discriminator remote 2
     min-tx-interval 100
     min-rx-interval 100
    #
    return
  • P1的配置文件

    #
    sysname P1
    #
    vlan batch 10 20
    #
    mpls lsr-id 2.2.2.2
    #
    mpls
    #
    mpls ldp
     #
     ipv4-family
    #
    interface Vlanif10
     ip address 10.1.1.2 255.255.255.0
     mpls
     mpls ldp
    #
    interface Vlanif20
     ip address 10.2.1.1 255.255.255.0
     mpls
     mpls ldp
    #
    interface 10GE1/0/1
     port link-type trunk 
     port trunk allow-pass vlan 10 
    #
    interface 10GE2/0/2
     port link-type trunk 
     port trunk allow-pass vlan 20 
    #
    interface LoopBack1
     ip address 2.2.2.2 255.255.255.255
    #
    ospf 1
     area 0.0.0.0
      network 2.2.2.2 0.0.0.0
      network 10.1.1.0 0.0.0.255
      network 10.2.1.0 0.0.0.255
    #
    return
  • P2的配置文件

    #
    sysname P2
    #
    vlan batch 30 40
    #
    mpls lsr-id 3.3.3.3
    #
    mpls
    #
    mpls ldp
     #
     ipv4-family
    #
    interface Vlanif30
     ip address 10.3.1.2 255.255.255.0
     mpls
     mpls ldp
    #
    interface Vlanif40
     ip address 10.4.1.1 255.255.255.0
     mpls
     mpls ldp
    #
    interface 10GE1/0/1
     port link-type trunk 
     port trunk allow-pass vlan 30 
    #
    interface 10GE2/0/2
     port link-type trunk 
     port trunk allow-pass vlan 40 
    #
    interface LoopBack1
     ip address 3.3.3.3 255.255.255.255
    #
    ospf 1
     area 0.0.0.0
      network 3.3.3.3 0.0.0.0
      network 10.3.1.0 0.0.0.255
      network 10.4.1.0 0.0.0.255
    #
    return
  • PE2的配置文件

    #
    sysname PE2
    #
    vlan batch 20 40
    #
    bfd
    #
    mpls lsr-id 4.4.4.4
    #
    mpls
    #
    mpls ldp
     #
     ipv4-family
    #
    interface Vlanif20
     ip address 10.2.1.2 255.255.255.0
     mpls
     mpls ldp
    #
    interface Vlanif40
     ip address 10.4.1.2 255.255.255.0
     mpls
     mpls ldp
    #
    interface 10GE1/0/1
     port link-type trunk 
     port trunk allow-pass vlan 20 
    #
    interface 10GE2/0/2
     port link-type trunk 
     port trunk allow-pass vlan 40 
    #
    interface LoopBack1
     ip address 4.4.4.4 255.255.255.255
    #
    bfd pe2tope1 bind peer-ip 1.1.1.1
     discriminator local 2
     discriminator remote 1
     min-tx-interval 100
     min-rx-interval 100
    #
    ospf 1
     area 0.0.0.0
      network 4.4.4.4 0.0.0.0
      network 10.2.1.0 0.0.0.255
      network 10.4.1.0 0.0.0.255
    #
    return
翻译
下载文档
更新时间:2019-05-05

文档编号:EDOC1100004215

浏览量:29382

下载量:486

平均得分:
本文档适用于这些产品
相关文档
相关版本
Share
上一页 下一页