所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

CloudEngine 12800 V200R003C00 配置指南-MPLS

本文档介绍了MPLS的配置,具体包括MPLS基础、MPLS LDP配置、MPLS QoS配置、MPLS TE配置和SR-TE配置。
评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
配置转发捷径将流量引入TE隧道示例

配置转发捷径将流量引入TE隧道示例

组网需求

在应用MPLS TE的场景中,当创建了TE隧道之后,流量不会被自动引入到TE隧道中。此时需要采用一定的方式将流量引入TE隧道。其中,配置转发捷径是一种常用的方式,在该方式中TE隧道将作为逻辑链路参与本地的IGP路由计算。通过设置TE隧道的Metric值,可以使TE隧道被优选,从而将流量引入TE隧道。

图4-32所示,各设备之间通过OSPF协议实现路由互通,在LSRA上建立了一条经过LSRB到达LSRC的TE隧道;链路上标注的数字代表开销值。如果在LSRA上同时存在去往LSRE和LSRC的流量,则根据OSPF的选路结果,这两部分流量将都从接口10GE1/0/2转发。假设LSRA和LSRD之间链路的带宽为100Mbit/s,去往LSRC的流量带宽需求为50Mbit/s,去往LSRE的流量带宽需求为60Mbit/s,两者相加为110Mbit/s。此时,LSRA和LSRD之间链路会发生拥塞,造成流量延迟或丢失。

为了解决上述问题,可在LSRA上的TE隧道接口配置转发捷径,将去往LSRC的流量引入TE隧道。这样,这部分流量将从接口10GE1/0/1转发,避免了网络拥塞的发生。

说明:

配置了转发捷径后,LSRA不会将TE隧道作为路由发布给邻居,因此TE隧道只能参与LSRA本地的路由计算。

请确保该场景下STP处于去使能状态,否则可能会导致某一接口被阻塞。

图4-32 配置转发捷径将流量引入TE隧道组网图

配置思路

采用如下的思路配置转发捷径将流量引入TE隧道:

  1. 配置各接口的IP地址,并使用OSPF协议实现各节点之间公网路由可达,同时配置链路的OSPF cost值。

  2. 在LSRA创建一条目的地址为LSRC的TE隧道,路径为LSRA→LSRB→LSRC。本例采用RSVP-TE建立动态MPLS TE隧道,配置LSR ID并全局使能各节点以及接口的MPLS TE、RSVP-TE、CSPF功能,使能OSPF TE。在主隧道入节点创建隧道接口,配置隧道的IP地址、隧道协议、目的地址、隧道ID、动态信令协议RSVP-TE。

  3. 在LSRA的TE隧道接口下使能转发捷径功能,并配置TE隧道的IGP度量值。

操作步骤

  1. 配置各接口的IP地址,并配置OSPF以及链路的OSPF cost值

    # 配置LSRA。按图4-32配置各设备的接口IP地址,其中LSRB、LSRC、LSRD和LSRE的配置与LSRA类似,不再赘述。

    <HUAWEI> system-view
    [~HUAWEI] sysname LSRA
    [*HUAWEI] commit
    [~LSRA] vlan batch 100 400
    [*LSRA] interface vlanif 100
    [*LSRA-Vlanif100] ip address 172.1.1.1 255.255.255.0
    [*LSRA-Vlanif100] ospf cost 15
    [*LSRA-Vlanif100] quit
    [*LSRA] interface vlanif 400
    [*LSRA-Vlanif400] ip address 172.4.1.1 255.255.255.0
    [*LSRA-Vlanif400] ospf cost 10
    [*LSRA-Vlanif400] quit
    [*LSRA] interface 10ge 1/0/1
    [*LSRA-10GE1/0/1] port link-type trunk
    [*LSRA-10GE1/0/1] port trunk allow-pass vlan 100
    [*LSRA-10GE1/0/1] quit
    [*LSRA] interface 10ge 1/0/2
    [*LSRA-10GE1/0/2] port link-type trunk
    [*LSRA-10GE1/0/2] port trunk allow-pass vlan 400
    [*LSRA-10GE1/0/2] quit
    [*LSRA] interface loopback 1
    [*LSRA-LoopBack1] ip address 1.1.1.9 255.255.255.255
    [*LSRA-LoopBack1] quit
    [*LSRA] ospf 1
    [*LSRA-ospf-1] area 0
    [*LSRA-ospf-1-area-0.0.0.0] network 1.1.1.9 0.0.0.0
    [*LSRA-ospf-1-area-0.0.0.0] network 172.1.1.0 0.0.0.255
    [*LSRA-ospf-1-area-0.0.0.0] network 172.4.1.0 0.0.0.255
    [*LSRA-ospf-1-area-0.0.0.0] commit
    [~LSRA-ospf-1-area-0.0.0.0] quit
    [~LSRA-ospf-1] quit

    配置完成后,在LSRA、LSRB、LSRC节点上执行display ip routing-table命令,应可以看到相互之间都学到了到对方Loopback1的路由。

  2. 配置MPLS基本能力,使能MPLS TE、RSVP-TE和CSPF

    为了在LSRA创建一条目的地址为LSRC的TE隧道,需要在LSRA、LSRB和LSRC进行以下配置。

    # 配置LSRA。LSRB和LSRC的配置与LSRA类似,不再赘述。其中,只需在主隧道的入节点上使能CSPF。

    [~LSRA] mpls lsr-id 1.1.1.9
    [*LSRA] mpls
    [*LSRA-mpls] mpls te
    [*LSRA-mpls] mpls rsvp-te
    [*LSRA-mpls] mpls te cspf
    [*LSRA-mpls] quit
    [*LSRA] interface vlanif 100
    [*LSRA-Vlanif100] mpls
    [*LSRA-Vlanif100] mpls te
    [*LSRA-Vlanif100] mpls rsvp-te
    [*LSRA-Vlanif100] commit
    [~LSRA-Vlanif100] quit
    

  3. 配置OSPF TE

    为了在LSRA创建一条目的地址为LSRC的TE隧道,需要在LSRA、LSRB和LSRC进行以下配置。

    # 配置LSRA。LSRB和LSRC的配置与LSRA类似,不再赘述。

    [~LSRA] ospf 1
    [~LSRA-ospf-1] opaque-capability enable
    [*LSRA-ospf-1] area 0
    [*LSRA-ospf-1-area-0.0.0.0] mpls-te enable
    [*LSRA-ospf-1-area-0.0.0.0] commit
    [~LSRA-ospf-1-area-0.0.0.0] quit
    [~LSRA-ospf-1] quit

  4. 创建MPLS TE隧道

    # 配置TE隧道的显式路径。

    [~LSRA] explicit-path pri-path
    [*LSRA-explicit-path-pri-path] next hop 172.1.1.2
    [*LSRA-explicit-path-pri-path] next hop 172.2.1.2
    [*LSRA-explicit-path-pri-path] next hop 3.3.3.9
    [*LSRA-explicit-path-pri-path] commit
    [~LSRA-explicit-path-pri-path] quit
    

    # 在LSRA上创建隧道接口。

    [~LSRA] interface tunnel 1
    [*LSRA-Tunnel1] ip address unnumbered interface loopback 1
    [*LSRA-Tunnel1] tunnel-protocol mpls te
    [*LSRA-Tunnel1] destination 3.3.3.9
    [*LSRA-Tunnel1] mpls te tunnel-id 100
    [*LSRA-Tunnel1] mpls te path explicit-path pri-path
    [*LSRA-Tunnel1] commit

  5. 配置转发捷径

    在TE隧道接口下使能转发捷径,配置IGP度量值为10(绝对度量)。

    # 配置LSRA。

    [~LSRA-Tunnel1] mpls te igp shortcut ospf
    [*LSRA-Tunnel1] mpls te igp metric absolute 10
    [*LSRA-Tunnel1] quit
    [*LSRA] ospf 1
    [*LSRA-ospf-1] enable traffic-adjustment
    [*LSRA-ospf-1] commit
    [~LSRA-ospf-1] quit

  6. 检查配置结果

    配置完成后,在LSRA上执行命令display ip routing-table 3.3.3.9,可以看到去往LSRC(3.3.3.9)的路由下一跳为1.1.1.9,转发出接口为Tunnel1,去往LSRC的流量被引入了TE隧道。

    [~LSRA] display ip routing-table 3.3.3.9
    Proto: Protocol        Pre: Preference
    Route Flags: R - relay, D - download to fib, T - to vpn-instance, B - black hole route
    ------------------------------------------------------------------------------
    Routing Table : _public_
    Summary Count : 1
    
    Destination/Mask    Proto   Pre  Cost        Flags NextHop         Interface
    
            3.3.3.9/32  OSPF    10   10            D   1.1.1.9         Tunnel1
    

配置文件

  • LSRA的配置文件

    #
    sysname LSRA
    #
    vlan batch 100 400
    #
    mpls lsr-id 1.1.1.9
    #
    mpls
     mpls te
     mpls rsvp-te
     mpls te cspf
    #
    explicit-path pri-path
     next hop 172.1.1.2
     next hop 172.2.1.2
     next hop 3.3.3.9
    #
    interface Vlanif100
     ip address 172.1.1.1 255.255.255.0
     ospf cost 15
     mpls
     mpls te
     mpls rsvp-te
    #
    interface Vlanif400
     ip address 172.4.1.1 255.255.255.0
     ospf cost 10
    #
    interface 10GE1/0/1
     port link-type trunk
     port trunk allow-pass vlan 100
    #
    interface 10GE1/0/2
     port link-type trunk
     port trunk allow-pass vlan 400
    #
    interface LoopBack1
     ip address 1.1.1.9 255.255.255.255
    #
    interface Tunnel1
     ip address unnumbered interface LoopBack1
     tunnel-protocol mpls te
     mpls te igp shortcut ospf
     mpls te igp metric absolute 10
     destination 3.3.3.9
     mpls te tunnel-id 100
     mpls te path explicit-path pri-path
    #
    ospf 1
     opaque-capability enable
     enable traffic-adjustment
     area 0.0.0.0
      network 1.1.1.9 0.0.0.0
      network 172.1.1.0 0.0.0.255
      network 172.4.1.0 0.0.0.255
      mpls-te enable 
    #
    return
  • LSRB的配置文件

    #
    sysname LSRB
    #
    vlan batch 100 200
    # 
    mpls lsr-id 2.2.2.9
    #
    mpls
     mpls te
     mpls rsvp-te
    #
    interface Vlanif100
     ip address 172.1.1.2 255.255.255.0
     ospf cost 15
     mpls
     mpls te
     mpls rsvp-te
    # 
    interface Vlanif200
     ip address 172.2.1.1 255.255.255.0
     ospf cost 10
     mpls
     mpls te
     mpls rsvp-te
    #
    interface 10GE1/0/1
     port link-type trunk
     port trunk allow-pass vlan 100
    # 
    interface 10GE1/0/2
     port link-type trunk
     port trunk allow-pass vlan 200
    #
    interface LoopBack1
     ip address 2.2.2.9 255.255.255.255
    # 
    ospf 1
     opaque-capability enable
     area 0.0.0.0
      network 2.2.2.9 0.0.0.0
      network 172.1.1.0 0.0.0.255
      network 172.2.1.0 0.0.0.255
      mpls-te enable
    #
    return
  • LSRC的配置文件

    #
    sysname LSRC
    #
    vlan batch 200 300
    #
    mpls lsr-id 3.3.3.9
    #
    mpls
     mpls te
     mpls rsvp-te
    #
    interface Vlanif200
     ip address 172.2.1.2 255.255.255.0
     ospf cost 10
     mpls
     mpls te 
     mpls rsvp-te
    #
    interface Vlanif300
     ip address 172.3.1.1 255.255.255.0
     ospf cost 10
    #
    interface 10GE1/0/1
     port link-type trunk
     port trunk allow-pass vlan 200
    #
    interface 10GE1/0/2
     port link-type trunk
     port trunk allow-pass vlan 300
    #
    interface LoopBack1
     ip address 3.3.3.9 255.255.255.255
    #
    ospf 1
     opaque-capability enable
     area 0.0.0.0
      network 3.3.3.9 0.0.0.0
      network 172.2.1.0 0.0.0.255
      network 172.3.1.0 0.0.0.255
      mpls-te enable
    #
    return
  • LSRD的配置文件

    #
    sysname LSRD
    #
    vlan batch 300 400 500
    #
    interface Vlanif300
     ip address 172.3.1.2 255.255.255.0
     ospf cost 10
    #
    interface Vlanif400
     ip address 172.4.1.2 255.255.255.0
     ospf cost 10
    #
    interface Vlanif500
     ip address 172.5.1.1 255.255.255.0
     ospf cost 10
    #
    interface 10GE1/0/1
     port link-type trunk
     port trunk allow-pass vlan 300
    #
    interface 10GE1/0/2
     port link-type trunk
     port trunk allow-pass vlan 400
    #
    interface 10GE1/0/3
     port link-type trunk
     port trunk allow-pass vlan 500
    #
    ospf 1
     area 0.0.0.0
      network 172.3.1.0 0.0.0.255
      network 172.4.1.0 0.0.0.255
      network 172.5.1.0 0.0.0.255
    #
    return
  • LSRE的配置文件

    #
    sysname LSRE
    #
    vlan batch 500
    #
    interface Vlanif500
     ip address 172.5.1.2 255.255.255.0
     ospf cost 10
    #
    interface 10GE1/0/1
     port link-type trunk
     port trunk allow-pass vlan 500
    #
    ospf 1
     area 0.0.0.0
      network 172.5.1.0 0.0.0.255
    #
    return
翻译
下载文档
更新时间:2019-05-05

文档编号:EDOC1100004215

浏览量:29662

下载量:487

平均得分:
本文档适用于这些产品
相关文档
相关版本
Share
上一页 下一页