所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

CloudEngine 12800 V200R003C00 配置指南-MPLS

本文档介绍了MPLS的配置,具体包括MPLS基础、MPLS LDP配置、MPLS QoS配置、MPLS TE配置和SR-TE配置。
评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
配置本地LDP会话示例

配置本地LDP会话示例

组网需求

图2-15所示,LSRA、LSRC为IP/MPLS骨干网的PE设备。LSRA和LSRC上需要部署MPLS L2VPN或L3VPN业务来实现VPN站点的互联,因此LSR间需要配置本地LDP会话来建立LDP LSP,实现承载VPN业务。

图2-15 配置LDP本地会话组网

配置思路

采用如下思路配置本地LDP会话:

  1. 在LSR上配置OSPF,实现骨干网的IP连通性。
  2. 在LSR上配置本地LDP会话,实现创建公网隧道来承载VPN业务。

操作步骤

  1. 交换机上创建VLAN、VLANIF接口,配置VLANIF接口的IP地址,并将相应的物理接口加入到VLAN

    # 配置LSRA。LSRB和LSRC的配置与LSRA类似,不再赘述。

    <HUAWEI> system-view
    [~HUAWEI] sysname LSRA
    [*HUAWEI] commit
    [~LSRA] interface loopback 0
    [*LSRA-LoopBack0] ip address 1.1.1.1 32
    [*LSRA-LoopBack0] quit
    [*LSRA] vlan batch 10
    [*LSRA] interface vlanif 10
    [*LSRA-Vlanif10] ip address 10.1.1.1 24
    [*LSRA-Vlanif10] quit
    [*LSRA] interface 10ge 1/0/1
    [*LSRA-10GE1/0/1] port link-type trunk
    [*LSRA-10GE1/0/1] port trunk allow-pass vlan 10
    [*LSRA-10GE1/0/1] quit
    [*LSRA] commit

  2. 配置OSPF协议发布各节点接口所连网段和LSR ID的主机路由

    # 配置LSRA。

    [~LSRA] ospf 1
    [*LSRA-ospf-1] area 0
    [*LSRA-ospf-1-area-0.0.0.0] network 1.1.1.1 0.0.0.0
    [*LSRA-ospf-1-area-0.0.0.0] network 10.1.1.0 0.0.0.255
    [*LSRA-ospf-1-area-0.0.0.0] commit
    [~LSRA-ospf-1-area-0.0.0.0] quit
    [~LSRA-ospf-1] quit

    # 配置LSRB。

    [~LSRB] ospf 1
    [*LSRB-ospf-1] area 0
    [*LSRB-ospf-1-area-0.0.0.0] network 2.2.2.2 0.0.0.0
    [*LSRB-ospf-1-area-0.0.0.0] network 10.1.1.0 0.0.0.255
    [*LSRB-ospf-1-area-0.0.0.0] network 10.2.1.0 0.0.0.255
    [*LSRB-ospf-1-area-0.0.0.0] commit
    [~LSRB-ospf-1-area-0.0.0.0] quit
    [~LSRB-ospf-1] quit

    # 配置LSRC。

    [~LSRC] ospf 1
    [*LSRC-ospf-1] area 0
    [*LSRC-ospf-1-area-0.0.0.0] network 3.3.3.3 0.0.0.0
    [*LSRC-ospf-1-area-0.0.0.0] network 10.2.1.0 0.0.0.255
    [*LSRC-ospf-1-area-0.0.0.0] commit
    [~LSRC-ospf-1-area-0.0.0.0] quit
    [~LSRC-ospf-1] quit

    # 配置完成后,在各节点上执行display ip routing-table命令,可以看到相互之间都学到了彼此的路由。

  3. 在各LSR上使能全局MPLS和MPLS LDP

    # 配置LSRA。

    [~LSRA] mpls lsr-id 1.1.1.1
    [*LSRA] mpls
    [*LSRA-mpls] quit
    [*LSRA] mpls ldp
    [*LSRA-mpls-ldp] commit
    [~LSRA-mpls-ldp] quit

    # 配置LSRB。

    [~LSRB] mpls lsr-id 2.2.2.2
    [*LSRB] mpls
    [*LSRB-mpls] quit
    [*LSRB] mpls ldp
    [*LSRB-mpls-ldp] commit
    [~LSRB-mpls-ldp] quit

    # 配置LSRC。

    [~LSRC] mpls lsr-id 3.3.3.3
    [*LSRC] mpls
    [*LSRC-mpls] quit
    [*LSRC] mpls ldp
    [*LSRC-mpls-ldp] commit
    [~LSRC-mpls-ldp] quit
    

  4. 在各LSR的接口上使能MPLS和MPLS LDP

    # 配置LSRA。

    [~LSRA] interface vlanif 10 
    [~LSRA-Vlanif10] mpls
    [*LSRA-Vlanif10] mpls ldp
    [*LSRA-Vlanif10] commit
    [~LSRA-Vlanif10] quit

    # 配置LSRB。

    [~LSRB] interface vlanif 10 
    [~LSRB-Vlanif10] mpls 
    [*LSRB-Vlanif10] mpls ldp
    [*LSRB-Vlanif10] commit
    [*LSRB-Vlanif10] quit 
    [*LSRB] interface vlanif 20 
    [*LSRB-Vlanif20] mpls
    [*LSRB-Vlanif20] mpls ldp
    [*LSRB-Vlanif20] commit
    [~LSRB-Vlanif20] quit
    

    # 配置LSRC。

    [~LSRC] interface vlanif 20 
    [~LSRC-Vlanif20] mpls 
    [*LSRC-Vlanif20] mpls ldp
    [*LSRC-Vlanif20] commit
    [~LSRC-Vlanif20] quit

  5. 检查配置结果

    # 配置完成后,在节点上执行display mpls ldp session命令,可以看到LSRA和LSRB、LSRB和LSRC之间的本地LDP会话状态为“Operational”。

    以LSRA的显示为例:

    [~LSRA] display mpls ldp session
     LDP Session(s) in Public Network
     LAM: Label Advertisement Mode,  KA: KeepAlive
     SsnAge: Session Age, Unit(DDDD:HH:MM)
     An asterisk (*) before a session means the session is being deleted.
     ------------------------------------------------------------------------------
     PeerID             Status      LAM  SsnRole  SsnAge      KASent/Rcv
     ------------------------------------------------------------------------------
     2.2.2.2:0          Operational DU   Passive  0000:00:22   91/91
     ------------------------------------------------------------------------------
     TOTAL: 1 Session(s) Found.
    

配置文件

  • LSRA的配置文件

    #
    sysname LSRA
    #
    vlan batch 10
    #
    mpls lsr-id 1.1.1.1
    # 
    mpls
    #
    mpls ldp
     #
     ipv4-family
    #
    interface Vlanif10
     ip address 10.1.1.1 255.255.255.0
     mpls
     mpls ldp
    #
    interface 10GE1/0/1
     port link-type trunk 
     port trunk allow-pass vlan 10 
    #
    interface LoopBack0
     ip address 1.1.1.1 255.255.255.255
    #
    ospf 1
     area 0.0.0.0
      network 1.1.1.1 0.0.0.0
      network 10.1.1.0 0.0.0.255
    #
    return
  • LSRB的配置文件

    #
    sysname LSRB
    #
    vlan batch 10 20
    #
    mpls lsr-id 2.2.2.2
    #
    mpls
    #
    mpls ldp
     #
     ipv4-family
    #
    interface Vlanif10
     ip address 10.1.1.2 255.255.255.0
     mpls
     mpls ldp
    #
    interface Vlanif20
     ip address 10.2.1.1 255.255.255.0
     mpls
     mpls ldp
    #
    interface 10GE1/0/1
     port link-type trunk 
     port trunk allow-pass vlan 10
    #
    interface 10GE2/0/2
     port link-type trunk 
     port trunk allow-pass vlan 20 
    #
    interface LoopBack0
     ip address 2.2.2.2 255.255.255.255
    #
    ospf 1
     area 0.0.0.0
      network 2.2.2.2 0.0.0.0
      network 10.1.1.0 0.0.0.255
      network 10.2.1.0 0.0.0.255
    #
    return
  • LSRC的配置文件

    #
    sysname LSRC
    #
    vlan batch 20
    #
    mpls lsr-id 3.3.3.3
    #
    mpls
    #
    mpls ldp
     #
     ipv4-family
    #
    interface Vlanif20
     ip address 10.2.1.2 255.255.255.0
     mpls
     mpls ldp
    #
    interface 10GE1/0/1
     port link-type trunk 
     port trunk allow-pass vlan 20 
    #
    interface LoopBack0
     ip address 3.3.3.3 255.255.255.255
    #
    ospf 1
     area 0.0.0.0
      network 3.3.3.3 0.0.0.0
      network 10.2.1.0 0.0.0.255
    #
    return
翻译
下载文档
更新时间:2019-05-05

文档编号:EDOC1100004215

浏览量:27929

下载量:477

平均得分:
本文档适用于这些产品
相关文档
相关版本
Share
上一页 下一页