所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

CloudEngine 12800 V200R003C00 配置指南-MPLS

本文档介绍了MPLS的配置,具体包括MPLS基础、MPLS LDP配置、MPLS QoS配置、MPLS TE配置和SR-TE配置。
评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
配置MPLS L2VPN私网QoS示例

配置MPLS L2VPN私网QoS示例

组网需求

图3-8,某企业机构,自建骨干网。分支Site站点较少(举例中只列出2个站点,其余省略),分支Site1使用CE1连接PE1设备接入骨干网,分支Site2使用CE2连接PE2接入骨干网。现在Site1和Site2的用户需要进行二层业务的互通,同时要求在穿越骨干网时保留二层报文中用户信息,且要求在网络拥塞时保证语音(802.1p优先级为7)优先级一直最高、视频(802.1p优先级为6)其次、数据(802.1p优先级为5)优先级最低,这样设备可以根据优先级的高低对三类业务提供不同的QoS服务。

图3-8 配置MPLS L2VPN私网QoS组网图

配置思路

采用如下的思路配置MPLS L2VPN私网QoS:

  1. 为实现Site1和Site2的二层业务互通,同时在穿越骨干网时保留二层报文的用户信息,需要使用Martini方式VPLS实现。

  2. 为保证语音优先级一直最高、视频其次、数据优先级最低,在PE1和PE2上配置DiffServ域,配置VPLS网络优先级映射,将语音报文EXP值设置最高(置为6),视频报文其次(置为5),数据报文最低(置为4)。实现优先保证语音业务。

  3. 在PE1和PE2上将VPLS的差分服务模式都设置为Pipe模式,使VPN中的业务在VPLS网络中以企业要求的优先级进行转发,在VPLS网络的出口处不改变报文本身携带的PHB行为及颜色,仅根据VPLS标签的EXP值进行队列调度。

操作步骤

  1. 配置Martini方式的VPLS,实现Site1和Site2的用户进行二层业务的互通。

    详细配置步骤请参见配置Martini方式VPLS示例,此处不再赘述。

  2. 配置将VLAN报文的802.1p优先级映射为PHB行为,并为报文着色。

    VLAN报文的802.1p优先级映射为PHB行为,并为报文着色,采用缺省映射关系进行映射,如表3-5所示。
    表3-5 DiffServ域中入方向上VLAN报文的802.1p优先级和PHB行为/颜色之间的映射关系

    报文类型

    802.1p优先级

    PHB行为

    Color

    数据

    5

    EF

    green

    视频

    6

    CS6

    green

    语音

    7

    CS7

    green

  3. 配置DiffServ域

    # 配置PE1。

    [~PE1] diffserv domain ds1
    [*PE1-dsdomain-ds1] exp-outbound cs7 green map 6
    [*PE1-dsdomain-ds1] exp-outbound cs6 green map 5
    [*PE1-dsdomain-ds1] exp-outbound ef green map 4
    [*PE1-dsdomain-ds1] quit
    [*PE1] commit

    # 配置PE2。

    [~PE2] diffserv domain ds1
    [*PE2-dsdomain-ds1] exp-outbound cs7 green map 6
    [*PE2-dsdomain-ds1] exp-outbound cs6 green map 5
    [*PE2-dsdomain-ds1] exp-outbound ef green map 4
    [*PE2-dsdomain-ds1] quit
    [*PE2] commit

  4. 在PE1和PE2上配置diffServ模式

    # 配置PE1。

    [~PE1] mpls l2vpn mode pipe domain ds1
    [*PE1] commit

    # 配置PE2。

    [~PE2] mpls l2vpn mode pipe domain ds1
    [*PE2] commit

配置文件

  • CE1的配置文件

    #
    sysname CE1
    #
    vlan batch 10
    #
    interface Vlanif10
     ip address 192.168.1.5 255.255.255.0
    #
    interface 10GE1/0/1
     port link-type trunk
     port trunk allow-pass vlan 10
    #
    return
  • CE2的配置文件

    #
    sysname CE2
    #
    vlan batch 40
    #
    interface Vlanif40
     ip address 192.168.1.6 255.255.255.0
    #
    interface 10GE1/0/1
     port link-type trunk
     port trunk allow-pass vlan 40
    #
    return
  • PE1的配置文件

    #
    sysname PE1
    #
    vlan batch 10 20
    #
    diffserv domain ds1
     exp-outbound ef green map 4
     exp-outbound cs6 green map 5
     exp-outbound cs7 green map 6
    #
    mpls lsr-id 1.1.1.9
    #
    mpls
    #
    mpls l2vpn mode pipe domain ds1
    #
    mpls l2vpn
    #
    vsi a2 static 
     pwsignal ldp 
      vsi-id 2    
      peer 3.3.3.9
    # 
    mpls ldp
    #
    mpls ldp remote-peer 3.3.3.9
     remote-ip 3.3.3.9
    #
    interface Vlanif10
     l2 binding vsi a2
    #
    interface Vlanif20
     ip address 172.1.1.1 255.255.255.0
     mpls
     mpls ldp
    #
    interface 10GE1/0/1
     port link-type trunk
     port trunk allow-pass vlan 10
    #
    interface 10GE2/0/2
     port link-type trunk
     port trunk allow-pass vlan 20
    #
    interface LoopBack1
     ip address 1.1.1.9 255.255.255.255
    #
    ospf 1
     area 0.0.0.0
      network 1.1.1.9 0.0.0.0
      network 172.1.1.0 0.0.0.255
    #
    return
  • P的配置文件

    #
    sysname P
    #
    vlan batch 20 30
    #
    mpls lsr-id 2.2.2.9
    #
    mpls
    #
    mpls ldp
    #
    interface Vlanif20
     ip address 172.1.1.2 255.255.255.0
     mpls
     mpls ldp
    #
    interface Vlanif30
     ip address 172.2.1.1 255.255.255.0
     mpls
     mpls ldp
    #
    interface 10GE1/0/1
     port link-type trunk
     port trunk allow-pass vlan 20
    #
    interface 10GE2/0/2
     port link-type trunk
     port trunk allow-pass vlan 30
    #
    interface LoopBack1
     ip address 2.2.2.9 255.255.255.255
    #
    ospf 1
     area 0.0.0.0
      network 2.2.2.9 0.0.0.0
      network 172.1.1.0 0.0.0.255
      network 172.2.1.0 0.0.0.255
    #
    return
  • PE2的配置文件

    #
    sysname PE2
    #
    vlan batch 30 40
    #
    diffserv domain ds1
     exp-outbound ef green map 4
     exp-outbound cs6 green map 5
     exp-outbound cs7 green map 6
    #
    mpls lsr-id 3.3.3.9
    #
    mpls
    #
    mpls l2vpn mode pipe domain ds1
    #
    mpls l2vpn
    #
    vsi a2 static
     pwsignal ldp
      vsi-id 2
      peer 1.1.1.9
    #
    mpls ldp
    #
    mpls ldp remote-peer 1.1.1.9
     remote-ip 1.1.1.9
    #
    interface Vlanif30
     ip address 172.2.1.2 255.255.255.0
     mpls
     mpls ldp
    #
    interface Vlanif40
     l2 binding vsi a2
    #
    interface 10GE1/0/1
     port link-type trunk
     port trunk allow-pass vlan 30
    #
    interface 10GE2/0/2
     port link-type trunk
     port trunk allow-pass vlan 40
    #
    interface LoopBack1
     ip address 3.3.3.9 255.255.255.255
    #
    ospf 1
     area 0.0.0.0
      network 3.3.3.9 0.0.0.0
      network 172.2.1.0 0.0.0.255
    #
    return
翻译
下载文档
更新时间:2019-05-05

文档编号:EDOC1100004215

浏览量:29600

下载量:487

平均得分:
本文档适用于这些产品
相关文档
相关版本
Share
上一页 下一页