所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

CloudEngine 12800 V200R003C00 配置指南-MPLS

本文档介绍了MPLS的配置,具体包括MPLS基础、MPLS LDP配置、MPLS QoS配置、MPLS TE配置和SR-TE配置。
评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
配置远端LDP会话示例

配置远端LDP会话示例

组网需求

图2-16所示,LSRA、LSRC是IP/MPLS骨干网的PE设备。LSRA和LSRC上需要部署MPLS L2VPN业务来实现VPN站点的二层互联,因此LSRA和LSRC之间需要配置远端LDP会话来实现VC标签交换。

图2-16 配置远端LDP会话组网

配置思路

若LSRA和LSRC直连,在LSR上配置本地LDP会话不仅建立LDP LSP来承载业务,还可以实现VC标签的交换,而本例中因为LSRA和LSRC非直连,所以必须配置远端LDP会话。采用如下配置思路:

  1. 在LSR上配置OSPF,实现骨干网的IP连通性。
  2. 在LSRA和LSRC上配置远端LDP会话,实现VC标签的交换。

操作步骤

  1. 交换机上创建VLAN、VLANIF接口,配置VLANIF接口的IP地址,并将相应的物理接口加入到VLAN

    # 配置LSRA。LSRB和LSRC的配置与LSRA类似,不再赘述。

    <HUAWEI> system-view
    [~HUAWEI] sysname LSRA
    [*HUAWEI] commit
    [~LSRA] interface loopback 0
    [*LSRA-LoopBack0] ip address 1.1.1.1 32
    [*LSRA-LoopBack0] quit
    [*LSRA] vlan batch 10
    [*LSRA] interface vlanif 10
    [*LSRA-Vlanif10] ip address 10.1.1.1 24
    [*LSRA-Vlanif10] quit
    [*LSRA] interface 10ge 1/0/1
    [*LSRA-10GE1/0/1] port link-type trunk
    [*LSRA-10GE1/0/1] port trunk allow-pass vlan 10
    [*LSRA-10GE1/0/1] quit
    [*LSRA] commit

  2. 配置OSPF协议发布各节点接口所连网段和LSR ID的主机路由

    # 配置LSRA。

    [~LSRA] ospf 1
    [*LSRA-ospf-1] area 0
    [*LSRA-ospf-1-area-0.0.0.0] network 1.1.1.1 0.0.0.0
    [*LSRA-ospf-1-area-0.0.0.0] network 10.1.1.0 0.0.0.255
    [*LSRA-ospf-1-area-0.0.0.0] commit
    [~LSRA-ospf-1-area-0.0.0.0] quit
    [~LSRA-ospf-1] quit

    # 配置LSRB。

    [~LSRB] ospf 1
    [*LSRB-ospf-1] area 0
    [*LSRB-ospf-1-area-0.0.0.0] network 2.2.2.2 0.0.0.0
    [*LSRB-ospf-1-area-0.0.0.0] network 10.1.1.0 0.0.0.255
    [*LSRB-ospf-1-area-0.0.0.0] network 10.2.1.0 0.0.0.255
    [*LSRB-ospf-1-area-0.0.0.0] commit
    [~LSRB-ospf-1-area-0.0.0.0] quit
    [~LSRB-ospf-1] quit

    # 配置LSRC。

    [~LSRC] ospf 1
    [*LSRC-ospf-1] area 0
    [*LSRC-ospf-1-area-0.0.0.0] network 3.3.3.3 0.0.0.0
    [*LSRC-ospf-1-area-0.0.0.0] network 10.2.1.0 0.0.0.255
    [*LSRC-ospf-1-area-0.0.0.0] commit
    [~LSRC-ospf-1-area-0.0.0.0] quit
    [~LSRC-ospf-1] quit

    配置完成后,在各节点上执行display ip routing-table命令,可以看到相互之间都学到了彼此的路由。

  3. 在各LSR上配置全局MPLS和MPLS LDP

    # 配置LSRA。

    [~LSRA] mpls lsr-id 1.1.1.1 
    [*LSRA] mpls
    [*LSRA-mpls] quit 
    [*LSRA] mpls ldp
    [*LSRA-mpls-ldp] commit
    [~LSRA-mpls-ldp] quit
    

    # 配置LSRB。

    [~LSRB] mpls lsr-id 2.2.2.2 
    [*LSRB] mpls 
    [*LSRB-mpls] quit 
    [*LSRB] mpls ldp
    [*LSRB-mpls-ldp] commit
    [~LSRB-mpls-ldp] quit

    # 配置LSRC。

    [~LSRC] mpls lsr-id 3.3.3.3 
    [*LSRC] mpls 
    [*LSRC-mpls] quit 
    [*LSRC] mpls ldp
    [*LSRC-mpls-ldp] commit
    [~LSRC-mpls-ldp] quit

  4. 在远端LDP会话两端LSR上指定远端对等体及IP地址

    # 配置LSRA。

    [~LSRA] mpls ldp remote-peer LSRC
    [*LSRA-mpls-ldp-remote-LSRC] remote-ip 3.3.3.3
    [*LSRA-mpls-ldp-remote-LSRC] commit 
    [~LSRA-mpls-ldp-remote-LSRC] quit
    

    # 配置LSRC。

    [~LSRC] mpls ldp remote-peer LSRA 
    [*LSRC-mpls-ldp-remote-LSRA] remote-ip 1.1.1.1
    [*LSRC-mpls-ldp-remote-LSRA] commit
    [~LSRC-mpls-ldp-remote-LSRA] quit

  5. 检查配置结果

    # 配置完成后,在节点上执行display mpls ldp session命令,可以看到LSRA和LSRC之间的远端LDP会话状态为“Operational”。

    以LSRA的显示为例:

    [~LSRA] display mpls ldp session
     LDP Session(s) in Public Network
     LAM: Label Advertisement Mode,  KA: KeepAlive
     SsnAge: Session Age, Unit(DDDD:HH:MM)
     An asterisk (*) before a session means the session is being deleted.
     --------------------------------------------------------------------------
     PeerID             Status      LAM  SsnRole  SsnAge       KASent/Rcv
     --------------------------------------------------------------------------
     3.3.3.3:0          Operational DU   Passive  0000:00:01  6/6
     --------------------------------------------------------------------------
     TOTAL: 1 Session(s) Found.
    

    # 在远端LDP会话两端LSR上执行display mpls ldp remote-peer命令,可以看到LSR的远端对等体信息。

    以LSRA的显示为例:

    [~LSRA] display mpls ldp remote-peer
     LDP Remote Entity Information
     ------------------------------------------------------------------------------
     Remote Peer Name  : LSRC
     Remote Peer IP    : 3.3.3.3            LDP ID        : 1.1.1.1:0
     Transport Address : 1.1.1.1            Entity Status : Active
    
     Configured Keepalive Hold Timer : 45 Sec
     Configured Keepalive Send Timer : ----
     Configured Hello Hold Timer     : 45 Sec
     Negotiated Hello Hold Timer     : 45 Sec
     Configured Hello Send Timer     : ----
     Configured Delay Timer          : ----
     Hello Packet sent/received      : 61/59
     Label Advertisement Mode        : Downstream Unsolicited
     Auto-config                     : ----
     Session-Protect effect          : NO
     Session-Protect Duration        : ----
     Session-Protect Remain          : ----
     ------------------------------------------------------------------------------
     TOTAL: 1 Remote-Peer(s) Found.
    

配置文件

  • LSRA的配置文件

    #
    sysname LSRA
    #
    vlan batch 10
    #
    mpls lsr-id 1.1.1.1
    #
    mpls
    #
    mpls ldp
     #
     ipv4-family
    #
    mpls ldp remote-peer LSRC
     remote-ip 3.3.3.3
    #
    interface Vlanif10
     ip address 10.1.1.1 255.255.255.0
    #
    interface 10GE1/0/1
     port link-type trunk 
     port trunk allow-pass vlan 10 
    #
    interface LoopBack0
     ip address 1.1.1.1 255.255.255.255
    #
    ospf 1
     area 0.0.0.0
      network 1.1.1.1 0.0.0.0
      network 10.1.1.0 0.0.0.255
    #
    return
  • LSRB的配置文件

    #
    sysname LSRB
    #
    vlan batch 10 20
    #
    mpls lsr-id 2.2.2.2
    #
    mpls
    #
    mpls ldp
     #
     ipv4-family
    #
    interface Vlanif10
     ip address 10.1.1.2 255.255.255.0
    #
    interface Vlanif20
     ip address 10.2.1.1 255.255.255.0
    #
    interface 10GE1/0/1
     port link-type trunk 
     port trunk allow-pass vlan 10 
    #
    interface 10GE2/0/2
     port link-type trunk 
     port trunk allow-pass vlan 20 
    #
    interface LoopBack0
     ip address 2.2.2.2 255.255.255.255
    #
    ospf 1
     area 0.0.0.0
      network 2.2.2.2 0.0.0.0
      network 10.1.1.0 0.0.0.255
      network 10.2.1.0 0.0.0.255
    #
    return
  • LSRC的配置文件

    #
    sysname LSRC
    #
    vlan batch 20
    #
    mpls lsr-id 3.3.3.3
    #
    mpls
    #
    mpls ldp
     #
     ipv4-family
    #
    mpls ldp remote-peer LSRA
     remote-ip 1.1.1.1
    #
    interface Vlanif20
     ip address 10.2.1.2 255.255.255.0
    #
    interface 10GE1/0/1
     port link-type trunk 
     port trunk allow-pass vlan 20 
    #
    interface LoopBack0
     ip address 3.3.3.3 255.255.255.255
    #
    ospf 1
     area 0.0.0.0
      network 3.3.3.3 0.0.0.0
      network 10.2.1.0 0.0.0.255
    #
    return
翻译
下载文档
更新时间:2019-05-05

文档编号:EDOC1100004215

浏览量:27629

下载量:477

平均得分:
本文档适用于这些产品
相关文档
相关版本
Share
上一页 下一页