所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

CloudEngine 12800 V200R003C00 配置指南-MPLS

本文档介绍了MPLS的配置,具体包括MPLS基础、MPLS LDP配置、MPLS QoS配置、MPLS TE配置和SR-TE配置。
评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
配置SR-TE Group差分服务示例

配置SR-TE Group差分服务示例

组网需求

图5-14所示,CE1和CE2分别通过PE1和PE2接入SR-TE网络。CE1往CE2存在多种业务流量,其中有2种流量为重要业务,流量峰值分别为10000Kbit/s和20000Kbit/s,其他为普通业务,流量总和为50000Kbit/s且流量总和峰值可能超过50000Kbit/s。

为了保证重要业务的转发质量,需要部署SR-TE Group功能实现在网络带宽紧张时对重要业务的优先转发。

图5-14 SR-TE Group差分服务组网图
说明:

本示例中CE1、PE1相连的接口为10GE1/0/1,CE2、PE2相连的接口为10GE1/0/1,PE1、PE2相连的接口为10GE1/0/2,PE1、PE2与控制器相连的接口为10GE1/0/3


表5-6 接口的IP地址

设备

接口

IP地址

CE1

10GE1/0/1

192.168.1.1/24

CE2

10GE1/0/1

192.168.2.1/24

PE1

10GE1/0/1

192.168.1.2/24

10GE1/0/2

20.1.1.1/24

10GE1/0/3

20.1.2.1/24

LoopBack0

1.1.1.1/32

PE2

10GE1/0/1

192.168.2.2/24

10GE1/0/2

20.1.1.2/24

10GE1/0/3

20.1.3.1/24

LoopBack0

2.2.2.2/32

配置思路

采用如下思路配置SR-TE Group差分服务:
  1. 在PE1和PE2之间建立3条SR-TE隧道,并分别指定带宽。
  2. 在PE1上将业务流量引入SR-TE隧道,使得3条SR-TE隧道形成等价多路径。
  3. 在PE1上分别为3条SR-TE隧道指定服务等级。
  4. 在PE1上配置业务的服务等级,使得2种重要业务经其中2条SR-TE隧道转发,其他业务通过另一条SR-TE隧道转发。

数据准备

为完成此配置例,需准备如下数据:

  • 网络中设备互连的接口IP地址,详细数据请参见表5-6
  • SR-TE隧道ID分别为1、2、3。
  • SR-TE隧道Tunnel1、Tunnel2、Tunnel3的带宽分别为10000Kbit/s、20000Kbit/s、50000Kbit/s。
  • SR-TE隧道Tunnel1、Tunnel2的服务等级同时为AF4和CS7,Tunnel3的服务等级为default。
  • 2条重要业务的服务等级分别为AF4、CS7。

操作步骤

  1. 配置各接口的IP地址

    配置各接口的IP地址和掩码。具体配置请参考配置文件

  2. 配置IS-IS协议发布各节点接口所连网段和LSR-ID的主机路由

    在PE1和PE2上配置IS-IS,使设备间路由互通。具体配置请参考配置文件

  3. 配置控制器和PE2之间的IS-IS邻居

    在控制器和PE2之间配置IS-IS邻居,使控制器和PE2能够互通,以便PE2将网络拓扑信息通过IS-IS泛洪给控制器。具体配置请参考配置文件

  4. 配置SR-TE基本功能
    1. 配置MPLS基本能力,使能MPLS TE

      # 配置PE1。PE2的配置与PE1类似,这里不再赘述。具体配置请参考配置文件

      [~PE1] mpls lsr-id 1.1.1.1
      [*PE1] mpls
      [*PE1-mpls] mpls te
      [*PE1-mpls] quit
      [*PE1] interface 10ge 1/0/2
      [*PE1-10GE1/0/2] mpls
      [*PE1-10GE1/0/2] mpls te
      [*PE1-10GE1/0/2] quit
      [*PE1] commit

    2. 在各节点全局使能SR能力

      # 配置PE1。PE2的配置与PE1类似,这里不再赘述。具体配置请参考配置文件

      [~PE1] segment-routing
      [*PE1-segment-routing] quit
      [*PE1] commit

    3. 在各节点配置IS-IS的SR-TE能力

      # 配置PE1。PE2的配置与PE1类似,这里不再赘述。具体配置请参考配置文件

      [~PE1] isis 1
      [*PE1-isis-1] cost-style wide
      [*PE1-isis-1] traffic-eng level-2
      [*PE1-isis-1] segment-routing mpls
      [*PE1-isis-1] quit
      [*PE1] commit

    4. 在入节点配置隧道接口

      # 在PE1上配置隧道接口Tunnel1、Tunnel2和Tunnel3。

      [~PE1] interface tunnel 1
      [*PE1-Tunnel1] ip address unnumbered interface loopback 0
      [*PE1-Tunnel1] tunnel-protocol mpls te
      [*PE1-Tunnel1] destination 2.2.2.2
      [*PE1-Tunnel1] mpls te tunnel-id 1
      [*PE1-Tunnel1] mpls te signal-protocol segment-routing
      [*PE1-Tunnel1] mpls te pce delegate
      [*PE1-Tunnel1] quit
      [*PE1] interface tunnel 2
      [*PE1-Tunnel2] ip address unnumbered interface loopback 0
      [*PE1-Tunnel2] tunnel-protocol mpls te
      [*PE1-Tunnel2] destination 2.2.2.2
      [*PE1-Tunnel2] mpls te tunnel-id 2
      [*PE1-Tunnel2] mpls te signal-protocol segment-routing
      [*PE1-Tunnel2] mpls te pce delegate
      [*PE1-Tunnel2] quit
      [*PE1] interface tunnel 3
      [*PE1-Tunnel3] ip address unnumbered interface loopback 0
      [*PE1-Tunnel3] tunnel-protocol mpls te
      [*PE1-Tunnel3] destination 2.2.2.2
      [*PE1-Tunnel3] mpls te tunnel-id 3
      [*PE1-Tunnel3] mpls te signal-protocol segment-routing
      [*PE1-Tunnel3] mpls te pce delegate
      [*PE1-Tunnel3] quit
      [*PE1] commit
      

    5. 在入节点配置流量引入隧道

      # 在PE1上配置到5.5.5.0的静态路由,出接口为隧道接口Tunnel1、Tunnel2和Tunnel3,将流量引入隧道。

      [~PE1] ip route-static 5.5.5.0 255.255.255.0 tunnel1
      [*PE1] ip route-static 5.5.5.0 255.255.255.0 tunnel2
      [*PE1] ip route-static 5.5.5.0 255.255.255.0 tunnel3
      [*PE1] commit
      

  5. 配置隧道带宽

    # 在PE1上配置隧道Tunnel1、Tunnel2和Tunnel3所需的带宽分别为带宽为10000Kbit/s、20000Kbit/s和50000Kbit/s,并使能隧道的流量统计功能。

    [~PE1] interface tunnel 1
    [*PE1-Tunnel1] mpls te bandwidth ct0 10000
    [*PE1-Tunnel1] statistic enable
    [*PE1-Tunnel1] quit
    [*PE1] interface tunnel 2
    [*PE1-Tunnel2] mpls te bandwidth ct0 20000
    [*PE1-Tunnel2] statistic enable
    [*PE1-Tunnel2] quit
    [*PE1] interface tunnel 3
    [*PE1-Tunnel3] mpls te bandwidth ct0 50000
    [*PE1-Tunnel3] statistic enable
    [*PE1-Tunnel3] quit
    [*PE1] commit
    

  6. 配置隧道的服务等级

    # 在PE1上配置隧道Tunnel1、Tunnel2的服务等级同时为AF4和CS7,Tunnel3的服务等级为default。

    [~PE1] interface tunnel 1
    [*PE1-Tunnel1] mpls te service-class af4 cs7
    [*PE1-Tunnel1] quit
    [*PE1] interface tunnel 2
    [*PE1-Tunnel2] mpls te service-class af4 cs7
    [*PE1-Tunnel2] quit
    [*PE1] interface tunnel 3
    [*PE1-Tunnel3] mpls te service-class default
    [*PE1-Tunnel3] quit
    [*PE1] commit
    

  7. 配置业务报文的服务等级
    1. 配置流分类

      [~PE1] acl 3002
      [*PE1-acl4-advance-3002] rule permit ip destination 5.5.5.1 32
      [*PE1-acl4-advance-3002] commit
      [~PE1-acl4-advance-3002] quit
      [~PE1] acl 3003
      [*PE1-acl4-advance-3003] rule permit ip destination 5.5.5.2 32
      [*PE1-acl4-advance-3003] commit
      [~PE1-acl4-advance-3003] quit
      [~PE1] traffic classifier c1
      [*PE1-classifier-c1] if-match acl 3002
      [*PE1-classifier-c1] quit
      [*PE1] traffic classifier c2
      [*PE1-classifier-c2] if-match acl 3003
      [*PE1-classifier-c2] quit
      [*PE1] commit
      

    2. 配置流行为

      [~PE1] traffic behavior b1
      [*PE1-behavior-b1] remark local-precedence af4
      [*PE1-behavior-b1] quit
      [*PE1] traffic behavior b2
      [*PE1-behavior-b2] remark local-precedence cs7
      [*PE1-behavior-b2] quit
      [*PE1] commit
      

    3. 配置流策略

      [~PE1] traffic policy p1
      [*PE1-trafficpolicy-p1] classifier c1 behavior b1
      [*PE1-trafficpolicy-p1] classifier c2 behavior b2
      [*PE1-trafficpolicy-p1] quit
      [*PE1] commit
      

    4. 应用流策略

      [~PE1] interface 10ge 1/0/1
      [*PE1-10GE1/0/1] traffic-policy p1 inbound
      [*PE1-10GE1/0/1] quit
      [*PE1] commit
      

  8. 检查配置结果

    上述配置成功后,在PE1上执行display mpls te tunnel命令,可以看到SR-TE隧道的建立情况。

    [~PE1] display mpls te tunnel
    -------------------------------------------------------------------------------
    Ingress LsrId   Destination     LSPID In/OutLabel     R Tunnel-name
    -------------------------------------------------------------------------------
    1.1.1.1         2.2.2.2         1     -/864256        I Tunnel1
    1.1.1.1         2.2.2.2         2     -/864256        I Tunnel2
    1.1.1.1         2.2.2.2         3     -/864256        I Tunnel3
    -------------------------------------------------------------------------------
    R: Role, I: Ingress, T: Transit, E: Egress
    在PE1上执行display ip routing-table命令,可以查看到ECMP出接口为Tunnel1、Tunnel2和Tunnel3。
    [~PE1] display ip routing-table 4.4.4.4
    Proto: Protocol        Pre: Preference
    Route Flags: R - relay, D - download to fib, T - to vpn-instance, B - black hole route
    ------------------------------------------------------------------------------
    Routing Table : _public_
    Summary Count : 1
    
    Destination/Mask    Proto   Pre  Cost        Flags NextHop         Interface
    
          5.5.5.0/24    Static  60   0             D   1.1.1.1         Tunnel1  
                        Static  60   0             D   1.1.1.1         Tunnel2  
                        Static  60   0             D   1.1.1.1         Tunnel3  
    

配置文件

  • PE1的配置文件

    #
    sysname PE1
    #
    mpls lsr-id 1.1.1.1
    #
    mpls
     mpls te
    #                                                                               
    acl number 3002                                                                 
     rule 5 permit ip destination 5.5.5.1 32                                         
    #                                                                               
    acl number 3003                                                                 
     rule 5 permit ip destination 5.5.5.2 32                                         
    #
    traffic classifier c1 type or
     if-match acl 3002
    #
    traffic classifier c2 type or
     if-match acl 3003
    #
    traffic behavior b1
     remark local-precedence af4  
    #
    traffic behavior b2
     remark local-precedence cs7  
    #
    traffic policy p1
     classifier c1 behavior b1 precedence 5
     classifier c2 behavior b2 precedence 10
    #
    segment-routing
    #
    isis 1
     is-level level-2
     cost-style wide
     network-entity 11.1111.1111.1111.00
     traffic-eng level-2
     segment-routing mpls
    #
    interface 10GE1/0/1
     undo portswitch
     ip address 192.168.1.2 255.255.255.0
     traffic-policy p1 inbound 
    #
    interface 10GE1/0/2
     undo portswitch
     ip address 20.1.1.1 255.255.255.0
     isis enable 1
     mpls
     mpls te
    #
    interface 10GE1/0/3
     undo portswitch
     ip address 20.1.2.1 255.255.255.0
     isis enable 1
    #
    interface LoopBack0
     ip address 1.1.1.1 255.255.255.255
     isis enable 1
    #
    interface Tunnel1
     ip address unnumbered interface LoopBack0
     tunnel-protocol mpls te
     destination 2.2.2.2
     mpls te signal-protocol segment-routing
     mpls te bandwidth ct0 10000
     statistic enable
     mpls te tunnel-id 1
     mpls te pce delegate
     mpls te service-class af4 cs7  
    #
    interface Tunnel2
     ip address unnumbered interface LoopBack0
     tunnel-protocol mpls te
     destination 2.2.2.2
     mpls te signal-protocol segment-routing
     mpls te bandwidth ct0 20000
     statistic enable
     mpls te tunnel-id 2
     mpls te pce delegate
     mpls te service-class af4 cs7  
    #
    interface Tunnel3
     ip address unnumbered interface LoopBack0
     tunnel-protocol mpls te
     destination 2.2.2.2
     mpls te signal-protocol segment-routing
     mpls te bandwidth ct0 50000
     statistic enable
     mpls te tunnel-id 3
     mpls te pce delegate
     mpls te service-class default
    #
    ip route-static 5.5.5.0 255.255.255.0 Tunnel1
    ip route-static 5.5.5.0 255.255.255.0 Tunnel2
    ip route-static 5.5.5.0 255.255.255.0 Tunnel3
    #
    return
  • PE2的配置文件

    #
    sysname PE2
    #
    mpls lsr-id 2.2.2.2
    #
    mpls
     mpls te
    #
    segment-routing
    #
    isis 1
     is-level level-2
     cost-style wide
     network-entity 11.1111.1111.2222.00
     traffic-eng level-2
     segment-routing mpls
    #
    interface 10GE1/0/1
     undo portswitch
     ip address 192.168.2.2 255.255.255.0
    #
    interface 10GE1/0/2
     undo portswitch
     ip address 20.1.1.2 255.255.255.0
     isis enable 1
     mpls
     mpls te
    #
    interface 10GE1/0/3
     undo portswitch
     ip address 20.1.3.1 255.255.255.0
     isis enable 1
    #
    interface LoopBack0
     ip address 2.2.2.2 255.255.255.255
     isis enable 1
    #
    ip route-static 5.5.5.0 255.255.255.0 192.168.2.1
    #
    return
  • CE1的配置文件

    #
    sysname CE1
    #
    interface 10GE1/0/1
     undo portswitch
     ip address 192.168.1.1 255.255.255.0
    #
    return
  • CE2的配置文件

    #
    sysname CE2
    #
    interface 10GE1/0/1
     undo portswitch
     ip address 192.168.2.1 255.255.255.0
    #
    return
翻译
下载文档
更新时间:2019-05-05

文档编号:EDOC1100004215

浏览量:27439

下载量:477

平均得分:
本文档适用于这些产品
相关文档
相关版本
Share
上一页 下一页