所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

CloudEngine 12800 V200R003C00 配置指南-MPLS

本文档介绍了MPLS的配置,具体包括MPLS基础、MPLS LDP配置、MPLS QoS配置、MPLS TE配置和SR-TE配置。
评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
配置动态MPLS TE隧道示例

配置动态MPLS TE隧道示例

组网需求

图4-30所示,某企业自建MPLS骨干网,LSRA、LSRB、LSRC均属于MPLS骨干网设备。MPLS骨干网的路由协议使用OSPF。现要求在MPLS骨干网创建公网隧道承载L2VPN或L3VPN业务,同时要求该隧道适应网络拓扑变化保证数据传输的稳定性。

为了实现该需求,需要使用RSVP-TE信令建立一条动态MPLS TE隧道。

图4-30 配置动态MPLS TE隧道组网图

配置思路

采用如下的思路配置动态MPLS TE隧道:

  1. 在MPLS骨干网可以使用MPLS LDP和MPLS TE隧道承载L2VPN或L3VPN业务。由于企业网络拓扑经常发生变动,为了保证数据传输的稳定性,这里采用MPLS TE隧道。

  2. 配置OSPF路由协议,实现MPLS骨干网设备路由可达。

  3. 使能各节点MPLS TE和RSVP-TE功能,以便建立MPLS TE隧道。

  4. 使能OSPF TE,使得TE信息可以通过OSPF发布到其他节点。

  5. 在入节点创建隧道接口,配置隧道属性,使能MPLS TE CSPF,创建动态MPLS TE隧道。

  6. 将流量引入TE隧道,使得PC1通往PC2的流量经过TE隧道转发。

操作步骤

  1. 配置各接口的IP地址

    # 配置LSRA。

    <HUAWEI> system-view
    [~HUAWEI] sysname LSRA
    [*HUAWEI] commit
    [~LSRA] vlan batch 10 100
    [*LSRA] interface vlanif 10
    [*LSRA-Vlanif10] ip address 10.1.1.1 255.255.255.0
    [*LSRA] interface vlanif 100
    [*LSRA-Vlanif100] ip address 172.1.1.1 255.255.255.0
    [*LSRA-Vlanif100] quit
    [*LSRA] interface 10ge 1/0/0
    [*LSRA-10GE1/0/0] port link-type trunk
    [*LSRA-10GE1/0/0] port trunk allow-pass vlan 100
    [*LSRA-10GE1/0/0] quit
    [*LSRA] interface 10ge 2/0/0
    [*LSRA-10GE2/0/0] port link-type trunk
    [*LSRA-10GE2/0/0] port trunk allow-pass vlan 10
    [*LSRA-10GE2/0/0] quit
    [*LSRA] interface loopback 1
    [*LSRA-LoopBack1] ip address 1.1.1.9 255.255.255.255
    [*LSRA-LoopBack1] quit
    [*LSRA] commit
    

    图4-30配置LSRB和LSRC的接口IP地址,具体配置与配置LSRA类似,不再赘述。

  2. 配置OSPF协议发布路由

    # 配置LSRA。

    [~LSRA] ospf 1
    [*LSRA-ospf-1] area 0.0.0.0
    [*LSRA-ospf-1-area-0.0.0.0] network 1.1.1.9 0.0.0.0
    [*LSRA-ospf-1-area-0.0.0.0] network 172.1.1.0 0.0.0.255
    [*LSRA-ospf-1-area-0.0.0.0] quit
    [*LSRA-ospf-1] quit
    [*LSRA] commit
    

    在LSRB和LSRC上配置OSPF,具体配置与配置LSRA类似,不再赘述。

    配置完成后,在各节点上执行display ip routing-table命令,可以看到相互之间都学到了到对方的路由。

  3. 配置MPLS基本能力,使能MPLS TE、RSVP-TE

    在各节点全局使能MPLS、MPLS TE和RSVP-TE,在隧道沿途的接口上使能MPLS、MPLS TE和RSVP-TE。

    # 配置LSRA。

    [~LSRA] mpls lsr-id 1.1.1.9
    [*LSRA] mpls
    [*LSRA-mpls] mpls te
    [*LSRA-mpls] mpls rsvp-te
    [*LSRA-mpls] quit
    [*LSRA] interface vlanif 100
    [*LSRA-Vlanif100] mpls
    [*LSRA-Vlanif100] mpls te
    [*LSRA-Vlanif100] mpls rsvp-te
    [*LSRA-Vlanif100] quit
    [*LSRA] commit
    

    配置LSRB和LSRC与配置LSRA类似,不再赘述。

  4. 配置OSPF TE

    # 配置LSRA。

    [~LSRA] ospf 1
    [*LSRA-ospf-1] opaque-capability enable
    [*LSRA-ospf-1] area 0.0.0.0
    [*LSRA-ospf-1-area-0.0.0.0] mpls-te enable 
    [*LSRA-ospf-1-area-0.0.0.0] quit
    [*LSRA-ospf-1] quit
    [*LSRA] commit
    

    配置LSRB和LSRC与配置LSRA类似,不再赘述。

  5. 配置MPLS TE隧道接口,使能MPLS TE CSPF

    在隧道入节点上创建Tunnel接口,并配置Tunnel接口的IP地址、隧道协议、目的地址、Tunnel ID、动态信令协议。

    # 配置LSRA。

    [~LSRA] interface tunnel 1
    [*LSRA-Tunnel1] ip address unnumbered interface loopback 1
    [*LSRA-Tunnel1] tunnel-protocol mpls te
    [*LSRA-Tunnel1] destination 3.3.3.9
    [*LSRA-Tunnel1] mpls te tunnel-id 100
    [*LSRA-Tunnel1] mpls te signal-protocol rsvp-te
    [*LSRA-Tunnel1] commit
    [~LSRA-Tunnel1] quit
    [~LSRA] mpls
    [~LSRA-mpls] mpls te cspf
    [*LSRA-mpls] quit
    [*LSRA] commit
    

  6. 将流量引入TE隧道,使得PC1通往PC2的流量经过TE隧道转发。

    在隧道入节点上创建静态路由将流量引入TE隧道。

    # 配置LSRA。

    [~LSRA] ip route-static 10.2.1.0 255.255.255.0 tunnel1
    [*LSRA] commit
    

  7. 检查配置结果

    配置完成后,在LSRA上执行display interface tunnel命令可以看到隧道接口状态为Up。

    [~LSRA] display interface tunnel 1
    Tunnel1 current state : UP (ifindex: 724)
    Line protocol current state : UP 
    Last line protocol up time : 2014-06-07 01:56:03
    Description: 
    ...

    在LSRA上执行display mpls te tunnel-interface命令可以看到隧道接口信息。

    [~LSRA] display mpls te tunnel-interface
        Tunnel Name       : Tunnel1
        Signalled Tunnel Name: -
        Tunnel State Desc : CR-LSP is Up
        Tunnel Attributes   :     
        Active LSP          : Primary LSP
        Traffic Switch      : - 
        Session ID          : 100
        Ingress LSR ID      : 1.1.1.9               Egress LSR ID: 3.3.3.9
        Admin State         : UP                    Oper State   : UP
        Signaling Protocol  : RSVP
        FTid                : 1
        Tie-Breaking Policy : None                  Metric Type  : None
        Bfd Cap             : None                  
        Reopt               : Disabled              Reopt Freq   : -              
        Auto BW             : Disabled              Threshold    : - 
        Current Collected BW: -                     Auto BW Freq : -
        Min BW              : -                     Max BW       : -
        Offload             : Disabled              Offload Freq : - 
        Low Value           : -                     High Value   : - 
        Readjust Value      : - 
        Offload Explicit Path Name: -
        Tunnel Group        : -                                              
        Interfaces Protected: -
        Excluded IP Address : -
        Referred LSP Count  : 0  
        Primary Tunnel      : -                     Pri Tunn Sum : -              
        Backup Tunnel       : -                                                    
        Group Status        : -                     Oam Status   : -             
        IPTN InLabel        : -                     Tunnel BFD Status : -
        BackUp LSP Type     : None                  BestEffort   : Disabled
        Secondary HopLimit  : -
        BestEffort HopLimit  : -
        Secondary Explicit Path Name: -
        Secondary Affinity Prop/Mask: 0x0/0x0
        BestEffort Affinity Prop/Mask: 0x0/0x0  
        IsConfigLspConstraint: -
        Hot-Standby Revertive Mode:  Revertive
        Hot-Standby Overlap-path:  Disabled
        Hot-Standby Switch State:  CLEAR
        Bit Error Detection:  Disabled
        Bit Error Detection Switch Threshold:  -
        Bit Error Detection Resume Threshold:  -
        Ip-Prefix Name    : -
        P2p-Template Name : -
        PCE Delegate      : No                     LSP Control Status : Local control
        Auto BW Remain Time   : -                     Reopt Remain Time     : -
    
    
        Primary LSP ID      : 1.1.1.9:1
        LSP State           : UP                    LSP Type     : Primary
        Setup Priority      : 7                     Hold Priority: 7
        IncludeAll          : 0x0
        IncludeAny          : 0x0
        ExcludeAny          : 0x0
        Affinity Prop/Mask  : 0x0/0x0               Resv Style   :  SE
        Configured Bandwidth Information:
        CT0 Bandwidth(Kbit/sec): 0               CT1 Bandwidth(Kbit/sec): 0
        CT2 Bandwidth(Kbit/sec): 0               CT3 Bandwidth(Kbit/sec): 0
        CT4 Bandwidth(Kbit/sec): 0               CT5 Bandwidth(Kbit/sec): 0
        CT6 Bandwidth(Kbit/sec): 0               CT7 Bandwidth(Kbit/sec): 0
        Actual Bandwidth Information:
        CT0 Bandwidth(Kbit/sec): 0               CT1 Bandwidth(Kbit/sec): 0
        CT2 Bandwidth(Kbit/sec): 0               CT3 Bandwidth(Kbit/sec): 0
        CT4 Bandwidth(Kbit/sec): 0               CT5 Bandwidth(Kbit/sec): 0
        CT6 Bandwidth(Kbit/sec): 0               CT7 Bandwidth(Kbit/sec): 0
        Explicit Path Name  : -                                Hop Limit: -
        Record Route        : Disabled              Record Label : Disabled
        Route Pinning       : Disabled
        FRR Flag            : Disabled
        IdleTime Remain     : -
        BFD Status          : -
        Soft Preemption     : Disabled
        Reroute Flag        : Disabled
        Pce Flag            : Normal
    

    在LSRA上执行display mpls te cspf tedb all命令查看TEDB中的链路信息。

    [~LSRA] display mpls te cspf tedb all
    Maximum Nodes Supported: 2000    Current Total Node Number: 3
    Maximum Links Supported: 8000    Current Total Link Number: 4
    Id     Router-Id        IGP      Process-Id     Area            Link-Count
    1      3.3.3.9          OSPF     1              0               1         
    2      1.1.1.9          OSPF     1              0               1         
    3      2.2.2.9          OSPF     1              0               2    

配置文件

  • LSRA的配置文件

    #
    sysname LSRA
    #
    vlan batch 10 100
    #
    mpls lsr-id 1.1.1.9
    #
    mpls
     mpls te
     mpls rsvp-te
     mpls te cspf
    #
    interface Vlanif10
     ip address 10.1.1.1 255.255.255.0
    #
    interface Vlanif100
     ip address 172.1.1.1 255.255.255.0
     mpls
     mpls te
     mpls rsvp-te
    #
    interface 10GE1/0/0
     port link-type trunk
     port trunk allow-pass vlan 100
    #
    interface 10GE2/0/0
     port link-type trunk
     port trunk allow-pass vlan 10
    #
    interface LoopBack1
     ip address 1.1.1.9 255.255.255.255
    #
    interface Tunnel1
     ip address unnumbered interface LoopBack1
     tunnel-protocol mpls te
     destination 3.3.3.9
     mpls te tunnel-id 100
    #
    ospf 1
     opaque-capability enable
     area 0.0.0.0
      network 1.1.1.9 0.0.0.0
      network 172.1.1.0 0.0.0.255
      mpls-te enable
    #
    ip route-static 10.2.1.0 255.255.255.0 tunnel1
    #
    return
  • LSRB的配置文件

    #
    sysname LSRB
    #
    vlan batch 100 200
    #
    mpls lsr-id 2.2.2.9
    #
    mpls
     mpls te
     mpls rsvp-te
    #
    interface Vlanif100
     ip address 172.1.1.2 255.255.255.0
     mpls
     mpls te
     mpls rsvp-te
    #
    interface Vlanif200
     ip address 172.2.1.1 255.255.255.0
     mpls
     mpls te
     mpls rsvp-te
    #
    interface 10GE1/0/0
     port link-type trunk
     port trunk allow-pass vlan 100
    #
    interface 10GE2/0/0
     port link-type trunk
     port trunk allow-pass vlan 200
    #
    interface LoopBack1
     ip address 2.2.2.9 255.255.255.255
    #
    ospf 1
     opaque-capability enable
     area 0.0.0.0
      network 2.2.2.9 0.0.0.0
      network 172.1.1.0 0.0.0.255
      network 172.2.1.0 0.0.0.255
      mpls-te enable
    #
    return
  • LSRC的配置文件

    #
    sysname LSRC
    #
    vlan batch 20 200
    #
    mpls lsr-id 3.3.3.9
    #
    mpls
     mpls te
     mpls rsvp-te
    #
    interface Vlanif20
     ip address 10.2.1.1 255.255.255.0
    #
    interface Vlanif200
     ip address 172.2.1.2 255.255.255.0
     mpls
     mpls te
     mpls rsvp-te
    #
    interface 10GE1/0/0
     port link-type trunk
     port trunk allow-pass vlan 200
    #
    interface 10GE2/0/0
     port link-type trunk
     port trunk allow-pass vlan 20
    #
    interface LoopBack1
     ip address 3.3.3.9 255.255.255.255
    #
    ospf 1
     opaque-capability enable
     area 0.0.0.0
      network 3.3.3.9 0.0.0.0
      network 172.2.1.0 0.0.0.255
      mpls-te enable
    #
    return
翻译
下载文档
更新时间:2019-05-05

文档编号:EDOC1100004215

浏览量:27946

下载量:477

平均得分:
本文档适用于这些产品
相关文档
相关版本
Share
上一页 下一页