所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

CloudEngine 12800 V200R003C00 配置指南-MPLS

本文档介绍了MPLS的配置,具体包括MPLS基础、MPLS LDP配置、MPLS QoS配置、MPLS TE配置和SR-TE配置。
评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
配置CR-LSP热备份的SRLG示例

配置CR-LSP热备份的SRLG示例

组网需求

图4-35所示,在LSRA和LSRC之间建立了一条MPLS TE隧道,其路径为LSRA→LSRB→LSRC。

链路LSRA→LSRB和LSRA→LSRE属于同一个SRLG(假设为SRLG1);链路LSRB→LSRC和LSRE→LSRC属于同一个SRLG(假设为SRLG2)。

为了提高可靠性,要求配置CR-LSP热备份,备份隧道的路径与主隧道链路不能属于同一个SRLG。

图4-35 配置CR-LSP热备份的SRLG组网图

配置思路

本例按如下思路配置CR-LSP热备份的SRLG:

  1. 配置各接口的IP地址,并使用OSPF协议实现各节点之间公网路由可达。

  2. 配置LSR ID并全局使能各节点以及接口的MPLS、MPLS TE、RSVP-TE、CSPF功能,使能OSPF TE。

  3. 在主隧道入节点创建隧道接口,配置隧道的IP地址、隧道协议、目的地址、隧道ID、动态信令协议RSVP-TE。显式路径为:LSRA→LSRB→LSRC。

  4. 在SRLG成员接口上配置SRLG组号。

  5. 在主隧道入节点配置SRLG路径计算模式。

  6. 在主隧道入节点配置CR-LSP热备份功能。

操作步骤

  1. 配置各接口的IP地址,并配置OSPF

    # 配置LSRA。按图4-35配置各设备的接口IP地址,其中LSRB、LSRC、LSRE和LSRF的配置与LSRA类似,不再赘述。

    <HUAWEI> system-view
    [~HUAWEI] sysname LSRA
    [*HUAWEI] commit
    [~LSRA] vlan batch 100 400 600
    [*LSRA] interface vlanif 100
    [*LSRA-Vlanif100] ip address 172.1.1.1 255.255.255.0
    [*LSRA-Vlanif100] quit
    [*LSRA] interface vlanif 400
    [*LSRA-Vlanif400] ip address 172.4.1.1 255.255.255.0
    [*LSRA-Vlanif400] quit
    [*LSRA] interface vlanif 600
    [*LSRA-Vlanif600] ip address 172.6.1.1 255.255.255.0
    [*LSRA-Vlanif600] quit
    [*LSRA] interface 10ge 1/0/1
    [*LSRA-10GE1/0/1] port link-type trunk
    [*LSRA-10GE1/0/1] port trunk allow-pass vlan 100
    [*LSRA-10GE1/0/1] quit
    [*LSRA] interface 10ge 1/0/2
    [*LSRA-10GE1/0/2] port link-type trunk
    [*LSRA-10GE1/0/2] port trunk allow-pass vlan 600
    [*LSRA-10GE1/0/2] quit
    [*LSRA] interface 10ge 1/0/3
    [*LSRA-10GE1/0/3] port link-type trunk
    [*LSRA-10GE1/0/3] port trunk allow-pass vlan 400
    [*LSRA-10GE1/0/3] quit
    [*LSRA] interface loopback 1
    [*LSRA-LoopBack1] ip address 1.1.1.9 255.255.255.255
    [*LSRA-LoopBack1] quit
    [*LSRA] ospf 1
    [*LSRA-ospf-1] area 0
    [*LSRA-ospf-1-area-0.0.0.0] network 1.1.1.9 0.0.0.0
    [*LSRA-ospf-1-area-0.0.0.0] network 172.1.1.0 0.0.0.255
    [*LSRA-ospf-1-area-0.0.0.0] network 172.4.1.0 0.0.0.255
    [*LSRA-ospf-1-area-0.0.0.0] network 172.6.1.0 0.0.0.255
    [*LSRA-ospf-1-area-0.0.0.0] quit
    [*LSRA-ospf-1] quit
    [*LSRA] commit

    # 配置完成后,在各节点上执行display ip routing-table命令,应可以看到相互之间都学到了到对方Loopback1的路由。以LSRA的显示为例:

    [~LSRA] display ip routing-table
    Proto: Protocol        Pre: Preference
    Route Flags: R - relay, D - download to fib, T - to vpn-instance, B - black hole route
    ------------------------------------------------------------------------------
    Routing Table : _public_
             Destinations : 16       Routes : 18        
    
    Destination/Mask    Proto   Pre  Cost        Flags NextHop         Interface
    
            1.1.1.9/32  Direct  0    0             D   127.0.0.1       LoopBack1
            2.2.2.9/32  OSPF    10   1             D   172.1.1.2       Vlanif100
            3.3.3.9/32  OSPF    10   2             D   172.1.1.2       Vlanif100
                        OSPF    10   2             D   172.4.1.2       Vlanif400
                        OSPF    10   2             D   172.6.1.2       Vlanif600
            5.5.5.9/32  OSPF    10   1             D   172.4.1.2       Vlanif400
            6.6.6.9/32  OSPF    10   1             D   172.6.1.2       Vlanif600
          127.0.0.0/8   Direct  0    0             D   127.0.0.1       InLoopBack0
          127.0.0.1/32  Direct  0    0             D   127.0.0.1       InLoopBack0
          172.1.1.0/24  Direct  0    0             D   172.1.1.1       Vlanif100
          172.1.1.1/32  Direct  0    0             D   127.0.0.1       Vlanif100
          172.2.1.0/24  OSPF    10   2             D   172.1.1.2       Vlanif100
          172.4.1.0/24  Direct  0    0             D   172.4.1.1       Vlanif400
          172.4.1.1/32  Direct  0    0             D   127.0.0.1       Vlanif400
          172.5.1.0/24  OSPF    10   2             D   172.4.1.2       Vlanif400
          172.6.1.0/24  Direct  0    0             D   172.6.1.1       Vlanif600
          172.6.1.1/32  Direct  0    0             D   127.0.0.1       Vlanif600
          172.7.1.0/24  OSPF    10   2             D   172.6.1.2       Vlanif600
    

  2. 配置MPLS基本能力,使能MPLS TE、RSVP-TE和CSPF

    # 配置LSRA。LSRB、LSRC、LSRE和LSRF的配置与LSRA类似,不再赘述。其中,只需在主隧道的入节点LSRA上使能CSPF。

    [~LSRA] mpls lsr-id 1.1.1.9
    [*LSRA] mpls
    [*LSRA-mpls] mpls te
    [*LSRA-mpls] mpls rsvp-te
    [*LSRA-mpls] mpls te cspf
    [*LSRA-mpls] quit
    [*LSRA] interface vlanif 100
    [*LSRA-Vlanif100] mpls
    [*LSRA-Vlanif100] mpls te
    [*LSRA-Vlanif100] mpls rsvp-te
    [*LSRA-Vlanif100] quit
    [*LSRA] interface vlanif 400
    [*LSRA-Vlanif400] mpls
    [*LSRA-Vlanif400] mpls te
    [*LSRA-Vlanif400] mpls rsvp-te
    [*LSRA-Vlanif400] quit
    [*LSRA] interface vlanif 600
    [*LSRA-Vlanif600] mpls
    [*LSRA-Vlanif600] mpls te
    [*LSRA-Vlanif600] mpls rsvp-te
    [*LSRA-Vlanif600] quit
    [*LSRA] commit

  3. 配置OSPF TE

    # 配置LSRA。LSRB、LSRC、LSRE和LSRF的配置与LSRA类似,不再赘述。

    [~LSRA] ospf
    [*LSRA-ospf-1] opaque-capability enable
    [*LSRA-ospf-1] area 0
    [*LSRA-ospf-1-area-0.0.0.0] mpls-te enable
    [*LSRA-ospf-1-area-0.0.0.0] quit
    [*LSRA-ospf-1] quit
    [*LSRA] commit

  4. 在入节点创建主CR-LSP的MPLS TE Tunnel

    # 在LSRA上配置主CR-LSP的显式路径。

    [~LSRA] explicit-path pri-path
    [*LSRA-explicit-path-pri-path] next hop 172.1.1.2
    [*LSRA-explicit-path-pri-path] next hop 172.2.1.2
    [*LSRA-explicit-path-pri-path] next hop 3.3.3.9
    [*LSRA-explicit-path-pri-path] quit
    [*LSRA] commit

    # 在LSRA上配置主CR-LSP的MPLS TE隧道接口。

    [~LSRA] interface tunnel 1
    [*LSRA-Tunnel1] ip address unnumbered interface loopBack 1
    [*LSRA-Tunnel1] tunnel-protocol mpls te
    [*LSRA-Tunnel1] destination 3.3.3.9
    [*LSRA-Tunnel1] mpls te tunnel-id 100
    [*LSRA-Tunnel1] mpls te path explicit-path pri-path
    [*LSRA-Tunnel1] quit
    [*LSRA] commit

    # 在LSRA上执行命令display interface tunnel 1查看隧道状态,可发现隧道状态为UP。

    [~LSRA] display interface tunnel 1
    Tunnel1 current state : UP (ifindex: 2446)
    Line protocol current state : UP 
    Last line protocol up time : 2017-07-12 09:35:40
    Description: 
    ...

  5. 配置SRLG

    链路LSRA→LSRB和LSRA→LSRE属于SRLG1,链路LSRB→LSRC和LSRE→LSRC属于SRLG2。在主隧道入节点LSRA配置SRLG路径计算模式。

    # 配置LSRA。

    [~LSRA] interface vlanif 100
    [~LSRA-Vlanif100] mpls te srlg 1
    [*LSRA-Vlanif100] quit
    [*LSRA] interface vlanif 400
    [*LSRA-Vlanif400] mpls te srlg 1
    [*LSRA-Vlanif400] quit
    [*LSRA] commit

    # 配置LSRB。

    [~LSRB] interface vlanif 200
    [~LSRB-Vlanif200] mpls te srlg 2
    [*LSRB-Vlanif200] quit
    [*LSRB] commit

    # 配置LSRE。

    [~LSRE] interface vlanif 500
    [~LSRE-Vlanif500] mpls te srlg 2
    [*LSRE-Vlanif500] quit
    [*LSRE] commit

    # 在LSRA上配置SRLG路径计算模式。

    [~LSRA] mpls
    [~LSRA-mpls] mpls te srlg path-calculation strict
    [*LSRA-mpls] quit
    [*LSRA] commit

    # 执行命令display mpls te srlg all,查看SRLG信息和SRLG成员接口。以LSRA为例:

    [~LSRA] display mpls te srlg all
    Total SRLG supported : 1024
    Total SRLG configured : 2
     SRLG           1:         Vlanif100         Vlanif400
    

    # 执行命令display mpls te link-administration srlg-information,查看接口属于哪些SRLG。以LSRA为例:

    [~LSRA] display mpls te link-administration srlg-information
     SRLGs on Vlanif100 :
                  1
     SRLGs on Vlanif400 :
                  1
    

    # 执行命令display mpls te cspf tedb srlg,查看SRLG的TEDB信息。以LSRA为例:

    [~LSRA] display mpls te cspf tedb srlg 1
    Interface-Address   IGP-Type            Area      
    172.1.1.1           OSPF                0         
    172.4.1.1           OSPF                0         
    
    [~LSRA] display mpls te cspf tedb srlg 2
    Interface-Address   IGP-Type            Area      
    172.2.1.1           OSPF                0         
    172.5.1.1           OSPF                0         
    

  6. 在入节点配置CR-LSP热备份

    # 配置LSRA。

    [~LSRA] interface tunnel 1
    [~LSRA-Tunnel1] mpls te backup hot-standby
    [*LSRA-Tunnel1] quit
    [*LSRA] commit

    # 在LSRA上执行display mpls te tunnel-interface命令查看隧道信息,可以看到热备份CR-LSP已经成功建立。

    [~LSRA] display mpls te tunnel-interface
        Tunnel Name       : Tunnel1
        Signalled Tunnel Name: -
        Tunnel State Desc : Primary CR-LSP Up and HotBackup CR-LSP Up
        Tunnel Attributes   :     
        Active LSP          : Primary LSP
        Traffic Switch      : - 
        Session ID          : 100
        Ingress LSR ID      : 1.1.1.9               Egress LSR ID: 3.3.3.9
        Admin State         : UP                    Oper State   : UP
        Signaling Protocol  : RSVP
        FTid                : 1
        Tie-Breaking Policy : None                  Metric Type  : None
        Bfd Cap             : None                  
        Reopt               : Disabled              Reopt Freq   : -              
        Auto BW             : Disabled              Threshold    : - 
        Current Collected BW: -                     Auto BW Freq : -
        Min BW              : -                     Max BW       : -
        Offload             : Disabled              Offload Freq : - 
        Low Value           : -                     High Value   : - 
        Readjust Value      : - 
        Offload Explicit Path Name: -
        Tunnel Group        : Primary
        Interfaces Protected: -
        Excluded IP Address : -
        Referred LSP Count  : 0
        Primary Tunnel      : -                     Pri Tunn Sum : -
        Backup Tunnel       : -
        Group Status        : Up                    Oam Status   : None
        IPTN InLabel        : -                     Tunnel BFD Status : -
        BackUp LSP Type     : Hot-Standby           BestEffort   : Disabled
        Secondary HopLimit  : -
        BestEffort HopLimit  : -
        Secondary Explicit Path Name: -
        Secondary Affinity Prop/Mask: 0x0/0x0
        BestEffort Affinity Prop/Mask: 0x0/0x0  
        IsConfigLspConstraint: -
        Hot-Standby Revertive Mode:  Revertive
        Hot-Standby Overlap-path:  Disabled
        Hot-Standby Switch State:  CLEAR
        Bit Error Detection:  Disabled
        Bit Error Detection Switch Threshold:  -
        Bit Error Detection Resume Threshold:  -
        Ip-Prefix Name    : -
        P2p-Template Name : -
        PCE Delegate      : No                     LSP Control Status : Local control
        Auto BW Remain Time   : -                     Reopt Remain Time     : -
    
    
        Primary LSP ID      : 1.1.1.9:18
        LSP State           : UP                    LSP Type     : Primary
        Setup Priority      : 7                     Hold Priority: 7
        IncludeAll          : 0x0
        IncludeAny          : 0x0
        ExcludeAny          : 0x0
        Affinity Prop/Mask  : 0x0/0x0               Resv Style   :  SE
        Configured Bandwidth Information:
        CT0 Bandwidth(Kbit/sec): 0               CT1 Bandwidth(Kbit/sec): 0
        CT2 Bandwidth(Kbit/sec): 0               CT3 Bandwidth(Kbit/sec): 0
        CT4 Bandwidth(Kbit/sec): 0               CT5 Bandwidth(Kbit/sec): 0
        CT6 Bandwidth(Kbit/sec): 0               CT7 Bandwidth(Kbit/sec): 0
        Actual Bandwidth Information:
        CT0 Bandwidth(Kbit/sec): 0               CT1 Bandwidth(Kbit/sec): 0
        CT2 Bandwidth(Kbit/sec): 0               CT3 Bandwidth(Kbit/sec): 0
        CT4 Bandwidth(Kbit/sec): 0               CT5 Bandwidth(Kbit/sec): 0
        CT6 Bandwidth(Kbit/sec): 0               CT7 Bandwidth(Kbit/sec): 0
        Explicit Path Name  : pri-path                         Hop Limit: -
        Record Route        : Enabled               Record Label : Disabled
        Route Pinning       : Disabled
        FRR Flag            : Disabled
        IdleTime Remain     : -
        BFD Status          : -
        Soft Preemption     : Disabled
        Reroute Flag        : Enabled
        Pce Flag            : Normal
        
        Backup LSP ID       : 1.1.1.9:19
        IsBestEffortPath    : No
        LSP State           : UP                    LSP Type     : Hot-Standby
        Setup Priority      : 7                     Hold Priority: 7
        IncludeAll          : 0x0
        IncludeAny          : 0x0
        ExcludeAny          : 0x0
        Affinity Prop/Mask  : 0x0/0x0               Resv Style   :  SE
        Configured Bandwidth Information:
        CT0 Bandwidth(Kbit/sec): 0               CT1 Bandwidth(Kbit/sec): 0
        CT2 Bandwidth(Kbit/sec): 0               CT3 Bandwidth(Kbit/sec): 0
        CT4 Bandwidth(Kbit/sec): 0               CT5 Bandwidth(Kbit/sec): 0
        CT6 Bandwidth(Kbit/sec): 0               CT7 Bandwidth(Kbit/sec): 0
        Actual Bandwidth Information:
        CT0 Bandwidth(Kbit/sec): 0               CT1 Bandwidth(Kbit/sec): 0
        CT2 Bandwidth(Kbit/sec): 0               CT3 Bandwidth(Kbit/sec): 0
        CT4 Bandwidth(Kbit/sec): 0               CT5 Bandwidth(Kbit/sec): 0
        CT6 Bandwidth(Kbit/sec): 0               CT7 Bandwidth(Kbit/sec): 0
        Explicit Path Name  : -                                Hop Limit: -
        Record Route        : Enabled               Record Label : Disabled
        Route Pinning       : Disabled
        FRR Flag            : Disabled
        IdleTime Remain     : -
        BFD Status          : -
        Soft Preemption     : Disabled
        Reroute Flag        : Enabled
        Pce Flag            : Normal
        

    # 在LSRA上执行display mpls te hot-standby state interface tunnel 1命令查看热备份信息。

    [~LSRA] display mpls te hot-standby state interface tunnel 1
    (s): same path
    ----------------------------------------------------------------
    Verbose information about the Tunnel1 hot-standby state
    ----------------------------------------------------------------
        Tunnel name           : Tunnel1
        Session ID            : 100
        Main LSP index        : 0x2041
        Hot-standby LSP index : 0x2081
        HSB switch result     : main LSP
        HSB switch reason     : -
        WTR config time       : 10 s
        WTR remain time       : -
        Using overlapped path : no 
    

  7. 检查配置结果

    # 完成上述配置之后,可以在LSRA上执行display mpls te tunnel path命令查看主CR-LSP和备份CR-LSP经过的节点信息。

    [~LSRA] display mpls te tunnel path
     Tunnel Interface Name : Tunnel1
     Lsp ID : 1.1.1.9 :100 :18
     Hop Information
      Hop 0   172.1.1.1
      Hop 1   172.1.1.2
      Hop 2   2.2.2.9
      Hop 3   172.2.1.1
      Hop 4   172.2.1.2
      Hop 5   3.3.3.9
    
     Tunnel Interface Name : Tunnel1
     Lsp ID : 1.1.1.9 :100 :19
     Hop Information
      Hop 0   172.6.1.1
      Hop 1   172.6.1.2
      Hop 2   6.6.6.9
      Hop 3   172.7.1.1
      Hop 4   172.7.1.2
      Hop 5   3.3.3.9
    

    # 在LSRA的10GE1/0/2上执行shutdown命令。

    [~LSRA] interface 10ge 1/0/2
    [~LSRA-10GE1/0/2] shutdown
    [*LSRA-10GE1/0/2] quit
    [*LSRA] commit

    # 在LSRA上再次执行命令display mpls te hot-standby state interface tunnel 1可看到热备份LSP的Token为0x0,表示热备份LSP没有建立,尽管有其它可使用的路径LSRA→LSRE→LSRC。

    [~LSRA] display mpls te hot-standby state interface tunnel 1
    (s): same path
    ----------------------------------------------------------------
    Verbose information about the Tunnel1 hot-standby state
    ----------------------------------------------------------------
        Tunnel name           : Tunnel1
        Session ID            : 100
        Main LSP index        : 0x2041
        Hot-standby LSP index : 0x0
        HSB switch result     : main LSP
        HSB switch reason     : -
        WTR config time       : 10 s
        WTR remain time       : -
        Using overlapped path : - 
    

配置文件

  • LSRA的配置文件

    #
    sysname LSRA
    #
    vlan batch 100 400 600
    #
    mpls lsr-id 1.1.1.9
    #
    mpls
     mpls te
     mpls te srlg path-calculation strict
     mpls rsvp-te
     mpls te cspf
    #
    explicit-path pri-path
     next hop 172.1.1.2
     next hop 172.2.1.2
     next hop 3.3.3.9
    #    
    interface Vlanif100
     ip address 172.1.1.1 255.255.255.0
     mpls
     mpls te
     mpls te srlg 1
     mpls rsvp-te
    #    
    interface Vlanif400
     ip address 172.4.1.1 255.255.255.0
     mpls
     mpls te
     mpls te srlg 1
     mpls rsvp-te
    #
    interface Vlanif600
     ip address 172.6.1.1 255.255.255.0
     mpls
     mpls te
     mpls rsvp-te
    #
    interface 10GE1/0/1
     port link-type trunk
     port trunk allow-pass vlan 100
    #    
    interface 10GE1/0/2
     port link-type trunk
     port trunk allow-pass vlan 600
    #
    interface 10GE1/0/3
     port link-type trunk
     port trunk allow-pass vlan 400
    #
    interface LoopBack1
     ip address 1.1.1.9 255.255.255.255
    #
    interface Tunnel1
     ip address unnumbered interface LoopBack1
     tunnel-protocol mpls te
     destination 3.3.3.9
     mpls te record-route
     mpls te backup hot-standby
     mpls te tunnel-id 100
     mpls te path explicit-path pri-path
    #
    ospf 1
     opaque-capability enable
     area 0.0.0.0
      network 1.1.1.9 0.0.0.0
      network 172.1.1.0 0.0.0.255
      network 172.4.1.0 0.0.0.255
      network 172.6.1.0 0.0.0.255
      mpls-te enable
    #
    return
  • LSRB的配置文件

    #
    sysname LSRB
    #
    vlan batch 100 200
    # 
    mpls lsr-id 2.2.2.9
    #
    mpls
     mpls te
     mpls rsvp-te
    #
    interface Vlanif100
     ip address 172.1.1.2 255.255.255.0
     mpls
     mpls te
     mpls rsvp-te
    # 
    interface Vlanif200
     ip address 172.2.1.1 255.255.255.0
     mpls
     mpls te
     mpls te srlg 2
     mpls rsvp-te
    #
    interface 10GE1/0/1
     port link-type trunk
     port trunk allow-pass vlan 100
    # 
    interface 10GE1/0/2
     port link-type trunk
     port trunk allow-pass vlan 200
    #
    interface LoopBack1
     ip address 2.2.2.9 255.255.255.255
    # 
    ospf 1
     opaque-capability enable
     area 0.0.0.0
      network 2.2.2.9 0.0.0.0
      network 172.1.1.0 0.0.0.255
      network 172.2.1.0 0.0.0.255
      mpls-te enable
    #
    return
  • LSRC的配置文件

    #
    sysname LSRC
    #
    vlan batch 200 500 700
    #
    mpls lsr-id 3.3.3.9
    #
    mpls
     mpls te
     mpls rsvp-te
    #
    interface Vlanif200
     ip address 172.2.1.2 255.255.255.0
     mpls
     mpls te
     mpls rsvp-te
    #
    interface Vlanif500
     ip address 172.5.1.2 255.255.255.0
     mpls
     mpls te
     mpls rsvp-te
    #
    interface Vlanif700
     ip address 172.7.1.2 255.255.255.0
     mpls
     mpls te
     mpls rsvp-te
    #
    interface 10GE1/0/1
     port link-type trunk
     port trunk allow-pass vlan 200
    #
    interface 10GE1/0/2
     port link-type trunk
     port trunk allow-pass vlan 500
    #
    interface 10GE1/0/3
     port link-type trunk
     port trunk allow-pass vlan 700
    #
    interface LoopBack1
     ip address 3.3.3.9 255.255.255.255
    #
    ospf 1
     opaque-capability enable
     area 0.0.0.0
      network 3.3.3.9 0.0.0.0
      network 172.2.1.0 0.0.0.255
      network 172.5.1.0 0.0.0.255
      network 172.7.1.0 0.0.0.255
      mpls-te enable
    #
    return
  • LSRE的配置文件

    #
    sysname LSRE
    #
    vlan batch 400 500
    #
    mpls lsr-id 5.5.5.9
    #
    mpls
     mpls te
     mpls rsvp-te
    #
    interface Vlanif400
     ip address 172.4.1.2 255.255.255.0
     mpls
     mpls te
     mpls rsvp-te
    #
    interface Vlanif500
     ip address 172.5.1.1 255.255.255.0
     mpls
     mpls te
     mpls te srlg 2
     mpls rsvp-te
    #
    interface 10GE1/0/1
     port link-type trunk
     port trunk allow-pass vlan 400
    #
    interface 10GE1/0/2
     port link-type trunk
     port trunk allow-pass vlan 500
    #
    interface LoopBack1
     ip address 5.5.5.9 255.255.255.255
    #
    ospf 1
     opaque-capability enable
     area 0.0.0.0
      network 5.5.5.9 0.0.0.0
      network 172.4.1.0 0.0.0.255
      network 172.5.1.0 0.0.0.255
      mpls-te enable
    #
    return
  • LSRF的配置文件

    #
    sysname LSRF
    #
    vlan batch 600 700
    #
    mpls lsr-id 6.6.6.9
    #
    mpls
     mpls te
     mpls rsvp-te
    #
    interface Vlanif600
     ip address 172.6.1.2 255.255.255.0
     mpls
     mpls te
     mpls rsvp-te
    #
    interface Vlanif700
     ip address 172.7.1.1 255.255.255.0
     mpls
     mpls te
     mpls rsvp-te
    #
    interface 10GE1/0/1
     port link-type trunk
     port trunk allow-pass vlan 600
    #
    interface 10GE1/0/2
     port link-type trunk
     port trunk allow-pass vlan 700
    #
    interface LoopBack1
     ip address 6.6.6.9 255.255.255.255
    #
    ospf 1
     opaque-capability enable
     area 0.0.0.0
      network 6.6.6.9 0.0.0.0
      network 172.6.1.0 0.0.0.255
      network 172.7.1.0 0.0.0.255
      mpls-te enable
    #
    return
翻译
下载文档
更新时间:2019-05-05

文档编号:EDOC1100004215

浏览量:29341

下载量:486

平均得分:
本文档适用于这些产品
相关文档
相关版本
Share
上一页 下一页