所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

CloudEngine 12800 V200R003C00 配置指南-MPLS

本文档介绍了MPLS的配置,具体包括MPLS基础、MPLS LDP配置、MPLS QoS配置、MPLS TE配置和SR-TE配置。
评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
配置LDP与IGP联动示例

配置LDP与IGP联动示例

组网需求

图2-24所示,MPLS骨干网络包括P1、P2、P3、PE2四个节点,各设备间运行OSPF路由协议。PE1到PE2之间建立两条LSP链路来承载网络业务,PE1->P1->P2->PE2为主链路,PE1->P1->P3->PE2为备份链路。当主链路故障后恢复时,由于IGP路由比LDP收敛速度快,IGP会先于LDP切换回主链路,因此造成MPLS流量丢失。对于实时性要求高的网络业务(例如VoIP,在线游戏,在线视频业务等),用户无法容忍业务的短时间中断,要求能够解决在LSP存在主备链路的组网中MPLS流量丢失的问题。

请确保该场景下STP处于未使能状态,否则可能会导致主用链路不可用。

图2-24 配置LDP与IGP联动组网

配置思路

配置LDP与IGP联动,可以实现此需求。采用如下配置思路:

  1. 在P、PE2上配置OSPF,实现骨干网的IP连通性。

  2. 在P、PE2上配置本地LDP会话,创建LDP LSP承载网络业务。

  3. 在P1、P2上配置LDP与IGP联动功能,避免流量丢失。

操作步骤

  1. 交换机上创建VLAN、VLANIF接口,配置VLANIF接口的IP地址,并将相应的物理接口加入到VLAN

    # 配置P1。P2、P3和PE2的配置与P1类似,不再赘述。

    <HUAWEI> system-view
    [~HUAWEI] sysname P1
    [*HUAWEI] commit
    [~P1] interface loopback 1
    [*P1-LoopBack1] ip address 1.1.1.9 32
    [*P1-LoopBack1] quit
    [*P1] vlan batch 10 30
    [*P1] interface vlanif 10
    [*P1-Vlanif10] ip address 10.1.1.1 24
    [*P1-Vlanif10] quit
    [*P1] interface vlanif 30
    [*P1-Vlanif30] ip address 10.3.1.1 24
    [*P1-Vlanif30] quit
    [*P1] interface 10ge 1/0/1
    [*P1-10GE1/0/1] port link-type trunk
    [*P1-10GE1/0/1] port trunk allow-pass vlan 10
    [*P1-10GE1/0/1] quit
    [*P1] interface 10ge 2/0/2
    [*P1-10GE2/0/2] port link-type trunk
    [*P1-10GE2/0/2] port trunk allow-pass vlan 30
    [*P1-10GE2/0/2] quit
    [*P1] commit

  2. 配置OSPF协议发布各节点接口所连网段和LSR ID的主机路由

    # 配置P1。P2、P3和PE2的配置与P1类似,不再赘述。

    [~P1] ospf 1
    [*P1-ospf-1] area 0
    [*P1-ospf-1-area-0.0.0.0] network 1.1.1.9 0.0.0.0
    [*P1-ospf-1-area-0.0.0.0] network 10.1.1.0 0.0.0.255
    [*P1-ospf-1-area-0.0.0.0] network 10.3.1.0 0.0.0.255
    [*P1-ospf-1-area-0.0.0.0] quit
    [*P1-ospf-1] quit
    [*P1] commit

  3. 配置P1的接口VLANIF30的cost值为1000

    [~P1] interface vlanif 30 
    [~P1-Vlanif30] ospf cost 1000 
    [*P1-Vlanif30] quit
    [*P1] commit

    上述配置完成后,在各节点上执行display ip routing-table命令,可以看到相互之间都学到了到达彼此的路由,且P1到PE2路由的出接口为Vlanif10。

  4. 使能各节点全局和各接口的MPLS和MPLS LDP

    # 配置P1。

    [~P1] mpls lsr-id 1.1.1.9 
    [*P1] mpls
    [*P1-mpls] quit 
    [*P1] mpls ldp 
    [*P1-mpls-ldp] quit 
    [*P1] interface vlanif 10 
    [*P1-Vlanif10] mpls 
    [*P1-Vlanif10] mpls ldp 
    [*P1-Vlanif10] quit
    [*P1] interface vlanif 30 
    [*P1-Vlanif30] mpls 
    [*P1-Vlanif30] mpls ldp
    [*P1-Vlanif30] commit
    [~P1-Vlanif30] quit

    # 配置P2。

    [~P2] mpls lsr-id 2.2.2.9 
    [*P2] mpls 
    [*P2-mpls] quit 
    [*P2] mpls ldp 
    [*P2-mpls-ldp] quit
    [*P2] interface vlanif 10 
    [*P2-Vlanif10] mpls 
    [*P2-Vlanif10] mpls ldp 
    [*P2-Vlanif10] quit
    [*P2] interface vlanif 20 
    [*P2-Vlanif20] mpls
    [*P2-Vlanif20] mpls ldp
    [*P2-Vlanif20] commit
    [~P2-Vlanif20] quit

    # 配置P3。

    [~P3] mpls lsr-id 3.3.3.9 
    [*P3] mpls 
    [*P3-mpls] quit 
    [*P3] mpls ldp 
    [*P3-mpls-ldp] quit
    [*P3] interface vlanif 30 
    [*P3-Vlanif30] mpls 
    [*P3-Vlanif30] mpls ldp 
    [*P3-Vlanif30] quit
    [*P3] interface vlanif 40 
    [*P3-Vlanif40] mpls 
    [*P3-Vlanif40] mpls ldp
    [*P3-Vlanif40] commit
    [~P3-Vlanif40] quit

    # 配置PE2。

    [~PE2] mpls lsr-id 4.4.4.9 
    [*PE2] mpls 
    [*PE2-mpls] quit 
    [*PE2] mpls ldp
    [*PE2-mpls-ldp] quit 
    [*PE2] interface vlanif 20 
    [*PE2-Vlanif20] mpls
    [*PE2-Vlanif20] mpls ldp 
    [*PE2-Vlanif20] quit 
    [*PE2] interface vlanif 40 
    [*PE2-Vlanif40] mpls 
    [*PE2-Vlanif40] mpls ldp
    [*PE2-Vlanif40] commit
    [~PE2-Vlanif40] quit

    上述配置完成后,相邻节点之间应该建立起LDP会话。在各节点上执行display mpls ldp session命令可以看到显示结果中Status项为“Operational”。以P1的显示为例:

    [~P1] display mpls ldp session
     LDP Session(s) in Public Network
     LAM: Label Advertisement Mode,  KA: KeepAlive
     SsnAge: Session Age, Unit(DDDD:HH:MM)
     An asterisk (*) before a session means the session is being deleted.
     ------------------------------------------------------------------------------
     PeerID             Status      LAM  SsnRole  SsnAge      KASent/Rcv
     ------------------------------------------------------------------------------
     2.2.2.9:0          Operational DU   Active   000:00:56   227/227
     3.3.3.9:0          Operational DU   Active   000:00:56   227/227
     ------------------------------------------------------------------------------
     TOTAL: 2 Session(s) Found.

  5. 在主备链路的分叉节点P1和主链路上的LDP邻居节点P2之间的链路两端接口上使能LDP与IGP联动功能

    # 配置P1。

    [~P1] interface vlanif 10 
    [~P1-Vlanif10] ospf ldp-sync
    [*P1-Vlanif10] commit
    [~P1-Vlanif10] quit

    # 配置P2。

    [~P2] interface vlanif 10 
    [~P2-Vlanif10] ospf ldp-sync
    [*P2-Vlanif10] commit
    [~P2-Vlanif10] quit

  6. 在主备链路的分叉节点P1和主链路上的LDP邻居节点P2之间的链路两端接口上配置定时器Hold-max-cost的值

    # 配置P1。

    [~P1] interface vlanif 10 
    [~P1-Vlanif10] ospf timer ldp-sync hold-max-cost 9
    [*P1-Vlanif10] commit 
    [~P1-Vlanif10] quit

    # 配置P2。

    [~P2] interface vlanif 10 
    [~P2-Vlanif10] ospf timer ldp-sync hold-max-cost 9
    [*P2-Vlanif10] commit 
    [~P2-Vlanif10] quit

  7. 检查配置结果

    上述配置完成后,在P1节点上执行display ospf ldp-sync命令,可以看到接口状态为“Sync-Achieved”。

    [~P1] display ospf ldp-sync interface vlanif 10
    
     Area 0.0.0.0
     Interface Vlanif10
     HoldDown Timer: 10        HoldMaxCost Timer: 9
     LDP State: Up             OSPF Sync State: Sync-Achieved
    

配置文件

  • P1的配置文件

    #
    sysname P1
    #
    vlan batch 10 30
    #
    mpls lsr-id 1.1.1.9
    #
    mpls
    #
    mpls ldp
     #
     ipv4-family
    #
    interface Vlanif10
     ip address 10.1.1.1 255.255.255.0
     ospf ldp-sync 
     ospf timer ldp-sync hold-max-cost 9
     mpls
     mpls ldp
    #
    interface Vlanif30
     ip address 10.3.1.1 255.255.255.0
     ospf cost 1000
     mpls
     mpls ldp
    #
    interface 10GE1/0/1
     port link-type trunk 
     port trunk allow-pass vlan 10 
    #
    interface 10GE2/0/2
     port link-type trunk 
     port trunk allow-pass vlan 30 
    #
    interface LoopBack1
     ip address 1.1.1.9 255.255.255.255
    #
    ospf 1
     area 0.0.0.0
      network 1.1.1.9 0.0.0.0
      network 10.1.1.0 0.0.0.255
      network 10.3.1.0 0.0.0.255
    #
    return
  • P2的配置文件

    #
    sysname P2
    #
    vlan batch 10 20
    #
    mpls lsr-id 2.2.2.9
    #
    mpls
    #
    mpls ldp
     #
     ipv4-family
    #
    interface Vlanif10
     ip address 10.1.1.2 255.255.255.0
     ospf ldp-sync 
     ospf timer ldp-sync hold-max-cost 9
     mpls
     mpls ldp
    #
    interface Vlanif20
     ip address 10.2.1.1 255.255.255.0
     mpls
     mpls ldp
    #
    interface 10GE1/0/1
     port link-type trunk 
     port trunk allow-pass vlan 10 
    #
    interface 10GE2/0/2
     port link-type trunk 
     port trunk allow-pass vlan 20 
    #
    interface LoopBack1
     ip address 2.2.2.9 255.255.255.255
    #
    ospf 1
     area 0.0.0.0
      network 2.2.2.9 0.0.0.0
      network 10.1.1.0 0.0.0.255
      network 10.2.1.0 0.0.0.255
    #
    return
  • P3的配置文件

    #
    sysname P3
    #
    vlan batch 30 40
    #
    mpls lsr-id 3.3.3.9
    #
    mpls
    #
    mpls ldp
     #
     ipv4-family
    #
    interface Vlanif30
     ip address 10.3.1.2 255.255.255.0
     mpls
     mpls ldp
    #
    interface Vlanif40
     ip address 10.4.1.1 255.255.255.0
     mpls
     mpls ldp
    #
    interface 10GE1/0/1
     port link-type trunk 
     port trunk allow-pass vlan 30 
    #
    interface 10GE2/0/2
     port link-type trunk 
     port trunk allow-pass vlan 40 
    #
    interface LoopBack1
     ip address 3.3.3.9 255.255.255.255
    #
    ospf 1
     area 0.0.0.0
      network 3.3.3.9 0.0.0.0
      network 10.3.1.0 0.0.0.255
      network 10.4.1.0 0.0.0.255
    #
    return
  • PE2的配置文件

    #
    sysname PE2
    #
    vlan batch 20 40
    #
    mpls lsr-id 4.4.4.9
    #
    mpls
    #
    mpls ldp
     #
     ipv4-family
    #
    interface Vlanif20
     ip address 10.2.1.2 255.255.255.0
     mpls
     mpls ldp
    #
    interface Vlanif40
     ip address 10.4.1.2 255.255.255.0
     mpls
     mpls ldp
    #
    interface 10GE1/0/1
     port link-type trunk 
     port trunk allow-pass vlan 20 
    #
    interface 10GE2/0/2
     port link-type trunk 
     port trunk allow-pass vlan 40 
    #
    interface LoopBack1
     ip address 4.4.4.9 255.255.255.255
    #
    ospf 1
     area 0.0.0.0
      network 4.4.4.9 0.0.0.0
      network 10.2.1.0 0.0.0.255
      network 10.4.1.0 0.0.0.255
    #
    return
翻译
下载文档
更新时间:2019-05-05

文档编号:EDOC1100004215

浏览量:27591

下载量:477

平均得分:
本文档适用于这些产品
相关文档
相关版本
Share
上一页 下一页