所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

CloudEngine 12800, 12800E V200R003C00 配置指南-以太网交换

本文档针对设备的以太网业务,主要包括以太网交换概述、MAC配置、以太网链路聚合配置、M-LAG(跨设备链路聚合)配置、VLAN配置、QinQ配置、VLAN mapping配置、GVRP配置、STP/RSTP配置、MSTP配置、VBST配置、ERPS(G.8032)配置、Loopback Detection配置和二层协议透明传输配置。
评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
配置VXLAN双活接入示例(静态方式,集中式网关)

配置VXLAN双活接入示例(静态方式,集中式网关)

组网需求

图4-22所示,服务器接入VXLAN网络时,要求:
  • 为了保证可靠性,采用双归接入。当一条接入链路发生故障时,流量可以快速切换到另一条链路。
  • 为了高效利用带宽,两条链路同时处于active状态,可实现使用负载分担的方式转发流量。
图4-22 配置VXLAN双活接入组网图

配置思路

采用如下思路配置VXLAN双活接入:
  1. 分别在Leaf1、Leaf2、Spine1上配置路由协议,实现网络三层互通。
  2. 分别在Leaf1、Leaf2、Spine1上配置VXLAN基本功能,实现VXLAN网络互通。
  3. 创建Eth-Trunk接口。
  4. 配置V-STP。

  5. 配置M-LAG:
    • 分别在Leaf1和Leaf2上配置DFS Group关联VXLAN。
    • 将Leaf1和Leaf2之间的链路配置为peer-link。
    • 分别在Leaf1和Leaf2上配置绑定DFS Group和用户侧Eth-Trunk接口。
说明:

如果Leaf1上行接入VXLAN网络的链路出现故障,当用户流量到达Leaf1时,由于没有可用的上行出接口,Leaf1会将用户流量全部丢弃。此时,可以配置monitor-link关联Leaf1的上行接口和下行接口,当Leaf1的上行出接口DOWN时,下行接口状态也会变为DOWN,这样用户侧流量就不会通过Leaf1进行转发,从而防止流量被丢弃。monitor-link的配置可以参见配置Monitor Link组的上行接口和下行接口。

数据准备

为完成此配置例,需准备如下的数据:

  • 网络中设备互连的接口IP地址。
  • 网络中使用的路由类型是OSPF(Open Shortest Path First)。
  • 服务器所属的VLAN ID是VLAN10。
  • 广播域BD ID是BD10。
  • VXLAN网络标识VNI ID是VNI 5010。

配置注意事项

对于CE12800,除了操作步骤中的配置之外,可以根据需要额外执行如下命令:
  • 在系统视图下执行assign forward nvo3 service extend enable命令,使能NVO3业务扩展功能。

    说明:

    设备默认情况下,NVO3的业务扩展功能未使能。此时在设备上部署NVO3业务后,若再叠加其他需要使用ACL的业务(如MQC、简化ACL、流量监管、BD流量统计、DHCP等),会较大概率出现叠加失败的情况。在部署NVO3业务的设备上,使能此命令后,在EC/ED/EF/EG(除CE-L48GT-EC、CE-L48GS-EC外)单板上,能减少这种业务叠加失败的问题。

  • 在系统视图下执行assign forward nvo3 f-linecard compatibility enable命令,用来防止在单板处于非增强模式时VXLAN流量不通。

    说明:

    在单板的互通模式为非增强模式时,如果VXLAN流量跨板转发,有可能出现VXLAN流量不通的问题。所以当单板的互通模式为非增强模式时必须配置assign forward nvo3 f-linecard compatibility enable命令才能正常使用VXLAN功能。

配置VXLAN举例的相关约束已经在操作步骤中加以说明。如果还想了解更多约束,请参见VXLAN配置注意事项。

操作步骤

  1. 配置路由协议

    # 配置Leaf1。Leaf2和Spine1的配置与Leaf1类似,这里不再赘述。配置OSPF时,注意需要发布32位Loopback接口地址。

    <HUAWEI> system-view
    [~HUAWEI] sysname Leaf1
    [*HUAWEI] commit
    [~Leaf1] interface loopback 1
    [*Leaf1-LoopBack1] ip address 10.2.2.2 32
    [*Leaf1-LoopBack1] quit
    [*Leaf1] interface loopback 2
    [*Leaf1-LoopBack2] ip address 10.3.3.3 32
    [*Leaf1-LoopBack2] quit
    [*Leaf1] interface 10ge 1/0/1
    [*Leaf1-10GE1/0/1] undo portswitch
    [*Leaf1-10GE1/0/1] ip address 192.168.1.1 24
    [*Leaf1-10GE1/0/1] quit
    [*Leaf1] ospf
    [*Leaf1-ospf-1] area 0
    [*Leaf1-ospf-1-area-0.0.0.0] network 10.2.2.2 0.0.0.0
    [*Leaf1-ospf-1-area-0.0.0.0] network 10.3.3.3 0.0.0.0
    [*Leaf1-ospf-1-area-0.0.0.0] network 192.168.1.0 0.0.0.255
    [*Leaf1-ospf-1-area-0.0.0.0] quit
    [*Leaf1-ospf-1] quit
    [*Leaf1] commit

    OSPF成功配置后,Leaf1、Leaf2、Spine1之间可通过OSPF协议发现对方的Loopback接口的IP地址,并能互相ping通。

  2. 配置VXLAN隧道模式并使能VXLAN的ACL扩展功能(仅CE12800需要配置此步骤)

    # 配置Leaf1。Leaf2和Spine1的配置与Leaf1类似,这里不再赘述。

    [~Leaf1] ip tunnel mode vxlan
    [*Leaf1] assign forward nvo3 acl extend enable
    [*Leaf1] commit
    
    说明:

    配置VXLAN隧道模式、使能VXLAN的ACL扩展功能后,需要保存配置并重启设备才能生效,您可以选择立即重启或完成所有配置后再重启。

  3. 分别在Leaf1、Leaf2和Spine1上配置VXLAN隧道

    # 配置Leaf1。Leaf2的配置与Leaf1类似,此处不再赘述。

    [~Leaf1] bridge-domain 10
    [*Leaf1-bd10] vxlan vni 5010
    [*Leaf1-bd10] quit
    [*Leaf1] interface nve1
    [*Leaf1-Nve1] source 10.2.2.2
    [*Leaf1-Nve1] mac-address 0000-5e00-0101
    [*Leaf1-Nve1] vni 5010 head-end peer-list 10.1.1.1
    [*Leaf1-Nve1] quit
    [*Leaf1] commit
    说明:

    由于Leaf1和Leaf2作为双活接入设备,请确保这两台设备上配置的NVE接口的IP地址相同。

    # 配置Spine1。

    [~Spine1] bridge-domain 10
    [*Spine1-bd10] vxlan vni 5010
    [*Spine1-bd10] quit
    [*Spine1] interface nve1
    [*Spine1-Nve1] source 10.1.1.1
    [*Spine1-Nve1] vni 5010 head-end peer-list 10.2.2.2
    [*Spine1-Nve1] quit
    [*Spine1] commit

    上述配置成功后,在Spine1上执行display vxlan vni命令可查看到VNI的状态是up;执行display vxlan tunnel命令可查看到VXLAN隧道的信息。

    [~Spine1] display vxlan vni
    Number of vxlan vni : 1
    VNI            BD-ID            State
    ---------------------------------------
    5010           10               up
    [~Spine1] display vxlan tunnel
    Number of vxlan tunnel : 1
    Tunnel ID   Source                Destination           State  Type     Uptime
    -----------------------------------------------------------------------------------
    4026531841  10.1.1.1              10.2.2.2              up     static   0035h21m

  4. 创建Eth-Trunk接口,并将以太物理接口加入Eth-Trunk接口

    服务器上行连接交换机的端口需要绑定在一个聚合链路中且链路聚合模式需要和交换机侧的聚合模式匹配。

    # 在Leaf1上创建Eth-Trunk,配置为LACP模式并加入成员口。Leaf2的配置与Leaf1类似,此处不再赘述。

    [~Leaf1] interface eth-trunk 1
    [*Leaf1-Eth-Trunk1] mode lacp-static
    [*Leaf1-Eth-Trunk1] trunkport 10ge 1/0/4
    [*Leaf1-Eth-Trunk1] trunkport 10ge 1/0/5
    [*Leaf1-Eth-Trunk1] quit
    [*Leaf1] interface eth-trunk 10
    [*Leaf1-Eth-Trunk10] mode lacp-static
    [*Leaf1-Eth-Trunk10] trunkport 10ge 1/0/2
    [*Leaf1-Eth-Trunk10] quit
    [*Leaf1] interface 10ge 1/0/2
    [*Leaf1-10GE1/0/2] lacp force-up
    [*Leaf1-10GE1/0/2] quit
    [*Leaf1] commit

  5. 配置V-STP

    # 配置Leaf1。

    [~Leaf1] stp mode rstp
    [*Leaf1] stp v-stp enable
    [*Leaf1] interface eth-trunk 10
    [*Leaf1-Eth-Trunk10] stp edged-port enable
    [*Leaf1-Eth-Trunk10] commit
    [~Leaf1-Eth-Trunk10] quit

    # 配置Leaf2。

    [~Leaf2] stp mode rstp
    [*Leaf2] stp v-stp enable
    [*Leaf2] interface eth-trunk 10
    [*Leaf2-Eth-Trunk10] stp edged-port enable
    [*Leaf2-Eth-Trunk10] commit
    [~Leaf2-Eth-Trunk10] quit

  6. 分别在Leaf1和Leaf2上配置DFS Group

    # 配置Leaf1。Leaf2的配置与Leaf1类似,此处不再赘述。

    [~Leaf1] dfs-group 1
    [*Leaf1-dfs-group-1] source ip 10.3.3.3
    [*Leaf1-dfs-group-1] quit
    [*Leaf1] commit

  7. 将Leaf1和Leaf2之间的链路配置为peer-link

    # 配置Leaf1。Leaf2的配置与Leaf1类似,此处不再赘述。

    [~Leaf1] interface eth-trunk 1
    [~Leaf1-Eth-Trunk1] peer-link 1
    [*Leaf1-Eth-Trunk1] quit
    [*Leaf1] commit

  8. 分别在Leaf1和Leaf2上配置绑定DFS和用户侧Eth-Trunk接口

    # 配置Leaf1。Leaf2的配置与Leaf1类似,此处不再赘述。

    [~Leaf1] interface eth-trunk 10
    [~Leaf1-Eth-Trunk10] dfs-group 1 m-lag 1
    [*Leaf1-Eth-Trunk10] quit
    [*Leaf1] commit

  9. 分别在Leaf1和Leaf2上配置VXLAN业务接入点

    # 配置Leaf1。Leaf2的配置与Leaf1类似,此处不再赘述。

    [~Leaf1] vlan 10
    [*Leaf1-vlan10] quit
    [*Leaf1] bridge-domain 10
    [*Leaf1-bd10] l2 binding vlan 10
    [*Leaf1-bd10] quit
    [*Leaf1] interface eth-trunk 10
    [*Leaf1-Eth-Trunk10] port link-type trunk
    [*Leaf1-Eth-Trunk10] undo port trunk allow-pass vlan 1
    [*Leaf1-Eth-Trunk10] port trunk allow-pass vlan 10
    [*Leaf1-Eth-Trunk10] quit
    [*Leaf1] commit

  10. 检查配置结果

    执行命令display dfs-group 1 m-lag,查看M-LAG的相关信息。

    [~Leaf1] display dfs-group 1 m-lag
    *                : Local node
    Heart beat state : OK
    Node 1 *
      Dfs-Group ID   : 1
      Priority       : 100
      Address        : ip address 10.3.3.3
      State          : Master
      Causation      : -
      System ID      : 0025-9e95-7c11
      SysName        : Leaf1
      Version        : V200R003C00
      Device Type    : CE12800
    Node 2
      Dfs-Group ID   : 1
      Priority       : 100
      Address        : ip address 10.4.4.4
      State          : Backup
      Causation      : -
      System ID      : 0025-9e95-7c31
      SysName        : Leaf2
      Version        : V200R003C00
      Device Type    : CE12800

    查看Leaf1上的M-LAG信息。

    [~Leaf1] display dfs-group 1 node 1 m-lag brief
    * - Local node
    
    M-Lag ID     Interface      Port State    Status                Consistency-check
           1     Eth-Trunk 10   Up            active(*)-active      -
    
    Failed reason:
        1 -- Relationship between vlan and port is inconsistent
        2 -- STP configuration under the port is inconsistent
        3 -- STP port priority configuration is inconsistent
        4 -- LACP mode of M-LAG is inconsistent
        5 -- M-LAG configuration is inconsistent

    查看Leaf2上的M-LAG信息。

    [~Leaf2] display dfs-group 1 node 2 m-lag brief
    * - Local node
    
    M-Lag ID     Interface      Port State    Status                Consistency-check
           1     Eth-Trunk 10   Up            active(*)-active      -
    
    Failed reason:
        1 -- Relationship between vlan and port is inconsistent
        2 -- STP configuration under the port is inconsistent
        3 -- STP port priority configuration is inconsistent
        4 -- LACP mode of M-LAG is inconsistent
        5 -- M-LAG configuration is inconsistent

    在Leaf1、Leaf2上执行display bridge-domain 10 verbose命令,可查看到广播域BD的信息。以Leaf1显示为例。

    [~Leaf1] display bridge-domain 10 verbose
      Bridge-domain ID        : 10
      Description             :
      State                   : Up
      MAC Learning            : Enable
      Statistics              : Disable
      Broadcast               : Forward
      Unknown-unicast         : Forward
      Unknown-multicast       : Forward
      Split-horizon           : Disable
      Vxlan Vni               : 5010
    
      ----------------
    Interface                                State
      Eth-Trunk1.5010                        up
    

配置文件

  • Leaf1的配置文件

    #
    sysname Leaf1
    #
    assign forward nvo3 acl extend enable
    #
    dfs-group 1
     source ip 10.3.3.3
    #
    vlan batch 10
    #
    stp mode rstp
    stp v-stp enable
    #
    bridge-domain 10
     l2 binding vlan 10
     vxlan vni 5010
    #
    interface Eth-Trunk1
     mode lacp-static
     peer-link 1
    #
    interface Eth-Trunk10
     port link-type trunk
     undo port trunk allow-pass vlan 1
     port trunk allow-pass vlan 10
     stp edged-port enable
     mode lacp-static
     dfs-group 1 m-lag 1
    #
    interface 10GE1/0/1
     undo portswitch
     ip address 192.168.1.1 255.255.255.0
    #
    interface 10GE1/0/2
     eth-trunk 10
     lacp force-up
    #
    interface 10GE1/0/4
     eth-trunk 1
    #
    interface 10GE1/0/5
     eth-trunk 1
    #
    interface LoopBack1
     ip address 10.2.2.2 255.255.255.255
    #
    interface LoopBack2
     ip address 10.3.3.3 255.255.255.255
    #
    interface Nve1
     source 10.2.2.2
     vni 5010 head-end peer-list 10.1.1.1
     mac-address 0000-5e00-0101
    #
    ospf 1
     area 0.0.0.0
      network 10.2.2.2 0.0.0.0
      network 10.3.3.3 0.0.0.0
      network 192.168.1.0 0.0.0.255
    #
    return
  • Leaf2的配置文件

    #
    sysname Leaf2
    #
    assign forward nvo3 acl extend enable
    #
    dfs-group 1
     source ip 10.4.4.4
    #
    vlan batch 10
    #
    stp mode rstp
    stp v-stp enable
    #
    bridge-domain 10
     l2 binding vlan 10
     vxlan vni 5010
    #
    interface Eth-Trunk1
     mode lacp-static
     peer-link 1
    #
    interface Eth-Trunk10
     port link-type trunk
     undo port trunk allow-pass vlan 1
     port trunk allow-pass vlan 10
     stp edged-port enable
     mode lacp-static
     dfs-group 1 m-lag 1
    #
    interface 10GE1/0/1
     undo portswitch
     ip address 192.168.2.1 255.255.255.0
    #
    interface 10GE1/0/2
     eth-trunk 10
     lacp force-up
    #
    interface 10GE1/0/4
     eth-trunk 1
    #
    interface 10GE1/0/5
     eth-trunk 1
    #
    interface LoopBack1
     ip address 10.2.2.2 255.255.255.255
    #
    interface LoopBack2
     ip address 10.4.4.4 255.255.255.255
    #
    interface Nve1
     source 10.2.2.2
     vni 5010 head-end peer-list 10.1.1.1
     mac-address 0000-5e00-0101
    #
    ospf 1
     area 0.0.0.0
      network 10.2.2.2 0.0.0.0
      network 10.4.4.4 0.0.0.0
      network 192.168.2.0 0.0.0.255
    #
    return
  • Spine1的配置文件

    #
    sysname Spine1
    #
    assign forward nvo3 acl extend enable
    #
    bridge-domain 10
     vxlan vni 5010
    #
    interface 10GE1/0/1
     undo portswitch
     ip address 192.168.1.2 255.255.255.0
    #
    interface 10GE1/0/2
     undo portswitch
     ip address 192.168.2.2 255.255.255.0
    #
    interface LoopBack1
     ip address 10.1.1.1 255.255.255.255
    #
    interface Nve1
     source 10.1.1.1
     vni 5010 head-end peer-list 10.2.2.2
    #
    ospf 1
     area 0.0.0.0
      network 10.1.1.1 0.0.0.0
      network 192.168.1.0 0.0.0.255
      network 192.168.2.0 0.0.0.255
    #
    return
翻译
下载文档
更新时间:2019-05-05

文档编号:EDOC1100004255

浏览量:11084

下载量:276

平均得分:
本文档适用于这些产品
相关文档
相关版本
Share
上一页 下一页