所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

CloudEngine 12800, 12800E V200R003C00 配置指南-以太网交换

本文档针对设备的以太网业务,主要包括以太网交换概述、MAC配置、以太网链路聚合配置、M-LAG(跨设备链路聚合)配置、VLAN配置、QinQ配置、VLAN mapping配置、GVRP配置、STP/RSTP配置、MSTP配置、VBST配置、ERPS(G.8032)配置、Loopback Detection配置和二层协议透明传输配置。
评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
配置基于子网划分VLAN示例

配置基于子网划分VLAN示例

组网需求

某数据中心拥有多种业务,如办公业务、生产业务、灾备业务,每种业务使用的IP地址网段各不相同。为了便于管理,现需要将同一种类型业务划分到同一VLAN中,不同类型的业务划分到不同VLAN中。

图5-24所示,Switch连接有办公业务服务器、生产业务服务器、灾备业务服务器,不同业务的IP地址网段各不相同。现需要将不同类型的业务划分到不同的VLAN中,通过不同的VLAN ID分流到不同的远端网络上以实现业务互通。

图5-24 基于子网划分VLAN组网图

配置思路

采用如下的思路配置基于子网划分VLAN:

  1. 创建VLAN,确定每种业务所属的VLAN。
  2. 关联子网和VLAN,实现根据报文中的源IP地址或指定网段确定VLAN。

  3. 配置接口加入VLAN,实现基于子网的VLAN通过当前接口。
  4. 使能基于子网划分VLAN。

操作步骤

  1. 创建VLAN

    # 在Switch上创建VLAN100、VLAN200和VLAN300。

    <HUAWEI> system-view
    [~HUAWEI] sysname Switch
    [*HUAWEI] commit
    [~Switch] vlan batch 100 200 300
    [*Switch] commit
    

  2. 配置接口

    # 在Switch上配置接口10GE1/0/5、10GE1/0/6、10GE1/0/7为Hybrid类型,分别以untagged方式加入VLAN100、VLAN200和VLAN300。并使能基于子网划分VLAN功能。

    [~Switch] interface 10ge 1/0/5
    [~Switch-10GE1/0/5] port link-type hybrid
    [*Switch-10GE1/0/5] port hybrid untagged vlan 100
    [*Switch-10GE1/0/5] port hybrid pvid vlan 100
    [*Switch-10GE1/0/5] ip-subnet-vlan enable
    [*Switch-10GE1/0/5] quit
    [*Switch] interface 10ge 1/0/6
    [*Switch-10GE1/0/6] port link-type hybrid
    [*Switch-10GE1/0/6] port hybrid untagged vlan 200
    [*Switch-10GE1/0/6] port hybrid pvid vlan 200
    [*Switch-10GE1/0/6] ip-subnet-vlan enable
    [*Switch-10GE1/0/6] quit
    [*Switch] interface 10ge 1/0/7
    [*Switch-10GE1/0/7] port link-type hybrid
    [*Switch-10GE1/0/7] port hybrid untagged vlan 300
    [*Switch-10GE1/0/7] port hybrid pvid vlan 300
    [*Switch-10GE1/0/7] ip-subnet-vlan enable
    [*Switch-10GE1/0/7] quit
    [*Switch] commit

    # 在Switch上配置接口10GE1/0/2加入VLAN100。

    [~Switch] interface 10ge 1/0/2
    [~Switch-10GE1/0/2] port link-type trunk
    [*Switch-10GE1/0/2] port trunk allow-pass vlan 100
    [*Switch-10GE1/0/2] quit
    [*Switch] commit
    

    # 在Switch上配置接口10GE1/0/3加入VLAN200。

    [~Switch] interface 10ge 1/0/3
    [~Switch-10GE1/0/3] port link-type trunk
    [*Switch-10GE1/0/3] port trunk allow-pass vlan 200
    [*Switch-10GE1/0/3] quit
    [*Switch] commit

    # 在Switch上配置接口10GE1/0/4加入VLAN300。

    [~Switch] interface 10ge 1/0/4
    [~Switch-10GE1/0/4] port link-type trunk
    [*Switch-10GE1/0/4] port trunk allow-pass vlan 300
    [*Switch-10GE1/0/4] quit
    [*Switch] commit

  3. 配置基于子网划分VLAN

    # 在Switch上配置VLAN100与IP地址192.168.1.2/24关联。

    [~Switch] vlan 100
    [~Switch-vlan100] ip-subnet-vlan 1 ip 192.168.1.2 24
    [*Switch-vlan100] quit

    # 在Switch上配置VLAN200与IP地址192.168.2.2/24关联。

    [*Switch] vlan 200
    [*Switch-vlan200] ip-subnet-vlan 1 ip 192.168.2.2 24
    [*Switch-vlan200] quit
    

    # 在Switch上配置VLAN300与IP地址192.168.3.2/24关联。

    [*Switch] vlan 300
    [*Switch-vlan300] ip-subnet-vlan 1 ip 192.168.3.2 24
    [*Switch-vlan300] quit
    [*Switch] commit
    

  4. 验证配置结果

    在Switch上执行以下命令,显示信息如下:

    [~Switch] display ip-subnet-vlan vlan all
     IP-subnet-VLAN count: 3                  total count: 3
     ----------------------------------------------------------------
     VLAN    Index  IpAddress            SubnetMask          Priority
     ----------------------------------------------------------------
     100         1  192.168.1.2          255.255.255.0              0
     200         1  192.168.2.2          255.255.255.0              0
     300         1  192.168.3.2          255.255.255.0              0
     ----------------------------------------------------------------

    生产业务、办公业务和灾备业务分别可以和生产中心、园区办公网、灾备数据中心互相ping通,但是生产业务不能和园区办公网、灾备数据中心ping通,办公业务不能和生产中心、灾备数据中心ping通,灾备业务不能和生产中心、园区办公网ping通。

配置文件

Switch的配置文件

#
sysname Switch
#
vlan batch 100 200 300
#
vlan 100
 ip-subnet-vlan 1 ip 192.168.1.2 255.255.255.0
#
vlan 200
 ip-subnet-vlan 1 ip 192.168.2.2 255.255.255.0
#
vlan 300
 ip-subnet-vlan 1 ip 192.168.3.2 255.255.255.0
#
interface 10GE1/0/2
 port link-type trunk
 port trunk allow-pass vlan 100
 device transceiver 10GBASE-COPPER
#
interface 10GE1/0/3 
 port link-type trunk
 port trunk allow-pass vlan 200
 device transceiver 10GBASE-COPPER
#
interface 10GE1/0/4 
 port link-type trunk
 port trunk allow-pass vlan 300
 device transceiver 10GBASE-COPPER
#
interface 10GE1/0/5
 port link-type hybrid
 port hybrid pvid vlan 100
 port hybrid untagged vlan 100
 ip-subnet-vlan enable
 device transceiver 10GBASE-COPPER
#
interface 10GE1/0/6
 port link-type hybrid
 port hybrid pvid vlan 200
 port hybrid untagged vlan 200
 ip-subnet-vlan enable
 device transceiver 10GBASE-COPPER
#
interface 10GE1/0/7
 port link-type hybrid
 port hybrid pvid vlan 300
 port hybrid untagged vlan 300
 ip-subnet-vlan enable
 device transceiver 10GBASE-COPPER
#
return
翻译
下载文档
更新时间:2019-05-05

文档编号:EDOC1100004255

浏览量:11228

下载量:276

平均得分:
本文档适用于这些产品
相关文档
相关版本
Share
上一页 下一页