所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

CloudEngine 12800, 12800E V200R003C00 配置指南-以太网交换

本文档针对设备的以太网业务,主要包括以太网交换概述、MAC配置、以太网链路聚合配置、M-LAG(跨设备链路聚合)配置、VLAN配置、QinQ配置、VLAN mapping配置、GVRP配置、STP/RSTP配置、MSTP配置、VBST配置、ERPS(G.8032)配置、Loopback Detection配置和二层协议透明传输配置。
评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
配置手工负载分担模式链路聚合示例

配置手工负载分担模式链路聚合示例

组网需求

图3-22所示,SwitchA和SwitchB通过以太链路分别都连接VLAN10和VLAN20的网络,且SwitchA和SwitchB之间有较大的数据流量。

用户希望SwitchA和SwitchB之间能够提供较大的链路带宽来使相同VLAN间互相通信。同时用户也希望能够提供一定的冗余度,保证数据传输和链路的可靠性。

图3-22 配置手工负载分担模式链路聚合组网图

配置思路

采用如下的思路配置负载分担链路聚合:

  1. 创建Eth-Trunk接口并加入成员接口,实现增加链路带宽。

  2. 创建VLAN并将接口加入VLAN。

  3. 配置负载分担方式,实现流量在Eth-Trunk各成员接口间的负载分担,增加可靠性。

操作步骤

  1. 在SwitchA和SwitchB上创建Eth-Trunk接口并加入成员接口,配置手动负载分担模式。

    <HUAWEI> system-view
    [~HUAWEI] sysname SwitchA
    [*HUAWEI] commit
    [~SwitchA] interface eth-trunk 1
    [*SwitchA-Eth-Trunk1] mode manual load-balance 
    [*SwitchA-Eth-Trunk1] trunkport 10ge 1/0/1 to 1/0/3
    [*SwitchA-Eth-Trunk1] commit
    [~SwitchA-Eth-Trunk1] quit
    <HUAWEI> system-view
    [~HUAWEI] sysname SwitchB
    [*HUAWEI] commit
    [~SwitchB] interface eth-trunk 1
    [*SwitchB-Eth-Trunk1] mode manual load-balance 
    *SwitchB-Eth-Trunk1] trunkport 10ge 1/0/1 to 1/0/3
    [*SwitchB-Eth-Trunk1] commit
    [~SwitchB-Eth-Trunk1] quit

  2. 创建VLAN并将接口加入VLAN。

    # 创建VLAN10和VLAN20并分别加入接口。SwitchB的配置与SwitchA类似,不再赘述。

    [~SwitchA] vlan batch 10 20
    [*SwitchA] interface 10ge 1/0/4
    [*SwitchA-10GE1/0/4] port link-type trunk
    [*SwitchA-10GE1/0/4] port trunk allow-pass vlan 10
    [*SwitchA-10GE1/0/4] quit
    [*SwitchA] interface 10ge 1/0/5
    [*SwitchA-10GE1/0/5] port link-type trunk
    [*SwitchA-10GE1/0/5] port trunk allow-pass vlan 20
    [*SwitchA-10GE1/0/5] quit
    [*SwitchA] commit

    # 配置Eth-Trunk1接口允许VLAN10和VLAN20通过。SwitchB的配置与SwitchA类似,不再赘述。

    [~SwitchA] interface eth-trunk 1
    [~SwitchA-Eth-Trunk1] port link-type trunk
    [*SwitchA-Eth-Trunk1] port trunk allow-pass vlan 10 20
    [*SwitchA-Eth-Trunk1] commit
    [~SwitchA-Eth-Trunk1] quit

  3. 配置Eth-Trunk1的负载分担方式。SwitchB的配置与SwitchA类似,不再赘述。

    [~SwitchA] load-balance profile a
    [*SwitchA-load-balance-profile-a] l2 dst-mac
    [*SwitchA-load-balance-profile-a] commit
    [~SwitchA-load-balance-profile-a] quit

  4. 验证配置结果

    在任意视图下执行display eth-trunk 1命令,检查Eth-Trunk是否创建成功,及成员接口是否正确加入。

    [~SwitchA] display eth-trunk 1
    Eth-Trunk1's state information is: 
    Working Mode: Normal           Hash Arithmetic: profile a
    Least Active-linknumber: 1     Max Bandwidth-affected-linknumber: 32
    Operating Status: up           Number of Up Ports in Trunk: 3
    --------------------------------------------------------------------------------
    PortName                Status       Weight
    10GE1/0/1               Up           1
    10GE1/0/2               Up           1
    10GE1/0/3               Up           1
    

    从以上信息看出Eth-Trunk 1中包含3个成员接口10GE1/0/110GE1/0/210GE1/0/3,成员接口的状态都为Up。Eth-Trunk 1的“Operating Status”Up

配置文件

  • SwitchA的配置文件

    #
    sysname SwitchA
    #
    load-balance profile a
     l2 dst-mac
    #
    vlan batch 10 20
    # 
    interface Eth-Trunk1
     port link-type trunk 
     port trunk allow-pass vlan 10 20
    # 
    interface 10GE1/0/1 
     eth-trunk 1
    # 
    interface 10GE1/0/2 
     eth-trunk 1
    # 
    interface 10GE1/0/3 
     eth-trunk 1
    #
    interface 10GE1/0/4 
     port link-type trunk 
     port trunk allow-pass vlan 10
    #
    interface 10GE1/0/5 
     port link-type trunk 
     port trunk allow-pass vlan 20
    #
    return
  • SwitchB的配置文件

    #
    sysname SwitchB
    #
    load-balance profile a
     l2 dst-mac
    #
    vlan batch 10 20
    # 
    interface Eth-Trunk1
     port link-type trunk 
     port trunk allow-pass vlan 10 20
    # 
    interface 10GE1/0/1 
     eth-trunk 1
    # 
    interface 10GE1/0/2 
     eth-trunk 1
    # 
    interface 10GE1/0/3 
     eth-trunk 1
    #
    interface 10GE1/0/4 
     port link-type trunk 
     port trunk allow-pass vlan 10
    #
    interface 10GE1/0/5 
     port link-type trunk 
     port trunk allow-pass vlan 20
    #
    return
翻译
下载文档
更新时间:2019-05-05

文档编号:EDOC1100004255

浏览量:12331

下载量:276

平均得分:
本文档适用于这些产品
相关文档
相关版本
Share
上一页 下一页