所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

CloudEngine 12800, 12800E V200R003C00 配置指南-以太网交换

本文档针对设备的以太网业务,主要包括以太网交换概述、MAC配置、以太网链路聚合配置、M-LAG(跨设备链路聚合)配置、VLAN配置、QinQ配置、VLAN mapping配置、GVRP配置、STP/RSTP配置、MSTP配置、VBST配置、ERPS(G.8032)配置、Loopback Detection配置和二层协议透明传输配置。
评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
配置链路聚合负载均衡示例

配置链路聚合负载均衡示例

组网需求

图3-26所示,在两台Switch设备上配置链路聚合组,链路聚合中包含4个成员接口。用户发现从SwitchA到SwitchB方向的业务流量在4条链路上负载分担不均衡,有些链路上的流量很多,有些链路上的流量很少,进一步发现SwitchA的Eth-Trunk接口出方向的流量是源MAC地址和源IP地址变化的流量。

图3-26 配置链路聚合负载均衡组网图

配置思路

采用如下的思路配置链路聚合负载均衡:

  1. 基于流量模型调整负载分担模板中的Eth-Trunk负载分担HASH算法,实现流量负载均衡。

操作步骤

  1. 查看SwitchA上Eth-Trunk1各成员接口的负载分担情况,发现4个成员口出方向的流量负载分担不是非常均衡。

    [~SwitchA] display interface brief
    PHY: Physical                     
    *down: administratively down                   
    ^down: standby                                  
    (l): loopback                           
    (s): spoofing                                       
    (b): BFD down                              
    (e): ETHOAM down                                    
    (d): Dampening Suppressed                                 
    (p): port alarm down              
    (dl): DLDP down
    InUti/OutUti: input utility rate/output utility rate
    Interface                  PHY      Protocol  InUti OutUti   inErrors  outErrors
    Eth-Trunk1                 up       up           0% 50.00%          0          0
      10GE1/0/1                up       up           0% 46.00%          0          0
      10GE1/0/2                up       up           0% 51.99%          0          0
      10GE1/0/3                up       up           0% 51.99%          0          0
      10GE1/0/4                up       up           0% 50.00%          0          0

  2. 发现实际网络中从SwitchA的Eth-Trunk接口出方向的流量是源MAC地址和源IP地址变化的流量,根据这个流量模型调整负载分担模板中的Eth-Trunk负载分担HASH算法为hash-mode(8)。

    缺省情况下,负载分担模板中的Eth-Trunk负载分担HASH算法为hash-mode(1)。

    出方向的流量不均衡请调整当前设备的负载分担方式,入方向的流量不均衡请调整上行设备的负载分担方式。

    [~SwitchA] load-balance profile default
    [~SwitchA-load-balance-profile-default] eth-trunk hash-mode 8
    [*SwitchA-load-balance-profile-default] commit
    [~SwitchA-load-balance-profile-default] quit

  3. 查看Eth-Trunk1各接口的负载分担情况,发现4个成员口出方向的流量负载分担相比之前变得均衡了。

    [~SwitchA] display interface brief
    PHY: Physical
    *down: administratively down
    ^down: standby
    (l): loopback
    (s): spoofing
    (b): BFD down
    (e): ETHOAM down
    (d): Dampening Suppressed
    (p): port alarm down
    (dl): DLDP down
    InUti/OutUti: input utility rate/output utility rate
    Interface                  PHY      Protocol  InUti OutUti   inErrors  outErrors
    Eth-Trunk1                 up       up           0% 50.00%          0          0
      10GE1/0/1                up       up           0% 49.99%          0          0
      10GE1/0/2                up       up           0% 50.00%          0          0
      10GE1/0/3                up       up           0% 49.99%          0          0
      10GE1/0/4                up       up           0% 49.99%          0          0

配置文件

  • SwitchA的配置文件

    #
    sysname SwitchA
    #
    load-balance profile default
     eth-trunk hash-mode 8
    #
    vlan batch 10
    #
    interface Eth-Trunk1
     port link-type trunk 
     port trunk allow-pass vlan 10
    #
    interface 10GE1/0/1 
     eth-trunk 1
    # 
    interface 10GE1/0/2 
     eth-trunk 1
    # 
    interface 10GE1/0/3 
     eth-trunk 1
    #
    interface 10GE1/0/4 
     eth-trunk 1
    #
    return
  • SwitchB的配置文件

    #
    sysname SwitchB
    #
    vlan batch 10
    #
    interface Eth-Trunk1
     port link-type trunk 
     port trunk allow-pass vlan 10
    #
    interface 10GE1/0/1 
     eth-trunk 1
    # 
    interface 10GE1/0/2 
     eth-trunk 1
    # 
    interface 10GE1/0/3 
     eth-trunk 1
    #
    interface 10GE1/0/4 
     eth-trunk 1
    #
    return
翻译
下载文档
更新时间:2019-05-05

文档编号:EDOC1100004255

浏览量:12381

下载量:276

平均得分:
本文档适用于这些产品
相关文档
相关版本
Share
上一页 下一页