所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

CloudEngine 12800, 12800E V200R003C00 配置指南-以太网交换

本文档针对设备的以太网业务,主要包括以太网交换概述、MAC配置、以太网链路聚合配置、M-LAG(跨设备链路聚合)配置、VLAN配置、QinQ配置、VLAN mapping配置、GVRP配置、STP/RSTP配置、MSTP配置、VBST配置、ERPS(G.8032)配置、Loopback Detection配置和二层协议透明传输配置。
评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
配置2 to 1的VLAN Mapping示例

配置2 to 1的VLAN Mapping示例

组网需求

图7-6所示,某数据中心的两个分支布局在不同的地理位置,分支1和分支2位于相同的网段。分支1和分支2属于不同的业务部门,所属的VLAN分别为VLAN5和VLAN6,服务器通过接入层交换机、汇聚层交换机接入核心层网络。为了实现业务的临时互通,可以在汇聚层交换机上部署QinQ功能,同时为了不改变核心层交换机VLAN的部署,在核心层交换机上部署VLAN Mapping来实现上述功能。

图7-6 配置VLAN Mapping示例(2 to 1)组网图

配置思路

采用如下的思路配置2 to 1的VLAN Mapping:

  1. 将连接服务器的接入层交换机Switch1和Swicth2的接口分别划分到指定VLAN中。

  2. 在汇聚层交换机Switch3上部署QinQ功能,以节省VLAN资源。

  3. 在汇聚层交换机Switch4上部署透传VLAN6的报文。

  4. 在核心层交换机Swicth5上部署2 to 1的VLAN Mapping功能,实现分支1和分支2的业务可以互通。

操作步骤

  1. 将Switch1、Switch2的下行口划分到指定VLAN,上行口允许VLAN通过

    # 配置Switch1。

    <HUAWEI> system-view
    [~HUAWEI] sysname Switch1
    [*HUAWEI] commit
    [~Switch1] vlan batch 5
    [*Switch1] interface 10ge 1/0/1
    [*Switch1-10GE1/0/1] port default vlan 5
    [*Switch1-10GE1/0/1] quit
    [*Switch1] interface 10ge 1/0/2
    [*Switch1-10GE1/0/2] port link-type trunk
    [*Switch1-10GE1/0/2] port trunk allow-pass vlan 5
    [*Switch1-10GE1/0/2] quit
    [*Switch1] commit

    # 配置Switch2。

    <HUAWEI> system-view
    [~HUAWEI] sysname Switch2
    [*HUAWEI] commit
    [~Switch2] vlan batch 6
    [*Switch2] interface 10ge 1/0/1
    [*Switch2-10GE1/0/1] port default vlan 6
    [*Switch2-10GE1/0/1] quit
    [*Switch2] interface 10ge 1/0/2
    [*Switch2-10GE1/0/2] port link-type trunk
    [*Switch2-10GE1/0/2] port trunk allow-pass vlan 6
    [*Switch2-10GE1/0/2] quit
    [*Switch2] commit

  2. 在Switch3上部署QinQ功能

    # 在Switch3上配置接口10GE1/0/1的类型为QinQ,10GE1/0/1的外层Tag为VLAN100。

    <HUAWEI> system-view
    [~HUAWEI] sysname Switch3
    [*HUAWEI] commit
    [~Switch3] vlan batch 100
    [*Switch3] interface 10ge 1/0/1
    [*Switch3-10GE1/0/1] port link-type dot1q-tunnel
    [*Switch3-10GE1/0/1] port default vlan 100
    [*Switch3-10GE1/0/1] quit
    [*Switch3] interface 10ge 1/0/2
    [*Switch3-10GE1/0/2] port link-type trunk
    [*Switch3-10GE1/0/2] port trunk allow-pass vlan 100
    [*Switch3-10GE1/0/2] quit
    [*Switch3] commit
    

  3. 在Switch4上配置透传VLAN6的报文

    <HUAWEI> system-view
    [~HUAWEI] sysname Switch4
    [*HUAWEI] commit
    [~Switch4] vlan batch 6
    [*Switch4] interface 10ge 1/0/1
    [*Switch4-10GE1/0/1] port link-type trunk
    [*Switch4-10GE1/0/1] port trunk allow-pass vlan 6
    [*Switch4-10GE1/0/1] quit
    [*Switch4] interface 10ge 1/0/2
    [*Switch4-10GE1/0/2] port link-type trunk
    [*Switch4-10GE1/0/2] port trunk allow-pass vlan 6
    [*Switch4-10GE1/0/2] quit
    [*Switch4] commit
    

  4. 在Switch5上配置VLAN Mapping

    <HUAWEI> system-view
    [~HUAWEI] sysname Switch5
    [*HUAWEI] commit
    [~Switch5] vlan batch 6 100
    [*Switch5] interface 10ge 1/0/1
    [*Switch5-10GE1/0/1] port link-type trunk
    [*Switch5-10GE1/0/1] port trunk allow-pass vlan 6
    [*Switch5-10GE1/0/1] port vlan-mapping vlan 100 inner-vlan 5 map-single-vlan 6
    [*Switch5-10GE1/0/1] quit
    [*Switch5] interface 10ge 1/0/2
    [*Switch5-10GE1/0/2] port link-type trunk
    [*Switch5-10GE1/0/2] port trunk allow-pass vlan 6
    [*Switch5-10GE1/0/2] quit
    [*Switch5] interface 10ge 1/0/3
    [*Switch5-10GE1/0/3] port link-type trunk
    [*Switch5-10GE1/0/3] port trunk allow-pass vlan 6
    [*Switch5-10GE1/0/3] quit
    [*Switch5] commit
    

  5. 验证配置结果

    将分支1的Server1和分支2的Server2配置在同一个网段,比如配置分支1的Server1的IP地址为172.16.0.5/16,配置分支2的Server2的IP地址为172.16.0.6/16,分支1和分支2可以互通。以分支1的Server1 ping分支2的Server2的显示为例。

    <Server1> ping 172.16.0.6
    Pinging 172.16.0.6 with 32 bytes of data:
    Reply from 172.16.0.6: bytes=32 time<1ms TTL=128
    Reply from 172.16.0.6: bytes=32 time<1ms TTL=128
    Reply from 172.16.0.6: bytes=32 time<1ms TTL=128
    Reply from 172.16.0.6: bytes=32 time<1ms TTL=128
    
    Ping statistics for 172.16.0.6:
        Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
    Approximate round trip times in milli-seconds:
        Minimum = 0ms, Maximum = 0ms, Average = 0ms

配置文件

  • Switch1的配置文件

    #
    sysname Switch1
    #
    vlan batch 5
    #
    interface 10GE1/0/1
     port default vlan 5
    #
    interface 10GE1/0/2
     port link-type trunk
     port trunk allow-pass vlan 5
    #
    return
  • Switch2的配置文件

    #
    sysname Switch2
    #
    vlan batch 6
    #
    interface 10GE1/0/1
     port default vlan 6
    #
    interface 10GE1/0/2
     port link-type trunk
     port trunk allow-pass vlan 6
    #
    return
  • Switch3的配置文件

    #
    sysname Switch3
    #
    vlan batch 100
    #
    interface 10GE1/0/1
     port link-type dot1q-tunnel
     port default vlan 100
    #
    interface 10GE1/0/2
     port link-type trunk
     port trunk allow-pass vlan 100
    #
    return
  • Switch4的配置文件

    #
    sysname Switch4
    #
    vlan batch 6
    #
    interface 10GE1/0/1
     port link-type trunk
     port trunk allow-pass vlan 6
    #
    interface 10GE1/0/2
     port link-type trunk
     port trunk allow-pass vlan 6
    #
    return
  • Switch5的配置文件

    #
    sysname Switch5
    #
    vlan batch 6 100
    #
    interface 10GE1/0/1
     port link-type trunk 
     port trunk allow-pass vlan 6
     port vlan-mapping vlan 100 inner-vlan 5 map-single-vlan 6
    #
    interface 10GE1/0/2
     port link-type trunk 
     port trunk allow-pass vlan 6
    #
    interface 10GE1/0/3
     port link-type trunk 
     port trunk allow-pass vlan 6
    #
    return
翻译
下载文档
更新时间:2019-05-05

文档编号:EDOC1100004255

浏览量:11046

下载量:276

平均得分:
本文档适用于这些产品
相关文档
相关版本
Share
上一页 下一页