所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

CloudEngine 12800, 12800E V200R003C00 配置指南-以太网交换

本文档针对设备的以太网业务,主要包括以太网交换概述、MAC配置、以太网链路聚合配置、M-LAG(跨设备链路聚合)配置、VLAN配置、QinQ配置、VLAN mapping配置、GVRP配置、STP/RSTP配置、MSTP配置、VBST配置、ERPS(G.8032)配置、Loopback Detection配置和二层协议透明传输配置。
评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
配置M-LAG双归接入普通以太网络示例(根桥方式)

配置M-LAG双归接入普通以太网络示例(根桥方式)

组网需求

图4-20所示,采用M-LAG方式将主机双归接入普通以太网络。由于用户对于业务的可靠性要求很高,如果主机和接入设备之间做链路聚合只能保证链路级的可靠性,接入设备发生故障时则会导致业务中断。这时用户可以采用跨设备链路聚合技术,正常工作时链路进行负载分担且任何一台设备故障对业务均没有影响,保证业务的高可靠性。由于普通以太网络中存在阻塞端口无法传输M-LAG主备设备的心跳报文,这里采用配置DFS Group绑定管理网口IP地址,保证M-LAG主备设备的心跳报文能够正常传输。

图4-20 配置M-LAG双归接入普通以太网络组网图

配置思路

  1. 将SwitchA和SwitchB配置为根桥,配置相同的桥ID,保证M-LAG主备设备在二层网络中处于根桥地位。

  2. 分别在SwitchA和SwitchB上配置管理网口的IP地址,且保证能够三层互通,用于M-LAG主备设备间心跳报文的传输。

  3. 分别在SwitchA和SwitchB上配置M-LAG特性,实现服务器的双归接入。

  4. 在SwitchC和SwitchD上创建VLANIF接口并配置IP地址,在VLANIF接口上创建VRRP备份组,作为M-LAG主备设备的网关。

操作步骤

  1. 将SwitchA和SwitchB配置为根桥,配置相同的桥ID

    说明:

    如果组成M-LAG的设备下行接入的是交换设备,必须配置根保护功能。

    # 配置SwitchA。

    <HUAWEI> system-view
    [~HUAWEI] sysname SwitchA
    [*HUAWEI] commit
    [~SwitchA] stp root primary
    [*SwitchA] stp bridge-address 39-39-39
    [*SwitchA] interface eth-trunk 1
    [*SwitchA-Eth-Trunk1] trunkport 10ge 1/0/5
    [*SwitchA-Eth-Trunk1] trunkport 10ge 1/0/6
    [*SwitchA-Eth-Trunk1] stp edged-port enable
    [*SwitchA-Eth-Trunk1] commit
    [~SwitchA-Eth-Trunk1] quit

    # 配置SwitchB。

    <HUAWEI> system-view
    [~HUAWEI] sysname SwitchB
    [*HUAWEI] commit
    [~SwitchB] stp root primary
    [*SwitchB] stp bridge-address 39-39-39
    [*SwitchB] interface eth-trunk 1
    [*SwitchB-Eth-Trunk1] trunkport 10ge 1/0/5
    [*SwitchB-Eth-Trunk1] trunkport 10ge 1/0/6
    [*SwitchB-Eth-Trunk1] stp edged-port enable
    [*SwitchB-Eth-Trunk1] commit
    [~SwitchB-Eth-Trunk1] quit

  2. 分别配置SwitchA和SwitchB管理网口的IP地址

    # 配置SwitchA。

    [~SwitchA] interface meth 0/0/0
    [~SwitchA-MEth0/0/0] ip address 10.1.1.1 24
    [*SwitchA-MEth0/0/0] quit
    [*SwitchA] commit

    # 配置SwitchB。

    [~SwitchB] interface meth 0/0/0
    [~SwitchB-MEth0/0/0] ip address 10.1.1.2 24
    [*SwitchB-MEth0/0/0] quit
    [*SwitchB] commit

  3. 在SwitchA和SwitchB上分别创建DFS并绑定管理网口的IP地址

    SwitchA和SwitchB管理网口需要保证能够三层互通。

    # 配置SwitchA。

    [~SwitchA] dfs-group 1
    [*SwitchA-dfs-group-1] source ip 10.1.1.1
    [*SwitchA-dfs-group-1] priority 150
    [*SwitchA-dfs-group-1] quit
    [*SwitchA] commit
    

    # 配置SwitchB。

    [~SwitchB] dfs-group 1
    [*SwitchB-dfs-group-1] source ip 10.1.1.2
    [*SwitchB-dfs-group-1] priority 120
    [*SwitchB-dfs-group-1] quit
    [*SwitchB] commit
    

  4. 配置SwitchA和SwitchB之间的Peer-link

    # 配置SwitchA。

    [~SwitchA] interface eth-trunk 0
    [*SwitchA-Eth-Trunk0] trunkport 10ge 1/0/3
    [*SwitchA-Eth-Trunk0] trunkport 10ge 2/0/4
    [*SwitchA-Eth-Trunk0] undo stp enable
    [*SwitchA-Eth-Trunk0] mode lacp-static
    [*SwitchA-Eth-Trunk0] peer-link 1
    [*SwitchA-Eth-Trunk0] quit
    [*SwitchA] commit
    

    # 配置SwitchB。

    [~SwitchB] interface eth-trunk 0
    [*SwitchB-Eth-Trunk0] trunkport 10ge 1/0/3
    [*SwitchB-Eth-Trunk0] trunkport 10ge 2/0/4
    [*SwitchB-Eth-Trunk0] undo stp enable
    [*SwitchB-Eth-Trunk0] mode lacp-static
    [*SwitchB-Eth-Trunk0] peer-link 1
    [*SwitchB-Eth-Trunk0] quit
    [*SwitchB] commit
    

  5. 配置SwitchA和SwitchB连接服务器的Eth-Trunk接口加入VLAN 11并绑定DFS Group

    服务器上行连接交换机的端口需要绑定在一个聚合链路中且链路聚合模式需要和交换机侧的聚合模式匹配。

    # 配置SwitchA。

    [~SwitchA] vlan batch 11
    [*SwitchA] interface eth-trunk 1
    [*SwitchA-Eth-Trunk1] mode lacp-dynamic
    [*SwitchA-Eth-Trunk1] port link-type access
    [*SwitchA-Eth-Trunk1] port default vlan 11
    [*SwitchA-Eth-Trunk1] dfs-group 1 m-lag 1
    [*SwitchA-Eth-Trunk1] quit
    [*SwitchA] commit

    # 配置SwitchB。

    [~SwitchB] vlan batch 11
    [*SwitchB] interface eth-trunk 1
    [*SwitchB-Eth-Trunk1] mode lacp-dynamic
    [*SwitchB-Eth-Trunk1] port link-type access
    [*SwitchB-Eth-Trunk1] port default vlan 11
    [*SwitchB-Eth-Trunk1] dfs-group 1 m-lag 1
    [*SwitchB-Eth-Trunk1] quit
    [*SwitchB] commit
    

  6. 配置SwitchA和SwitchC之间为聚合链路以及SwitchB和SwitchD之间为聚合链路,并配置接口类型和通过的VLAN

    # 配置SwitchA。

    [~SwitchA] interface eth-trunk 2
    [*SwitchA-Eth-Trunk2] mode lacp-static
    [*SwitchA-Eth-Trunk2] port link-type trunk
    [*SwitchA-Eth-Trunk2] port trunk allow-pass vlan 11
    [*SwitchA-Eth-Trunk2] trunkport 10ge 1/0/1
    [*SwitchA-Eth-Trunk2] trunkport 10ge 1/0/2
    [*SwitchA-Eth-Trunk2] quit
    [*SwitchA] commit
    

    # 配置SwitchB。

    [~SwitchB] interface eth-trunk 2
    [*SwitchB-Eth-Trunk2] mode lacp-static
    [*SwitchB-Eth-Trunk2] port link-type trunk
    [*SwitchB-Eth-Trunk2] port trunk allow-pass vlan 11
    [*SwitchB-Eth-Trunk2] trunkport 10ge 1/0/1
    [*SwitchB-Eth-Trunk2] trunkport 10ge 1/0/2
    [*SwitchB-Eth-Trunk2] quit
    [*SwitchB] commit
    

    # 配置SwitchC。

    <HUAWEI> system-view
    [~HUAWEI] sysname SwitchC
    [*HUAWEI] commit
    [~SwitchC] vlan batch 11
    [*SwitchC] interface eth-trunk 2
    [*SwitchC-Eth-Trunk2] mode lacp-static
    [*SwitchC-Eth-Trunk2] port link-type trunk
    [*SwitchC-Eth-Trunk2] port trunk allow-pass vlan 11
    [*SwitchC-Eth-Trunk2] trunkport 10ge 1/0/1
    [*SwitchC-Eth-Trunk2] trunkport 10ge 1/0/2
    [*SwitchC-Eth-Trunk2] quit
    [*SwitchC] commit
    

    # 配置SwitchD。

    <HUAWEI> system-view
    [~HUAWEI] sysname SwitchD
    [*HUAWEI] commit
    [~SwitchD] vlan batch 11
    [*SwitchD] interface eth-trunk 2
    [*SwitchD-Eth-Trunk2] mode lacp-static
    [*SwitchD-Eth-Trunk2] port link-type trunk
    [*SwitchD-Eth-Trunk2] port trunk allow-pass vlan 11
    [*SwitchD-Eth-Trunk2] trunkport 10ge 1/0/1
    [*SwitchD-Eth-Trunk2] trunkport 10ge 1/0/2
    [*SwitchD-Eth-Trunk2] quit
    [*SwitchD] commit
    

  7. 在SwitchC和SwitchD上创建VLANIF接口并配置IP地址,在VLANIF接口上创建VRRP备份组

    # 在SwitchC上创建VRRP备份组1,配置SwitchC在该备份组中的优先级为120。

    [~SwitchC] interface vlanif 11
    [*SwitchC-Vlanif11] ip address 10.2.1.1 24
    [*SwitchC-Vlanif11] vrrp vrid 1 virtual-ip 10.2.1.111
    [*SwitchC-Vlanif11] vrrp vrid 1 priority 120
    [*SwitchC-Vlanif11] quit
    [*SwitchC] commit
    

    # 在SwitchD上创建VRRP备份组1,其在该备份组中的优先级为缺省值100。

    [~SwitchD] interface vlanif 11
    [*SwitchD-Vlanif11] ip address 10.2.1.2 24
    [*SwitchD-Vlanif11] vrrp vrid 1 virtual-ip 10.2.1.111
    [*SwitchD-Vlanif11] quit
    [*SwitchD] commit
    

  8. 验证配置结果

    • 执行命令display dfs-group,查看M-LAG的相关信息。

      # 查看DFS Group编号为1的M-LAG信息。

      [~SwitchA] display dfs-group 1 m-lag
      *                : Local node
      Heart beat state : OK
      Node 1 *
        Dfs-Group ID   : 1
        Priority       : 150
        Address        : ip address 10.1.1.1
        State          : Master
        Causation      : -
        System ID      : 0025-9e95-7c31
        SysName        : SwitchA
        Version        : V100R006C00
        Device Type    : CE12800
      Node 2
        Dfs-Group ID   : 1
        Priority       : 120
        Address        : ip address 10.1.1.2
        State          : Backup
        Causation      : -
        System ID      : 0025-9e95-7c11
        SysName        : SwitchB
        Version        : V100R006C00
        Device Type    : CE12800

      # 查看SwitchA上的M-LAG信息。

      [~SwitchA] display dfs-group 1 node 1 m-lag brief
      * - Local node
      
      M-Lag ID     Interface      Port State    Status
             1     Eth-Trunk 1    Up            active(*)-active

      # 查看SwitchB上的M-LAG信息。

      [~SwitchA] display dfs-group 1 node 2 m-lag brief
      * - Local node
      
      M-Lag ID     Interface      Port State    Status
             1     Eth-Trunk 1    Up            active-active(*)

      通过以上显示信息可以看到,“Heart beat state”的状态是“OK”,表明心跳状态正常;SwitchA作为Node 1,优先级为150,“State”的状态是“Master”;SwitchB作为Node 2,优先级为120,“State”的状态是“Backup”。同时“Causation”的状态是“-”,Node 1的“Port State”状态为“Up”,Node 2的“Port State”状态为“Up”,且Node 1和Node 2的M-LAG状态均为“active”,表明M-LAG的配置正确。

    • 在SwitchC和SwitchD上分别执行display vrrp命令,可以看到SwitchC在备份组中的状态为Master,SwitchD在备份组中的状态为Backup。

      [~SwitchC] display vrrp verbose
      Vlanif11 | Virtual Router 1
      State        : Master
      Virtual IP     : 10.2.1.111
      Master IP      : 10.2.1.1
      PriorityRun    : 120
      PriorityConfig : 120                                                        
      MasterPriority : 120                                                        
      Preempt        : YES   Delay Time : 0s    Remain : --    
      TimerRun       : 1s                                                              
      TimerConfig    : 1s                                                           
      Auth Type      : NONE                                                            
      Virtual MAC    : 0000-5e00-0101                                                
      Check TTL      : YES                                                             
      Config Type    : Normal                                                   
      Create Time       : 2015-01-30 11:39:18                                           
      Last Change Time  : 2015-02-04 11:38:58 
      [~SwitchD] display vrrp verbose
      Vlanif11 | Virtual Router 1
      State        : Backup
      Virtual IP     : 10.2.1.111
      Master IP      : 10.2.1.1
      PriorityRun    : 100
      PriorityConfig : 100                                                        
      MasterPriority : 120                                                        
      Preempt        : YES   Delay Time : 0s   Remain : --     
      TimerRun       : 1s                                                        
      TimerConfig    : 1s                                                        
      Auth Type      : NONE                                                       
      Virtual MAC    : 0000-5e00-0101                                             
      Check TTL      : YES                                                        
      Config Type    : Normal                                                
      Create Time      : 2015-01-30 11:39:18                                      
      Last Change Time : 2015-02-04 11:38:58 

配置文件

  • SwitchA的配置文件

    #
    sysname SwitchA
    #
    dfs-group 1
     priority 150
     source ip 10.1.1.1
    #
    vlan batch 11
    #
    stp bridge-address 0039-0039-0039
    stp instance 0 root primary
    #
    interface MEth0/0/0
     ip address 10.1.1.1 255.255.255.0
    #
    interface Eth-Trunk0
     stp disable
     mode lacp-static
     peer-link 1
    #
    interface Eth-Trunk1
     port default vlan 11
     stp edged-port enable
     mode lacp-dynamic
     dfs-group 1 m-lag 1
    #
    interface Eth-Trunk2
     port link-type trunk
     port trunk allow-pass vlan 11
     mode lacp-static 
    #
    interface 10GE1/0/1
     eth-trunk 2
    #
    interface 10GE1/0/2
     eth-trunk 2
    #
    interface 10GE1/0/3
     eth-trunk 0
    #
    interface 10GE1/0/5
     eth-trunk 1
    #
    interface 10GE1/0/6
     eth-trunk 1
    #
    interface 10GE2/0/4
     eth-trunk 0
    #
    return
    
  • SwitchB的配置文件

    #
    sysname SwitchB
    #
    dfs-group 1
     priority 120
     source ip 10.1.1.2
    #
    vlan batch 11
    #
    stp bridge-address 0039-0039-0039
    stp instance 0 root primary
    #
    interface MEth0/0/0
     ip address 10.1.1.2 255.255.255.0
    #
    interface Eth-Trunk0
     stp disable
     mode lacp-static
     peer-link 1
    #
    interface Eth-Trunk1
     port default vlan 11
     stp edged-port enable
     mode lacp-dynamic
     dfs-group 1 m-lag 1
    #
    interface Eth-Trunk2
     port link-type trunk
     port trunk allow-pass vlan 11
     mode lacp-static
    #
    interface 10GE1/0/1
     eth-trunk 2
    #
    interface 10GE1/0/2
     eth-trunk 2
    #
    interface 10GE1/0/3
     eth-trunk 0
    #
    interface 10GE1/0/5
     eth-trunk 1
    #
    interface 10GE1/0/6
     eth-trunk 1
    #
    interface 10GE2/0/4
     eth-trunk 0
    #
    return
    
  • SwitchC的配置文件

    #
    sysname SwitchC
    #
    vlan batch 11
    #
    interface Vlanif11
     ip address 10.2.1.1 255.255.255.0
     vrrp vrid 1 virtual-ip 10.2.1.111
     vrrp vrid 1 priority 120
    #
    interface Eth-Trunk2
     port link-type trunk
     port trunk allow-pass vlan 11
     mode lacp-static
    #
    interface 10GE1/0/1
     eth-trunk 2
    #
    interface 10GE1/0/2
     eth-trunk 2
    #
    return
    
  • SwitchD的配置文件

    #
    sysname SwitchD
    #
    vlan batch 11
    #
    interface Vlanif11
     ip address 10.2.1.2 255.255.255.0
     vrrp vrid 1 virtual-ip 10.2.1.111
    #
    interface Eth-Trunk2
     port link-type trunk
     port trunk allow-pass vlan 11
     mode lacp-static
    #
    interface 10GE1/0/1
     eth-trunk 2
    #
    interface 10GE1/0/2
     eth-trunk 2
    #
    return
    
翻译
下载文档
更新时间:2019-05-05

文档编号:EDOC1100004255

浏览量:12249

下载量:276

平均得分:
本文档适用于这些产品
相关文档
相关版本
Share
上一页 下一页