所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

CloudEngine 12800, 12800E V200R003C00 配置指南-以太网交换

本文档针对设备的以太网业务,主要包括以太网交换概述、MAC配置、以太网链路聚合配置、M-LAG(跨设备链路聚合)配置、VLAN配置、QinQ配置、VLAN mapping配置、GVRP配置、STP/RSTP配置、MSTP配置、VBST配置、ERPS(G.8032)配置、Loopback Detection配置和二层协议透明传输配置。
评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
配置GVRP示例

配置GVRP示例

组网需求

图8-6所示,公司A和分公司之间通过多台交换设备连接,要求实现分公司跟总公司的互相通信。随着公司业务的扩展,公司A的销售部与公司B的采购部建立起业务关系,现在需要通过GVRP功能实现公司B的采购部(VLAN 100,VLAN 102~VLAN 105)和公司A的销售部(VLAN 100,VLAN 102~VLAN 105)互相通信,由于公司B的其他部门和公司A没有业务关系,不需要互相通信。

图8-6 配置GVRP的组网图

配置思路

采用如下的思路配置GVRP:

  1. 在SwitchA~SwitchC上均先使能全局GVRP功能,后使能接口GVRP功能,实现VLAN的动态注册。

  2. 公司A及分公司的所有交换机配置GVRP功能并配置接口注册模式为Normal,以简化配置。

  3. 公司B的所有交换机配置GVRP功能并将与公司A相连的接口的GVRP注册模式配置为Fixed,以控制只允许公司B配置的VLAN通过。

操作步骤

  1. 配置SwitchA

    # 全局使能GVRP功能。

    <HUAWEI> system-view
    [~HUAWEI] sysname SwitchA
    [*HUAWEI] commit
    [~SwitchA] gvrp
    [*SwitchA] commit
    

    # 配置接口10GE1/0/1为Trunk类型,并允许所有VLAN通过,使能接口GVRP功能,注册模式为Normal。

    [~SwitchA] interface 10ge 1/0/1
    [~SwitchA-10GE1/0/1] port link-type trunk
    [*SwitchA-10GE1/0/1] port trunk allow-pass vlan all
    [*SwitchA-10GE1/0/1] gvrp
    [*SwitchA-10GE1/0/1] gvrp registration normal
    [*SwitchA-10GE1/0/1] commit
    [~SwitchA-10GE1/0/1] quit
    

    # 配置接口10GE1/0/2为Trunk类型,并允许所有VLAN通过,使能接口GVRP功能,注册模式为Normal。

    [~SwitchA] interface 10ge 1/0/2
    [~SwitchA-10GE1/0/2] port link-type trunk
    [*SwitchA-10GE1/0/2] port trunk allow-pass vlan all
    [*SwitchA-10GE1/0/2] gvrp
    [*SwitchA-10GE1/0/2] gvrp registration normal
    [*SwitchA-10GE1/0/2] commit
    [~SwitchA-10GE1/0/2] quit
    

    SwitchC的配置与SwitchA相同,不再赘述。

  2. 配置SwitchB

    # 全局使能GVRP功能,创建VLAN 100,VLAN 102~VLAN 105。

    <HUAWEI> system-view
    [~HUAWEI] sysname SwitchB
    [*HUAWEI] commit
    [~SwitchB] gvrp
    [*SwitchB] vlan batch 100 102 to 105 
    [*SwitchB] commit
    

    # 配置接口10GE1/0/1为Trunk类型,并允许所有VLAN通过,使能接口GVRP功能,注册模式为Fixed。

    [~SwitchB] interface 10ge 1/0/1
    [~SwitchB-10GE1/0/1] port link-type trunk
    [*SwitchB-10GE1/0/1] port trunk allow-pass vlan all
    [*SwitchB-10GE1/0/1] gvrp
    [*SwitchB-10GE1/0/1] gvrp registration fixed
    [*SwitchB-10GE1/0/1] commit
    [~SwitchB-10GE1/0/1] quit
    

    # 配置接口10GE1/0/2为Trunk类型,并允许加入的VLAN通过,使能接口GVRP功能,注册模式为Normal。

    [~SwitchB] interface 10ge 1/0/2
    [~SwitchB-10GE1/0/2] port link-type trunk
    [*SwitchB-10GE1/0/2] port trunk allow-pass vlan all
    [*SwitchB-10GE1/0/2] gvrp
    [*SwitchB-10GE1/0/2] gvrp registration normal
    [*SwitchB-10GE1/0/2] commit
    [~SwitchB-10GE1/0/2] quit
    

  3. 验证配置结果

    配置完成后,公司A的员工可以与分公司的员工互通。公司A属于VLAN 100,VLAN 102~VLAN 105的员工可以与公司B的员工互通。

    在SwitchA上使用命令display gvrp status,查看全局GVRP的使能情况,结果如下:

    [~SwitchA] display gvrp status
    GVRP status: enabled.
    

    在SwitchA上使用命令display gvrp statistics,查看接口的GVRP统计信息,其中包括:GVRP状态、GVRP注册失败次数、上一个GVRP数据单元源MAC地址和接口GVRP注册类型,结果如下:

    [~SwitchA] display gvrp statistics
    
      GVRP statistics on port 10GE1/0/1 
        GVRP status                         : Enabled                               
        GVRP registrations failed           : 0                                     
        GVRP last PDU origin                : 0000-0000-0000                        
        GVRP registration type              : Normal
    
      GVRP statistics on port 10GE1/0/2
        GVRP status                         : Enabled                               
        GVRP registrations failed           : 0                                     
        GVRP last PDU origin                : 0000-0000-0000                        
        GVRP registration type              : Normal

    SwitchB和SwitchC的查看方法与SwitchA类似,这里不再赘述。

配置文件

  • SwitchA的配置文件

    #
    sysname SwitchA
    #
    gvrp
    #
    interface 10GE1/0/1
     port link-type trunk
     port trunk allow-pass vlan 2 to 4094
     gvrp
    #
    interface 10GE1/0/2
     port link-type trunk
     port trunk allow-pass vlan 2 to 4094
     gvrp
    #
    return
  • SwitchB的配置文件

    #
    sysname SwitchB
    #
    vlan batch 100 102 to 105
    #
    gvrp
    #
    interface 10GE1/0/1
     port link-type trunk
     port trunk allow-pass vlan 2 to 4094
     gvrp
     gvrp registration fixed
    #
    interface 10GE1/0/2
     port link-type trunk
     port trunk allow-pass vlan 2 to 4094
     gvrp
    #
    return
  • SwitchC的配置文件

    #
    sysname SwitchC
    #
    gvrp
    #
    interface 10GE1/0/1
     port link-type trunk
     port trunk allow-pass vlan 2 to 4094
     gvrp
    #
    interface 10GE1/0/2
     port link-type trunk
     port trunk allow-pass vlan 2 to 4094
     gvrp
    #
    return
翻译
下载文档
更新时间:2019-05-05

文档编号:EDOC1100004255

浏览量:11255

下载量:276

平均得分:
本文档适用于这些产品
相关文档
相关版本
Share
上一页 下一页