所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

CloudEngine 12800, 12800E V200R003C00 配置指南-以太网交换

本文档针对设备的以太网业务,主要包括以太网交换概述、MAC配置、以太网链路聚合配置、M-LAG(跨设备链路聚合)配置、VLAN配置、QinQ配置、VLAN mapping配置、GVRP配置、STP/RSTP配置、MSTP配置、VBST配置、ERPS(G.8032)配置、Loopback Detection配置和二层协议透明传输配置。
评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
配置VLAN聚合示例

配置VLAN聚合示例

组网需求

某公司拥有多个部门且位于同一网段,为了提升业务安全性,将不同部门的用户划分到不同VLAN中。现由于业务需要,不同部门间的用户需要互通。

图5-27所示,VLAN2和VLAN3为不同部门,现需要实现不同VLAN间的用户可以互相访问。

图5-27 配置VLAN聚合组网图

配置思路

可以在SwitchB上部署VLAN聚合,将不同部门的VLAN聚合到Super VLAN中,这样,不同部门的用户可通过Super VLAN访问Internet。同时,为使部门间用户互通,在Super VLAN上部署Proxy ARP功能。采用如下思路配置VLAN聚合:

  1. 在SwitchA和SwitchB上配置VLAN和接口,将不同部门用户划分到不同VLAN中,并透传各VLAN到SwitchB。

  2. 在SwitchB上配置Super-VLAN及其对应的VLANIF接口、上行路由,使不同部门的用户能够访问Internet。

  3. 在SwitchB上启用Super-VLAN的Proxy ARP功能,使不同部门的用户间三层互通。

操作步骤

  1. 配置VLAN和接口,将不同部门用户划分到不同VLAN中,并透传各VLAN到SwitchB
    1. 配置SwitchA

      # 配置接口10GE1/0/1为Access类型。接口10GE1/0/2~10GE1/0/4的配置与10GE1/0/1类似,不再赘述。

      <HUAWEI> system-view
      [~HUAWEI] sysname SwitchA
      [*HUAWEI] commit
      [~SwitchA] interface 10ge 1/0/1
      [~SwitchA-10GE1/0/1] port link-type access
      [*SwitchA-10GE1/0/1] quit
      [*SwitchA] commit
      

      # 创建VLAN 2和VLAN 3,并将10GE1/0/1、10GE1/0/2加入VLAN 2,将10GE1/0/3、10GE1/0/4加入VLAN 3。

      [~SwitchA] vlan batch 2 3
      [*SwitchA] vlan 2
      [*SwitchA-vlan2] port 10ge 1/0/1 1/0/2
      [*SwitchA-vlan2] quit
      [*SwitchA] vlan 3
      [*SwitchA-vlan3] port 10ge 1/0/3 1/0/4
      [*SwitchA-vlan3] quit
      [*SwitchA] commit
      

      # 配置SwitchA连接SwitchB的接口,透传VLAN 2和VLAN 3到SwitchB。

      [~SwitchA] interface 10ge 1/0/5
      [~SwitchA-10GE1/0/5] port link-type trunk
      [*SwitchA-10GE1/0/5] port trunk allow-pass vlan 2 3
      [*SwitchA-10GE1/0/5] quit
      [*SwitchA] commit

    2. 配置SwitchB

      # 创建VLAN 2、VLAN 3、VLAN 4、VLAN 10,并配置SwitchB连接SwitchA的接口,使VLAN 2和VLAN 3透传到SwitchB。

      <HUAWEI> system-view
      [~HUAWEI] sysname SwitchB
      [*HUAWEI] commit
      [~SwitchB] vlan batch 2 3 4 10
      [*SwitchB] interface 10ge 1/0/5
      [*SwitchB-10GE1/0/5] port link-type trunk
      [*SwitchB-10GE1/0/5] port trunk allow-pass vlan 2 3
      [*SwitchB-10GE1/0/5] quit
      [*SwitchB] commit
      

  2. 配置Super-VLAN及其对应的VLANIF接口

    # 在SwitchB上配置Super-VLAN 4,并将VLAN 2和VLAN 3加入到Super-VLAN 4,作为其Sub-VLAN。

    [~SwitchB] vlan 4
    [~SwitchB-vlan4] aggregate-vlan
    [*SwitchB-vlan4] access-vlan 2 to 3
    [*SwitchB-vlan4] quit
    [*SwitchB] commit

    # 创建并配置VLANIF4,使不同部门的用户可通过Super-VLAN 4访问Internet。

    [~SwitchB] interface vlanif 4
    [*SwitchB-Vlanif4] ip address 10.1.1.1 24
    [*SwitchB-Vlanif4] quit
    [*SwitchB] commit

  3. 配置上行路由

    # 在SwitchB上配置上行接口10GE1/0/1,透传SwitchB与出口网关Router的互联VLAN。

    [~SwitchB] interface 10ge 1/0/1
    [~SwitchB-10GE1/0/1] port link-type trunk
    [*SwitchB-10GE1/0/1] port trunk allow-pass vlan 10
    [*SwitchB-10GE1/0/1] quit
    [*SwitchB] commit
    

    # 创建并配置VLANIF 10,指定其IP地址为SwitchB与出口网关Router对接的IP地址。

    [~SwitchB] interface vlanif 10
    [*SwitchB-Vlanif10] ip address 10.10.1.1 24
    [*SwitchB-Vlanif10] quit
    [*SwitchB] commit
    

    # 在SwitchB上配置一条到出口网关Router的缺省静态路径,使用户能够访问Internet。

    [~SwitchB] ip route-static 0.0.0.0 0.0.0.0 10.10.1.2
    [*SwitchB] commit
    说明:

    还需要在出口网关Router上配置其与SwitchB对接的接口,指定其IP地址为10.10.1.2,具体配置请参见Router的配置手册。

  4. 配置用户IP地址

    分别为各用户配置IP地址,并使它们和VLAN 4处于同一网段。

    配置成功后,各部门用户可以访问Internet,但VLAN 2的用户与VLAN 3的用户间不可以相互ping通。还需要在SwitchB上配置Proxy ARP。

  5. 配置Proxy ARP

    # 在SwitchB的Super-VLAN 4下配置Proxy ARP,使不同部门的用户间三层互通。

    [~SwitchB] interface vlanif 4 
    [~SwitchB-Vlanif4] arp proxy inter-vlan enable
    [*SwitchB-Vlanif4] quit
    [*SwitchB] commit
    

  6. 检查配置结果

    配置完成后,VLAN 2的用户与VLAN 3的用户可以相互ping通,且都可以访问Internet。

配置文件

  • SwitchA的配置文件
    #
    sysname SwitchA
    #
    vlan batch 2 to 3
    #
    interface 10GE1/0/1
     port default vlan 2
    #
    interface 10GE1/0/2
     port default vlan 2
    #
    interface 10GE1/0/3
     port default vlan 3
    #
    interface 10GE1/0/4
     port default vlan 3
    #
    interface 10GE1/0/5
     port link-type trunk
     port trunk allow-pass vlan 2 to 3
    #
    return
  • SwitchB的配置文件

    #
    sysname SwitchB
    #
    vlan batch 2 to 4 10
    #
    vlan 4
     aggregate-vlan
     access-vlan 2 to 3
    #
    interface Vlanif4
     ip address 10.1.1.1 255.255.255.0
     arp proxy inter-vlan enable
    #
    interface Vlanif10
     ip address 10.10.1.1 255.255.255.0
    #
    interface 10GE1/0/1
     port link-type trunk
     port trunk allow-pass vlan 10
    #
    interface 10GE1/0/5
     port link-type trunk
     port trunk allow-pass vlan 2 to 3
    #
    ip route-static 0.0.0.0 0.0.0.0 10.10.1.2
    #
    return
翻译
下载文档
更新时间:2019-05-05

文档编号:EDOC1100004255

浏览量:11217

下载量:276

平均得分:
本文档适用于这些产品
相关文档
相关版本
Share
上一页 下一页