所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

CloudEngine 12800, 12800E V200R003C00 配置指南-以太网交换

本文档针对设备的以太网业务,主要包括以太网交换概述、MAC配置、以太网链路聚合配置、M-LAG(跨设备链路聚合)配置、VLAN配置、QinQ配置、VLAN mapping配置、GVRP配置、STP/RSTP配置、MSTP配置、VBST配置、ERPS(G.8032)配置、Loopback Detection配置和二层协议透明传输配置。
评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
配置基本QinQ示例

配置基本QinQ示例

组网需求

图6-7所示,某数据中心的租户1位于不同的地理位置,租户2位于不同的地理位置。SwitchA和SwitchB为数据中心的边缘设备,通过核心/骨干网连接。

现需要实现:
  • 租户1和租户2独立划分VLAN,两者互不影响。
  • 两租户之间流量通过核心/骨干网透明传输,相同租户之间互通,不同租户之间互相隔离。
可通过配置QinQ来实现以上需求。利用核心/骨干网提供的VLAN100使数据中心的租户1互通,利用核心/骨干网提供的VLAN200使数据中心的租户2互通,不同租户之间互相隔离。
图6-7 配置QinQ组网图

配置思路

采用如下的思路配置QinQ:

  1. SwitchA和SwitchB上均创建VLAN100和VLAN200,配置连接租户的接口为QinQ类型,并分别加入VLAN。实现不同租户添加不同的外层VLAN Tag。

  2. 配置SwitchA和SwitchB上连接核心/骨干网的接口加入相应VLAN,实现允许VLAN100和200的报文通过。

操作步骤

  1. 创建VLAN

    # 在SwitchA上创建VLAN100和VLAN200

    <HUAWEI> system-view
    [~HUAWEI] sysname SwitchA
    [*HUAWEI] commit
    [~SwitchA] vlan batch 100 200
    [*SwitchA] commit
    

    # 在SwitchB上创建VLAN100和VLAN200

    <HUAWEI> system-view
    [~HUAWEI] sysname SwitchB
    [*HUAWEI] commit
    [~SwitchB] vlan batch 100 200
    [*SwitchB] commit
    

  2. 配置接口类型为QinQ

    # 在SwitchA上配置接口10GE1/0/1、10GE1/0/2的类型为QinQ,10GE1/0/1的外层tag为VLAN100,10GE1/0/2的外层tag为VLAN200。SwitchB的配置与SwitchA类似,不再赘述。

    [~SwitchA] interface 10ge 1/0/1
    [~SwitchA-10GE1/0/1] port link-type dot1q-tunnel
    [*SwitchA-10GE1/0/1] port default vlan 100
    [*SwitchA-10GE1/0/1] quit
    [*SwitchA] interface 10ge 1/0/2
    [*SwitchA-10GE1/0/2] port link-type dot1q-tunnel
    [*SwitchA-10GE1/0/2] port default vlan 200
    [*SwitchA-10GE1/0/2] quit
    [*SwitchA] commit
    

  3. 配置Switch连接核心/骨干网侧的接口

    # 在SwitchA上配置接口10GE1/0/3加入VLAN100和VLAN200。SwitchB的配置与SwitchA类似,不再赘述。

    [~SwitchA] interface 10ge 1/0/3
    [~SwitchA-10GE1/0/3] port link-type trunk
    [*SwitchA-10GE1/0/3] port trunk allow-pass vlan 100 200
    [*SwitchA-10GE1/0/3] commit
    [~SwitchA-10GE1/0/3] quit

  4. 验证配置结果

    从数据中心一处租户1内任意VLAN的一台Server ping另外一处租户1同一VLAN内的Server,如果可以ping通则表示租户1内部可以互相通信。

    从数据中心一处租户2内任意VLAN的一台Server ping另外一处租户2同一VLAN内的Server,如果可以ping通则表示租户2内部可以互相通信。

    从数据中心一处租户1内任意VLAN的一台Server ping另外一处租户2同一VLAN内的Server,不能ping通,则表示租户之间是互相隔离的。

配置文件

  • SwitchA的配置文件

    #
    sysname SwitchA
    #
    vlan batch 100 200
    #
    interface 10GE1/0/1
     port link-type dot1q-tunnel
     port default vlan 100
    #
    interface 10GE1/0/2
     port link-type dot1q-tunnel
     port default vlan 200
    #
    interface 10GE1/0/3
     port link-type trunk
     port trunk allow-pass vlan 100 200
    #
    return
  • SwitchB的配置文件

    #
    sysname SwitchB
    #
    vlan batch 100 200
    #
    interface 10GE1/0/1
     port link-type dot1q-tunnel
     port default vlan 100
    #
    interface 10GE1/0/2
     port link-type dot1q-tunnel
     port default vlan 200
    #
    interface 10GE1/0/3
     port link-type trunk
     port trunk allow-pass vlan 100 200
    #
    return
翻译
下载文档
更新时间:2019-05-05

文档编号:EDOC1100004255

浏览量:11268

下载量:276

平均得分:
本文档适用于这些产品
相关文档
相关版本
Share
上一页 下一页