所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

CloudEngine 12800, 12800E V200R003C00 配置指南-以太网交换

本文档针对设备的以太网业务,主要包括以太网交换概述、MAC配置、以太网链路聚合配置、M-LAG(跨设备链路聚合)配置、VLAN配置、QinQ配置、VLAN mapping配置、GVRP配置、STP/RSTP配置、MSTP配置、VBST配置、ERPS(G.8032)配置、Loopback Detection配置和二层协议透明传输配置。
评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
配置VLAN内协议报文透传示例

配置VLAN内协议报文透传示例

组网需求

图5-30所示,某数据中心网络中拥有办公业务服务器ServerA和ServerB,ServerA和ServerB属于同一VLAN10,并且通过DHCP方式获取IP地址。SwitchB为二层交换设备,为了防止网络中针对DHCP的攻击,在SwitchB上部署了DHCP snooping功能,此时所有VLAN的协议报文都会上送CPU处理,CPU需要将其重新转发到其他设备进行处理,这样会对报文的转发速度和效率造成较大影响。为了解决上述问题,可以在交换机SwitchB上使能VLAN10的透传功能,VLAN10内的协议报文到达SwitchB后直接被二层转发出去,而不上送CPU处理,从而增加了设备转发协议报文的速率。

图5-30 配置VLAN内协议报文透传组网图

配置思路

采用如下的思路配置VLAN内协议报文透传功能:

  1. 将连接办公业务服务器的SwitchA的下行口划分到VLAN10。

  2. 在SwitchB上使能VLAN内协议报文透传功能,实现带指定VLAN的协议报文到达SwitchB时,直接被转发出去而不上送CPU处理。

操作步骤

  1. 将SwitchA的下行口划分到VLAN10,上行口允许VLAN10通过

    <HUAWEI> system-view
    [~HUAWEI] sysname SwitchA
    [*HUAWEI] commit
    [~SwitchA] vlan 10
    [*SwitchA-vlan10] quit
    [*SwitchA] interface 10ge 1/0/1
    [*SwitchA-10GE1/0/1] port default vlan 10
    [*SwitchA-10GE1/0/1] quit
    [*SwitchA] interface 10ge 1/0/2
    [*SwitchA-10GE1/0/2] port default vlan 10
    [*SwitchA-10GE1/0/2] quit
    [*SwitchA] interface 10ge 1/0/3
    [*SwitchA-10GE1/0/3] port link-type trunk
    [*SwitchA-10GE1/0/3] port trunk allow-pass vlan 10
    [*SwitchA-10GE1/0/3] quit
    [*SwitchA] commit

  2. 在SwitchB上使能VLAN内协议报文透传功能

    <HUAWEI> system-view
    [~HUAWEI] sysname SwitchB
    [*HUAWEI] commit
    [~SwitchB] vlan 10
    [*SwitchB-vlan10] quit
    [*SwitchB] interface 10ge 1/0/1
    [*SwitchB-10GE1/0/1] port link-type trunk
    [*SwitchB-10GE1/0/1] port trunk allow-pass vlan 10
    [*SwitchB-10GE1/0/1] quit
    [*SwitchB] interface 10ge 1/0/2
    [*SwitchB-10GE1/0/2] port link-type trunk
    [*SwitchB-10GE1/0/2] port trunk allow-pass vlan 10
    [*SwitchB-10GE1/0/2] quit
    [*SwitchB] vlan 10
    [*SwitchB-vlan10] protocol-transparent
    [*SwitchB-vlan10] quit
    [*SwitchB] commit

  3. 检查配置结果

    配置完成后,进入SwitchB的VLAN10视图,使用命令display this可以查看到该VLAN已经使能了VLAN内协议报文透传功能。

    [~SwitchB] vlan 10
    [~SwitchB-vlan10] display this
    #
    vlan 10
     protocol-transparent
    #
    return
    

配置文件

  • SwitchA的配置文件

    #
    sysname SwitchA
    #
    vlan batch 10
    #
    interface 10GE1/0/1
     port default vlan 10
    #
    interface 10GE1/0/2
     port default vlan 10
    #
    interface 10GE1/0/3
     port link-type trunk
     port trunk allow-pass vlan 10
    #
    return
    
  • SwitchB的配置文件

    #
    sysname SwitchB
    #
    vlan batch 10
    #
    vlan 10
     protocol-transparent
    #
    interface 10GE1/0/1
     port link-type trunk
     port trunk allow-pass vlan 10
    #
    interface 10GE1/0/2
     port link-type trunk
     port trunk allow-pass vlan 10
    #
    return
    
翻译
下载文档
更新时间:2019-05-05

文档编号:EDOC1100004255

浏览量:11172

下载量:276

平均得分:
本文档适用于这些产品
相关文档
相关版本
Share
上一页 下一页