所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

CloudEngine 12800, 12800E V200R003C00 配置指南-以太网交换

本文档针对设备的以太网业务,主要包括以太网交换概述、MAC配置、以太网链路聚合配置、M-LAG(跨设备链路聚合)配置、VLAN配置、QinQ配置、VLAN mapping配置、GVRP配置、STP/RSTP配置、MSTP配置、VBST配置、ERPS(G.8032)配置、Loopback Detection配置和二层协议透明传输配置。
评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
配置MUX VLAN示例(汇聚层设备)

配置MUX VLAN示例(汇聚层设备)

组网需求

图5-29所示,某数据中心网络中拥有办公业务服务器ServerA、ServerB、ServerC和ServerD,所有服务器都可以访问园区办公网络,对于数据中心管理员来说,希望数据中心内部的ServerA和ServerB是可以互相访问的,而ServerC和ServerD是隔离的,不能够互相访问。

为了解决上述问题,如图5-29所示,Switch1位于网络的汇聚层,Gateway设备作为下挂终端设备的网关设备,Switch2、Switch3为接入层设备。此时可在Switch1~Switch3上部署MUX VLAN特性。MUX VLAN不但能够实现企业需求,同时也解决了VLAN ID紧缺问题,也便于网络管理者维护。

说明:

CE12800E设备不支持该配置。

图5-29 配置MUX VLAN组网图

配置思路

采用如下思路配置MUX VLAN功能:

  1. 在Switch1~Switch3上均创建VLAN 2~VLAN 4,VLAN 2为主VLAN,VLAN 3为互通型从VLAN,VLAN 4为隔离型从VLAN。

  2. Gateway与Switch1通过接口10GE1/0/1对接,在Gateway上创建VLANIF 2,并配置IP地址为10.10.10.1/24,作为下挂Server的网关地址。

  3. 配置接入层设备Switch2和Switch3的上行口10GE1/0/1允许VLAN 2~VLAN 4通过,下行口使能MUX VLAN功能,并加入与连接Server所属相同的VLAN。

操作步骤

  1. 配置MUX VLAN

    # 分别在Switch1、Switch2和Switch3上均创建VLAN 2~VLAN 4,配置VLAN 2为Principal VLAN,VLAN 3为Group VLAN,VLAN 4为Separate VLAN。以Switch1为例,Switch2和Switch3步骤类似,不再赘述。

    <HUAWEI> system-view
    [~HUAWEI] sysname Switch1
    [*HUAWEI] commit
    [~Switch1] vlan batch 2 3 4
    [*Switch1] vlan 2
    [*Switch1-vlan2] mux-vlan
    [*Switch1-vlan2] subordinate group 3
    [*Switch1-vlan2] subordinate separate 4
    [*Switch1-vlan2] quit
    [*Switch1] commit
    

    # 配置Switch1的上行口10GE1/0/1加入VLAN 2,并使能MUX VLAN功能,配置下行口10GE1/0/2和10GE1/0/3允许VLAN 2~VLAN 4通过。

    [~Switch1] interface 10ge 1/0/1
    [~Switch1-10GE1/0/1] port link-type trunk
    [*Switch1-10GE1/0/1] port trunk allow-pass vlan 2
    [*Switch1-10GE1/0/1] port mux-vlan enable vlan 2
    [*Switch1-10GE1/0/1] quit
    [*Switch1] interface 10ge 1/0/2
    [*Switch1-10GE1/0/2] port link-type trunk
    [*Switch1-10GE1/0/2] port trunk allow-pass vlan 2 to 4
    [*Switch1-10GE1/0/2] quit
    [*Switch1] interface 10ge 1/0/3
    [*Switch1-10GE1/0/3] port link-type trunk
    [*Switch1-10GE1/0/3] port trunk allow-pass vlan 2 to 4
    [*Switch1-10GE1/0/3] quit
    [*Switch1] commit

  2. 在Gateway与Switch1对接的10GE1/0/1上创建VLANIF 2,并配置IP地址为10.10.10.1/24,作为下挂Server的网关地址。

    <HUAWEI> system-view
    [~HUAWEI] sysname Gateway
    [*HUAWEI] commit
    [~Gateway] vlan batch 2
    [*Gateway] interface 10ge 1/0/1
    [*Gateway-10GE1/0/1] port link-type trunk
    [*Gateway-10GE1/0/1] port trunk allow-pass vlan 2
    [*Gateway-10GE1/0/1] quit
    [*Gateway] interface vlanif 2
    [*Gateway-Vlanif2] ip address 10.10.10.1 24
    [*Gateway-Vlanif2] quit
    [*Gateway] commit
    说明:

    如果MUX VLAN中有多个Group VLAN,并且Group VLAN之间需要互通,则需要在Gateway的VLANIF接口下执行命令arp proxy intra-vlan enable配置VLAN内ARP Proxy功能。

  3. 配置接入层设备Switch2和Switch3的上行口10GE1/0/1允许VLAN 2~VLAN 4通过,下行口10GE1/0/2~10GE1/0/3使能MUX VLAN功能,并加入与连接Server所属相同的VLAN。以Switch2为例,Switch3和Switch2类似,不再赘述。

    # 配置上行口10GE1/0/1为trunk类型,允许VLAN 2~VLAN 4通过。

    [~Switch2] interface 10ge 1/0/1
    [~Switch2-10GE1/0/1] port link-type trunk
    [*Switch2-10GE1/0/1] port trunk allow-pass vlan 2 to 4
    [*Switch2-10GE1/0/1] quit
    [*Switch2] commit
    # 使能下行口10GE1/0/2和10GE1/0/3的MUX VLAN功能,并加入与连接Server所属相同的VLAN。
    [~Switch2] interface 10ge 1/0/2
    [~Switch2-10GE1/0/2] port default vlan 3
    [*Switch2-10GE1/0/2] port mux-vlan enable vlan 3
    [*Switch2-10GE1/0/2] quit
    [*Switch2] commit
    [~Switch2] interface 10ge 1/0/3
    [~Switch2-10GE1/0/3] port default vlan 3
    [*Switch2-10GE1/0/3] port mux-vlan enable vlan 3
    [*Switch2-10GE1/0/3] quit
    [*Switch2] commit

  4. 配置Server的IP地址

    分别为各Server配置IP地址,并使它们和网关地址处于同一网段。

  5. 检查配置结果

    配置成功后,各Server用户可以访问Internet,ServerA和ServerB之间可以互相ping通,ServerC和ServerD之间不能互相ping通,ServerA和ServerB也不能和ServerC或ServerD之间互相ping通。

配置文件

  • Gateway的配置文件
    #
    sysname Gateway
    #
    vlan batch 2
    #
    interface Vlanif2
     ip address 10.10.10.1 255.255.255.0
    #
    interface 10GE1/0/1
     port link-type trunk
     port trunk allow-pass vlan 2 
    #
    return
  • Switch1的配置文件
    #
    sysname Switch1
    #
    vlan batch 2 to 4
    #
    vlan 2
     mux-vlan
     subordinate separate 4 
     subordinate group 3
    #
    interface 10GE1/0/1
     port link-type trunk
     port trunk allow-pass vlan 2
     port mux-vlan enable vlan 2
    #
    interface 10GE1/0/2
     port link-type trunk
     port trunk allow-pass vlan 2 to 4
    #
    interface 10GE1/0/3
     port link-type trunk
     port trunk allow-pass vlan 2 to 4
    #
    return
    
  • Switch2的配置文件
    #
    sysname Switch2
    #
    vlan batch 2 to 4
    #
    vlan 2
     mux-vlan
     subordinate separate 4
     subordinate group 3
    #
    interface 10GE1/0/1
     port link-type trunk
     port trunk allow-pass vlan 2 to 4
    #
    interface 10GE1/0/2
     port default vlan 3
     port mux-vlan enable vlan 3
    #
    interface 10GE1/0/3
     port default vlan 3
     port mux-vlan enable vlan 3
    #
    return
  • Switch3的配置文件
    #
    sysname Switch3
    #
    vlan batch 2 to 4
    #
    vlan 2
     mux-vlan
     subordinate separate 4
     subordinate group 3
    #
    interface 10GE1/0/1
     port link-type trunk
     port trunk allow-pass vlan 2 to 4
    #
    interface 10GE1/0/2
     port default vlan 4
     port mux-vlan enable vlan 4
    #
    interface 10GE1/0/3
     port default vlan 4
     port mux-vlan enable vlan 4
    #
    return
翻译
下载文档
更新时间:2019-05-05

文档编号:EDOC1100004255

浏览量:11385

下载量:276

平均得分:
本文档适用于这些产品
相关文档
相关版本
Share
上一页 下一页