所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

CloudEngine 12800, 12800E V200R003C00 配置指南-以太网交换

本文档针对设备的以太网业务,主要包括以太网交换概述、MAC配置、以太网链路聚合配置、M-LAG(跨设备链路聚合)配置、VLAN配置、QinQ配置、VLAN mapping配置、GVRP配置、STP/RSTP配置、MSTP配置、VBST配置、ERPS(G.8032)配置、Loopback Detection配置和二层协议透明传输配置。
评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
配置基于VLAN ID的灵活QinQ示例

配置基于VLAN ID的灵活QinQ示例

组网需求

图6-8所示,某数据中心中,租户拥有办公业务服务器和生产业务服务器,其中VLAN 10~VLAN 30承载生产业务,VLAN 31~VLAN 50承载办公业务,租户位于不同的地理位置A地和B地,并且通过核心/骨干网中的SwitchA、SwitchB相连。为了保证各业务之间的安全性和节省核心/骨干网VLAN ID,要求两地的流量通过核心/骨干网透明传输,相同业务之间可以互通,不同业务之间相互隔离。

图6-8 配置基于VLAN ID的灵活QinQ组网图

配置思路

可以通过配置基于VLAN ID的灵活QinQ来实现以上需求。利用核心/骨干网提供的VLAN100使生产业务服务器互通,利用核心/骨干网提供的VLAN 200使数据中心的办公业务服务器互通,不同业务服务器之间互相隔离。

采用如下的思路配置基于VLAN ID的灵活QinQ:

  1. 在SwitchA和SwitchB上均创建VLAN 100和VLAN 200,在SwitchA和SwitchB的接口上配置灵活QinQ功能,实现不同业务添加不同的外层VLAN Tag。

  2. 配置SwitchA和SwitchB上连接核心/骨干网的接口加入相应VLAN,实现允许VLAN 100和VLAN 200的报文通过。

操作步骤

  1. 创建VLAN

    # 在SwitchA上创建VLAN100和VLAN200

    <HUAWEI> system-view
    [~HUAWEI] sysname SwitchA
    [*HUAWEI] commit
    [~SwitchA] vlan batch 100 200
    [*SwitchA] commit
    

    # 在SwitchB上创建VLAN100和VLAN200

    <HUAWEI> system-view
    [~HUAWEI] sysname SwitchB
    [*HUAWEI] commit
    [~SwitchB] vlan batch 100 200
    [*SwitchB] commit
    

  2. 在接口上配置灵活QinQ

    # 配置SwitchA的接口10GE1/0/1。

    [~SwitchA] interface 10ge 1/0/1
    [~SwitchA-10GE1/0/1] port link-type hybrid
    [*SwitchA-10GE1/0/1] port hybrid untagged vlan 100 200
    [*SwitchA-10GE1/0/1] port vlan-stacking vlan 10 to 30 stack-vlan 100
    [*SwitchA-10GE1/0/1] port vlan-stacking vlan 31 to 50 stack-vlan 200
    [*SwitchA-10GE1/0/1] quit
    [*SwitchA] commit
    

    # 配置SwitchB的接口10GE1/0/1。

    [~SwitchB] interface 10ge 1/0/1
    [~SwitchB-10GE1/0/1] port link-type hybrid
    [*SwitchB-10GE1/0/1] port hybrid untagged vlan 100 200
    [*SwitchB-10GE1/0/1] port vlan-stacking vlan 10 to 30 stack-vlan 100
    [*SwitchB-10GE1/0/1] port vlan-stacking vlan 31 to 50 stack-vlan 200
    [*SwitchB-10GE1/0/1] quit
    [*SwitchB] commit
    

  3. 配置Switch连接核心/骨干网侧的接口

    # 在SwitchA上配置接口10GE1/0/2加入VLAN100和VLAN200。SwitchB的配置与SwitchA类似,不再赘述。

    [~SwitchA] interface 10ge 1/0/2
    [~SwitchA-10GE1/0/2] port link-type trunk
    [*SwitchA-10GE1/0/2] port trunk allow-pass vlan 100 200
    [*SwitchA-10GE1/0/2] commit
    [~SwitchA-10GE1/0/2] quit

  4. 验证配置结果

    从数据中心A地租户VLAN10~VLAN30的一台生产业务Server ping B地租户同一VLAN内的生产业务Server,可以ping通则表示租户内部生产业务服务器可以互相通信。

    从数据中心A地租户VLAN31~VLAN50的一台办公业务Server ping B地租户同一VLAN内的办公业务Server,可以ping通则表示租户内部办公业务服务器可以互相通信。

    从数据中心A地租户VLAN10~VLAN30的一台生产业务Server ping B地租户内VLAN31~VLAN50的办公业务Server,不能ping通,则表示不同业务之间是互相隔离的。

配置文件

  • SwitchA的配置文件

    #
    sysname SwitchA
    #
    vlan batch 100 200
    #
    interface 10GE1/0/1
     port link-type hybrid
     port hybrid untagged vlan 100 200
     port vlan-stacking vlan 10 to 30 stack-vlan 100
     port vlan-stacking vlan 31 to 50 stack-vlan 200
    #
    interface 10GE1/0/2
     port link-type trunk
     port trunk allow-pass vlan 100 200
    #
    return
  • SwitchB的配置文件

    #
    sysname SwitchB
    #
    vlan batch 100 200
    #
    interface 10GE1/0/1
     port link-type hybrid
     port hybrid untagged vlan 100 200
     port vlan-stacking vlan 10 to 30 stack-vlan 100
     port vlan-stacking vlan 31 to 50 stack-vlan 200
    #
    interface 10GE1/0/2
     port link-type trunk
     port trunk allow-pass vlan 100 200
    #
    return
翻译
下载文档
更新时间:2019-05-05

文档编号:EDOC1100004255

浏览量:12277

下载量:276

平均得分:
本文档适用于这些产品
相关文档
相关版本
Share
上一页 下一页