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CloudEngine 8800, 7800, 6800, 5800 V200R003C00 告警处理

本文档介绍了设备支持的告警,内容包含告警解释、告警属性、告警参数、告警原因、告警处理。

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OSPF_1.3.6.1.2.1.14.16.2.3 ospfVirtNbrStateChange

OSPF_1.3.6.1.2.1.14.16.2.3 ospfVirtNbrStateChange

Trap Buffer信息解释

The status of the virtual neighbor changes. (VirtNbrArea=[VirtNbrArea], VirtNbrRtrId=[VirtNbrRtrId], ProcessId=[ProcessId], RouterId=[RouterId], VirtNbrState=[VirtNbrState], InstanceName=[InstanceName])

路由器虚连接邻居的状态发生变化。

Trap属性

Trap属性

描述

Alarm or Event

Alarm

Trap Severity

Error

Mnemonic Code

ospfVirtNbrStateChange

Trap OID

1.3.6.1.2.1.14.16.2.3

Alarm ID

0x08902009

Alarm Type

communicationsAlarm

Raise or Clear

None

Match trap

故障告警Trap和业务恢复Trap使用同一个Trap,通过NbrState参数区分。只有当邻居状态为8: Full时,此Trap为业务恢复Trap,当邻居为其他状态时,此Trap为故障告警Trap。

Trap Buffer信息参数

参数名称 参数含义

VirtNbrArea

Transit区域ID。

VirtNbrRtrId

虚连接邻居的Router ID。

ProcessId

OSPF进程号。

RouterId

本设备的Router ID。

VirtNbrState

虚连接邻居状态。

  • 1: Down
  • 2: Attempt
  • 3: Init
  • 4: 2-Way
  • 5: ExStart
  • 6: Exchange
  • 7: Loading
  • 8: Full

InstanceName

VPN实例名称。

VB信息参数

VB OID

VB Name

VB Index

1.3.6.1.2.1.14.1.1

ospfRouterId

N/A

1.3.6.1.2.1.14.11.1.1

ospfVirtNbrArea

ospfVirtNbrArea;

ospfVirtNbrRtrId;

1.3.6.1.2.1.14.11.1.2

ospfVirtNbrRtrId

ospfVirtNbrArea;

ospfVirtNbrRtrId;

1.3.6.1.2.1.14.11.1.5

ospfVirtNbrState

ospfVirtNbrArea;

ospfVirtNbrRtrId;

对系统的影响

虚连接邻居状态变化时都会发送该Trap,表明邻居状态发生改变。

  • 如果邻居状态由较低状态变为较高状态,则属于正常运行,无需关注。
  • 如果邻居状态由较高状态变为较低状态,则可能导致业务中断。

可能原因

原因1:The adjacency HoldTimer expired.(邻居定时器超时。)

原因2:The physical interface changed.(物理接口变化。)

原因3:The protocol did not work correctly.(协议原因。)

原因4:The BFD session was interrupted.(BFD会话断开。)

原因5:OSPF configurations changed.(OSPF配置变化。)

原因6:The peer router did not work properly.(邻居路由器原因。)

原因100:The alarm was cleared.(告警被清除。)

处理步骤

  • 原因1:The adjacency HoldTimer expired.
    1. 执行ping命令查看到对端设备的链路状态是否良好。

      • 如果不能ping通,请检查传输设备、链路情况、接口情况,通过调整硬件设备恢复业务。
      • 如果能够ping通,则请执行2

    2. 请收集告警信息、日志信息和配置信息,并联系技术支持人员。
  • 原因2:The physical interface changed.
    1. 执行display ip interface命令查看建立OSPF邻居的接口物理状态是否良好。

      • 如果接口的物理状态为“down”,请检查接口的光功率、传输设备是否正常,通过恢复物理接口状态来消除告警。
      • 如果接口的物理状态为“*down”,则该接口被人为执行shutdown操作了,请在接口下执行undo shutdown命令来消除告警。
      • 如果接口的物理状态为Up,则请执行2

    2. 执行display ospf interface命令查看建立OSPF邻居的接口协议状态。

      • 如果当前协议状态为Down,请检查是否配置了IP地址、IP地址配置得是否正确,通过对IP地址的检查来消除告警。
      • 如果当前协议状态为Up,则请执行3

    3. 请收集告警信息、日志信息和配置信息,并联系技术支持人员。
  • 原因3:The protocol did not work correctly.
    1. 分别在本地设备和对端设备的接口视图和OSPF视图下,执行display this命令检查链路两端的设备是否使能了相同的协议。

      • 如果相同,则请执行2
      • 如果不同,请在需要建立邻居的链路两端接口上配置相同的协议。

    2. 执行display ospf peer命令查看OSPF邻居信息。

      • 如果没有任何邻居信息,表示本设备无法接收到对端的Hello报文,或者接收到的Hello报文被丢弃,则请执行3
      • 如果显示的邻居信息为Init,表示本设备可以收到对端的Hello报文,而对端却无法收到本设备的Hello报文。执行ping命令查看到对端设备的链路状态是否良好。出现该问题一般是由于转发层面出了问题,导致报文被丢弃。如果不能通过解决转发故障来消除告警,则请执行4
      • 如果显示的邻居信息为2-way,表示设备运行OSPF接口上配置ospf dr-priority 0,请执行ospf dr-priority命令,调整接口的DR优先级大于0来消除告警。
      • 如果显示的邻居信息为Exstart,表示告警设备由于一直在进行DD协商,而无法完成DD同步,则请执行3
      • 如果显示的邻居信息为Loading,表示本设备认为收到的LSA为非法LSA,将其丢弃后不断的请求LSA。可以通过在需要建立OSPF邻居的链路两端执行reset ospf process命令来恢复告警。
        说明:

        复位OSPF连接(执行reset ospf process命令)会导致设备之间的OSPF邻接关系中断。务必仔细确认是否必须执行复位OSPF连接的操作。

    3. 在接口视图和OSPF进程下分别执行display this命令,检查链路两端配置的认证是否相同。

      • 如果相同,则请执行4
      • 如果不同,请将链路两端配置的认证方式改为一致。

    4. 请收集告警信息、日志信息和配置信息,并联系技术支持人员。
  • 原因4:The BFD session was interrupted.
    1. 执行ping命令查看到对端设备的链路状态是否良好。

      • 如果不能ping通对端设备,请检查传输设备、链路情况、接口情况,通过调整硬件设备恢复业务。
      • 如果能ping通对端设备,则请执行3

    2. 执行display ospf peer命令检查邻居关系是否为Up。

      • 如果邻居关系为Down,则请执行3
      • 如果邻居关系为Up,则请执行步骤1。

    3. 请收集告警信息、日志信息和配置信息,并联系技术支持人员。
  • 原因5:OSPF configurations changed.
    1. 在OSPF进程视图下执行display this命令,检查邻居两端的区域配置是否一致。

      • 如果不一致,将其修改一致。
      • 如果一致,则请执行2

    2. 在OSPF进程视图下执行display this命令,检查两端OSPF进程中是否都使能opaque-capability。

      • 如果不一致,将其修改一致。
      • 如果一致,则请执行3

    3. 执行display ospf interface命令,检查链路两端接口的“Type”是否一致。

      • 如果不一致,将其修改一致。
      • 如果一致,则请执行4

    4. 请收集告警信息、日志信息和配置信息,并联系技术支持人员。
  • 原因6:The peer router did not work properly.
    1. 对端设备是否属于其他厂商。

      • 如果属于其他厂商,则请执行2
      • 如果不属于其他厂商,则请执行3

    2. 请联系其他厂商对对端设备运行状况进行排查。
    3. 检查对端设备或者OSPF进程是否重启。

      • 如果对端设备或者OSPF进程已重启,请结合对端设备的告警、日志信息进行原因确认。
      • 如果对端设备或者OSPF进程没有重启,则请执行4

    4. 请收集告警信息、日志信息和配置信息,并联系技术支持人员。
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更新时间:2019-05-05

文档编号:EDOC1100004339

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