所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

CloudEngine 8800, 7800, 6800, 5800 V200R003C00 配置指南-设备管理

本文档介绍了设备管理的配置,具体包括查看设备状态、硬件管理、信息中心配置、NTP配置、以太时钟同步配置、故障管理配置、节能管理、性能管理、维护助手配置和OPS配置。
评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
配置带验证的单播NTP客户端/服务器模式示例

配置带验证的单播NTP客户端/服务器模式示例

组网需求

图4-11所示的组网中,SwitchB、SwitchC和SwitchD在同一个局域网中并且通过网络和SwitchA相连。SwitchA的时间已经同步到权威时钟(卫星定位系统)。

用户要求由SwitchB、SwitchC和SwitchD组成的局域网中三台设备时间同步到SwitchA以保证计费业务的准确性。

图4-11 单播NTP客户端/服务器模式组网图

配置思路

配置带验证的单播客户端/服务器模式来满足客户的对局域网时间同步的需求。配置思路如下:

  1. 选择SwitchA作为主时间服务器。

  2. SwitchA和SwitchB之间采用单播NTP客户端/服务器模式实现时钟同步。SwitchA作为服务器,SwitchB作为客户端。

  3. SwitchB分别和SwitchC、SwitchD之间采用单播NTP客户端/服务器模式实现时钟同步。其中SwitchB作为服务器,SwitchC和SwitchD均为客户端。

  4. 考虑到SwitchA和SwitchB是通过网络相连,安全性较低,因此使能NTP认证功能。

说明:

在单播服务器/客户端模式下配置NTP认证时,必须首先在客户端使能NTP认证,然后再指定NTP服务器地址,并同时指定发给服务器的验证密钥。否则将不进行验证,直接同步。

操作步骤

  1. 根据图4-11,配置IP地址,配置SwitchA,SwitchB,SwitchC和SwitchD路由可达

    # 在SwitchA上配置IP地址,SwitchB、SwitchC和SwitchD的配置请参考配置文件。

    <HUAWEI> system-view
    [~HUAWEI] sysname SwitchA
    [*HUAWEI] commit
    [~SwitchA] vlan 100
    [*SwitchA-vlan100] quit
    [*SwitchA] interface vlanif 100
    [*SwitchA-Vlanif100] ip address 10.1.1.1 24
    [*SwitchA-Vlanif100] quit
    [*SwitchA] interface 10ge 1/0/1
    [*SwitchA-10GE1/0/1] port link-type trunk
    [*SwitchA-10GE1/0/1] port trunk pvid vlan 100
    [*SwitchA-10GE1/0/1] port trunk allow-pass vlan 100
    [*SwitchA-10GE1/0/1] quit
    [*SwitchA] ospf 1
    [*SwitchA-ospf-1] area 0
    [*SwitchA-ospf-1-area-0.0.0.0] network 10.1.1.0 0.0.0.255
    [*SwitchA-ospf-1-area-0.0.0.0] quit
    [*SwitchA-ospf-1] quit
    

  2. SwitchA上配置NTP主时钟并启动NTP认证功能,使能SwitchA的NTP服务器功能

    # 在SwitchA上指定使用自己的本地时钟作为主时钟,层数为2。

    [*SwitchA] ntp refclock-master 2

    # 使能NTP认证功能、配置验证密钥并声明该密钥可信。

    [*SwitchA] ntp authentication enable
    [*SwitchA] ntp authentication-keyid 42 authentication-mode hmac-sha256 Hello@123456
    [*SwitchA] ntp trusted authentication-keyid 42
    [*SwitchA] commit

    # 使能NTP服务器功能。

    [*SwitchA] undo ntp server disable
    [*SwitchA] commit

  3. SwitchB上启动NTP认证功能,使能SwitchB的NTP服务器功能

    # 在SwitchB上使能NTP认证功能、配置验证密钥并声明该密钥可信。

    <SwitchB> system-view
    [~SwitchB] ntp authentication enable
    [*SwitchB] ntp authentication-keyid 42 authentication-mode hmac-sha256 Hello@123456
    [*SwitchB] ntp trusted authentication-keyid 42
    

    # 指定SwitchA作为SwitchB的NTP服务器,并使用已配置的验证密钥。

    [*SwitchB] ntp unicast-server 10.1.1.1 authentication-keyid 42
    [*SwitchB] commit

    # 使能NTP服务器功能

    [*SwitchB] undo ntp server disable
    [*SwitchB] commit

  4. SwitchC上指定SwitchB作为SwitchC的NTP服务器

    <SwitchC> system-view
    [~SwitchC] ntp authentication enable
    [*SwitchC] ntp authentication-keyid 42 authentication-mode hmac-sha256 Hello@123456
    [*SwitchC] ntp trusted authentication-keyid 42
    [*SwitchC] ntp unicast-server 10.1.3.1 authentication-keyid 42
    [*SwitchC] commit

  5. SwitchD上指定SwitchB作为SwitchD的NTP服务器

    <SwitchD> system-view
    [~SwitchD] ntp authentication enable
    [*SwitchD] ntp authentication-keyid 42 authentication-mode hmac-sha256 Hello@123456
    [*SwitchD] ntp trusted authentication-keyid 42
    [*SwitchD] ntp unicast-server 10.1.3.1 authentication-keyid 42
    [*SwitchD] commit

  6. 验证配置结果

    # 查看SwitchA的NTP状态。

    [~SwitchA] display ntp status
     clock status: synchronized
     clock stratum: 2
     reference clock ID: LOCAL(0)                                                   
     nominal frequency: 100.0000 Hz                                                 
     actual frequency: 100.0000 Hz                                                  
     clock precision: 2^18                                                          
     clock offset: 0.0000 ms                                                        
     root delay: 0.00 ms                                                            
     root dispersion: 11.18 ms                                                      
     peer dispersion: 10.00 ms                                                      
     reference time: 14:40:00.707 UTC Sep 11 2013(D5DAFF40.B538476F)                
     synchronization state: clock synchronized     

    SwitchB同步SwitchA的时钟。

    # 查看SwitchB的NTP状态,可以看到时钟状态为“synchronized”,即,已经完成同步。时钟的层数为3,比服务器SwitchA低1级。

    [~SwitchB] display ntp status
     clock status: synchronized
     clock stratum: 3
     reference clock ID: 10.1.1.1
     nominal frequency: 100.0000 Hz                                                 
     actual frequency: 100.0000 Hz                                                  
     clock precision: 2^18                                                          
     clock offset: 0.0601 ms                                                        
     root delay: 2.24 ms                                                            
     root dispersion: 21.11 ms                                                      
     peer dispersion: 10.93 ms                                                      
     reference time: 14:41:01.127 UTC Sep 11 2013(D5DAFE15.20B955F7)                
     synchronization state: clock synchronized  

    SwitchC可以同步SwitchB的时钟。

    # 查看SwitchC的NTP状态,可以看到时钟状态为“synchronized”,即,已经完成同步。时钟的层数为4,比服务器SwitchB低1级。

    [~SwitchC] display ntp status
     clock status: synchronized
     clock stratum: 4
     reference clock ID: 10.1.3.1
     nominal frequency: 100.0000 Hz                                                 
     actual frequency: 100.0000 Hz                                                  
     clock precision: 2^18                                                          
     clock offset: 0.0601 ms                                                        
     root delay: 2.24 ms                                                            
     root dispersion: 21.11 ms                                                      
     peer dispersion: 10.93 ms                                                      
     reference time: 14:41:40.127 UTC Sep 11 2013(D5DAFE15.20B955F7)                
     synchronization state: clock synchronized  

    # 查看SwitchD的NTP状态,可以看到时钟状态为“synchronized”,即,已经完成同步。时钟的层数为4,比服务器SwitchB低1级。

    [~SwitchD] display ntp status
     clock status: synchronized
     clock stratum: 4
     reference clock ID: 10.1.3.1
     nominal frequency: 100.0000 Hz                                                 
     actual frequency: 100.0000 Hz                                                  
     clock precision: 2^18
     clock offset: 3.8128 ms
     root delay: 31.26 ms
     root dispersion: 74.20 ms
     peer dispersion: 34.30 ms
     reference time: 14:41:24.761 UTC Sep 11 2013(D5DB00C0.C2DB7281)  
     synchronization state: clock synchronized    

配置文件

  • SwitchA的配置文件

    #
    sysname SwitchA
    #
    ntp ipv6 server disable
    ntp authentication-keyid 42 authentication-mode hmac-sha256 cipher %^%#fhKx(LFg)~2:d23J_(t~RNcW9g#Bv7}a[7(%$HG-%^%# 
    ntp trusted authentication-keyid 42  
    ntp refclock-master 2
    ntp authentication enable
    #
    vlan batch 100
    #
    interface Vlanif100
     ip address 10.1.1.1 255.255.255.0
    #
    interface 10GE1/0/1
     port link-type trunk
     port trunk pvid vlan 100
     port trunk allow-pass vlan 100
    #
    ospf 1
     area 0.0.0.0
      network 10.1.1.0 0.0.0.255
    #
    return
  • SwitchB的配置文件

    #
    sysname SwitchB
    #
    ntp ipv6 server disable
    ntp authentication-keyid 42 authentication-mode hmac-sha256 cipher %^%#fhKx(LFg)~2:d23J_(t~RNcW9g#Bv7}a[7(%$HG-%^%# 
    ntp trusted authentication-keyid 42
    ntp unicast-server 10.1.1.1 authentication-keyid 42
    ntp authentication enable
    #
    vlan batch 110 to 111
    #
    interface Vlanif110
     ip address 10.1.2.1 255.255.255.0
    #
    interface Vlanif111
     ip address 10.1.3.1 255.255.255.0
    #
    interface 10GE1/0/1
     port link-type trunk
     port trunk pvid vlan 110
     port trunk allow-pass vlan 110
    #
    interface 10GE1/0/2
     port link-type trunk
     port trunk pvid vlan 111
     port trunk allow-pass vlan 111
    #
    ospf 1
     area 0.0.0.0
      network 10.1.2.0 0.0.0.255
      network 10.1.3.0 0.0.0.255
    #
    return
  • SwitchC的配置文件

    #
    sysname SwitchC
    #
    ntp server disable
    ntp ipv6 server disable
    ntp authentication-keyid 42 authentication-mode hmac-sha256 cipher %^%#fhKx(LFg)~2:d23J_(t~RNcW9g#Bv7}a[7(%$HG-%^%# 
    ntp trusted authentication-keyid 42
    ntp unicast-server 10.1.3.1 authentication-keyid 42
    ntp authentication enable
    #
    vlan batch 111
    #
    interface Vlanif111
     ip address 10.1.3.2 255.255.255.0
    #
    interface 10GE1/0/1
     port link-type trunk
     port trunk pvid vlan 111
     port trunk allow-pass vlan 111
    #
    return
  • SwitchD的配置文件

    #
    sysname SwitchD
    #
    ntp server disable
    ntp ipv6 server disable
    ntp authentication-keyid 42 authentication-mode hmac-sha256 cipher %^%#fhKx(LFg)~2:d23J_(t~RNcW9g#Bv7}a[7(%$HG-%^%# 
    ntp trusted authentication-keyid 42
    ntp unicast-server 10.1.3.1 authentication-keyid 42
    ntp authentication enable
    #
    vlan batch 111
    #
    interface Vlanif111
     ip address 10.1.3.3 255.255.255.0
    #
    interface 10GE1/0/1
     port link-type trunk
     port trunk pvid vlan 111
     port trunk allow-pass vlan 111
    #
    return
翻译
下载文档
更新时间:2019-05-05

文档编号:EDOC1100004379

浏览量:9477

下载量:336

平均得分:
本文档适用于这些产品
相关文档
相关版本
Share
上一页 下一页