所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级
CloudEngine 8800, 7800, 6800, 5800 V200R003C00 配置指南-网络管理与监控

本文档介绍了网络管理与监控的配置,具体包括SNMP配置、RMON配置、NETCONF配置、OpenFlow Agent配置、LLDP配置、NQA配置、镜像配置、报文捕获配置、路径/连通性探测配置、NetStream配置、sFlow配置和iPCA配置。

评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
配置LLDP功能示例-存在链路聚合的组网

配置LLDP功能示例-存在链路聚合的组网

组网需求

图5-9所示,SwitchA与SwitchB之间通过Eth-Trunk相连。网络管理系统NMS与Switch之间路由可达且SNMP配置已经完成。

网络管理员希望在NMS上可以获取到SwitchA与SwitchB的二层配置信息,用于了解设备的详细拓扑信息和判断网络中是否有配置冲突的情况。

图5-9 存在链路聚合的组网

配置思路

网络管理员希望从NMS上获取Switch的二层信息,可以通过配置LLDP功能来实现。配置思路如下:
  1. 将SwitchA和SwitchB以太网物理接口加入到Eth-Trunk中。
  2. 使能SwitchA和SwitchB的全局LLDP功能。
  3. 配置SwitchA和SwitchB的管理IP地址方便网管系统进行管理。

操作步骤

  1. 配置SwitchA和SwitchB的Eth-Trunk

    # 配置SwitchA。

    <HUAWEI> system-view
    [~HUAWEI] sysname SwitchA
    [*HUAWEI] commit
    [~SwitchA] vlan batch 100
    [*SwitchA] interface eth-trunk 1
    [*SwitchA-Eth-Trunk1] trunkport 10ge 1/0/1 to 1/0/3
    [*SwitchA-Eth-Trunk1] port link-type trunk
    [*SwitchA-Eth-Trunk1] port trunk allow-pass vlan 100
    [*SwitchA-Eth-Trunk1] commit
    [~SwitchA-Eth-Trunk1] quit

    # 配置SwitchB。

    <HUAWEI> system-view
    [~HUAWEI] sysname SwitchB
    [*HUAWEI] commit
    [~SwitchB] vlan batch 100
    [*SwitchB] interface eth-trunk 1
    [*SwitchB-Eth-Trunk1] trunkport 10ge 1/0/1 to 1/0/3
    [*SwitchB-Eth-Trunk1] port link-type trunk
    [*SwitchB-Eth-Trunk1] port trunk allow-pass vlan 100
    [*SwitchB-Eth-Trunk1] commit
    [~SwitchB-Eth-Trunk1] quit

  2. 使能SwitchA和SwitchB的全局LLDP功能

    # 配置SwitchA。
    [~SwitchA] lldp enable
    [*SwitchA] commit
    # 配置SwitchB。
    [~SwitchB] lldp enable
    [*SwitchB] commit

  3. 配置SwitchA和SwitchB的管理IP地址

    说明:

    以下所配置的IP地址为设备上已经存在的IP地址。具体配置请见配置文件。

    # 配置SwitchA。
    [~SwitchA] lldp management-address 10.10.10.1
    [*SwitchA] commit
    # 配置SwitchB。
    [~SwitchB] lldp management-address 10.10.10.2
    [*SwitchB] commit

  4. 验证配置结果

    • 查看SwitchA的配置。

      # 查看各设备的成员接口是否已经加入到Eth-Trunk1。

      [~SwitchA] display eth-trunk 1
      Eth-Trunk1's state information is:
      WorkingMode: NORMAL         Hash arithmetic: According to SIP-XOR-DIP
      Least Active-linknumber: 1  Max Bandwidth-affected-linknumber: 16
      Operate status: up          Number Of Up Ports In Trunk: 3
      --------------------------------------------------------------------------------
      PortName                Status      Weight
      10GE1/0/1               Up          1
      10GE1/0/2               Up          1
      10GE1/0/3               Up          1                                           

      # 查看SwitchA的邻居信息。

      [~SwitchA] display lldp neighbor brief
      Local Interface         Exptime(s) Neighbor Interface      Neighbor Device      
      ------------------------------------------------------------------------------- 
      10GE1/0/1                      115 10GE1/0/1               SwitchB
      10GE1/0/2                      115 10GE1/0/2               SwitchB
      10GE1/0/3                      115 10GE1/0/3               SwitchB
      
    • 查看SwitchB的配置。

      请参见SwitchA的查看过程。

配置文件

  • SwitchA的配置文件

    #
    sysname SwitchA
    #
     vlan batch 100
    #
    interface Vlanif100
     ip address 10.10.10.1 255.255.255.0
    #
    interface Eth-Trunk1
     port link-type trunk
     port trunk allow-pass vlan 100
    #
    interface 10GE1/0/1
     eth-trunk 1
    #
    interface 10GE1/0/2
     eth-trunk 1
    #
    interface 10GE1/0/3
     eth-trunk 1
    #
    lldp enable
    #
    lldp management-address 10.10.10.1
    #
    return
  • SwitchB的配置文件

    #
    sysname SwitchB
    #
     vlan batch 100
    #
    interface Vlanif100
     ip address 10.10.10.2 255.255.255.0
    #
    interface Eth-Trunk1
     port link-type trunk
     port trunk allow-pass vlan 100
    #
    interface 10GE1/0/1
     eth-trunk 1
    #
    interface 10GE1/0/2
     eth-trunk 1
    #
    interface 10GE1/0/3
     eth-trunk 1
    #
    lldp enable
    #
    lldp management-address 10.10.10.2
    #
    return
翻译
下载文档
更新时间:2019-05-05

文档编号:EDOC1100004380

浏览量:19625

下载量:322

平均得分:
本文档适用于这些产品

相关版本

相关文档

Share
上一页 下一页