所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级
CloudEngine 8800, 7800, 6800, 5800 V200R003C00 配置指南-网络管理与监控

本文档介绍了网络管理与监控的配置,具体包括SNMP配置、RMON配置、NETCONF配置、OpenFlow Agent配置、LLDP配置、NQA配置、镜像配置、报文捕获配置、路径/连通性探测配置、NetStream配置、sFlow配置和iPCA配置。

评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
配置普通LSP隧道LSP Trace测试示例

配置普通LSP隧道LSP Trace测试示例

组网需求

图6-16所示。

  • SwitchA、SwitchB、SwitchC都运行OSPF协议,并学习到彼此Loopback接口的32位主机路由。

  • SwitchA、SwitchB、SwitchC上都启用MPLS和MPLS LDP。

  • SwitchA、SwitchB、SwitchC之间的VLANIF接口都启用MPLS和MPLS LDP,正确触发LDP LSP的建立。

使用NQA LSP Trace功能测试LSP的路径。

图6-16 LSP Trace测试组网图

配置思路

采用如下思路进行LSP Trace测试的配置:

  1. SwitchA作为NQA客户端。

  2. SwitchC作为NQA服务器端。

  3. 在SwitchA上配置LSP Trace测试例。

操作步骤

  1. 配置SwitchA、SwitchB和SwitchC之间的路由和LDP会话

    具体配置请参见SwitchA、SwitchB和SwitchC的配置文件。

  2. 配置LSP Trace测试例

    # 使能NQA客户端,配置普通隧道的LSP Trace测试例。

    <HUAWEI> system-view
    [~HUAWEI] sysname SwitchA
    [*HUAWEI] commit
    [~SwitchA] nqa test-instance admin lsptrace
    [*SwitchA-nqa-admin-lsptrace] test-type lsptrace
    [*SwitchA-nqa-admin-lsptrace] lsp-type ipv4
    [*SwitchA-nqa-admin-lsptrace] destination-address ipv4 10.3.3.9 lsp-masklen 32
    [*SwitchA-nqa-admin-lsptrace] commit

  3. 启动测试操作

    [~SwitchA-nqa-admin-lsptrace] start now
    [*SwitchA-nqa-admin-lsptrace] commit

  4. 验证测试结果

    [~SwitchA-nqa-admin-lsptrace] display nqa results test-instance admin lsptrace
                                                                                    
    NQA entry(admin, lsptrace): test flag is inactive, test type is LSPTRACE        
      1 . Test 1 result   The test is finished                                      
       Completion:success                     Attempts number:1                     
       Disconnect operation number:0          Operation timeout number:0            
       System busy operation number:0         Connection fail number:0              
       Operation sequence errors number:0     RTT stats errors number:0             
       Drop operation number:0                                                      
       Last good path Time: 2013-12-09 08:58:14.9                                   
       1 . Hop 1                                                                    
        Send operation times: 3              Receive response times: 3              
        Min/Max/Average completion time: 2/7/4                                      
        Sum/Square-Sum  completion time: 12/62                                      
        RTD over thresholds number:0                                                
        Last response packet receive time: 2013-12-09 08:58:14.9                    
        Destination IP address:10.1.1.2                                             
        Lost packet ratio: 0 %                                                      
       2 . Hop 2                                                                    
        Send operation times: 3              Receive response times: 3              
        Min/Max/Average completion time: 2/3/2                                      
        Sum/Square-Sum  completion time: 7/17                                       
        RTD over thresholds number:0                                                
        Last response packet receive time: 2013-12-09 08:58:14.9                    
        Destination IP address:10.3.3.9                                              
        Lost packet ratio: 0 %                                                  

配置文件

  • SwitchA的配置文件

    #
    sysname SwitchA
    #
    vlan batch 100
    #
    mpls lsr-id 10.3.1.9
    #
    mpls
    #
    mpls ldp
     #
     ipv4-family
    #
    interface Vlanif100
     ip address 10.1.1.1 255.255.255.0
     mpls
     mpls ldp
    #
    interface 10GE1/0/1
     port link-type trunk
     port trunk pvid vlan 100
     port trunk allow-pass vlan 100
    #
    interface LoopBack1
     ip address 10.3.1.9 255.255.255.255
    #
    ospf 1
     area 0.0.0.0
      network 10.3.1.9 0.0.0.0
      network 10.1.1.0 0.0.0.255
    #
    nqa test-instance admin lsptrace
     test-type lsptrace
     destination-address ipv4 10.3.3.9 lsp-masklen 32
    #
    return
  • SwitchB的配置文件

    #
    sysname SwitchB
    # 
    vlan batch 100 110
    #
    mpls lsr-id 10.3.2.9
    #
    mpls
    #
    mpls ldp
     #
     ipv4-family
    #
    interface Vlanif100
     ip address 10.1.1.2 255.255.255.0
     mpls
     mpls ldp
    #
    interface Vlanif110
     ip address 10.2.1.1 255.255.255.0
     mpls
     mpls ldp
    #
    interface 10GE1/0/1
     port link-type trunk
     port trunk pvid vlan 100
     port trunk allow-pass vlan 100
    #
    interface 10GE1/0/2
     port link-type trunk
     port trunk pvid vlan 110
     port trunk allow-pass vlan 110
    #
    interface LoopBack1
     ip address 10.3.2.9 255.255.255.255
    #
    ospf 1
     area 0.0.0.0
      network 10.3.2.9 0.0.0.0
      network 10.1.1.0 0.0.0.255
      network 10.2.1.0 0.0.0.255
    #
    return
  • SwitchC的配置文件

    #
    sysname SwitchC
    #
    vlan batch 110
    #
    mpls lsr-id 10.3.3.9
    #
    mpls
    #
    mpls ldp
     #
     ipv4-family
    #
    interface Vlanif110
     ip address 10.2.1.2 255.255.255.0
     mpls
     mpls ldp
    #
    interface 10GE1/0/2
     port link-type trunk
     port trunk pvid vlan 110
     port trunk allow-pass vlan 110
    #
    interface LoopBack1
     ip address 10.3.3.9 255.255.255.255
    #
    ospf 1
     area 0.0.0.0
      network 10.3.3.9 0.0.0.0
      network 10.2.1.0 0.0.0.255
    #
    return
翻译
下载文档
更新时间:2019-05-05

文档编号:EDOC1100004380

浏览量:19535

下载量:322

平均得分:
本文档适用于这些产品

相关版本

相关文档

Share
上一页 下一页