所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

eSight V300R009C00 维护指南 11

评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
ALM-316010196 OMMHA双机心跳中断

ALM-316010196 OMMHA双机心跳中断

告警解释

eSight每隔5分时查询OMMHA心跳状态,当eSight检测到OMMHA心跳中断,产生此告警。当eSight检测到OMMHA心跳状态恢复正常后,系统会自动清除此告警,无需手工清除。

告警属性

告警ID

告警级别

告警类型

316010196

重要

环境告警

对系统的影响

主用服务器发生故障,不能使用。主用服务器发生故障,不能使用。

可能原因

心跳IP中断。常见原因有:

  • 连接主用服务器或备用服务器的网络配置发生变更,或者FS平台虚拟网络异常,造成的链路中断。
  • OMMHA主备用服务器处于异常状态。

处理步骤

  1. 检查双机IP地址通信是否正常。

    # ping -I 10.137.66.167 10.137.66.168

    # ping -I 192.168.66.167 192.168.66.168

    10.137.66.167:本端系统IP地址;

    10.137.66.168:对端系统IP地址;

    192.168.66.167:本端心跳IP地址;

    192.168.66.168:对端心跳IP地址;
    • 如果返回如下信息,且告警信息清除。处理完毕。
      64 bytes from 10.137.66.167: icmp_seq=1 ttl=64 time=0.034 ms
    • 否 转到2

  2. 查看eSight主备用服务器是否正常运行。

    1. 使用PuTTY,以root用户登录任一服务器。如果显示以下信息,则服务器处于正常状态。
      eSightServer1:~#

      eSightServer1为服务器主机名,请以实际为准。

    2. 使用PuTTY,以root用户登录另一台服务器。如果显示以下信息,则服务器处于正常状态。
      eSightServer2:~#

      eSightServer1为服务器主机名,请以实际为准。

    如果两台服务器都处于正常状态,执行4,否则执行3

  3. 等待服务器启动完成或手动重新启动服务器。

    1. 停止eSight备用服务器。
      1. ossuser用户登录eSight备用服务器。
      2. 执行以下命令停止eSight系统。

        > cd /opt/ommha/ha/bin

        > ./stop.sh

        如果显示以下信息,说明备用服务器停止成功。

        stop HA successfully.
    2. 停止eSight主用服务器。
      1. ossuser用户登录eSight主用服务器。
      2. 执行以下命令停止eSight系统。

        > cd /opt/ommha/ha/bin

        > ./stop.sh

        如果显示以下信息,说明主用服务器停止成功。

        stop HA successfully.
    3. 启动eSight主用服务器。
      1. ossuser用户登录eSight主用服务器。
      2. 执行以下命令启动eSight系统。

        > cd /opt/ommha/ha/bin

        > ./start.sh

        如果显示以下信息,说明操作成功。

        start HA successfully.
    4. 启动eSight备用服务器。
      1. ossuser用户登录eSight备用服务器。
      2. 执行以下命令启动eSight系统。

        > cd /opt/ommha/ha/bin

        > ./start.sh

        如果显示以下信息,说明操作成功。

        start HA successfully.

    如果eSight启动成功,执行4。否则执行5

  4. 查看OMMHA双机状态。

    1. 以ossuser登录任意一台eSight服务器。
    2. 执行以下命令,切换到状态查询脚本所在目录。

      > cd /opt/ommha/ha/bin

    3. 查询双机状态。

      > sh status.sh

      如果节点的“HAActive ”“active”,说明此节点为主用服务器;如果节点的节点“HAActive ”“standby”,说明此节点为备用服务器。
         
       NodeName    HostName        HAVersion    StartTime                   HAActive        HAAllResOK   HARunPhase  
       ha1        eSightServer174  V100R001C01  2017-07-05 14:14:50         active            normal       Actived  
       ha2        eSightServer165  V100R001C01  2017-07-07 10:43:20         standby           normal     Deactived   
        
       NodeName    ResName         ResStatus         ResHAStatus               ResType  
       ha1          MySQL          Active normal      Normal                Active_standby  
       ha1        NMSServer          Normal           Normal                Single_active  
       ha1        RMFloatIp          Normal           Normal                Single_active  
       ha1       RMSouthFloatIp      Normal           Normal                Single_active  
       ha2         MySQL           Standby normal     Normal                Active_standby  
       ha2       NMSServer           Stopped          Unknown               Single_active  
       ha2        RMFloatIp          Stopped          Normal                Single_active  
       ha2      RMSouthFloatIp       Stopped          Normal                Single_active  
      表9-265 eSight高可用性系统正常资源状态

      资源项

      说明

      节点

      正常状态值

      MySQL

      数据库资源状态标识。

      主用服务器

      “Active_normal”

      备用服务器

      “Standby_normal”

      NMSServer

      eSight服务资源状态标识。

      主用服务器

      “Normal”

      备用服务器

      “Stopped ”

      RMFloatIp

      系统浮动IP地址状态标识。

      主用服务器

      “Normal”

      备用服务器

      “Stopped ”

      RMSouthFloatIp

      南向浮动IP地址状态标识。

      说明:

      只有在南北向隔离场景下,系统才会显示此状态。

      主用服务器

      “Normal”

      备用服务器

      “Stopped”

      如果状态正常,处理完毕。否则,请执行5

  5. 请联系华为技术支持工程师。

告警清除

此告警修复后,系统会自动清除此告警,无需手工清除。

翻译
下载文档
更新时间:2019-11-22

文档编号:EDOC1100011879

浏览量:32035

下载量:264

平均得分:
本文档适用于这些产品

相关版本

相关文档

Share
上一页 下一页