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eSight V300R009C00 维护指南 11

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ALM-505001003 磁盘占用率过高告警

ALM-505001003 磁盘占用率过高告警

告警解释

当维护工具检测(检测周期为1分钟)到磁盘或者某一分区的占用率大于或等于产生门限80%时,产生该告警。当磁盘或者某一分区的占用率小于或等于清除门限75%时,该告警会自动清除。

告警属性

告警ID

告警级别

告警类型

505001003

重要

业务质量告警

告警参数

参数名称

参数含义

服务器名称

发生告警的服务器主机名称。

服务器IP地址

发生告警的服务器IP(Internet Protocol)地址。

磁盘

发生告警的服务器磁盘名称。

产生门限

告警产生的门限值。

清除门限

告警清除的门限值。

使用率

磁盘空间使用率。

对系统的影响

磁盘占用率过高可能导致eSight服务进行磁盘写操作失败,并可能引发数据库异常。

可能原因

  • eSight服务器磁盘占用率的产生门限值设置不合理。
  • 磁盘中的无用文件过多。
    • 回收站未被清空。
    • eSight服务器收到过多的网元告警、事件、日志,短期内大量数据从数据库中导出到磁盘文件中。
    • 保留了过多的暂存的数据文件、备份文件。

处理步骤

  1. 检查eSight服务器磁盘占用率的产生门限值是否设置不合理。

    1. 联系管理员检查是否服务器磁盘占用率的产生门限值设置不合理。
      • 是:请管理员处理。待管理员处理后,转步骤1.2。若无法等待管理员处理完毕,转步骤5
      • 否:=>转步骤2
    2. 等待5分钟,在当前告警列表查看本告警是否恢复。
    • 是:告警处理结束。
    • 否:=>转步骤2

  2. 使用Xwindows软件登录服务器后,查看回收站是否已清空。

  3. 检查磁盘中是否存在其他无用文件。

    1. 执行如下命令,查看文件系统占用率。

      # df -h

      Filesystem            Size  Used Avail Use% Mounted on 
      /dev/sda2              13G  3.3G  8.8G  28% / 
      devtmpfs               12G  200K   12G   1% /dev 
      tmpfs                  24G  7.1G   17G  30% /dev/shm 
      /dev/sda5             1.1G   74M  955M   8% /boot 
      /dev/sda6             8.1G  133M  7.9G   2% /home 
      /dev/sda10            214G   50G  164G  24% /opt 
      /dev/sda7             5.1G  179M  4.9G   4% /tmp 
      /dev/sda8              11G  2.7G  7.4G  27% /usr 
      /dev/sda9             5.1G  824M  4.2G  17% /var 
      shm                    24G  7.1G   17G  30% /dev/shm     

      “Use%”列为各文件系统占用率,检查哪些文件系统占用率大于产生门限值。

    2. 进入占用率高的文件系统,查询该位置的所有文件、目录大小,并排序后显示。

      # cd filepatch

      # du -sk * | sort -n

    3. 根据查询结果,找到占用磁盘空间多的目录。
    4. 进入占用磁盘空间多的目录后查询该位置所有文件、目录大小,并排序后显示。

      # cd filepatch

      # du -sk * | sort -n

    5. 根据查询结果,找到引起文件系统占用率过高的目录或文件。
    6. 重复执行步骤3.4步骤3.5,查找引起文件系统占用率过高的文件,并进行清理。建议优先清理历史备份的安装包、补丁包、适配层安装包,安装过程中的备份文件,core文件等。可清理的eSight及数据库无用文件请参见表9-266。执行文件清理后,转步骤4

    如果无法确认文件是否可以删除,请联系系统管理员或华为技术支持工程师。

    表9-266 可清理的eSight日志文件

    目录

    待清理的文件

    清理操作

    “eSight安装目录/AppBase/var/iemp/log”

    eSight日志文件

    将文件备份到其他机器后,使用rm命令删除所有core文件。

    “eSight安装目录/mttools/var/iemp/log”

    维护工具日志文件

    将文件备份到其他机器后,使用rm命令删除所有core文件。

  4. 等待5分钟,在当前告警列表查看本告警是否恢复。

    • 是:告警处理结束。
    • 否:=>转步骤5

  5. 请收集上述告警处理过程中的信息,联系技术支持。

告警清除

此告警修复后,系统会自动清除此告警,无需手工清除。

以下情况会导致之前产生的该告警无法自动被清除,需要手工清除。

  • 产生该告警的主机名称、主机IP发生了变化。
  • 产生该告警的硬盘的挂接点发生了变化。
  • 产生该告警的服务器不被监控了。
  • 高可用系统场景下发生了主备倒换。

参考信息

无。

翻译
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更新时间:2019-11-22

文档编号:EDOC1100011879

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