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eSight V300R009C00 维护指南 11

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ALM-80001 自动备份失败

ALM-80001 自动备份失败

告警解释

当维护工具检测到数据库数据自动备份失败时,产生此告警。此告警修复后需要手工清除。

告警属性

告警ID

告警级别

告警类型

80001

次要

通信告警

告警参数

参数名称

参数含义

服务器地址

产品的主服务器IP(Internet Protocol)地址。

产品名

源数据所属产品名:“eSight”。

对系统的影响

本次自动备份任务执行失败,未生成备份数据供恢复使用。

可能原因

  • eSight与数据库连接异常。
  • 备份路径所在服务器的网络连接异常。
  • 备份数据量过大(超过1T)导致备份超时。

处理步骤

  1. 在当前告警列表中查看此告警的定位信息,确认数据备份失败的产品。

    1. 在“当前告警”页面的告警列表中,单击此告警名称打开“告警详情”对话框。
    2. 在“告警详情”对话框的“定位信息”中,查看并记录“产品名”、和“服务器地址”的值。

  2. 联系管理员检查步骤1中确认的产品的数据库连接是否正常。

    • 是:=>转步骤3
    • 否:=>联系数据库管理员解决数据库连接问题,转步骤8

  3. 确认数据的备份路径是否在本地服务器。

    1. 在维护工具客户端的主菜单中,选择“备份恢复 > 备份策略设置”。
    2. 在“备份策略设置”页面的“备份路径”中,查看数据的备份路径是否在本地服务器。
    • 是:=>转步骤5
    • 否:=>记录备份路径所在远程服务器的IP地址,转步骤4

  4. 检查备份路径所在远程服务器的连接状态是否正常。

    1. 在维护工具客户端的主菜单中,选择“系统 > 服务器管理”。
    2. 在“服务器管理”页面中,查看远程服务器所在“连接状态”列的值是否为“在线”。
    • 是:=>转步骤5
    • 否:=>联系设备维护人员解决服务器网络连接问题,转步骤8

  5. 检查备份的数据量是否过大(超过1T)而导致备份超时。

    1. 在维护工具客户端的主菜单中,选择“系统 > 数据库信息”。
    2. 在“数据库信息”页面中,查看步骤1中确认的“产品名”的所有数据库存储空间总大小是否超过1T(1024GB)。

      单个数据库存储空间总大小=总的数据空间-可用数据空间

  6. 参考设置数据溢出转储,将数据库数据转储,使备份源数据在1T内。转步骤8
  7. 请收集上述告警处理过程中的信息,联系技术支持。
  8. 立即备份数据,详细操作请参见参考信息

告警清除

在eSight上手工清除此告警。手工清除告警的操作请参见《eSight操作指南》“告警管理”> "操作流程”。

参考信息

立即备份数据操作方法如下:

  1. 登录维护工具,在主菜单中选择“备份恢复 > 备份策略设置”。
  2. 选择“启动定时备份”,设置“备份开始时间”和“备份周期”。

    建议设置备份周期单位为最短周期“天”。当备份周期单位为“月”时,“备份开始时间”不能选择29、30和31日。

    为了避免备份数据库时发生异常,定时备份时间请跟告警转储时间错开,建议在业务空闲时间进行。

  3. 可选:单击“自定义备份文件夹”左侧的,设置自定义备份文件夹。

    在自定义备份文件夹列表中,单击“操作”列中的,在“修改自定义备份的文件夹”对话框中添加需要备份的文件夹,然后单击“确认”。

    • 该步骤是可选的。

      若不配置,系统只会依据系统配置备份默认文件(备份到下一步骤中设置的路径)。

      若配置,在备份文件时,除了备份用户根据需要设置的备份文件,还备份系统默认的备份文件。

    • 备份的文件夹必须是产品目录下已存在的文件夹。比如:“eSight安装目录/AppBase”目录下子文件夹。
    • 目录的路径长度不能超过255字符,目录总数不能超过255个。
    • 如果备份的文件夹相同,只保存一个;如果文件夹存在包含关系,只保存父文件夹。

  4. 可选:单击“加密设置”左侧的,设置备份包的加密密码。

    配置了加密密码的备份包,可以更好的防止数据泄露和篡改。

  5. 设置备份路径和备份文件数量。

    • 备份到远程服务器
      1. 选择“备份到本地服务器”。
      2. 在“本地服务器备份路径”列表中,单击“操作”列中的,在“修改备份目录”对话框中设置备份文件保存的路径。
        • 不建议经常更换备份路径,以免造成老的备份包丢失。
        • 建议创建一个新目录作为备份目录,以免在备份恢复时与网管的业务之间产生相互影响。
      3. 在“阈值设置”区域中,设置“备份文件数量”。
      4. 单击“应用”。
      5. 在“确认”对话框中,单击“是”。

        “备份策略设置”页面最下方显示“设置备份策略成功。”,表明备份策略设置成功。

    • 备份到远程服务器
      1. 选择“备份到远程服务器”。
      2. 设置“服务器IP地址”、“连接类型及端口”、“用户名”、“密码”和“远程服务器备份路径”。
        • 连接类型及端口:可以选择“FTP”(File Transfer Protocol)、“SFTP”(Secure File Transfer Protocol)、“SFTP + KEY”和“FTPS”(File Transfer Protocol over SSL)四种连接类型。为了保证传输安全,建议使用SFTP和FTPS协议。

          其中,“SFTP + KEY”为SFTP协议加密钥的连接方式,需要提前配置主服务器和远程服务器之间的密钥互信。以Linux操作系统自带的SFTP服务为例,说明“SFTP + KEY”互信设置方法,详情请参见《eSight维护指南》中“备份与恢复”章节。

          与远程服务器之间的密钥互信配置方法:
          1. 缺省的私钥名称为“id_ftp_rsa”。

            私钥文件是OpenSSH文件格式的,而不是ppk(putty private key)格式的。

          2. 私钥存放的路径:维护工具启动用户所属Home目录下“.ssh”文件夹中(文件夹不存在时需要用户创建)。

            如windows操作系统用administrator用户启动维护工具,administrator用户home目录若为“C:\Users\Administrator”,则私钥放置目录为“C:\Users\Administrator\.ssh”;Linux操作系统用ossuser用户启动维护工具,ossuser用户的home目录若为“/ossuser”,则私钥放置目录为“/ossuser/.ssh”。

          3. 在高可用场景下,需要在备机放置相同的私钥。

          SFTP协议默认端口号为22;FTP协议默认端口号为21;FTPS协议默认端口号为990。当使用FTPS协议时需要先配置客户端证书,详情请参见《eSight维护指南》中“备份与恢复”章节。

        • 用户名:连接协议对应的用户名。
        • 远程服务器备份路径:该路径为远程服务器共享目录的相对路径。

          缺省远程备份路径为连接远程服务器所使用用户的Home目录。

          例如连接远程服务器用户为“ossuser”,且用户所属Home目录在Windows环境中为“C:/ossuser”。则表示如果输入AAA,文件将保存到“C:/ossuser/AAA”下;在Linux环境中为“/ossuser”,则表示如果输入AAA,文件将保存到“/ossuser/AAA”下。

      3. 可选: 单击“有效性校验”。显示“校验成功”表明设置信息正确。否则,请检查并重新设置相关信息。
      4. 设置“备份文件数量”。
      5. 单击“应用”。
      6. 在“确认”对话框中,单击“是”。

        显示“设置备份策略成功”表明备份策略设置成功。

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更新时间:2019-11-22

文档编号:EDOC1100011879

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