所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

NE40E V800R010C00 配置指南 - NAT与IPv6过渡技术 01

评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
配置NAT框间冷备关联CGN单板功能示例

配置NAT框间冷备关联CGN单板功能示例

本节介绍了如何通过NAT框间冷备关联CGN单板功能,提高NAT设备的可靠性。

组网需求

图2-23所示,在集中式部署组网场景下,CGN1设备的1号槽位和CGN2的1号槽位分别部署了VSUF-160业务板,CGN1和CGN2设备分别作为独立设备部署在城域网核心的两台CR附近。

一般情况下,CGN业务板故障之后,BGP并没有撤销发布给下游设备的默认路由,流量依然会通过静态路由到达CGN设备,导致流量中断。为解决上述问题,可以配置NAT框间冷备关联CGN单板的功能,通过配置ServiceIf接口关联HA业务状态监控组及时感知到CGN业务单板的运行情况,触发主备设备的切换,从而使流量切换到备份CGN设备上。

图2-23  NAT框间冷备组网图
说明:

本例中的interface1代表GE1/0/0


背景信息

采用如下的思路配置NAT框间冷备关联CGN单板功能:
  1. 配置NAT基本功能。
  2. 创建HA业务状态监控组,并绑定HA备份组。
  3. 配置ServiceIf接口,并绑定HA业务状态监控组。

数据准备

为完成此配置例,需准备如下的数据:

序号

数据

1

VSM HA备份组的索引

2

CGN1设备的1个业务板上的主用CPU的槽位号和CPU号(场景需求中已指明为1号槽的0号CPU)

3

CGN2设备的1个业务板上的备用CPU的槽位号和CPU号(场景需求中已指明为1号槽的0号CPU)

4

业务实例组的名称

5

NAT实例的名称和索引

6

HA业务状态监控组的名称

7

ServiceIf接口的编号

操作步骤

  1. 在主备设备上配置1号业务板的会话表资源为6M。

    # 在主设备CGN1设备上配置。
    <HUAWEI> system-view
    [~HUAWEI] sysname CGN1
    [*HUAWEI] commit
    [~CGN1] license
    [*CGN1-license] active nat session-table size 6 slot 1 engine 0
    [*CGN1-license] commit
    [~CGN1-license] quit
    # 在备设备CGN2设备上配置。
    <HUAWEI> system-view
    [~HUAWEI] sysname CGN2
    [*HUAWEI] commit
    [~CGN2] license
    [*CGN2-license] active nat session-table size 6 slot 1 engine 0
    [*CGN2-license] commit
    [~CGN2-license] quit

  2. 在主备设备上分别创建VSM HA备份组。

    # 在CGN1设备上创建个VSM HA备份组1,并配置双机框间备份的成员为1号槽位号的0号CPU。

    [~CGN1] service-location 1
    [*CGN1-service-location-1] location slot 1 engine 0
    [*CGN1-service-location-1] commit
    [~CGN1-service-location-1] quit

    # 在CGN2设备上创建个VSM HA备份组1,并配置HA双机框间备份的成员为1号槽位号的0号CPU。

    [~CGN2] service-location 1
    [*CGN2-service-location-1] location slot 1 engine 0
    [*CGN2-service-location-1] commit
    [~CGN2-service-location-1] quit

  3. 在主备设备上分别创建VSM HA业务实例组绑定VSM HA备份组。

    # 在CGN1设备上创建VSM HA业务实例组group1,并绑定VSM HA备份组1。

    [~CGN1] service-instance-group group1
    [*CGN1-service-instance-group-group1] service-location 1
    [*CGN1-service-instance-group-group1] commit
    [~CGN1-service-instance-group-group1] quit

    # 在CGN2设备上创建VSM HA业务实例组group1,并绑定VSM HA备份组1。

    [~CGN2] service-instance-group group1
    [*CGN2-service-instance-group-group1] service-location 1
    [*CGN2-service-instance-group-group1] commit
    [~CGN2-service-instance-group-group1] quit

  4. 在主备设备上分别创建VSM HA业务状态监控组绑定VSM HA备份组。

    # 在CGN1设备上创建VSM HA业务状态监控组group1,并绑定VSM HA备份组1。

    [~CGN1] monitor-location-group group1
    [*CGN1-monitor-location-group-group1] service-location 1
    [*CGN1-monitor-location-group-group1] commit
    [~CGN1-monitor-location-group-group1] quit

    # 在CGN2设备上创建VSM HA业务状态监控组group1,并绑定VSM HA备份组1。

    [~CGN2] monitor-location-group group1
    [*CGN2-monitor-location-group-group1] service-location 1
    [*CGN2-monitor-location-group-group1] commit
    [~CGN2-monitor-location-group-group1] quit

  5. 在主备设备上分别创建ServiceIf接口,并绑定HA业务状态监控组。

    # 在CGN1设备上创建ServiceIf 1接口,并绑定VSM HA业务状态监控组group1。

    [~CGN1] interface serviceif 1
    [*CGN1-ServiceIf1] ip address 10.1.1.1 255.255.255.0
    [*CGN1-ServiceIf1] track monitor-location-group group1
    [*CGN1-ServiceIf1] commit
    [~CGN1-ServiceIf1] quit

    # 在CGN2设备上创建ServiceIf 1接口,并绑定VSM HA业务状态监控组group1。

    [~CGN2] interface serviceif 1
    [*CGN2-ServiceIf1] ip address 10.1.1.2 255.255.255.0
    [*CGN2-ServiceIf1] track monitor-location-group group1
    [*CGN2-ServiceIf1] commit
    [~CGN2-ServiceIf1] quit

  6. 在主备设备上分别配置静态路由,路由出接口为ServiceIf接口。通过路由协议,将主备设备的静态路由发布到下游BRAS设备上,形成主备路由。

    # 在CGN1设备上配置静态路由,路由出接口为ServiceIf 1接口。

    [~CGN1] ip route-static 0.0.0.0 0.0.0.0 serviceif 1
    [*CGN1] commit
    [~CGN1] quit

    # 在CGN2设备上配置静态路由,路由出接口为ServiceIf 1接口。

    [~CGN2] ip route-static 0.0.0.0 0.0.0.0 serviceif 1
    [*CGN2] commit
    [~CGN2] quit

  7. 在主备设备上分别创建NAT实例,并绑定VSM HA业务实例组。

    # 在CGN1设备上创建NAT实例nat,并绑定业务实例组group1。

    [~CGN1] nat instance nat id 1
    [*CGN1-nat-instance-nat] service-instance-group group1
    [*CGN1-nat-instance-nat] nat address-group address-group1 group-id 1 10.38.160.100 10.38.160.105
    [*CGN1-nat-instance-nat] commit
    [~CGN1-nat-instance-nat] quit

    # 在CGN2设备上创建NAT实例nat,并绑定业务实例组group1。

    [~CGN2] nat instance nat id 1
    [*CGN2-nat-instance-nat] service-instance-group group1
    [*CGN2-nat-instance-nat] nat address-group address-group1 group-id 1 10.38.160.100 10.38.160.105
    [*CGN2-nat-instance-nat] commit
    [~CGN2-nat-instance-nat] quit

  8. 在主备设备上配置NAT引流策略和NAT转换策略,具体请参照《IPv6过渡技术-NAT配置》中的配置集中式NAT示例

    # 在CGN1设备上配置引流策略和NAT转换策略。

    1. 配置NAT的引流策略。

      1. 配置基于ACL流分类规则,地址访问控制列表号为3001,ACL规则的编号为1,只有内部网段地址为192.168.10.0/24的主机可以访问Internet。
        [~CGN1] acl 3001
        [*CGN1-acl4-advance-3001] rule 1 permit ip source 192.168.10.0 0.0.0.255
        [*CGN1-acl4-advance-3001] commit
        [~CGN1-acl4-advance-3001] quit
      2. 配置流分类。
        [~CGN1] traffic classifier classifier1
        [*CGN1-classifier-classifier1] if-match acl 3001
        [*CGN1-classifier-classifier1] commit
        [~CGN1-classifier-classifier1] quit
      3. 定义流行为behavior1,配置流量动作为绑定NAT实例nat。
        [~CGN1] traffic behavior behavior1
        [*CGN1-behavior-behavior1] nat bind instance nat
        [*CGN1-behavior-behavior1] commit
        [~CGN1-behavior-behavior1] quit
      4. 定义NAT策略policy1,将所有应用的ACL规则和动作进行关联。
        [~CGN1] traffic policy policy1
        [*CGN1-policy-policy1] classifier classifier1 behavior behavior1
        [*CGN1-policy-policy1] commit
        [~CGN1-policy-policy1] quit
      5. 在接口GE1/0/0视图下应用NAT引流策略。
        [~CGN1] interface gigabitEthernet 1/0/0
        [~CGN1-GigabitEthernet1/0/0] ip address 192.168.10.1 255.255.255.0
        [*CGN1-GigabitEthernet1/0/0] traffic-policy policy1 inbound
        [*CGN1-GigabitEthernet1/0/0] commit
        [~CGN1-GigabitEthernet1/0/0] quit
    2. 配置NAT转换策略。

      [~CGN1] nat instance nat
      [~CGN1-nat-instance-nat] nat outbound 3001 address-group address-group1
      [*CGN1-nat-instance-nat] commit
      [~CGN1-nat-instance-nat] quit
    说明:

    CGN2的配置过程与CGN1完全相同,具体配置请参考CGN2设备的配置文件

    # 分别在两台CGN设备上执行display nat instance nat命令,查看NAT的配置信息。

    [~CGN1] display nat instance nat
    nat instance nat id 1                                                                                                               
     service-instance-group group1                                                                                                        
     nat address-group address-group1 group-id 1 10.38.160.100 10.38.160.105                                                                     
     nat outbound 3001 address-group address-group1
    [~CGN2] display nat instance nat
    nat instance nat id 1                                                                                                               
     service-instance-group group1                                                                                                         
     nat address-group address-group1 group-id 1 10.38.160.100 10.38.160.105                                                                     
     nat outbound 3001 address-group address-group1

配置文件

  • CGN1设备的配置文件

    #
    sysname CGN1
    #
    license
     active nat session-table size 6 slot 1 engine 0
    #
    acl 3001
     rule 1 permit ip source 192.168.10.0 0.0.0.255
    #
    traffic classifier classifier1
     if-match acl 3001
    #
    traffic behavior behavior1
     nat bind instance nat
    #
    traffic policy policy1
     classifier classifier1 behavior behavior1
    #
    service-location 1
     location slot 1 engine 0
    #
    service-instance-group group1
     service-location 1
    #
    monitor-location-group group1
     service-location 1
    #
    nat instance nat id 1
     service-instance-group group1                                                                                                         
     nat address-group address-group1 group-id 1 10.38.160.100 10.38.160.105                                                                     
     nat outbound 3001 address-group address-group1
    
    #
    interface GigabitEthernet 1/0/0
     undo shutdown
     ip address 192.168.10.1 255.255.255.0
     traffic-policy policy1 inbound
    #
    interface serviceif 1
     ip address 10.1.1.1 255.255.255.0
     track monitor-location-group group1
    #
    ip route-static  0.0.0.0 0.0.0.0 serviceif 1
    #
    return
  • CGN2设备的配置文件

    #
    sysname CGN2
    #
    license
     active nat session-table size 6 slot 1 engine 0
    #
    acl 3001
     rule 1 permit ip source 192.168.10.0 0.0.0.255
    #
    traffic classifier classifier1
     if-match acl 3001
    #
    traffic behavior behavior1
     nat bind instance nat
    #
    traffic policy policy1
     classifier classifier1 behavior behavior1
    #
    service-location 1
     location slot 1 engine 0
    #
    service-instance-group group1
     service-location 1
    #
    monitor-location-group group1
     service-location 1
    #
    nat instance nat id 1
     service-instance-group group1                                                                                                         
     nat address-group address-group1 group-id 1 10.38.160.100 10.38.160.105                                                                     
      nat outbound 3001 address-group address-group1
    #
    interface GigabitEthernet 1/0/0
     undo shutdown
     ip address 192.168.10.1 255.255.255.0
     traffic-policy policy1 inbound
    #
    interface serviceif 1
     ip address 10.1.1.2 255.255.255.0
     track monitor-location-group group1
    #
    ip route-static  0.0.0.0 0.0.0.0 serviceif 1
    #
    return
下载文档
更新时间:2018-07-12

文档编号:EDOC1100028549

浏览量:21055

下载量:209

平均得分:
本文档适用于这些产品
相关文档
相关版本
Share
上一页 下一页