所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

NE40E V800R010C00 配置指南 - NAT与IPv6过渡技术 01

评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
配置集中式DS-Lite示例

配置集中式DS-Lite示例

介绍集中式DS-Lite功能的配置示例,实现IPv4私网地址用户穿越IPv6网络访问IPv4公网的解决方案。

组网需求

图3-7所示,使用私网IPv4地址的家庭用户的计算机通过CPE设备(需要支持双栈和DS-Lite功能)接入到IPv6城域网中,CPE和DS-Lite设备之间建立DS-Lite隧道。CPE将私网IPv4流量封装在DS-Lite隧道中进行传输,然后在DS-Lite设备上解封装并通过NAT技术将IPv4私网地址转成IPv4公网地址发送给IPv4 Internet。DS-Lite设备的1号和2号槽位上有两块DS-Lite业务板。DS-Lite设备通过GE1/0/0与IPv6城域网连接,通过GE1/0/1与Internet相连,要求IPv4家庭用户能够通过IPv6城域网访问IPv4 Internet。运营商具有10.38.160.100至10.38.160.110共11个公网IPv4地址。

通过配置要达到以下要求:
  • 内部私网IPv4家庭用PC机可以通过IPv6城域网访问IPv4 Internet。
  • 实现内部私网IPv4家庭用户和公网地址进行多对多的转换。
图3-7  DS-Lite应用组网图
说明:

本例中的interface1、interface2分别代表GE1/0/1、GE1/0/0


配置思路

采用如下思路配置集中式DS-Lite:。

  1. 配置基本的License功能。
  2. 配置DS-Lite实例,将DS-Lite业务板绑定到DS-Lite实例。
  3. 配置DS-Lite隧道的Local IPv6地址和Remote IPv6地址。
  4. 配置DS-Lite地址池。地址池地址从10.38.160.100至10.38.160.110。
  5. 配置DS-Lite隧道流量策略。
  6. 配置DS-Lite隧道与地址池绑定。
  7. 配置接口和路由协议。
  8. 将Local IP路由发布到IPv6网络,将地址池路由发布到IPv4网络。

数据准备

  • DS-Lite实例名ds-lite1

  • 绑定到DS-Lite实例的业务板所在的槽位号12

  • 配置DS-Lite隧道时所需的Local IP地址2001:DB8::1和Remote IP地址2001:DB8:2::1

  • DS-Lite地址池的编号1,从10.38.160.100到10.38.160.110的地址段

  • 用于指定需要进行DS-Lite流量分类的ACL6规则编号用于和DS-Lite地址池绑定的ACL6规则编号

操作步骤

  1. 配置基本的license功能。

    <HUAWEI> system-view
    [~DS-Lite] sysname DS-Lite
    [*DS-Lite] commit
    [~DS-Lite] license
    [~DS-Lite-license] active ds-lite vsuf slot 1
    [*DS-Lite-license] active ds-lite vsuf slot 2
    [*DS-Lite-license] active nat session-table size 16 slot 1 engine 0
    [*DS-Lite-license] active nat session-table size 16 slot 2 engine 0
    [*DS-Lite-license] commit
    [~DS-Lite-license] quit

  2. 配置DS-Lite实例,将DS-Lite业务板绑定到DS-Lite实例。

    [~DS-Lite] service-location 1
    [*DS-Lite-service-location-1] location slot 1 engine 0 backup slot 2 engine 0
    [*DS-Lite-service-location-1] commit
    [~DS-Lite-service-location-1] quit
    [~DS-Lite] service-instance-group 1
    [*DS-Lite-instance-group-1] service-location 1
    [*DS-Lite-instance-group-1] commit
    [~DS-Lite-instance-group-1] quit
    [~DS-Lite] ds-lite instance ds-lite1 id 1
    [*DS-Lite-ds-lite-instance-ds-lite1] service-instance-group 1
    [*DS-Lite-ds-lite-instance-ds-lite1] quit
    [~DS-Lite-ds-lite-instance-ds-lite1] commit

  3. 配置DS-Lite隧道的Local IPv6地址和Remote IPv6地址。

    [~DS-Lite] ds-lite instance ds-lite1
    [~DS-Lite-ds-lite-instance-ds-lite1] local-ipv6 2001:DB8::1 prefix-length 128
    [*DS-Lite-ds-lite-instance-ds-lite1] remote-ipv6 2001:DB8:2::1 prefix-length 64
    [*DS-Lite-ds-lite-instance-ds-lite1] commit
    [~DS-Lite-ds-lite-instance-ds-lite1] quit

  4. 配置DS-Lite地址池。地址池地址从10.38.160.100至10.38.160.110。

    [~DS-Lite] ds-lite instance ds-lite1
    [*DS-Lite-ds-lite-instance-ds-lite1] ds-lite address-group group1 group-id 1 10.38.160.100 10.38.160.110
    [*DS-Lite-ds-lite-instance-ds-lite1] commit
    [~DS-Lite-ds-lite-instance-ds-lite1] quit

  5. 配置DS-Lite隧道流量策略。
    1. 配置基于ACL6的流分类规则。

      [~DS-Lite] acl ipv6 3500
      [*DS-Lite-acl6-basic-3500] rule permit ipv6 source 2001:DB8:2::1 64 destination 2001:DB8::1 128
      [*DS-Lite-acl6-basic-3500] commit
      [~DS-Lite-acl6-basic-3500] quit

    2. 配置流分类。

      [~DS-Lite] traffic classifier c1
      [*DS-Lite-classifier-c1] if-match ipv6 acl 3500
      [*DS-Lite-classifier-c1] commit
      [~DS-Lite-classifier-c1] quit

    3. 定义流行为,配置流量动作为绑定DS-Lite实例ds-lite1。

      [~DS-Lite] traffic behavior b1 
      [*DS-Lite-behavior-b1] ds-lite bind instance ds-lite1
      [*DS-Lite-behavior-b1] commit
      [~DS-Lite-behavior-b1] quit

    4. 定义DS-Lite策略,将该规则和动作进行关联。

      [~DS-Lite] traffic policy p1
      [*DS-Lite-trafficpolicy-p1] classifier c1 behavior b1
      [*DS-Lite-trafficpolicy-p1] commit
      [~DS-Lite-trafficpolicy-p1] quit

    5. 在接口GE1/0/1接口应用此策略。

      [~DS-Lite] interface GigabitEthernet 1/0/1
      [~DS-Lite-GigabitEthernet1/0/1] traffic-policy p1 inbound
      [*DS-Lite-GigabitEthernet1/0/1] commit
      [~DS-Lite-GigabitEthernet1/0/1] quit

  6. 配置DS-Lite隧道与地址池绑定。
    1. 配置基于IPv6 ACL的流分类规则,通过地址池group1进行转换的是隧道报文源地址范围为2001:DB8:2::1/64。

      [~DS-Lite] acl ipv6 3000
      [*DS-Lite-acl6-adv-3000] rule permit ipv6 source 2001:DB8:2::1 64
      [*DS-Lite-acl6-adv-3000] commit
      [~DS-Lite-acl6-adv-3000] quit

    2. 将ACL规则与DS-Lite地址池进行关联。在DS-Lite实例ds-lite1中将IPv6 ACL 3000与地址池group1绑定。

      [~DS-Lite] ds-lite instance ds-lite1
      [~DS-Lite-ds-lite-instance-ds-lite1] ds-lite outbound 3000 address-group group1
      [*DS-Lite-ds-lite-instance-ds-lite1] commit
      [~DS-Lite-ds-lite-instance-ds-lite1] quit

  7. 配置接口和路由协议。
    1. 配置ISIS。

      [~DS-Lite] isis 100
      [*DS-Lite-isis-100] network-entity 10.1000.1000.1000.00
      [*DS-Lite-isis-100] commit
      [~DS-Lite-isis-100] quit
      [~DS-Lite] isis 1000
      [*DS-Lite-isis-1000] network-entity 10.1000.1000.1002.00
      [*DS-Lite-isis-1000] ipv6 enable
      [*DS-Lite-isis-1000] commit
      [~DS-Lite-isis-1000] quit

    2. 配置DS-Lite设备与IPv6网络相连接口。

      [~DS-Lite] interface GigabitEthernet1/0/0
      [~DS-Lite-GigabitEthernet1/0/0] ipv6 enable
      [*DS-Lite-GigabitEthernet1/0/0] ipv6 address 2001:DB8:1::2:1 64
      [*DS-Lite-GigabitEthernet1/0/0] isis ipv6 enable 1000
      [*DS-Lite-GigabitEthernet1/0/0] commit
      [~DS-Lite-GigabitEthernet1/0/0] quit

    3. 配置DS-Lite设备与IPv4网络相连接口。

      [~DS-Lite] interface GigabitEthernet1/0/1
      [~DS-Lite-GigabitEthernet1/0/1] ip address 192.168.10.1 24
      [*DS-Lite-GigabitEthernet1/0/1] isis enable 100
      [*DS-Lite-GigabitEthernet1/0/1] commit
      [~DS-Lite-GigabitEthernet1/0/1] quit

  8. 将Local IP路由发布到IPv6网络,将地址池路由发布到IPv4网络。首先将Local IP路由和地址池路由分别引入ISIS。在本版本中Local IP路由和地址池路由为unr路由。

    [~DS-Lite] isis 1000
    [~DS-Lite-isis-1000] ipv6 import-route unr
    [*DS-Lite-isis-1000] commit
    [~DS-Lite-isis-1000] quit
    [~DS-Lite] isis 100
    [~DS-Lite-isis-100] import-route unr
    [*DS-Lite-isis-100] commit
    [~DS-Lite-isis-100] quit

  9. 检查配置结果。

    # 配置完成后,DS-Lite设备和其他设备之间能够建立ISIS邻居,状态达到up。在CPE设备上有Local IP和地址池地址路由。

    [~DS-Lite] display ipv6 routing-table 2001:DB8::1
    Routing Table : Public
    Summary Count : 1
     Destination  : 2001:DB8::1                         PrefixLength : 128
     NextHop      : FE80::218:82FF:FE84:CCF             Preference   : 15
     Cost         : 10                                  Protocol     : ISIS
     RelayNextHop : ::                                  TunnelID     : 0x0
     Interface    : GigabitEthernet1/0/1               Flags        : D   

    # 查看索引号为0的基板CPU的1号槽位号上用户的信息。

    [~DS-Lite] display nat user-information slot 1 Engine 0 verbose
    This operation will take a few minutes. Press 'Ctrl+C' to break ...             
    Slot: 1 Engine: 0                                                               
    Total number:  1.                                                               
      ---------------------------------------------------------------------------   
      User Type                             :  DS-Lite                               
      CPE IP                                :  2001:DB8:2::1/128                        
      User ID                               :  2                                    
      VPN Instance                          :  -                                    
      Address Group                         :  group1                                    
      DS-Lite Instance                      :  ds-lite1                                  
      Public IP                             :  10.38.160.101                           
      Start Port                            :  1024                                 
      Port Range                            :  256                                  
      Port Total                            :  256                                  
      Extend Port Alloc Times               :  0                                    
      Extend Port Alloc Number              :  0                                    
      First/Second/Third Extend Port Start  :  0/0/0                                
      Total/TCP/UDP/ICMP Session Limit      :  8192/10240/10240/512                 
      Total/TCP/UDP/ICMP Session Current    :  0/0/0/0                              
      Total/TCP/UDP/ICMP Rev Session Limit  :  8192/10240/10240/512                 
      Total/TCP/UDP/ICMP Rev Session Current:  0/0/0/0                              
      Total/TCP/UDP/ICMP Port Limit         :  0/0/0/0                              
      Total/TCP/UDP/ICMP Port Current       :  0/0/0/0                              
      Nat ALG Enable                        :  NULL                                 
      Token/TB/TP                           :  0/0/0                                
      Port Forwarding Flag                  :  Non Port Forwarding                  
      Port Forwarding Ports                 :  0 0 0 0 0                            
      Aging Time(s)                         :  -                                    
      Left Time(s)                          :  -                                    
      Port Limit Discard Count              :  0                                    
      Session Limit Discard Count           :  0                                    
      Fib Miss Discard Count                :  0                                    
      -->Transmit Packets                   :  0                                    
      -->Transmit Bytes                     :  0                                    
      -->Drop Packets                       :  0                                    
      <--Transmit Packets                   :  0                                    
      <--Transmit Bytes                     :  0                                    
      <--Drop Packets                       :  0                                    
      ---------------------------------------------------------------------------  

配置文件

DS-Lite设备的配置文件。

#                                                                               
 sysname DS-Lite                                                                
#
license
 active ds-lite vsuf slot 1
 active ds-lite vsuf slot 2
 active nat session-table size 16 slot 1 engine 0
 active nat session-table size 16 slot 2 engine 0
#
service-location 1
 location slot 1 engine 0 backup slot 2 engine 0
#
service-instance-group 1
 service-location 1
#                                                                                                                                                                                                                                           
ds-lite instance ds-lite1 id 1
 service-instance-group 1
 ds-lite address-group group1 group-id 1 10.38.160.100 10.38.160.110
 ds-lite outbound 3000 address-group group1
 local-ipv6 2001:DB8::1  prefix-length 128
 remote-ipv6 2001:DB8:2::1  prefix-length 64
#                                                                                                                                                           
acl ipv6 number 3500                                                            
 rule 5 permit ipv6 source 2001:DB8:2::1 64 destination 2001:DB8::1 128                                                   
#                                                                               
acl ipv6 number 3000                                                            
 rule 0 permit ipv6 source 2001:DB8:2::1/64                                           
#                                                                                                                                                             
traffic classifier c1 operator or                                                                                                           
 if-match ipv6 acl 3500                                                                                                                                             
#                                                                               
traffic behavior b1
 ds-lite bind instance ds-lite1                                                             
#                                                                                                                                                   
traffic policy p1                                                               
 share-mode                                                                                                                                  
 classifier c1 behavior b1                                                                                                             
#                                                                               
isis 100  
 network-entity 10.1000.1000.1000.00                                                                     
 import-route unr                                                                                                                                                                                        
#                                                                               
isis 1000                                                                       
 network-entity 10.0000.0000.0002.000                                            
 #                                                                              
 ipv6 enable topology standard                                                  
 ipv6 import-route unr                                                          
 #                                                                              
#                                                                                
interface GigabitEthernet1/0/0                                                  
 undo shutdown                                                                  
 ipv6 enable                                                                    
 ip address 172.26.1.1 255.255.255.0                                           
 ipv6 address 2001:DB8:1::2:1/64                                                     
 isis ipv6 enable 1000 
 traffic-policy p1 inbound        
# 
interface GigabitEthernet1/0/1                                                  
 undo shutdown                                                                                                                                      
 ip address 192.168.10.2 255.255.255.0 
 isis enable 100    
#                                                                                                                                                            
return
下载文档
更新时间:2018-07-12

文档编号:EDOC1100028549

浏览量:19967

下载量:205

平均得分:
本文档适用于这些产品
相关文档
相关版本
Share
上一页 下一页