所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

NE40E V800R010C00 配置指南 - NAT与IPv6过渡技术 01

评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
配置分布式DS-Lite示例

配置分布式DS-Lite示例

介绍分布式DS-Lite功能的配置示例,实现IPv4私网地址用户穿越IPv6网络访问IPv4公网的解决方案。

组网需求

图3-8所示,使用私网IPv4地址的家庭用户的计算机通过CPE设备(需要支持双栈和DS-Lite功能)接入到IPv6城域网中,CPE和DS-Lite设备之间建立DS-Lite隧道。CPE将私网IPv4流量封装在DS-Lite隧道中进行传输,然后在DS-Lite设备上解封装并通过NAT技术将IPv4私网地址转成IPv4公网地址发送给IPv4 Internet。DS-Lite设备通过GE1/0/0与IPv6城域网连接,通过GE1/0/1与Internet相连,要求IPv4家庭用户能够通过IPv6城域网访问IPv4 Internet。运营商具有192.168.160.100至192.168.160.110共11个公网IPv4地址。

通过配置要达到以下要求:
  • 内部私网IPv4家庭用PC机可以通过IPv6城域网访问IPv4 Internet。
  • 实现内部私网IPv4家庭用户和公网地址进行多对多的转换。
图3-8  DS-Lite应用组网图

配置思路

采用如下思路配置分布式DS-Lite:
  1. 配置基本的License功能。
  2. 配置DS-Lite实例,将DS-Lite业务板绑定到DS-Lite实例。
  3. 配置DS-Lite隧道的Local IPv6地址和Remote IPv6地址。
  4. 配置DS-Lite地址池。地址池地址从192.168.160.100至192.168.160.110。
  5. 配置DS-Lite用户信息。
  6. 配置DS-Lite隧道流量策略。
  7. 配置DS-Lite隧道与地址池绑定。
  8. 配置接口和路由协议。
  9. 将Local IP路由发布到IPv6网络,将地址池路由发布到IPv4网络。

数据准备

  • DS-Lite实例名

  • 绑定到DS-Lite实例的业务板所在的槽位号

  • 配置DS-Lite隧道时所需的Local IP地址和Remote IP地址

  • DS-Lite地址池的编号,起始和结束的IP地址

  • 用于绑定到DS-Lite实例的用户组名

  • 用于指定需要进行DS-Lite流量分类的ACL6规则编号

  • 用于和DS-Lite地址池绑定的ACL6规则编号

操作步骤

  1. 配置基本的license功能。

    <HUAWEI> system-view
    [~HUAWEI] sysname BRAS
    [*HUAWEI] commit
    [~BRAS] license
    [~BRAS-license] active ds-lite vsuf slot 1
    [*BRAS-license] active nat session-table size 16 slot 1 engine 0
    [*BRAS-license] commit
    [~BRAS-license] quit

  2. 配置DS-Lite实例,将DS-Lite业务板绑定到DS-Lite实例。

    [~BRAS] service-location 1
    [*BRAS-service-location-1] location slot 1 engine 0
    [*BRAS-service-location-1] commit
    [~BRAS-service-location-1] quit
    [~BRAS] service-instance-group 1
    [*BRAS-instance-group-1] service-location 1
    [*BRAS-instance-group-1] commit
    [~BRAS-instance-group-1] quit
    [~BRAS] ds-lite instance ds-lite1 id 1
    [*BRAS-ds-lite-instance-ds-lite1] service-instance-group 1
    [*BRAS-ds-lite-instance-ds-lite1] commit
    [~BRAS-ds-lite-instance-ds-lite1] quit

  3. 配置DS-Lite隧道的Local IPv6地址和Remote IPv6地址。

    [~BRAS] ds-lite instance ds-lite1
    [*BRAS-ds-lite-instance-ds-lite1] local-ipv6 2001:DB8::1 prefix-length 128
    [*BRAS-ds-lite-instance-ds-lite1] remote-ipv6 2001:DB8::2 prefix-length 64
    [*BRAS-ds-lite-instance-ds-lite1] commit
    [~BRAS-ds-lite-instance-ds-lite1] quit

  4. 配置DS-Lite地址池。地址池地址从192.168.160.100至192.168.160.110。

    [~BRAS] ds-lite instance ds-lite1
    [*BRAS-ds-lite-instance-ds-lite1] ds-lite address-group group1 group-id 1 192.168.160.100 192.168.160.110
    [*BRAS-ds-lite-instance-ds-lite1] commit
    [~BRAS-ds-lite-instance-ds-lite1] quit

  5. 配置DS-Lite用户信息。
    1. 配置设备的BRAS业务功能,使用户能够上线。详细配置过程请参见《HUAWEI NetEngine40E 路由器 配置指南-用户接入》。

      注意:
      BRAS设备的IPv6地址池视图下必须配置DNS服务器地址和AFTR名称,AFTR名称即为DS-Lite服务器。此处配置有两个注意事项:
      • 当BRAS设备采用ND方式给CPE分配WAN口地址时,必须在PD地址池中配置AFTR名称和DNS信息,否则,DS-Lite设备和CPE间的DS-Lite隧道无法建立。

      • 在BRAS设备上配置AFTR名称后,还需要DNS服务器上增加该AFTR名和DS-Lite实例中配置的local-ip地址的对应关系,将DS-Lite设备的local-ip地址通告给CPE设备,否则CPE和DS-Lite服务器之间的DS-Lite隧道无法建立。

    2. 配置用户组。

      [~BRAS] user-group group1
      [*BRAS] commit

    3. 指定用户所属的域。

      [~BRAS] aaa
      [*BRAS-aaa] domain isp1 
      [*BRAS-aaa-domain-isp1] user-group group1 bind ds-lite instance ds-lite1
      [*BRAS-aaa-domain-isp1] quit
      [*BRAS-aaa] commit
      [~BRAS-aaa] quit

  6. 配置DS-Lite隧道流量策略。
    1. 配置基于ACL6的流分类规则。

      [~BRAS] acl ipv6 6001
      [*BRAS-acl6-ucl-6001] rule 1 permit ipv6 source user-group group1 destination ipv6-address 2001:DB8::1 128
      [*BRAS-acl6-ucl-6001] commit
      [~BRAS-acl6-ucl-6001] quit

    2. 配置流分类。

      [~BRAS] traffic classifier c1
      [*BRAS-classifier-c1] if-match ipv6 acl 6001
      [*BRAS-classifier-c1] commit
      [~BRAS-classifier-c1] quit

    3. 定义流行为,配置流量动作为绑定DS-Lite实例ds-lite1。

      [~BRAS] traffic behavior b1 
      [*BRAS-behavior-b1] ds-lite bind instance ds-lite1
      [*BRAS-behavior-b1] commit
      [~BRAS-behavior-b1] quit

    4. 定义DS-Lite策略,将该规则和动作进行关联。

      [~BRAS] traffic policy p1
      [*BRAS-trafficpolicy-p1] classifier c1 behavior b1
      [*BRAS-trafficpolicy-p1] commit
      [~BRAS-trafficpolicy-p1] quit

    5. 在系统视图下应用DS-Lite引流策略。

      [~BRAS] traffic-policy p1 inbound
      [*BRAS] commit

  7. 配置DS-Lite隧道与地址池绑定。
    1. 配置基于IPv6 ACL的流分类规则,通过地址池group1进行转换的是隧道报文源地址范围为2001:DB8::2/64。

      [~BRAS] acl ipv6 3000
      [*BRAS-acl6-adv-3000] rule permit ipv6 source 2001:DB8::2 64
      [*BRAS-acl6-adv-3000] commit
      [~BRAS-acl6-adv-3000] quit

    2. 将ACL规则与DS-Lite地址池进行关联。在DS-Lite实例ds-lite1中将IPv6 ACL 3000与地址池group1绑定。

      [~BRAS] ds-lite instance ds-lite1
      [*BRAS-ds-lite-instance-ds-lite1] ds-lite outbound 3000 address-group group1
      [*BRAS-ds-lite-instance-ds-lite1] commit
      [~BRAS-ds-lite-instance-ds-lite1] quit

  8. 配置接口和路由协议。
    1. 配置ISIS。

      [~BRAS] isis 100
      [*BRAS-isis-100] network-entity 10.1000.1000.1000.00
      [*BRAS-isis-100] commit
      [~BRAS-isis-100] quit
      [~BRAS] isis 1000
      [*BRAS-isis-1000] network-entity 10.1000.1000.1002.00
      [*BRAS-isis-1000] ipv6 enable
      [*BRAS-isis-1000] commit
      [~BRAS-isis-1000] quit

    2. 配置DS-Lite设备与IPv6网络相连接口。

      [~BRAS] interface GigabitEthernet1/0/0
      [*BRAS-GigabitEthernet1/0/0] ipv6 enable
      [*BRAS-GigabitEthernet1/0/0] isis ipv6 enable 1000
      [*BRAS-GigabitEthernet1/0/0] commit
      [~BRAS-GigabitEthernet1/0/0] quit

    3. 配置DS-Lite设备与IPv4网络相连接口。

      [~BRAS] interface GigabitEthernet1/0/1
      [~BRAS-GigabitEthernet1/0/1] ip address 172.16.1.1 24
      [*BRAS-GigabitEthernet1/0/1] isis enable 100
      [*BRAS-GigabitEthernet1/0/1] commit
      [~BRAS-GigabitEthernet1/0/1] quit

  9. 将Local IP路由发布到IPv6网络,将地址池路由发布到IPv4网络。首先将Local IP路由和地址池路由分别引入ISIS。在本版本中Local IP路由和地址池路由为unr路由。

    [~BRAS] isis 1000
    [~BRAS-isis-1000] ipv6 import-route unr
    [*BRAS-isis-1000] commit
    [~BRAS-isis-1000] quit
    [~BRAS] isis 100
    [~BRAS-isis-100] import-route unr
    [*BRAS-isis-100] commit
    [~BRAS-isis-100] quit

  10. 配置完成后,DS-Lite设备和其他设备之间能够建立ISIS邻居,状态达到up。在CPE设备上有Local IP和地址池地址路由。

    [~BRAS] display ipv6 routing-table 2001:DB8::1
    Routing Table : Public
    Summary Count : 1
    
     Destination  : 2001:DB8::1                         PrefixLength : 128
     NextHop      : FE80::218:82FF:FE84:CCF             Preference   : 15
     Cost         : 10                                  Protocol     : ISIS
     RelayNextHop : ::                                  TunnelID     : 0x0
     Interface    : GigabitEthernet1/0/1                Flags        : D   
    

配置文件

DS-Lite设备的配置文件

#                                                                               
sysname BRAS                                                                
#
license
 active ds-lite vsuf slot 1
 active nat session-table size 16 slot 1 engine 0
#
radius-server group rd1
 radius-server authentication 192.168.7.249 1645 weight 0
 radius-server accounting 192.168.7.249 1646 weight 0
 radius-server shared-key itellin
 radius-server type plus11
 radius-server traffic-unit kbyte
#
interface Virtual-Template1
 ppp authentication-mode auto
#
interface GigabitEthernet1/0/0                                                  
 undo shutdown                                                                  
 ipv6 enable                                                                    
 isis ipv6 enable 1000 
# 
interface GigabitEthernet1/0/1                                                  
 undo shutdown                                                                                                                                      
 ip address 172.16.1.2 255.255.255.0 
 isis enable 100    
# 
ipv6 prefix pre1 local
 prefix 2001:DB8::/64
#
ipv6 pool pool1 bas local
prefix pre1
dns-server 2001:DB8::1:2      //配置IPv6 DNS服务器地址,DS-Lite场景建议在local地址池下配置DNS服务器地址。当BRAS设备采用ND方式给CPE分配WAN口地址时,必须在PD地址池中配置AFTR名字和DNS信息,否则Ds-lite隧道无法建立。 
aftr-name www.111.com         //配置AFTR名,AFTR即为DS-Lite服务器。在DS-Lite上配置AFTR名称后,还需要将该配置通告给CPE,否则CPE和DS-Lite服务器之间的DS-Lite隧道无法建立。通告方法是在DNS服务器上增加该AFTR名和DS-Lite实例中配置的local-ip地址的对应关系。
#
service-location 1
 location slot 1 engine 0 backup slot 2 engine 0
#
service-instance-group 1
 service-location 1
#                                                                                                                                                                                                                                           
ds-lite instance ds-lite1 id 1
 service-instance-group 1
 ds-lite address-group group1 group-id 1 192.168.160.100 192.168.160.110
 ds-lite outbound 3000 address-group group1
 local-ipv6 2001:DB8::1 prefix-length 128
 remote-ipv6 2001:DB8::2 prefix-length 64
#                                                                                                                                                           
acl ipv6 6001
 rule 1 permit ipv6 source user-group group1 destination ipv6-address 2001:DB8::1 128
#
acl ipv6 3000
 rule 1 permit ipv6 source 2001:DB8::2 64
#                                                                                                                                                             
traffic classifier c1 operator or                                                                                                           
 if-match ipv6 acl 6001                                                                                                                                             
#                                                                               
traffic behavior b1
 ds-lite bind instance ds-lite1                                                             
#                                                                                                                                                   
traffic policy p1                                                               
 share-mode                                                                                                                                  
 classifier c1 behavior b1                                                                                                             
#                                                                               
traffic-policy p1 inbound
#
isis 100  
 network-entity 10.1000.1000.1000.00                                                                     
 import-route unr                                                                                                                                                                                        
#                                                                               
isis 1000                                                                       
 network-entity 10.0000.0000.0002.000                                            
 #                                                                              
 ipv6 enable topology standard                                                  
 ipv6 import-route unr                                                          
 #
#
user-group group1
#
aaa
 authentication-scheme auth1
  authentication-mode radius
#
 accounting-scheme acct1
  accounting-mode radius
#
 domain isp1
  authentication-scheme auth1
  accounting-scheme acct1
  radius-server group rd1
  ipv6-pool pool1
  user-group group1 bind ds-lite instance ds-lite1
#                                                                                                                                                            
return
下载文档
更新时间:2018-07-12

文档编号:EDOC1100028549

浏览量:19968

下载量:205

平均得分:
本文档适用于这些产品
相关文档
相关版本
Share
上一页 下一页