所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

NE40E V800R010C00 配置指南 - NAT与IPv6过渡技术 01

评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
配置IPv6 over IPv4手动隧道示例

配置IPv6 over IPv4手动隧道示例

本举例介绍IPv6 over IPv4手动隧道的配置过程。

组网需求

图7-1所示,两个IPv6网络分别通过DeviceA和DeviceC与IPv4骨干网络中的DeviceB连接,要求在DeviceA和DeviceC之间配置IPv6 over IPv4手动隧道,使两个IPv6网络可以互通。

图7-1  配置IPv6 over IPv4手动隧道组网图
说明:

本例中interface1,interface2分别代表GE1/0/0,GE2/0/0



配置注意事项

在配置过程中,需要注意以下事项:

  • 首先创建Tunnel接口,然后才能配置Tunnel的其他参数。

  • 在Tunnel两端的路由设备上都需要进行下列配置,需要注意的是,本端Tunnel的源地址就是对端Tunnel的目的地址,本端Tunnel的目的地址就是对端Tunnel的源地址。

  • 为了支持路由协议,也需要配置Tunnel接口的网络地址。

配置思路

配置IPv6 over IPv4手动隧道的思路如下:

  1. 配置物理接口的IP地址

  2. 配置隧道接口的IPv6地址、源接口、目的地址

  3. 配置协议类型为IPv6-IPv4

数据准备

为完成此配置例,需准备如下的数据:

  • 接口的IP地址

  • 隧道的IPv6地址、源接口和目的地址

操作步骤

  1. 配置DeviceA

    # 配置接口的IP地址。

    <HUAWEI> system-view
    [~HUAWEI] sysname DeviceA
    [*HUAWEI] commit
    [~DeviceA] interface gigabitethernet 1/0/0
    [~DeviceA-GigabitEthernet1/0/0] ip address 192.168.50.2 255.255.255.0
    [*DeviceA-GigabitEthernet1/0/0] undo shutdown
    [*DeviceA-GigabitEthernet1/0/0] quit

    # 配置协议类型为IPv6-IPv4。

    [*DeviceA] interface Tunnel 10
    [*DeviceA-Tunnel10] tunnel-protocol ipv6-ipv4

    # 配置隧道接口的IPv6地址、源接口、目的地址。

    [*DeviceA-Tunnel10] ipv6 enable
    [*DeviceA-Tunnel10] ipv6 address 2001:db8::1 64
    [*DeviceA-Tunnel10] source 192.168.50.2
    [*DeviceA-Tunnel10] destination 192.168.51.2
    [*DeviceA-Tunnel10] quit

    # 配置静态路由。

    [*DeviceA] ip route-static 192.168.51.2 255.255.255.0 192.168.50.1
    [*DeviceA] commit

  2. 配置DeviceB

    # 配置接口的IP地址。

    <HUAWEI> system-view
    [~HUAWEI] sysname DeviceB
    [*HUAWEI] commit
    [~DeviceB] interface gigabitethernet 1/0/0
    [~DeviceB-GigabitEthernet1/0/0] ip address 192.168.50.1 255.255.255.0
    [*DeviceB-GigabitEthernet1/0/0] undo shutdown
    [*DeviceB-GigabitEthernet1/0/0] quit
    [*DeviceB] interface gigabitethernet 2/0/0
    [*DeviceB-GigabitEthernet2/0/0] ip address 192.168.51.1 255.255.255.0
    [*DeviceB-GigabitEthernet2/0/0] undo shutdown
    [*DeviceB-GigabitEthernet2/0/0] commit
    [~DeviceB-GigabitEthernet2/0/0] quit

  3. 配置DeviceC

    # 配置接口的IP地址。

    <HUAWEI> system-view
    [~HUAWEI] sysname DeviceC
    [*HUAWEI] commit
    [~DeviceC] interface gigabitethernet 1/0/0
    [~DeviceC-GigabitEthernet1/0/0] ip address 192.168.51.2 255.255.255.0
    [*DeviceC-GigabitEthernet1/0/0] undo shutdown
    [*DeviceC-GigabitEthernet1/0/0] quit

    # 配置协议类型为IPv6-IPv4。

    [*DeviceC] interface Tunnel 10
    [*DeviceC-Tunnel10] tunnel-protocol ipv6-ipv4

    # 配置隧道接口的IPv6地址、源接口、目的地址。

    [*DeviceC-Tunnel10] ipv6 enable
    [*DeviceC-Tunnel10] ipv6 address 2001:db8::2 64
    [*DeviceC-Tunnel10] source 192.168.51.2
    [*DeviceC-Tunnel10] destination 192.168.50.2
    [*DeviceC-Tunnel10] quit

    # 配置静态路由。

    [*DeviceC] ip route-static 192.168.50.2 255.255.255.0 192.168.51.1
    [*DeviceC] commit

  4. 检查配置结果

    # 在DeviceC上Ping DeviceA的接口GE1/0/0的IPv4地址,可收到返回的报文。

    [~DeviceC] ping 192.168.50.2
      PING 192.168.50.2: 56  data bytes, press CTRL_C to break
        Reply from 192.168.50.2: bytes=56 Sequence=1 ttl=254 time=84 ms
        Reply from 192.168.50.2: bytes=56 Sequence=2 ttl=254 time=27 ms
        Reply from 192.168.50.2: bytes=56 Sequence=3 ttl=254 time=25 ms
        Reply from 192.168.50.2: bytes=56 Sequence=4 ttl=254 time=3 ms
        Reply from 192.168.50.2: bytes=56 Sequence=5 ttl=254 time=24 ms
      --- 192.168.50.2 ping statistics ---
        5 packet(s) transmitted
        5 packet(s) received
        0.00% packet loss
        round-trip min/avg/max = 3/32/84 ms

    # 在DeviceC上Ping隧道的DeviceA接口Tunnel1的IPv6地址,可收到返回的报文。

    [~DeviceC] ping ipv6 2001:db8::1
      PING 2001:db8::1 : 56  data bytes, press CTRL_C to break
        Reply from 2001:db8::1
        bytes=56 Sequence=1 hop limit=64  time = 28 ms
        Reply from 2001:db8::1
        bytes=56 Sequence=2 hop limit=64  time = 27 ms
        Reply from 2001:db8::1
        bytes=56 Sequence=3 hop limit=64  time = 26 ms
        Reply from 2001:db8::1
        bytes=56 Sequence=4 hop limit=64  time = 27 ms
        Reply from 2001:db8::1
        bytes=56 Sequence=5 hop limit=64  time = 26 ms
      --- 2001:db8::1 ping statistics ---
        5 packet(s) transmitted
        5 packet(s) received
        0.00% packet loss
    round-trip min/avg/max = 26/26/28 ms

配置文件

  • DeviceA的配置文件

    #
     sysname DeviceA
    #
    interface GigabitEthernet1/0/0
     undo shutdown
     ip address 192.168.50.2 255.255.255.0
    #
    interface Tunnel 10
     ipv6 enable
     ipv6 address 2001:db8::1/64
     tunnel-protocol ipv6-ipv4
     source 192.168.50.2
     destination 192.168.51.2
    #
    ip route-static 192.168.51.0 255.255.255.0 192.168.50.1
    #
    return
  • DeviceB的配置文件

    #
     sysname DeviceB
    #
    interface GigabitEthernet1/0/0
     undo shutdown
     ip address 192.168.50.1 255.255.255.0
    #
    interface GigabitEthernet2/0/0
     undo shutdown
     ip address 192.168.51.1 255.255.255.0
    #
    return
  • DeviceC的配置文件

    #
     sysname DeviceC
    #
    interface GigabitEthernet1/0/0
     undo shutdown
     ip address 192.168.51.2 255.255.255.0
    #
    interface Tunnel 10
     ipv6 enable
     ipv6 address 2001:db8::2/64
     tunnel-protocol ipv6-ipv4
     source 192.168.51.2
     destination 192.168.50.2
    #
    ip route-static 192.168.50.0 255.255.255.0 192.168.51.1
    #
    return
下载文档
更新时间:2018-07-12

文档编号:EDOC1100028549

浏览量:19891

下载量:204

平均得分:
本文档适用于这些产品
相关文档
相关版本
Share
上一页 下一页