所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

NE40E V800R010C00 配置指南 - NAT与IPv6过渡技术 01

评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
配置6to4隧道示例

配置6to4隧道示例

本举例介绍6to4隧道的配置过程。

组网需求

图7-2所示,两个IPv6网络都是6to4网络,DeviceA和DeviceB分别与相应的6to4网络以及IPv4骨干网络相连,要求在DeviceA和DeviceB之间配置6to4隧道,以便两个6to4网络内的主机可以互通。

为了让6to4网络之间互通,需要为6to4网络内的主机配置6to4地址。6to4地址的前缀是2002:IPv4地址:,前缀长度为48bits。如图7-2所示,DeviceA与IPv4网络连接的接口的IPv4地址是1.1.1.1,则DeviceA所在的6to4网络的6to4地址前缀应该是2002:0101:0101::,前缀长度为64。

图7-2  配置6to4隧道组网图
说明:

本例中interface1,interface2分别代表GE1/0/0,GE2/0/0



配置注意事项

在配置过程中,需要注意以下事项:

  • 首先创建Tunnel接口,然后才能配置Tunnel的其他参数。

  • 在配置6to4隧道时,只需确定Tunnel的源,Tunnel的目的地址是从原始的IPv6报文的目的地址中获取的。但两个6to4隧道的源不允许相同。

  • 在边界路由设备与6to4网络相连的接口上必须配置6to4地址,在边界路由设备与IPv4网络相连的接口上必须配置IPv4地址。为了支持路由协议,也需要配置Tunnel接口的网络地址。

配置思路

配置6to4隧道的思路如下:

  1. 在路由设备上配置IPv4/IPv6双协议栈

  2. 在路由设备上配置6to4隧道

  3. 在路由设备上配置相关路由

数据准备

为完成此配置例,需准备如下的数据:

  • 接口的IPv4地址和IPv6地址

  • 隧道的源接口

操作步骤

  1. 配置DeviceA

    # 配置IPv4/IPv6双协议栈。

    <HUAWEI> system-view
    [~HUAWEI] sysname DeviceA
    [*HUAWEI] commit
    [~DeviceA] interface GigabitEthernet 1/0/0
    [~DeviceA-GigabitEthernet1/0/0] ip address 1.1.1.1 8
    [*DeviceA-GigabitEthernet1/0/0] undo shutdown
    [*DeviceA-GigabitEthernet1/0/0] quit
    [*DeviceA] interface gigabitethernet 2/0/0
    [*DeviceA-GigabitEthernet2/0/0] ipv6 enable
    [*DeviceA-GigabitEthernet2/0/0] ipv6 address 2002:0101:0101:1::1 64
    [*DeviceA-GigabitEthernet2/0/0] undo shutdown
    [*DeviceA-GigabitEthernet2/0/0] quit

    # 配置6to4隧道。

    [*DeviceA] interface Tunnel 10
    [*DeviceA-Tunnel10] tunnel-protocol ipv6-ipv4 6to4
    [*DeviceA-Tunnel10] ipv6 enable
    [*DeviceA-Tunnel10] ipv6 address 2002:0101:0101::1 64
    [*DeviceA-Tunnel10] source 1.1.1.1
    [*DeviceA-Tunnel10] quit

    # 配置到其他6to4网络的路由。

    [*DeviceA] ipv6 route-static 2002:: 16 Tunnel 10
    [*DeviceA] commit

  2. 配置DeviceB

    # 配置IPv4/IPv6双协议栈。

    <HUAWEI> system-view
    [~HUAWEI] sysname DeviceB
    [*HUAWEI] commit
    [~DeviceB] interface GigabitEthernet 1/0/0
    [~DeviceB-GigabitEthernet1/0/0] ip address 2.2.2.2 8
    [*DeviceB-GigabitEthernet1/0/0] undo shutdown
    [*DeviceB-GigabitEthernet1/0/0] quit
    [*DeviceB] interface gigabitethernet 2/0/0
    [*DeviceB-GigabitEthernet2/0/0] ipv6 enable
    [*DeviceB-GigabitEthernet2/0/0] ipv6 address 2002:0202:0202:1::1 64
    [*DeviceB-GigabitEthernet2/0/0] undo shutdown
    [*DeviceB-GigabitEthernet2/0/0] quit

    # 配置6to4隧道。

    [*DeviceB] interface Tunnel 10
    [*DeviceB-Tunnel10] tunnel-protocol ipv6-ipv4 6to4
    [*DeviceB-Tunnel10] ipv6 enable
    [*DeviceB-Tunnel10] ipv6 address 2002:0202:0202::1 64
    [*DeviceB-Tunnel10] source 2.2.2.2
    [*DeviceB-Tunnel10] quit

    # 配置到其他6to4网络的路由。

    [*DeviceB] ipv6 route-static 2002:: 16 Tunnel 10
    [*DeviceB] commit
    说明:

    Device A和Device B之间需要有一条可达的路由。在本例中两台路由设备直连,所以没有配置路由协议。

  3. 检查配置结果

    # 在Device A上查看1/0/0的IPv6状态为UP。

    [~DeviceA] display ipv6 interface Tunnel 10
    Tunnel10 current state : UP
    IPv6 protocol current state : UP
    link-local address is FE80::101:101
      Global unicast address(es):
        2002:101:101::1, subnet is 2002:101:101::/64
      Joined group address(es):
        FF02::1:FF01:101
        FF02::1:FF00:1
        FF02::2
        FF02::1
      MTU is 1500 bytes
      ND DAD is enabled, number of DAD attempts: 1.
      ND reachable time is 1200000 milliseconds.
      ND retransmit interval is 1000 milliseconds.
      Hosts use stateless autoconfig for addresses.

    # 从Device A可以Ping通Device B的接口GE2/0/0的6to4地址。

    [~DeviceA] ping ipv6 2002:0202:0202:1::1
      PING 2002:202:202:1::1 : 56  data bytes, press CTRL_C to break 
        Reply from 2002:202:202:1::1
        bytes=56 Sequence=1 hop limit=64 time=37 ms
        Reply from 2002:202:202:1::1
        bytes=56 Sequence=2 hop limit=64 time=2 ms
        Reply from 2002:202:202:1::1
        bytes=56 Sequence=3 hop limit=64 time=8 ms
        Reply from 2002:202:202:1::1
        bytes=56 Sequence=4 hop limit=64 time=1 ms
        Reply from 2002:202:202:1::1
        bytes=56 Sequence=5 hop limit=64 time=2 ms
      ---2002:202:202:1::1 ping statistics---
        5 packet(s) transmitted
        5 packet(s) received
        0.00% packet loss
    round-trip min/avg/max = 4/9/25 ms

配置文件

  • DeviceA的配置文件

    #
     sysname DeviceA
    #
    interface GigabitEthernet1/0/0
     undo shutdown
     ip address 1.1.1.1 255.0.0.0
    #
    interface GigabitEthernet 2/0/0
     undo shutdown
     ipv6 enable
     ipv6 address 2002:101:101:1::1/64
    #
    interface Tunnel 10
     ipv6 enable
     ipv6 address 2002:101:101::1/64
     tunnel-protocol ipv6-ipv4 6to4
     source 1.1.1.1
    #
    ipv6 route-static 2002:: 16 Tunnel 10
    #
    return
  • DeviceB的配置文件

    #
     sysname DeviceB
    #
    interface GigabitEthernet1/0/0
     undo shutdown
     ip address 2.2.2.2 255.0.0.0
    #
    interface GigabitEthernet2/0/0
     undo shutdown
     ipv6 enable
     ipv6 address 2002:202:202:1::1/64
    #
    interface Tunnel 10
     ipv6 enable
     ipv6 address 2002:202:202::1/64
     tunnel-protocol ipv6-ipv4 6to4
     source 2.2.2.2
    #
    ipv6 route-static 2002:: 16 Tunnel 10
    #
    return
下载文档
更新时间:2018-07-12

文档编号:EDOC1100028549

浏览量:21101

下载量:209

平均得分:
本文档适用于这些产品
相关文档
相关版本
Share
上一页 下一页