所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

NE40E V800R010C00 配置指南 - NAT与IPv6过渡技术 01

评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
配置6to4中继示例

配置6to4中继示例

本举例介绍6to4中继的配置过程。

组网需求

图7-3所示,DeviceA为6to4路由设备,其IPv6侧连接的是6to4网络。DeviceB为6to4中继路由设备,它和IPv6的Internet网络(2001:db8::/64)相连。DeviceA和DeviceB通过IPv4骨干网络相连。要求在配置DeviceA和DeviceB之间的6to4隧道,使6to4网络的主机与IPv6网络的主机互通。

6to4中继路由设备与普通6to4路由设备之间的隧道的配置方法与普通6to4路由设备之间的隧道的配置方法相同。但是为了让6to4网络与IPv6网络互访,需要在普通6to4路由设备配置到IPv6网络的静态路由。

图7-3  配置6to4中继组网图
说明:

本例中interface1,interface2分别代表GE1/0/0,GE2/0/0



配置注意事项

在配置过程中,需要注意以下事项:

  • 首先创建Tunnel接口,然后才能配置Tunnel的其他参数。

  • 在配置6to4隧道时,只需确定Tunnel的源,Tunnel的目的地址是从原始的IPv6报文的目的地址中获取的。但两个6to4隧道的源不允许相同。

  • 在边界路由设备与6to4网络相连的接口上必须配置6to4地址,在边界路由设备与IPv4网络相连的接口上必须配置IPv4地址。为了支持路由协议,也需要配置Tunnel接口的网络地址。

配置思路

配置6to4中继思路如下:

  1. 在路由设备上配置IPv4/IPv6双协议栈

  2. 在路由设备上配置6to4隧道

  3. 在路由设备上配置相关的静态路由

数据准备

为完成此配置例,需准备如下的数据:

  • 接口的IPv4地址和IPv6地址

  • 隧道的源接口

  • 到非直连路由设备的静态路由

操作步骤

  1. 配置DeviceA

    # 配置IPv4/IPv6双协议栈。

    <HUAWEI> system-view
    [~HUAWEI] sysname DeviceA
    [*HUAWEI] commit
    [~DeviceA] interface GigabitEthernet 1/0/0
    [~DeviceA-GigabitEthernet1/0/0] ip address 1.1.1.1 255.0.0.0
    [*DeviceA-GigabitEthernet1/0/0] undo shutdown
    [*DeviceA-GigabitEthernet1/0/0] quit
    [*DeviceA] interface gigabitethernet 2/0/0
    [*DeviceA-GigabitEthernet2/0/0] ipv6 enable
    [*DeviceA-GigabitEthernet2/0/0] ipv6 address 2002:0101:0101:1::1 64
    [*DeviceA-GigabitEthernet2/0/0] undo shutdown
    [*DeviceA-GigabitEthernet2/0/0] quit

    # 配置6to4隧道。

    [*DeviceA] interface Tunnel10
    [*DeviceA-Tunnel10] tunnel-protocol ipv6-ipv4 6to4
    [*DeviceA-Tunnel10] ipv6 enable
    [*DeviceA-Tunnel10] ipv6 address 2002:0101:0101::1 64
    [*DeviceA-Tunnel10] source 1.1.1.1
    [*DeviceA-Tunnel10] quit

    # 配置到2002::/16的静态路由。

    [*DeviceA] ipv6 route-static 2002:: 16 Tunnel10

    # 配置到本地IPv6网络的缺省路由。

    [*DeviceA] ipv6 route-static :: 0 2002:0202:0202::1
    [*DeviceA] commit

  2. 配置DeviceB

    # 配置IPv4/IPv6双协议栈。

    <HUAWEI> system-view
    [~HUAWEI] sysname DeviceB
    [*HUAWEI] commit
    [~DeviceB] interface GigabitEthernet 1/0/0
    [~DeviceB-GigabitEthernet1/0/0] ip address 2.2.2.2 255.0.0.0
    [*DeviceB-GigabitEthernet1/0/0] undo shutdown
    [*DeviceB-GigabitEthernet1/0/0] quit
    [*DeviceB] interface gigabitethernet 2/0/0
    [*DeviceB-GigabitEthernet2/0/0] ipv6 enable
    [*DeviceB-GigabitEthernet2/0/0] ipv6 address 2001:db8::1 64
    [*DeviceB-GigabitEthernet2/0/0] undo shutdown
    [*DeviceB-GigabitEthernet2/0/0] quit

    # 配置6to4隧道。

    [*DeviceB] interface Tunnel 10
    [*DeviceB-Tunnel10] tunnel-protocol ipv6-ipv4 6to4
    [*DeviceB-Tunnel10] ipv6 enable
    [*DeviceB-Tunnel10] ipv6 address 2002:0202:0202::1 64
    [*DeviceB-Tunnel10] source 2.2.2.2
    [*DeviceB-Tunnel10] quit

    # 配置到2002::/16的静态路由。

    [*DeviceB] ipv6 route-static 2002:: 16 Tunnel10
    [*DeviceB] commit

  3. 检查配置结果

    # 从DeviceA可以Ping通DeviceB的接口GE2/0/0的IPv6地址。

    [~DeviceA] ping ipv6 2001:db8::1
      PING 2001:db8::1 : 56  data bytes, press CTRL_C to break
        Reply from 2001:db8::1
        bytes=56 Sequence=1 hop limit=64 time=10 ms
        Reply from 2001:db8::1
        bytes=56 Sequence=2 hop limit=64 time=2 ms
        Reply from 2001:db8::1
        bytes=56 Sequence=3 hop limit=64 time=2 ms
        Reply from 2001:db8::1
        bytes=56 Sequence=4 hop limit=64 time=2 ms
        Reply from 2001:db8::1
        bytes=56 Sequence=5 hop limit=64 time=2 ms
      --- 2001:db8::1 ping statistics ---
        5 packet(s) transmitted
        5 packet(s) received
        0.00% packet loss
    round-trip min/avg/max = 5/14/29 ms

配置文件

  • DeviceA的配置文件

    #
    sysname DeviceA
    #
    admin
    interface GigabitEthernet1/0/0
     undo shutdown
     ip address 1.1.1.1 255.0.0.0
    #
    interface GigabitEthernet2/0/0
     undo shutdown
     ipv6 enable
     ipv6 address 2002:101:101:1::1/64
    #
    interface Tunnel 10
     ipv6 enable
     ipv6 address 2002:101:101::1/64
     tunnel-protocol ipv6-ipv4 6to4
     source 1.1.1.1
    #
    ipv6 route-static :: 0 2002:202:202::1
    #
    ipv6 route-static 2002:: 16 Tunnel 10
    #
    return
  • DeviceB的配置文件

    #
    sysname DeviceB
    #
    admin
    interface GigabitEthernet1/0/0
     undo shutdown
     ip address 2.2.2.2 255.0.0.0
    #
    interface GigabitEthernet2/0/0
     undo shutdown
     ipv6 enable
     ipv6 address 2001:db8::1/64
    #
    interface Tunnel 10
     ipv6 enable
     ipv6 address 2002:202:202::1/64
     tunnel-protocol ipv6-ipv4 6to4
     source 2.2.2.2
    #
    ipv6 route-static 2002:: 16 Tunnel 10
    #
    return
下载文档
更新时间:2018-07-12

文档编号:EDOC1100028549

浏览量:21203

下载量:212

平均得分:
本文档适用于这些产品
相关文档
相关版本
Share
上一页 下一页