所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

NE40E V800R010C00 配置指南 - 用户接入 01

评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
VLL接入BRAS用户到Internet公网示例

VLL接入BRAS用户到Internet公网示例

组网需求

图7-9所示,PE1、P、PE2组成Martini方式的VLL骨干网,其中路由器作为PE2和BRAS设备。BRAS用户通过VLL接入Internet公网。在路由器上创建两个虚拟以太网接口VE5/0/0和VE5/0/1,其中VE5/0/0接口用来终结VLL,VE5/0/1作为BAS接口,用户提供接入认证。需求如下:

  • 用户归属于isp1域,以PPPoEoVoQ方式、通过VE5/0/1.1子接口接入Internet公网。

  • 通过地址池pool1为用户分配IP地址,其中地址池网段为172.82.1.2~172.82.1.200。

  • 采用RADIUS认证和RADIUS计费。RADIUS服务器地址为192.168.7.249,认证和计费端口分别是1812和1813,采用RADIUS+1.1协议,密钥为itellin。

  • DNS服务器地址为192.168.7.252。

  • 计费方案为actt1,认证方案为auth1。

图7-9  VLL接入BRAS用户到Internet组网图

配置思路

采用如下思路配置VLL接入BRAS用户到Internet:

  1. 路由器创建用来终结VLL的VE接口和用来接入Internet公网的VE接口。并绑定在同一个VE-Group。

  2. 配置VLL。

  3. 使能VLL接入。

  4. 配置BRAS接入,其中VE5/0/1接口作为BAS接口。

数据准备

完成本例配置,需准备如下数据:

  • VE-Group号。

  • PE及P上的MPLS LSR ID为各自Loopback1的IP地址。

配置步骤

  1. 路由器上创建两个VE接口,并绑定到同一个VE-Group

    # 创建VE5/0/0接口,用来终结VLL。

    <HUAWEI> system-view
    [~HUAWEI] sysname PE2
    [*PE2] commit
    [~PE2] interface virtual-ethernet5/0/0
    [*PE2-Virtual-Ethernet5/0/0] ve-group 1 l2-terminate
    [*PE2-Virtual-Ethernet5/0/0] quit
    [*PE2] commit

    # 创建VE5/0/1接口,用来接入Internet公网。

    [~PE2] interface virtual-ethernet5/0/1
    [*PE2-Virtual-Ethernet5/0/1] ve-group 1 l3-access
    [*PE2-Virtual-Ethernet5/0/1] quit
    [*PE2] commit
  2. 配置VLL

    # 在VLL骨干网上配置IGP,本示例中使用OSPF。

    按配置PE和P的各接口地址,配置OSPF时,注意需要发布PE1、P和PE2的32位Loopback接口地址。

    具体配置过程略。

    # 在MPLS骨干网上配置MPLS基本能力和LDP。

    • 配置PE1

    <HUAWEI> system-view
    [~HUAWEI] sysname PE1
    [*PE2] commit
    [~PE1] mpls lsr-id 1.1.1.9
    [*PE1] mpls
    [*PE1-mpls] quit
    [*PE1] mpls ldp
    [*PE1-mpls-ldp] quit
    [*PE1] commit
    [~PE1] interface gigabitethernet1/0/0
    [*PE1-GigabitEthernet1/0/0] mpls
    [*PE1-GigabitEthernet1/0/0] mpls ldp
    [*PE1-GigabitEthernet1/0/0] undo shutdown
    [*PE1-GigabitEthernet1/0/0] quit
    [*PE1] commit
    [~PE1] quit
    • 配置P

    <HUAWEI> system-view
    [~HUAWEI] sysname P
    [*P] commit
    [~P] mpls lsr-id 2.2.2.9
    [*P] mpls
    [*P-mpls] quit
    [*P] commit
    [~P] mpls ldp
    [*P-mpls-ldp] quit
    [*P] interface gigabitethernet1/0/0
    [*P-GigabitEthernet1/0/0] mpls
    [*P-GigabitEthernet1/0/0] mpls ldp
    [*P-GigabitEthernet1/0/0] undo shutdown
    [*P-GigabitEthernet1/0/0] quit
    [*P] commit
    [~P] interface gigabitethernet2/0/0
    [*P-GigabitEthernet2/0/0] mpls
    [*P-GigabitEthernet2/0/0] mpls ldp
    [*P-GigabitEthernet2/0/0] undo shutdown
    [*P-GigabitEthernet2/0/0] quit
    [*P] commit
    [~P] quit
    • 配置PE2

    [~PE2] mpls lsr-id 3.3.3.9
    [*PE2] mpls
    [*PE2-mpls] quit
    [*PE2] commit
    [~PE2] mpls ldp
    [*PE2-mpls-ldp] quit
    [*PE2] commit
    [~PE2] interface gigabitethernet5/0/0
    [*PE2-GigabitEthernet5/0/0] mpls
    [*PE2-GigabitEthernet5/0/0] mpls ldp
    [*PE2-GigabitEthernet5/0/0] undo shutdown
    [*PE2-GigabitEthernet5/0/0] quit
    [*PE2] commit
    [~PE2] quit

    # 在PE之间建立远端LDP会话。

    • 配置PE1

    [~PE1] mpls ldp remote-peer pe2
    [*PE1-mpls-ldp-remote-1] remote-ip 3.3.3.9
    [*PE1-mpls-ldp-remote-1] quit
    [*PE1] commit
    [~PE1] quit
    • 配置PE2

    [~PE2] mpls ldp remote-peer pe1
    [*PE2-mpls-ldp-remote-1] remote-ip 1.1.1.9
    [*PE2-mpls-ldp-remote-1] quit
    [*PE2] commit
    [~PE2] quit

    # 在PE上使能VLL,并创建静态VC连接。

    • 配置PE1:在接入CE的接口GigabitEthernet1/0/0上创建L2VC

    [~PE1] mpls l2vpn
    [*PE1-l2vpn] quit
    [*PE1] commit
    [~PE1] interface gigabitethernet 5/0/0.1
    [*PE1-GigabitEthernet5/0/0.1] vlan-type dot1q 1
    [*PE1-GigabitEthernet5/0/0.1] mpls l2vc 3.3.3.9 101
    [*PE1-GigabitEthernet5/0/0.1] undo shutdown
    [*PE1-GigabitEthernet5/0/0.1] quit
    [*PE1] commit
    [~PE1] quit
    • 配置PE2:在VE2/0/0上创建L2VC

    [~PE2] mpls l2vpn
    [*PE2-l2vpn] quit
    [*PE2] commit
    [~PE2] interface virtual-ethernet5/0/0.1
    [*PE2-Virtual-Ethernet5/0/0.1] vlan-type dot1q 1
    [*PE2-Virtual-Ethernet5/0/0.1] mpls l2vc 1.1.1.9 101
    [*PE2-Virtual-Ethernet5/0/0.1] quit
    [*PE2] commit
    [~PE2] quit

    # 验证配置结果。

    在PE上查看L2VPN连接信息,可以看到建立了一条L2VC,状态为Up。

    以PE2的显示为例:

    [~PE2] display mpls l2vc
    Total ldp vc : 1     1 up       0 down
     *Client Interface     : Virtual-Ethernet5/0/0
      Session State        : up
      AC Status            : up
      VC State             : up
      VC ID                : 101
      VC Type              : ethernet
      Destination          : 1.1.1.9
      Local VC Label       : 1025
      Remote VC Label      : 1024
      Control Word         : Disable
      Local VC MTU         : 1500
      Romete VC MTU        : 1500
      Tunnel Policy Name   : --
      Traffic Behavior Name: --
      PW Template Name     : --
      Create time          : 0 days, 0 hours, 3 minutes, 14 seconds
      UP time              : 0 days, 0 hours, 1 minutes, 48 seconds
      Last change time     : 0 days, 0 hours, 1 minutes, 48 seconds
  3. 配置BRAS接入,VE5/0/1为BAS接口,为用户提供接入Internet服务

    # 配置虚模板接口。

    [~PE2] interface virtual-template 1
    [*PE2-Virtual-Template1] ppp authentication-mode chap
    [*PE2-Virtual-Template1] quit
    [*PE2] commit

    # 配置认证方案。

    [~PE2] aaa
    [*PE2-aaa] authentication-scheme auth1
    [*PE2-aaa-authen-auth1] authentication-mode radius
    [*PE2-aaa-authen-auth1] quit
    [*PE2] commit

    # 配置计费方案。

    [~PE2-aaa] accounting-scheme acct1
    [*PE2-aaa-accounting-acct1] accounting-mode radius
    [*PE2-aaa-accounting-acct1] quit
    [*PE2-aaa] quit
    [*PE2] commit

    # 配置RADIUS服务器组。

    [~PE2] radius-server group rd1
    [*PE2-radius-rd1] radius-server authentication 192.168.7.249 1812
    [*PE2-radius-rd1] radius-server accounting 192.168.7.249 1813
    [*PE2-radius-rd1] radius-server type plus11
    [*PE2-radius-rd1] radius-server shared-key itellin
    [*PE2-radius-rd1] quit
    [*PE2] commit

    # 配置地址池。

    [~PE2] ip pool pool1 bas local
    [*PE2-ip-pool-pool1] gateway 172.82.1.1 255.255.255.0
    [*PE2-ip-pool-pool1] section 0 172.82.1.2 172.82.1.200
    [*PE2-ip-pool-pool1] dns-server 192.168.7.252
    [*PE2-ip-pool-pool1] quit
    [*PE2] commit

    # 配置isp1域。

    [~PE2] aaa
    [*PE2-aaa] domain isp1
    [*PE2-aaa-domain-isp1] authentication-scheme auth1
    [*PE2-aaa-domain-isp1] accounting-scheme acct1
    [*PE2-aaa-domain-isp1] radius-server group rd1
    [*PE2-aaa-domain-isp1] quit
    [*PE2] commit

    # 为VE2接口指定虚模板接口。

    [~PE2] interface virtual-ethernet5/0/1
    [*PE2-Virtual-Ethernet5/0/1] pppoe-server bind virtual-template 1
    [*PE2-Virtual-Ethernet5/0/1] quit
    [*PE2] commit

    # 配置BAS接口

    [~PE2] interface virtual-ethernet5/0/1.1
    [*PE2-Virtual-Ethernet5/0/1.1] user-vlan 1 2 qinq 100
    [*PE2-Virtual-Ethernet5/0/1.1.1-vlan-1-2-QinQ-100] quit
    [*PE2-Virtual-Ethernet5/0/1.1] commit
    [~PE2-Virtual-Ethernet5/0/1.1] bas
    [*PE2-Virtual-Ethernet5/0/1.1-bas] access-type layer2-subscriber
    [*PE2-Virtual-Ethernet5/0/1.1-bas] authentication-method ppp
    [*PE2-Virtual-Ethernet5/0/1.1-bas] quit
    [*PE2-Virtual-Ethernet5/0/1.1] commit
    [~PE2-Virtual-Ethernet5/0/1.1] quit

    # 配置上行接口。

    [~PE2] interface GigabitEthernet 1/0/0
    [*PE2-GigabitEthernet1/0/0] ip address 2.1.1.2 255.255.255.0
    [*PE2-GigabitEthernet1/0/0] undo shutdown
    [*PE2-GigabitEthernet1/0/0] quit
    [*PE2] commit

配置文件

  • PE1的配置文件

    #
     sysname PE1
    #
     mpls lsr-id 1.1.1.9
     mpls
    #
     mpls l2vpn
    #
    mpls ldp
    #
    interface GigabitEthernet1/0/0
     undo shutdown
     ip address 10.1.1.1 255.255.255.0
     mpls
     mpls ldp
    #
     mpls ldp remote-peer pe2
     remote-ip 3.3.3.9
    #
    interface GigabitEthernet5/0/0.1
     vlan-type dot1q 1
     mpls l2vc 3.3.3.9 101
    #
    interface LoopBack1
     ip address 1.1.1.9 255.255.255.255
    #
    ospf 1
     area 0.0.0.0
      network 10.1.1.0 0.0.0.255
      network 1.1.1.9 0.0.0.0
    #
    return
  • P的配置文件

    #
     sysname P
    #
     mpls lsr-id 2.2.2.9
     mpls
    #
    mpls ldp
    #
    interface GigabitEthernet1/0/0
     undo shutdown
     ip address 10.1.1.2 255.255.255.0
     mpls
     mpls ldp
    #
    interface GigabitEthernet2/0/0
     undo shutdown
     ip address 10.2.1.1 255.255.255.0
     mpls
     mpls ldp
    #
    interface LoopBack1
     ip address 2.2.2.9 255.255.255.255
    #
    ospf 1
     area 0.0.0.0
      network 10.1.1.0 0.0.0.255
      network 10.2.1.0 0.0.0.255
      network 2.2.2.9 0.0.0.0
    #
    return
  • PE2的配置文件

    #
     sysname PE2
    #
    radius-server group rd1
     radius-server authentication 192.168.7.249 1645 weight 0
     radius-server accounting 192.168.7.249 1646 weight 0
     radius-server shared-key itellin
     radius-server type plus11
     radius-server traffic-unit kbyte
    #
    mpls lsr-id 3.3.3.9
     mpls
    #
     mpls l2vpn
    #
    mpls ldp
    #
     mpls ldp remote-peer pe1
      remote-ip 1.1.1.9
    #
    interface Virtual-Template1
     ppp authentication-mode chap
    #
    interface GigabitEthernet1/0/0
     undo shutdown
     ip address 2.1.1.2 255.255.255.0
    #  
    interface GigabitEthernet5/0/0
     undo shutdown
     ip address 10.2.1.2 255.255.255.0
     mpls
     mpls ldp
    #
    interface Virtual-Ethernet5/0/0
     undo shutdown
     ve-group 1 l2-terminate
    #  
    interface Virtual-Ethernet5/0/0.1
     vlan-type dot1q 1
     mpls l2vc 1.1.1.9 101
    #
    interface Virtual-Ethernet5/0/1
     undo shutdown
     ve-group 1 l3-access
    #
    interface Virtual-Ethernet5/0/1.1
     undo shutdown
     user-vlan 1 2 qinq 100
     bas
      access-type layer2-subscriber
      authentication-method ppp
    #
    interface LoopBack1
     ip address 3.3.3.9 255.255.255.255
    #  
    ip pool pool1 bas local
     gateway 172.82.1.1 255.255.255.0
     section 0 172.82.1.2 172.82.1.200
     dns-server  192.168.7.252
    #
    aaa
    authentication-scheme  auth1
    accounting-scheme  acct1
    domain  isp1
     authentication-scheme auth1
     accounting-scheme acct1
     radius-server group rd1
     ip-pool pool1
    #
    ospf 1
     area 0.0.0.0
      network 10.2.1.0 0.0.0.255
      network 3.3.3.9 0.0.0.0  
    #
    return
下载文档
更新时间:2018-07-12

文档编号:EDOC1100028564

浏览量:16404

下载量:207

平均得分:
本文档适用于这些产品
相关文档
相关版本
分享
上一页 下一页