所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

NE40E V800R010C00 配置指南 - 用户接入 01

评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
配置vCPE示例

配置vCPE示例

介绍一个vCPE示例,结合配置组网图来理解业务的配置过程。配置示例包括组网需求、思路准备、操作步骤和配置文件。

组网需求

用户端的CPE设备不再提供地址分配、地址转换(NAT)等功能,CPE只承担二层功能,各用户终端直接向运营商设备(BRAS/DHCP server/Radius Server)等请求地址,由运营商设备完成用户终端私网地址和公网地址之间的转换。家庭用户和增值服务器(VSP)在同一个二层网路,并且在同一个VSI中。

图9-6  配置vCPE功能组网图

配置思路

在设备上部署vCPE功能,配置思路如下:
  1. 配置BAS基本功能

  2. 配置GRE隧道

  3. 配置session group

  4. 配置GRE Tunnel接口vCPE模式

  5. 配置GRE隧道组

  6. 配置用户地址池

  7. 配置VSI

  8. 配置VSI绑定到用户接入接口和VSP服务器接口

  9. 配置BAS接口vCPE功能

  10. 配置上行接口终结和透传功能

数据准备

为完成此配置例,需准备如下的数据:

  • RADIUS服务器组名称,RADIUS认证服务器和RADIUS计费服务器的IP地址、端口号

  • 认证模板的名称和认证方式

  • 计费模板的名称和计费方式

  • 地址池名称

  • 域名称

  • GRE隧道组名称

  • session group名称

操作步骤

  1. 配置AAA方案

    # 配置认证方案。

    <HUAWEI> system-view
    [~HUAWEI] aaa
    [~HUAWEI-aaa] authentication-scheme auth2
    [*HUAWEI-aaa-authen-auth2] authentication-mode radius
    [*HUAWEI-aaa-authen-auth2] quit
    [*HUAWEI-aaa] commit

    # 配置计费方案

    [~HUAWEI-aaa] accounting-scheme acct2
    [*HUAWEI-aaa-accounting-acct2] accounting-mode radius
    [*HUAWEI-aaa-accounting-acct2] quit
    [*HUAWEI-aaa] quit
    [*HUAWEI] commit

  2. 配置RADIUS服务器组

    [~HUAWEI] radius-server group rd2
    [*HUAWEI-radius-rd2] radius-server authentication 192.168.8.249 1812
    [*HUAWEI-radius-rd2] radius-server accounting 192.168.8.249 1813
    [*HUAWEI-radius-rd2] radius-server shared-key-cipher %#%#nxI_5dBV`1c>#OFGFh{MNjbcXl$10Ya1/CDk48B-%#% 
    [*HUAWEI-radius-rd2] quit
    [*HUAWEI] commit

  3. 配置DHCPv4服务器组

    [~HUAWEI] dhcp-server group group1
    [*HUAWEI-dhcp-server-group-group1] dhcp-server 10.1.1.1
    [*HUAWEI-dhcp-server-group-group1] quit
    [*HUAWEI] commit
    说明:

    如果DHCP Server回应报文的目的ip是网关地址,需要配置一个Loopback接口,这个Loopback接口的IP地址为192.168.1.1,掩码为255.255.255.255。.

  4. 配置地址池

    [~HUAWEI] ip pool pool2 bas remote overlap
    [*HUAWEI-ip-pool-pool2] dhcp-server group group1
    [*HUAWEI-ip-pool-pool2] quit
    [*HUAWEI-ip-pool-pool2] commit

  5. 配置session group

    [~HUAWEI] access session-group template tp1
    [*HUAWEI-session-group-tp1] grouping-identifier include pevlan cevlan
    [*HUAWEI-session-group-tp1] service-mode vcpe
    [*HUAWEI-session-group-tp1] quit
    [*HUAWEI-session-group-tp1] commit

  6. 配置GRE

    GRE隧道连通配置具体请参见GRE配置手册,此处略。配置vCPE用户经过GRE隧道进行公私网地址转换,需要进行如下配置:

    [~HUAWEI] interface tunnel 1
    [*HUAWEI-Tunnel1] tunnel-protocol gre
    [*HUAWEI-Tunnel1] ip address 40.1.1.2 255.255.255.0
    [*HUAWEI-Tunnel1] source 30.1.1.2
    [*HUAWEI-Tunnel1] destination 20.1.1.1
    [*HUAWEI-Tunnel1] gre mode vcpe
    [*HUAWEI-Tunnel1] quit
    [*HUAWEI] commit

  7. 配置GRE隧道组

    [~HUAWEI]  gre-group group1 mode vcpe
    [*HUAWEI-gre-group-group1] interface tunnel 1 master
    [*HUAWEI-gre-group-group1]  quit
    [*HUAWEI]  commit

  8. 配置域

    [~HUAWEI] aaa
    [~HUAWEI-aaa] domain isp2
    [*HUAWEI-aaa-domain-isp2] authentication-scheme auth2
    [*HUAWEI-aaa-domain-isp2] accounting-scheme acct2
    [*HUAWEI-aaa-domain-isp2] radius-server group rd2
    [*HUAWEI-aaa-domain-isp2] quit
    [*HUAWEI-aaa] quit
    [*HUAWEI] commit

  9. 创建VSI

    [~HUAWEI] mpls lsr-id 1.1.1.1
    [*HUAWEI] mpls
    [*HUAWEI-mpls] quit
    [*HUAWEI] mpls l2vpn
    [*HUAWEI-l2vpn] commit
    [~HUAWEI-l2vpn] quit
    [*HUAWEI] vsi v1 vcpe-mode
    [*HUAWEI-vsi-v1] commit
    [~HUAWEI-vsi-v1] quit

  10. 配置BAS接口

    # 配置vCPE家庭用户接入BAS接口,可对该家庭提供增值业务。

    [~HUAWEI] interface GigabitEthernet1/0/0.1
    [*HUAWEI-GigabitEthernet1/0/0.1] user-vlan 10 qinq 20
    [*HUAWEI-GigabitEthernet1/0/0.1-vlan-10-10-QinQ-20-20] bas
    [*HUAWEI-GigabitEthernet1/0/0.1-bas] access-type layer2-subscriber default-domain authentication isp2
    [*HUAWEI-GigabitEthernet1/0/0.1-bas] access session-group-template tp1
    [*HUAWEI-GigabitEthernet1/0/0.1-bas] basinfo-insert vcpe version1
    [*HUAWEI-GigabitEthernet1/0/0.1-bas] quit
    [*HUAWEI-GigabitEthernet1/0/0.1] l2 binding vsi v1
    [*HUAWEI-GigabitEthernet1/0/0.1] quit
    [*HUAWEI] commit

    # 配置vCPE家庭用户接入BAS接口,不对这些家庭用户提供增值业务。

    [~HUAWEI] interface GigabitEthernet1/0/0.2
    [*HUAWEI-GigabitEthernet1/0/0.2] user-vlan any-other
    [*HUAWEI-GigabitEthernet1/0/0.2] bas
    [*HUAWEI-GigabitEthernet1/0/0.2-bas] access-type layer2-subscriber default-domain authentication isp2
    [*HUAWEI-GigabitEthernet1/0/0.2-bas] access session-group-template tp1
    [*HUAWEI-GigabitEthernet1/0/0.2-bas] basinfo-insert vcpe version1
    [*HUAWEI-GigabitEthernet1/0/0.2-bas] quit
    [*HUAWEI-GigabitEthernet1/0/0.2] l2 binding vsi v1
    [*HUAWEI-GigabitEthernet1/0/0.2] quit
    [*HUAWEI] commit

  11. 配置网络侧接口,VSP服务器接口绑定VSI

    [~HUAWEI] interface GigabitEthernet2/0/0.1
    [*HUAWEI-GigabitEthernet2/0/0.1] encapsulation qinq-termination
    [*HUAWEI-GigabitEthernet2/0/0.1] qinq termination l2 transparent
    [*HUAWEI-GigabitEthernet2/0/0.1] qinq termination pe-vid 10 ce-vid any 
    [*HUAWEI-GigabitEthernet2/0/0.1] l2 binding vsi v1 
    [*HUAWEI-GigabitEthernet2/0/0.1] commit 
    [*HUAWEI-GigabitEthernet2/0/0.1] quit 

  12. (可选)配置诊断服务器接口

    [~HUAWEI] interface GigabitEthernet2/0/1.1
    [*HUAWEI-GigabitEthernet2/0/1.1] user-vlan 10 qinq 20
    [*HUAWEI-GigabitEthernet2/0/1.1-vlan-10-10-QinQ-20-20] bas
    [*HUAWEI-GigabitEthernet2/0/1.1-bas] access-type layer2-subscriber default-domain authentication isp2
    [*HUAWEI-GigabitEthernet2/0/1.1-bas] access session-group-template tp1
    [*HUAWEI-GigabitEthernet2/0/1.1-bas] basinfo-insert vcpe version1
    [*HUAWEI-GigabitEthernet2/0/1.1-bas] trouble-shooting enable
    [*HUAWEI-GigabitEthernet2/0/1.1-bas] quit
    [*HUAWEI-GigabitEthernet2/0/1.1] l2 binding vsi v1
    [*HUAWEI-GigabitEthernet2/0/1.1] commit

配置文件

  • 路由器的配置文件

    #
     sysname HUAWEI
    
    #
    dhcp-server group group1
     dhcp-server 10.1.1.1
    #
    ip pool pool2 bas remote overlap
      dhcp-server group group1
    #
    access session-group-template tp1
     grouping-identifier include pevlan cevlan
     service-mode vcpe
    #
    aaa
     authentication-scheme auth2
     #
     accounting-scheme acct2
     #
    domain isp2
     authentication-scheme default0
     accounting-scheme default0
     ip-pool pool2
      radius-server group rd2
     #
    interface GigabitEthernet1/0/0.1
     undo shutdown
     user-vlan 10 qinq 20
     l2 binding vsi v1
     bas
     #
      access-type layer2-subscriber default-domain authentication isp2
      access session-group-template tp1
      basinfo-insert vcpe version1
     #
    interface GigabitEthernet1/0/0.2
     undo shutdown
     user-vlan any-other
     l2 binding vsi v1
     bas
     #
      access-type layer2-subscriber default-domain authentication isp2
      access session-group-template tp1
      basinfo-insert vcpe version1
     #
    interface GigabitEthernet2/0/1.1
     undo shutdown
     user-vlan 10 qinq 20
     l2 binding vsi v1
     bas
     #
      access-type layer2-subscriber default-domain authentication isp2
      access session-group-template tp1
      basinfo-insert vcpe version1
      trouble-shooting enable
    #
    interface Tunnel1
     ip address 40.1.1.1 255.255.255.0
     tunnel-protocol gre
     source 20.1.1.1
     destination 30.1.1.2
     gre mode vcpe
    #
    interface GigabitEthernet2/0/0.1
     encapsulation qinq-termination
     qinq termination l2 transparent
     qinq termination pe-vid 10 ce-vid any 
     l2 binding vsi v1
    
    #
    gre-group group1 mode vcpe
     interface tunnel1 master
    #
    interface LoopBack1
     ip address 192.168.1.1 255.255.255.255
    #
    return
下载文档
更新时间:2018-07-12

文档编号:EDOC1100028564

浏览量:16058

下载量:205

平均得分:
本文档适用于这些产品
相关文档
相关版本
分享
上一页 下一页