所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

NE40E V800R010C00 配置指南 - 用户接入 01

评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
配置Client-Initialized场景下的L2TP接入示例

配置Client-Initialized场景下的L2TP接入示例

介绍一个Client-Initialized VPN的配置示例,结合配置组网图来理解业务的配置过程。配置示例包括组网需求、思路准备、操作步骤和配置文件。

组网需求

图10-8所示,VPN用户访问公司总部的过程如下:

  • 出差员工通过PSTN网络连接到接入服务器(NAS),公司总部的LNS侧设备通过Internet与NAS相连。要求由出差员工直接向LNS发起连接请求,与LNS的通讯数据通过隧道Tunnel传输。

  • LNS设备上收到了出差员工的请求之后,根据用户名、密码进行验证,并且给LAC客户分配私有IP地址。

  • 出差员工与公司总部间的通信通过与LNS之间的隧道传输。

  • 用户通过域domain1接入,从地址池pool1获取地址。

图10-8  Client-Initialized场景下的L2TP接入组网图

配置思路

配置Client-Initialized VPN的思路如下:

  1. 用户端安装L2TP客户端软件配置相关参数

  2. 配置LNS

    • 创建虚模板接口
    • 配置L2TP组及属性
    • 配置地址池和域
    • 配置LNS组及属性

数据准备

为完成此配置例,需准备如下的数据:

  • Client和LNS的用户名、口令

  • Loopback地址

  • 地址池名称、地址池网段和地址池网关

  • 用户所在域的域名

说明:

本节只列出了与L2TP相关的配置步骤。

操作步骤

  1. 用户侧的配置

    # 用户侧主机上必须装有L2TP客户端软件,并通过拨号方式连接到Internet。然后再进行如下配置(设置过程与相应的客户端软件有关):
    • 在用户侧设置VPN用户名为vpdnuser,口令为1qaz@WSX。

    • 将LNS的IP地址设为设备的Internet接口地址(本例中LNS侧与通道相连接的接口的IP地址为11.11.11.1)。

    • 修改连接属性,将采用的协议设置为L2TP。

  2. Device(LNS侧)的配置

    # 创建并配置虚拟接口模板。

    <Device> system-view
    [~Device] interface virtual-template 1
    [*Device-Virtual-Template1] ppp authentication-mode chap
    [*Device-Virtual-Template1] commit
    [~Device-Virtual-Template1] quit

    # 使能L2TP服务,创建一个L2TP组。

    [~Device] l2tp enable
    [~Device] l2tp-group lns1

    # 配置LNS侧本端名称及接收的隧道对端名称。

    [*Device-l2tp-lns1] tunnel name LNS
    [*Device-l2tp-lns1] allow l2tp virtual-template 1 remote vpdnuser
    说明:

    除缺省的L2TP组default-lns外,其余的L2TP组在配置LNS侧的连接时都必须指定隧道对端名remote lac-name。如果LAC上送的隧道名和其他所有L2TP组所配置的对端隧道名都不匹配,则使用default-lns作为L2TP组。

    remote lac-name是LAC设备上tunnel name配置的名称,未配置时是设备的主机名。

    # 启用隧道验证并设置隧道验证密码。

    [*Device-l2tp-lns1] tunnel authentication
    [*Device-l2tp-lns1] tunnel password simple 1qaz#EDC
    [*Device-l2tp-lns1] commit
    [~Device-l2tp-lns1] quit
    # 定义一个地址池,为拨入用户分配地址。
    [~Device] ip pool 1 bas local
    [*Device-ip-pool-1] gateway 192.168.0.2 255.255.255.0
    [*Device-ip-pool-1] section 0 192.168.0.10 192.168.0.100
    [*Device-ip-pool-1] commit
    [~Device-ip-pool-1] quit

    # 配置RADIUS服务器。

    [~Device] radius-server group radius1
    [*Device-radius-radius1] radius-server authentication 20.20.20.1 1812
    [*Device-radius-radius1] radius-server accounting 20.20.20.1 1813
    [*Device-radius-radius1] radius-server shared-key itellin
    [*Device-radius-radius1] commit
    [~Device-radius-radius1] quit

    # 配置domain1域。

    [~Device] aaa
    [*Device-aaa] domain domain1
    [*Device-aaa-domain-domain1] authentication-scheme default1
    [*Device-aaa-domain-domain1] accounting-scheme default1
    [*Device-aaa-domain-domain1] radius-server group radius1
    [*Device-aaa-domain-domain1] ip-pool pool1
    [*Device-aaa-domain-domain1] commit
    [~Device-aaa-domain-domain1] quit
    [~Device-aaa] quit

    # 配置环回接口0。

    [~Device] interface loopback 0
    [*Device-LoopBack0] ip address 192.168.10.1 255.255.255.255
    [*Device-LoopBack0] commit
    [~Device-LoopBack0] quit

    # 创建LNS组group1,并为其绑定隧道板和环回接口。

    [~Device] lns-group group1
    [*Device-lns-group-group1] bind slot 1 
    [*Device-lns-group-group1] bind source loopback 0
    [*Device-lns-group-group1] commit
    [~Device-lns-group-group1] quit

  3. 检查配置结果

    # 配置成功后,当该VPN用户上线时,在LNS上执行display l2tp tunnel命令可看到隧道建立成功。

    [~Device] display l2tp tunnel lns slot 1 
    LocalTID RemoteTID RemoteAddress    Port   Sessions RemoteName 
     ------------------------------------------------------------------------------       
    1        1         100.1.1.1        2134   1        vpdnuser
     ------------------------------------------------------------------------------       
    Total 1, 1 printed from slot 1 

    # 在LNS上执行display l2tp session命令可看到会话连接建立情况。

    <Device> display l2tp session lns slot 1 
    LocalSID  RemoteSID  LocalTID   RemoteTID  UserID  UserName                                                                       
     ------------------------------------------------------------------------------                                                     
      278       24768      13921      7958       62172    vpdnuser@domain1                                                                   
     ------------------------------------------------------------------------------       
    Total 1, 1 printed from slot 1 

    # 同时VPN用户可以访问公司总部。

配置文件

Device配置文件

#
 sysname Device
#
 l2tp enable
#
radius-server group radius1
 radius-server authentication 20.20.20.1 1812 
 radius-server accounting 20.20.20.1 1813 
 radius-server shared-key itellin
#
interface Virtual-Template1
 ppp authentication-mode auto 
#
interface GigabitEthernet1/0/0
 undo shutdown 
 ip address 11.11.11.1
#
interface LoopBack0
 ip address 192.168.10.1 255.255.255.255
#
ospf 1
 area 0.0.0.0
  network 202.38.160.0 0.0.0.255
  network 192.168.0.1 0.0.0.0
#
l2tp-group lns1
 allow l2tp virtual-template 1 remote vpdnuser
 tunnel password simple  1qaz#EDC
 tunnel name LNS
#
lns-group group1
 bind slot 1 
 bind source LoopBack0
#
ip pool 1 bas local
 gateway 192.168.0.2 255.255.255.0
 section 0 192.168.0.10 192.168.0.100
#
aaa
domain  domain1 
  authentication-scheme   default1
  accounting-scheme   default1
  radius-server group radius1
  ip-pool   pool1
下载文档
更新时间:2018-07-12

文档编号:EDOC1100028564

浏览量:18754

下载量:223

平均得分:
本文档适用于这些产品
相关文档
相关版本
分享
上一页 下一页